Autor Tema: [Release] Chaos Calmer 15.05  (Leído 73657 veces)

0 Usuarios y 1 Visitante están viendo este tema.

djbill

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #40 en: 16-09-2015, 09:35 (Miércoles) »
Muchas gracias por el aporte, acabo de instalar el OpenWRT en un Comtrend ar-5387un para que realice de AP en una red doméstica.

De primeras me pasa una cosa, al pulsar en los iconos "?" que hay en cada opción no me sale ningún tipo de ayuda.
¿Me falta algún paquete? Actualmente solo está instalada la versión 15.05 final aquí publicada y nada más, excepto las configuraciones de red.

Un saludo.



mat_up_14

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #41 en: 16-09-2015, 17:13 (Miércoles) »
acabo de instalar la version smp de cc 15.05, es un adb 4001N y me pasa algo raro al tirar un opkg update desde consola:
Código: [Seleccionar]
root@OpenWrt:~# opkg update
Collected errors:
 * opkg_conf_load: Could not lock /var/lock/opkg.lock: Resource temporarily unavailable.
root@OpenWrt:~#

alguna idea??

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1870
Re: [Release] Chaos Calmer 15.05
« Respuesta #42 en: 16-09-2015, 17:33 (Miércoles) »
acabo de instalar la version smp de cc 15.05, es un adb 4001N y me pasa algo raro al tirar un opkg update desde consola:
Código: [Seleccionar]
root@OpenWrt:~# opkg update
Collected errors:
 * opkg_conf_load: Could not lock /var/lock/opkg.lock: Resource temporarily unavailable.
root@OpenWrt:~#

alguna idea??

¿Te pasa todas las veces que lo intentas?
Reinicia y vuélvelo a intentar.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

mat_up_14

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #43 en: 16-09-2015, 18:27 (Miércoles) »
 >:( >:( >:( gracias, ya habia rebooteado cesde luci, pero la solucion fue apagar el router y volverlo a encender... gracias de nuevo.

Curr0

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #44 en: 16-09-2015, 19:35 (Miércoles) »
Router ar5387un con la compilación oficial smp. un HUB USB para tener 4 puertos de los que solo estoy usando uno, donde está conectado un pendrive de 8GB con 3 particiones 1GB para el overlay 6 GB para descargas y tal y el resto para swap. Le funciona el Wifi, ethernet, monta los USB donde le digo. Parece que todo correcto.

Hasta que intento hacer el system Overlay, que se pasa por el forro de la chaqueta..
Hola, seguro que tu me puedes ayudar con otra pregunta  ;D

¿Para qué quieres usar overlay si puedes montar la partición en un directorio en concreto?
¿No te cabe todo el software que tienes pensado instalar?
¿Qué pasa si desenchufas el pen?¿Y si lo vuelves a enchufar dentro de un rato?
¿Cuál es la opción más adecuada para quitarlo?

Saludos

Curr0

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #45 en: 16-09-2015, 19:49 (Miércoles) »
Muchas gracias por el aporte, acabo de instalar el OpenWRT en un Comtrend ar-5387un para que realice de AP en una red doméstica.

De primeras me pasa una cosa, al pulsar en los iconos "?" que hay en cada opción no me sale ningún tipo de ayuda.
¿Me falta algún paquete? Actualmente solo está instalada la versión 15.05 final aquí publicada y nada más, excepto las configuraciones de red.

Un saludo.

Si no recuerdo mal (porque lo tengo apagado) al lado del icono de ? hay un texto explicativo, pero ese  icono no es "pulsable".

Tengo el mismo router que tu con el último firmware y quiero configurarlo como AP en modo cliente, para conectar unos equipos a la red inalámbrica y con el mismo tipo de direccionamiento por todas las interfaces. Después de mirar varias opciones probé configurando relayd ( http://wiki.openwrt.org/doc/recipes/relayclient ) con luci pero me va fatal. Da un ping lentísimo e incluso me da error en las páginas de test de velocidad...  :(

¿Como tienes pensado configurarlo tu?

Saludos

Aldous

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #46 en: 16-09-2015, 22:03 (Miércoles) »
Router ar5387un con la compilación oficial smp. un HUB USB para tener 4 puertos de los que solo estoy usando uno, donde está conectado un pendrive de 8GB con 3 particiones 1GB para el overlay 6 GB para descargas y tal y el resto para swap. Le funciona el Wifi, ethernet, monta los USB donde le digo. Parece que todo correcto.

Hasta que intento hacer el system Overlay, que se pasa por el forro de la chaqueta..
Hola, seguro que tu me puedes ayudar con otra pregunta  ;D

¿Para qué quieres usar overlay si puedes montar la partición en un directorio en concreto?
¿No te cabe todo el software que tienes pensado instalar?
¿Qué pasa si desenchufas el pen?¿Y si lo vuelves a enchufar dentro de un rato?
¿Cuál es la opción más adecuada para quitarlo?

Saludos

Hola Cur0, se apenas nada pero intento responderte.
La idea de ponerlo en Overlay es para que efectivamente 'aumente' el espacio de la partición que se dedica al sistema. Es el AR53... hay menos problema de espacio pero el el TL.mr3420v1 que tengo tambien con solo 4 MB... es imprescindible hacerlo. De entrada trae muy poco y o elijes muy bien los paquetes o te escasea el espacio. le tengo puesto un cliente torrent y de dyndns, servidor samba y ftp y me estoy pegando con lo de chutarle la webcam... ya veremos si lo logro (no apostaría por mí;)
No he probado nunca a desenchufarlo en caliente, la verdad. ni se me ocurriría por pura precaución. tengo puesto un pincho de 8GB que costó como 4 euros en rebajas y está solo para eso. las cosas las saco del pincho por samba. Supongo que si se lo quitas en caliente se colgará porque no encontrará la mitad de los demonios que busque y se crujirá a errores y si se lo enchufas después no creo que sea capaz de funcionar bien. Si se lo quitas en frio y lo inicias sin el pincho arranca con la configuración... digamos que inicial de justo antes de hacerle el extroot.
La opción mas adecuada para quitarlo es con el router apagado. Si encendido asi luego le enchufas el USB apostaría a que no vas a tener funcionando el extroot ni de coña. pero si tienes los paquetes de hotplug y demás de usb y no lo usas de 'disco de sistema' con que hagas un umount y lo desenchufes no pasa nada. eso hago con el disco de 1TB que tengo también conectado.
Un saludo!

Aldous

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #47 en: 16-09-2015, 22:10 (Miércoles) »
Ahora me pasa algo super raro. Configuro Samba y se queda con lo que le digo. solo admite los usuarios que le he configurado, no admite invitados, los nombres de las carpetas son los que le he especificado... ¡genial! ¡¡funciona de lujo!!

Hasta que reinicio el router

y la configuraión de Samba vuelve a ser por defecto. aceptando invitados, sin control de usuario y con los nombres que lee de vete a saber donde.

¿PORQUEEEEE? ¿como puedo afrontar esto? no encuentro documentación relacionada por ninguna parte.

djbill

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #48 en: 17-09-2015, 09:29 (Jueves) »

Si no recuerdo mal (porque lo tengo apagado) al lado del icono de ? hay un texto explicativo, pero ese  icono no es "pulsable".

Tengo el mismo router que tu con el último firmware y quiero configurarlo como AP en modo cliente, para conectar unos equipos a la red inalámbrica y con el mismo tipo de direccionamiento por todas las interfaces. Después de mirar varias opciones probé configurando relayd ( http://wiki.openwrt.org/doc/recipes/relayclient ) con luci pero me va fatal. Da un ping lentísimo e incluso me da error en las páginas de test de velocidad...  :(

¿Como tienes pensado configurarlo tu?

Saludos

Respecto a lo de la ayuda, pensaba que era como DD-WRT, que te da más información de lo que hace ese parámetro.

Respecto al AP, mi idea inicial es configurarlo de modo simple; como indica esta guia: http://wiki.openwrt.org/doc/recipes/dumbap

El problema que me he encontrado es que estoy comparando rendimiento entre mi actual WRT54GL con DDWRT y el Comtrend con el firmware de Seguridad Wireless y el problema es que con el WRT consigo 20Mb/s y con el Comtrend apenas llega a 3Mb/s
Quiero probar con otra unidad similar que tengo a ver si es un problema de hardware.

Curr0

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #49 en: 17-09-2015, 09:41 (Jueves) »
tengo puesto un pincho de 8GB que costó como 4 euros en rebajas y está solo para eso. las cosas las saco del pincho por samba.
si tienes los paquetes de hotplug y demás de usb y no lo usas de 'disco de sistema' con que hagas un umount y lo desenchufes no pasa nada. eso hago con el disco de 1TB que tengo también conectado.
Un saludo!

¿Usas un hub USB para conectar dos discos? Supongo que no hay que configurar nada...
¿No te da problemas de alimentación?

Ahora me pasa algo super raro. Configuro Samba y se queda con lo que le digo. solo admite los usuarios que le he configurado, no admite invitados, los nombres de las carpetas son los que le he especificado... ¡genial! ¡¡funciona de lujo!!

Hasta que reinicio el router

y la configuraión de Samba vuelve a ser por defecto. aceptando invitados, sin control de usuario y con los nombres que lee de vete a saber donde.

¿PORQUEEEEE? ¿como puedo afrontar esto? no encuentro documentación relacionada por ninguna parte.
Yo estuve usando samba hace tiempo (incluso tuve configurado el system overlay  ^-^) y sorprendentemente funcionaba sin problemas. Lo configuré casi todo usando luci, asi que te recomiendo que instales  luci-i18n-samba-es y que configures todo lo que puedas usando luci o en su defecto usando uci.

Curr0

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #50 en: 17-09-2015, 09:54 (Jueves) »
El problema que me he encontrado es que estoy comparando rendimiento entre mi actual WRT54GL con DDWRT y el Comtrend con el firmware de Seguridad Wireless y el problema es que con el WRT consigo 20Mb/s y con el Comtrend apenas llega a 3Mb/s
Quiero probar con otra unidad similar que tengo a ver si es un problema de hardware.

Entonces te pasa lo mismo que a mi...
Yo tengo un WRT54G con ddwrt del año de la pera y va mil veces mejor. de hecho llegué a tener conectado el openwrt al ddwrt por cable de red por ese motivo, lo que me parece una chapuza.
Creo que haciendo dos subredes distintas (una para la red inalámbrica y otra para red cableada) va algo mejor...

Si lees un poco este hilo

https://www.reddit.com/r/openwrt/comments/3krm9l/is_the_ddwrt_project_still_active/

Comentan lo siguiente:
One thing I've noticed DD-WRT does seem to do well - it has a bit of a performance edge on some of the jankier routers out there. I'll use the WRT610N as a good example. Some of the weird wireless burst features (I forget the specifics) aren't implemented due to Broadcom's terribly non-open source chipset support, whereas I believe dd-wrt included the proprietary driver for said features. This is a non-issue in other, better chipsets (Atheros), so it's mostly about picking the right chipset/router.

mekkon

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #51 en: 17-09-2015, 13:42 (Jueves) »
Buenas,

Como consigo los 'oldpackages' para chaos calmer? en barrier breaker se descargan por defecto, pero no lo tengo muy claro para esta última versión.

Un saludo.

EDITO: me respondo a mi mismo:

editando este fichero: openwrt/feeds.conf.default

y quitando el comentario de esta linea:

#src-git oldpackages http://git.openwrt.org/packages.git

ya se descargan de forma habitual. ;)
« Última modificación: 17-09-2015, 13:49 (Jueves) por mekkon »

Noltari

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #52 en: 18-09-2015, 19:19 (Viernes) »
Buenas,

He actualizado los firmwares del primer post, de forma que no debería haber más fallos de arranque causados por el error de squashfs cuando el kernel no era múltiplo de 2 (había un 50% de posibilidades de que la imagen fuera válida/inválida).
Esto también pasa en el trunk y está pendiente de ser solucionado, pero jogo ya está avisado.
Lo suyo sería modificar la herramienta imagetag para que haga un align del kernel a un múltiplo de 2 antes de generar el binario.

Por otro lado, la imagen generada para el ARV7519RW22 ha sido arreglada y ahora no debería dar kernel panic, gracias al fix de Pteridium.

P.D: cualquier cosa que surja no dudéis en comentarla. Espero que todos los firmwares funcionen xD.

Un saludo,
Noltari.

francisgambin

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #53 en: 18-09-2015, 19:55 (Viernes) »
Buenas,

He actualizado los firmwares del primer post, de forma que no debería haber más fallos de arranque causados por el error de squashfs cuando el kernel no era múltiplo de 2 (había un 50% de posibilidades de que la imagen fuera válida/inválida).
Esto también pasa en el trunk y está pendiente de ser solucionado, pero jogo ya está avisado.
Lo suyo sería modificar la herramienta imagetag para que haga un align del kernel a un múltiplo de 2 antes de generar el binario.

Por otro lado, la imagen generada para el ARV7519RW22 ha sido arreglada y ahora no debería dar kernel panic, gracias al fix de Pteridium.

P.D: cualquier cosa que surja no dudéis en comentarla. Espero que todos los firmwares funcionen xD.

Un saludo,
Noltari.

Ole, si señor que tardes mas buneas nos das!!!

Muchísimas gracias por el aporte tan esperado, voy a probar inmediatamente en ARV7519RW22 rev1 solo quería hacerte una pregunta. ¿esta compilado con fpu emulador?

Ínsito muchas gracias, reportare los resultados obtenidos
« Última modificación: 18-09-2015, 19:57 (Viernes) por francisgambin »

Aldous

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #54 en: 19-09-2015, 15:43 (Sábado) »
tengo puesto un pincho de 8GB que costó como 4 euros en rebajas y está solo para eso. las cosas las saco del pincho por samba.
si tienes los paquetes de hotplug y demás de usb y no lo usas de 'disco de sistema' con que hagas un umount y lo desenchufes no pasa nada. eso hago con el disco de 1TB que tengo también conectado.
Un saludo!

¿Usas un hub USB para conectar dos discos? Supongo que no hay que configurar nada...
¿No te da problemas de alimentación?

Ahora me pasa algo super raro. Configuro Samba y se queda con lo que le digo. solo admite los usuarios que le he configurado, no admite invitados, los nombres de las carpetas son los que le he especificado... ¡genial! ¡¡funciona de lujo!!

Hasta que reinicio el router

y la configuraión de Samba vuelve a ser por defecto. aceptando invitados, sin control de usuario y con los nombres que lee de vete a saber donde.

¿PORQUEEEEE? ¿como puedo afrontar esto? no encuentro documentación relacionada por ninguna parte.
Yo estuve usando samba hace tiempo (incluso tuve configurado el system overlay  ^-^) y sorprendentemente funcionaba sin problemas. Lo configuré casi todo usando luci, asi que te recomiendo que instales  luci-i18n-samba-es y que configures todo lo que puedas usando luci o en su defecto usando uci.

Si el pincho los discos y demas chismes van a un hub usb marca amazon basics. no ha habido que configurar nada, lo coge sin problemas.

        [   13.324000] hub 1-1:1.0: USB hub found
        [   13.328000] hub 1-1:1.0: 4 ports detected

a mi samba nunca me habia dado el menor problema hasta ahora. Y de momento no lo puedo solucionar! lo he configurado desde luci, a mano... pero nada. cuando el router reinicia vuelve a sus valores por defecto el maldito samba.

se aceptan ideas

francisgambin

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #55 en: 19-09-2015, 20:50 (Sábado) »
Buenas,

He actualizado los firmwares del primer post, de forma que no debería haber más fallos de arranque causados por el error de squashfs cuando el kernel no era múltiplo de 2 (había un 50% de posibilidades de que la imagen fuera válida/inválida).
Esto también pasa en el trunk y está pendiente de ser solucionado, pero jogo ya está avisado.
Lo suyo sería modificar la herramienta imagetag para que haga un align del kernel a un múltiplo de 2 antes de generar el binario.

Por otro lado, la imagen generada para el ARV7519RW22 ha sido arreglada y ahora no debería dar kernel panic, gracias al fix de Pteridium.

P.D: cualquier cosa que surja no dudéis en comentarla. Espero que todos los firmwares funcionen xD.

Un saludo,
Noltari.

Ole, si señor que tardes mas buneas nos das!!!

Muchísimas gracias por el aporte tan esperado, voy a probar inmediatamente en ARV7519RW22 rev1 solo quería hacerte una pregunta. ¿esta compilado con fpu emulador?

Ínsito muchas gracias, reportare los resultados obtenidos


Buenas noches,

Pues con respecto al software compliado para ARV7519RW22 al fin he podido instalarlo sin kernel panic, pero sigue sin funcionar samba es decir, lo detecta todo y aparentemente funciona todo, pero en cuanto copio o leo mediante samba a los pocos megas (unos 8 o mas) se reinicia el router.

Esto ya lo comente en el hilo del livebox, me acurre exactamente lo mismo

Noltari

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #56 en: 20-09-2015, 13:40 (Domingo) »
Buenas noches,

Pues con respecto al software compliado para ARV7519RW22 al fin he podido instalarlo sin kernel panic, pero sigue sin funcionar samba es decir, lo detecta todo y aparentemente funciona todo, pero en cuanto copio o leo mediante samba a los pocos megas (unos 8 o mas) se reinicia el router.

Esto ya lo comente en el hilo del livebox, me acurre exactamente lo mismo
Buenas,

He recompilado únicamente el firmware del ARV7519RW22, con los siguientes cambios: https://github.com/openwrt-es/openwrt/commit/5c227591fc3bc2e7a06e92566b94d632c282dee3
  • VLANs
  • LEDs
  • USB lateral
¿Puedes probar el firmware y decirme si sigues teniendo el mismo problema?
Igual es tema de no tener las VLANs configuradas en el switch, porque el driver del ethernet es un poco mierder.

P.S: por favor, haz una prueba con el gigabit ethernet y otra con fast ethernet únicamente.

Saludos.
« Última modificación: 20-09-2015, 13:50 (Domingo) por Noltari »

Noltari

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #57 en: 20-09-2015, 16:02 (Domingo) »
Buenas noches,

Pues con respecto al software compliado para ARV7519RW22 al fin he podido instalarlo sin kernel panic, pero sigue sin funcionar samba es decir, lo detecta todo y aparentemente funciona todo, pero en cuanto copio o leo mediante samba a los pocos megas (unos 8 o mas) se reinicia el router.

Esto ya lo comente en el hilo del livebox, me acurre exactamente lo mismo
Buenas,

He recompilado únicamente el firmware del ARV7519RW22, con los siguientes cambios: https://github.com/openwrt-es/openwrt/commit/5c227591fc3bc2e7a06e92566b94d632c282dee3
  • VLANs
  • LEDs
  • USB lateral
¿Puedes probar el firmware y decirme si sigues teniendo el mismo problema?
Igual es tema de no tener las VLANs configuradas en el switch, porque el driver del ethernet es un poco mierder.

P.S: por favor, haz una prueba con el gigabit ethernet y otra con fast ethernet únicamente.

Saludos.
Vale, me respondo yo, sigue fallando.
A ver si descubro el motivo.

P.D: descargar ficheros grandes e incluso copiar ficheros grandes de un USB a otro también reinicia el router, por lo que hay algo que está fallando a nivel de interrupciones o acceso a memoria.

Saludos.
« Última modificación: 20-09-2015, 16:12 (Domingo) por Noltari »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4579
Re: [Release] Chaos Calmer 15.05
« Respuesta #58 en: 20-09-2015, 20:49 (Domingo) »
A ver si saco tiempo esta semana, y pruebo la nueva versión en un Comtrend VR3025u  ^-^

Gracias, Noltari, por mantenernos al día  ;)
Valoraciones positivas en compra/venta:
114 en Htcmania
104 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

skywalky

  • Visitante
Re: [Release] Chaos Calmer 15.05
« Respuesta #59 en: 05-10-2015, 17:49 (Lunes) »
Creo que he encontrado un fallo en el firmware del ARV7519RW22 y las VLANS. Si configuro un puerto WAN (el Gigabit) y le conecto el cable en caliente todo funciona correctamente pero si reinicio el router y tengo el portatil conectado en otro de los puertos, en lugar de asignarme al portatil una IP de la LAN me asigna una de la WAN. Es una cosa rara.

EDITO: Creo que he encontrado el "error". Igual es solo un problema de firewall. El error ocurre cuando el servidor DHCP del lado WAN asigna una IP concreta según la MAC al adaptador que estoy usando en el lado de la LAN. En lugar de darme la IP el DHCP del router me lo da el DHCP de la red de la WAN.
« Última modificación: 07-10-2015, 15:05 (Miércoles) por skywalky »