Autor Tema: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D  (Leído 3455 veces)

0 Usuarios y 1 Visitante están viendo este tema.

farguis

  • Visitante
[Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« en: 22-05-2013, 21:25 (Miércoles) »
Hola, resulta que llevo ya 2 dias intentando hacer un modo puente con un router Linksys V1.1 con OpenWRT (Cliente) y un netgear CG3100D (El que me dio ONO y el que tiene la red). Utilizo la ultima version para este router de OpenWRT kamikaze y logro que se conecte al Netgear pero no llego a tener internet.
He seguido las instrucciones de la pagina oficial y tambien de el tutorial que hay en esta web pero no hay manera.
http://wiki.openwrt.org/doc/howto/clientmode

Estando conectado al linksys mediante cable logro meterme a la direccion del Netguear saliendome su menu conque supongo que la red entonces esta correcta. No se si será problemas de DNS y Gateway en el linksys pero he ido probando creo que todas las posibilidades sin resultado.
Pero hay una cosa muy rara y es que metiendome en la pagina del Netguear en el filtrado del MAC si me sale la ip que tengo en el portatil conectado al Linksys pero luego en configuracion wireless advanzada pues en los dispositivos con conexion no me sale. AHora no se de quien es el problema, del Linksys, del netguear, mio .... jejeje espero que me ayudeis.
 Muchas gracias



« Última modificación: 22-05-2013, 21:28 (Miércoles) por farguis »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #1 en: 23-05-2013, 10:08 (Jueves) »
La verdad es que nunca he trabajado con la versión kamikaze ...  ^-^

Déjanos ver los ficheros 'network', 'firewall' y 'wireless' (estarán, imagino en /etc/config)

Además de eso ... cual es la IP del router principal ?
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

farguis

  • Visitante
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #2 en: 23-05-2013, 10:49 (Jueves) »
Uso kamikaze la version kamikaze (8.09.2)- brcm 2.4 openwrt-wrt54g-squashfs.bin, lei que esta era la mejor version (no se seguro donde, o a lo mejor el año estaba desfasado) no tengo disposicion de usar una u otra la verdad. La ip del router principal es 192.168.1.1

Este es el archivo network

        option 'proto' 'static'    
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'
                                    
config 'interface' 'lan'            
        option 'type' 'bridge'      
        option 'ifname' 'eth0.0'    
        option 'proto' 'static'    
        option 'netmask' '255.255.255.0'
        option 'ipaddr' '192.168.1.30'  
        option 'dns' '8.8.8.8'          
        option 'gateway' '192.168.1.1'  
                                        
config 'interface' 'wan'                
        option 'ifname' 'eth0.1'        
        option 'proto' 'dhcp'          
                                      
config 'route'                        
        option 'interface' 'lan'      
        option 'target' '0.0.0.0'
        option 'netmask' '0.0.0.0'
        option 'gateway' '192.168.1.1'

y este el wireless

        option 'proto' 'static'    

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'cuntry' 'DE'
        option 'channel' '3'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'network' 'lan'
        option 'mode' 'sta'
        option 'ssid' 'SSID'
        option 'encryption' 'psk2'
        option 'key' 'Password'

y estel firewal

        option 'proto' 'static'    

                                
config 'zone'                    
        option 'name' 'wan'      
        option 'input' 'REJECT'  
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'masq' '1'        
        option 'mtu_fix' '1'    
                                
config 'forwarding'              
        option 'src' 'lan'      
        option 'dest' 'wan'      
        option 'mtu_fix' '0'    
                                
config 'rule'                    
        option 'src' 'wan'      
        option 'proto' 'udp'    
        option 'dest_port' '68'  
        option 'target' 'ACCEPT'
                                
config 'include'                
        option 'path' '/etc/firewall.user'

Pues esto es todo, gracias realmente por el interés
« Última modificación: 23-05-2013, 10:50 (Jueves) por farguis »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #3 en: 23-05-2013, 13:01 (Jueves) »
La verdad es que no veo nada mal. Lo único que me despista es esto

Citar
config 'route'                       
        option 'interface' 'lan'     
        option 'target' '0.0.0.0'
        option 'netmask' '0.0.0.0'
        option 'gateway' '192.168.1.1'

Yo comentaria (con #) esas líneas.

Partiendo de que este router puede hacer de repetidor, porqué no pruebas con esta configuración ?:
http://wiki.openwrt.org/doc/recipes/broadcom.repeater

Has probado desactivando el firewall ?
El equipo de Ono está configurado como router ?
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

farguis

  • Visitante
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #4 en: 23-05-2013, 19:31 (Jueves) »
hola de nuevo. Pues he hecho lo que me has dicho de comentar esas lineas pero nada sigue sin ir. Resulta que para lo que quiero hacer necesito lo de modo cliente en vez de un repetidor pero aun asi gracias.

Hay un detalle bastante curioso y es que me meto por telnet al router linksys (Openwrt) y hago ping www.google.es y me da ping!. La conexion del ordenador he probado por DHCP y estatica y sigue sin irme ademas de probar con Linux y windows. Asi que no se cual es el fallo. Ando un poco desesperado grrr

El De Ono esta configurado como Router xk me conecto directamente con otro dispositivos a ese, y el firewall del open esta desactivado. Probe tambien un TPLINK con el firmware de casa y este si me deja en modo cliente transparente.

gracias
« Última modificación: 23-05-2013, 19:34 (Jueves) por farguis »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #5 en: 24-05-2013, 08:00 (Viernes) »
El DHCP del linksys tiene que estar deshabilitado.

Conecta un equipo por cable, y pon por aquí el resultado de ipconfig /all
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

farguis

  • Visitante
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #6 en: 24-05-2013, 10:44 (Viernes) »
Este es el archivo DHCP. Por Luci me aparece como desactivado y creo que lo está no??

        option domain   'lan'                                  
        option expandhosts      1                              
        option nonegcache       0                              
        option authoritative    1                              
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     0                        
        #list interface         br-lan                    
                                                          
config 'dhcp' 'lan'                                      
        option 'interface' 'lan'                          
        option 'start' '100'                              
        option 'limit' '150'          
        option 'leasetime' '12h'      
        option 'ignore' '1'    
config dhcp wan                
        option interface        wan
        option ignore   1          

Cuando te refieres a ipconfig /all supongo que diras ifconfig (linux) no?

eth0      Link encap:Ethernet  direcciónHW XX:XX:XX:XX:XX:3b  
          Direc. inet:192.168.1.50  Difus.:192.168.1.255  Másc:255.255.255.0
          Dirección inet6: XXXX::XXXX:XXXX:febe:673b/64 Alcance:Enlace
          ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:1737 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:548 errores:0 perdidos:0 overruns:0 carrier:5
          colisiones:0 long.colaTX:1000
          Bytes RX:123391 (123.3 KB)  TX bytes:50838 (50.8 KB)

lo        Link encap:Bucle local  
          Direc. inet:127.0.0.1  Másc:255.0.0.0
          Dirección inet6: ::1/128 Alcance:Anfitrión
          ACTIVO BUCLE FUNCIONANDO  MTU:65536  Métrica:1
          Paquetes RX:4394 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:4394 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:0
          Bytes RX:384615 (384.6 KB)  TX bytes:384615 (384.6 KB)

El router se que tiene internet porque me ido a bajar unos paquetes que no tenia instalados y me lo ha permitio, cosa que antes no. Y basicamente era lo que queria ... pero aun asi sigo con la curiosidad de a ver que esta pasando para que no me de internet.

Puede que tenga que configurar una ruta estatica diciendo que todo lo que me llegue por el router lo envie hacia el interfaz del otro y ya el que resuelva la ruta? Parecido a lo que me dijiste que comentará.
Gracias


                                  
« Última modificación: 24-05-2013, 10:45 (Viernes) por farguis »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #7 en: 24-05-2013, 11:38 (Viernes) »
Sí, el DHCP está deshabilitado.

El equipo recibe una IP del rango correcto "Direc. inet:192.168.1.50"


Puede que tenga que configurar una ruta estatica diciendo que todo lo que me llegue por el router lo envie hacia el interfaz del otro y ya el que resuelva la ruta? Parecido a lo que me dijiste que comentará.
Gracias
                                 

Pudiera ser ...  ^-^

No estarás conectado el PC a la 'boca' ethernet marcada como WAN no ?
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

farguis

  • Visitante
Re: [Pregunta] Modo puente cliente Linksys V.1.1 y Netgear CG3100D
« Respuesta #8 en: 24-05-2013, 13:15 (Viernes) »
No no, he ido alternano entre los 4 por si fuera el puerto. Puede ser que el router de Ono al solo ver la Mac del Linksys no quiera dirigir a otra ip que no este relacionada con esa MAC. El problema es que en el router Netguear no puedo ver las tablas ARP de enrutamiento (creo que se llamaban asi) y no puedo observar esto. Por decir algo  :'( .

//FINAL Y MÁS DOS RESPUESTAS