Autor Tema: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555  (Leído 468040 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

casidi22

  • Visitante


Pues está en el menú principal ... no debería tener perdida ;D

Enviado desde mi U30GT-H usando Tapatalk 2

:( En el menu principal veo la opcion de luci2 pero alli solo tengo la opcion de librerias (libubus y libubus-lua) y system (ubus y ubusd) pero el firmware arranca sin luci da igual que instale paquetes o no haga nada el firmware se carga sin errores pero no luci y he intentado muchos muchos .......muchos intentos y no se que se me pasa ¿subo el log? no veo errores pero se me puede pasar algo aunque creo que simplemente estoy compilando sin luci estoy usando
git clone git://github.com/gmtii/openwrt.git
 que subio gmtii.



gmtii

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #341 en: 17-04-2013, 00:17 (Miércoles) »
buenas

si haces lo de

./scripts/feeds update -a
./scripts/feeds install -a

verás que te canta un error sobre el Luci; debes realizar lo siguiente

En el fichero: feeds.conf.default
cambias la línea

src-svn luci http://svn.luci.subsignal.org/luci/trunk/contrib/package

por

src-svn luci http://svn.luci.subsignal.org/luci/trunk

de nuevo haces aquello de:

./scripts/feeds update -a
./scripts/feeds install -a

haces menu config, y ahora si debe aparecerte Luci en la primera pantalla.

PD: he actualizado el git con esto, el soporte de bus I2C en el primer LED de la derecha según nos contó RafaC (hay que quitar los condensadores) de modo que puedes meter el cambio en tu version haciendo un git checkout y git pull (creo que es así)

Saludos.
« Última modificación: 17-04-2013, 00:29 (Miércoles) por gmtii »

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #342 en: 17-04-2013, 01:15 (Miércoles) »
buenas

si haces lo de

./scripts/feeds update -a
./scripts/feeds install -a

verás que te canta un error sobre el Luci; debes realizar lo siguiente

En el fichero: feeds.conf.default
cambias la línea

src-svn luci http://svn.luci.subsignal.org/luci/trunk/contrib/package

por

src-svn luci http://svn.luci.subsignal.org/luci/trunk

de nuevo haces aquello de:

./scripts/feeds update -a
./scripts/feeds install -a

haces menu config, y ahora si debe aparecerte Luci en la primera pantalla.

PD: he actualizado el git con esto, el soporte de bus I2C en el primer LED de la derecha según nos contó RafaC (hay que quitar los condensadores) de modo que puedes meter el cambio en tu version haciendo un git checkout y git pull (creo que es así)

Saludos.
Has cambiado el branch a master, así los comandos son:
Código: [Seleccionar]
git checkout master
git pull origin master

A veces no poner el "origin master" impide bajar la última revisión.

Saludos.

casidi22

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #343 en: 17-04-2013, 15:39 (Miércoles) »
buenas

si haces lo de

./scripts/feeds update -a
./scripts/feeds install -a

verás que te canta un error sobre el Luci; debes realizar lo siguiente

En el fichero: feeds.conf.default
cambias la línea

src-svn luci http://svn.luci.subsignal.org/luci/trunk/contrib/package

por

src-svn luci http://svn.luci.subsignal.org/luci/trunk

de nuevo haces aquello de:

./scripts/feeds update -a
./scripts/feeds install -a

haces menu config, y ahora si debe aparecerte Luci en la primera pantalla.

PD: he actualizado el git con esto, el soporte de bus I2C en el primer LED de la derecha según nos contó RafaC (hay que quitar los condensadores) de modo que puedes meter el cambio en tu version haciendo un git checkout y git pull (creo que es así)

Saludos.
Has cambiado el branch a master, así los comandos son:
Código: [Seleccionar]
git checkout master
git pull origin master

A veces no poner el "origin master" impide bajar la última revisión.

Saludos.

Gmtii el fichero  feeds.conf.default no lo encontraba por ningun lado
Noltari
git checkout master
git pull origin master

me decia que estaba todo correcto pero luci no aparecia
con esto si me funciono
./scripts/feeds update -a
./scripts/feeds install -a
ya me aparecian todas las opciones y aqui el resultado


http://speedtest.ookla.com/result/2098294643.png

va perfecto como un cañon
Muchisiamas Gracias a todos ya tengo un router 3G-openwrt
 ;););););););););););););););););););););););););)
« Última modificación: 17-04-2013, 15:41 (Miércoles) por casidi22 »

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #344 en: 17-04-2013, 18:58 (Miércoles) »
Buenas gente!

En primer lugar me gustaría agradecer a gmtii que me haya enviado uno de estos routers para poder trastear con él, ya que si no me habría sido chungo-imposible colaborar en el desarrollo de este router.
Hemos estado ocupados actualizando los parches del ASL26555 a DTS, para mandarlos a OpenWrt y conseguir que esté integrado en el repositorio oficial.

Necesito feedback de alguien con la versión americana del router (8MB). Pongo también el firmware de las versiones de 16MB españolas, aunque estoy seguro de que funcionará 100% ;).
Firmware 8MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-8M-squashfs-sysupgrade_dts_rc.bin
Firmware 16MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade_dts_rc.bin

Parches DTS: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/asl26555_dts_lan_wan.patch

Saludos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #345 en: 18-04-2013, 09:00 (Jueves) »
Magnífico trabajo  >:(  >:(  >:(

Como ya te comenté, en la versión de 16 megas va fenomenal.
A ver si alguien con la de 8, lo prueba y cuenta algo ...  ^-^
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

zoylorino

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #346 en: 19-04-2013, 13:41 (Viernes) »
Hola. Soy nuevo en el foro. Tengo varios ASL y en algunos puedo flashearlos por cable con el firmware Luci sin problemas. Pero en otros me da el mismo kernel panic de la pagina 15 posteado por Noltari, pero con el fw sin Luci si lo carga.
  He intentado flashearlo desde la consola por telnet con sysupgrade, mtd o dd y aparentemente lo graba pero al reiniciarlo sigue con el antiguo. ¿Alguna idea?. Gracias y saludos.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #347 en: 19-04-2013, 15:06 (Viernes) »
Hola. Soy nuevo en el foro. Tengo varios ASL y en algunos puedo flashearlos por cable con el firmware Luci sin problemas. Pero en otros me da el mismo kernel panic de la pagina 15 posteado por Noltari, pero con el fw sin Luci si lo carga.
  He intentado flashearlo desde la consola por telnet con sysupgrade, mtd o dd y aparentemente lo graba pero al reiniciarlo sigue con el antiguo. ¿Alguna idea?. Gracias y saludos.
Lo primero es que yo no he posteado ese bootlog, sino que lo estaba citando.

Lo segundo es que ese problema ya ha sido solucionado por gmtii, por lo que asumo que no has leido las siguientes páginas al fallo.
Pista: https://foro.seguridadwireless.net/openwrt/nuevos-routers-de-telefonica/msg272629/#msg272629

Saludos.

gmtii

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #348 en: 19-04-2013, 15:09 (Viernes) »
sería interesante que pusieras el log del arranque, pero presumo que tienes el "problema" en que el uboot flashea la region 2 en vez de la 1, y de ahí el kernel panic... como esta explicado unos cuantos mensajes atrás, tienes que entrar en la opción 4 del uboot y meter los siguientes comando:

setenv activeregion 1
saveenv
reset

saludos

Hola. Soy nuevo en el foro. Tengo varios ASL y en algunos puedo flashearlos por cable con el firmware Luci sin problemas. Pero en otros me da el mismo kernel panic de la pagina 15 posteado por Noltari, pero con el fw sin Luci si lo carga.
  He intentado flashearlo desde la consola por telnet con sysupgrade, mtd o dd y aparentemente lo graba pero al reiniciarlo sigue con el antiguo. ¿Alguna idea?. Gracias y saludos.

Harald Blåtand

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #349 en: 21-04-2013, 15:41 (Domingo) »
Buenas gente!

En primer lugar me gustaría agradecer a gmtii que me haya enviado uno de estos routers para poder trastear con él, ya que si no me habría sido chungo-imposible colaborar en el desarrollo de este router.
Hemos estado ocupados actualizando los parches del ASL26555 a DTS, para mandarlos a OpenWrt y conseguir que esté integrado en el repositorio oficial.

Necesito feedback de alguien con la versión americana del router (8MB). Pongo también el firmware de las versiones de 16MB españolas, aunque estoy seguro de que funcionará 100% ;).
Firmware 8MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-8M-squashfs-sysupgrade_dts_rc.bin
Firmware 16MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade_dts_rc.bin

Parches DTS: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/asl26555_dts_lan_wan.patch

Saludos!

¿y cómo aplico el parche? ¿con qué comando?

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #350 en: 21-04-2013, 15:45 (Domingo) »
Buenas gente!

En primer lugar me gustaría agradecer a gmtii que me haya enviado uno de estos routers para poder trastear con él, ya que si no me habría sido chungo-imposible colaborar en el desarrollo de este router.
Hemos estado ocupados actualizando los parches del ASL26555 a DTS, para mandarlos a OpenWrt y conseguir que esté integrado en el repositorio oficial.

Necesito feedback de alguien con la versión americana del router (8MB). Pongo también el firmware de las versiones de 16MB españolas, aunque estoy seguro de que funcionará 100% ;).
Firmware 8MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-8M-squashfs-sysupgrade_dts_rc.bin
Firmware 16MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade_dts_rc.bin

Parches DTS: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/asl26555_dts_lan_wan.patch

Saludos!

¿y cómo aplico el parche? ¿con qué comando?
No hace falta que apliques el parche si usas el firmware precompilado que facilito.

Saludos.

Harald Blåtand

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #351 en: 21-04-2013, 17:23 (Domingo) »
Buenas gente!

En primer lugar me gustaría agradecer a gmtii que me haya enviado uno de estos routers para poder trastear con él, ya que si no me habría sido chungo-imposible colaborar en el desarrollo de este router.
Hemos estado ocupados actualizando los parches del ASL26555 a DTS, para mandarlos a OpenWrt y conseguir que esté integrado en el repositorio oficial.

Necesito feedback de alguien con la versión americana del router (8MB). Pongo también el firmware de las versiones de 16MB españolas, aunque estoy seguro de que funcionará 100% ;).
Firmware 8MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-8M-squashfs-sysupgrade_dts_rc.bin
Firmware 16MB: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade_dts_rc.bin

Parches DTS: https://dl.dropboxusercontent.com/u/4708147/openwrt/ramips/ASL26555/asl26555_dts_lan_wan.patch

Saludos!

¿y cómo aplico el parche? ¿con qué comando?
No hace falta que apliques el parche si usas el firmware precompilado que facilito.

Saludos.

Probé el fw en la versión de 8M y anda bien, no me da kernel panic ni nada, pero le faltó el paquete wireless-tools, solo eso.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #352 en: 21-04-2013, 18:16 (Domingo) »
Probé el fw en la versión de 8M y anda bien, no me da kernel panic ni nada, pero le faltó el paquete wireless-tools, solo eso.
Gracias por el feedback.
Se trataba de una compilación de prueba para confirmar que no había problemas en la versión americana, por lo que los paquetes no eran relevantes.

He mandado los parches: http://patchwork.openwrt.org/patch/3571/
Podéis bajaros mi repositorio de Github con los parches ya aplicados:
https://github.com/Noltari/openwrt/tree/ramips-r36376
Código: [Seleccionar]
git clone git://github.com/Noltari/openwrt.git -b ramips-r36376
Saludos.
« Última modificación: 22-04-2013, 16:54 (Lunes) por Noltari »

casidi22

  • Visitante
Re: Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #353 en: 21-04-2013, 22:43 (Domingo) »
Ayer empecé con mi otro router asl-26555, le solde los jampers en casa ajena por ir adelantando pero sólo tenía un soldador bbq y no recibo señal por el ttl, lo he desoldado y vuelto a soldar pero sigo sin recibir señal por el putty ¿hay puntos de soldadura compatibles en la placa?
veo q hay otro jampers en la placa más abajo ¿también es para el puerto serie?
P.d. Perdón por ser tan pesado

Enviado desde mi GT-I9001 usando Tapatalk 2

gmtii

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #354 en: 22-04-2013, 16:16 (Lunes) »
buen trabajo y gracias por la mención en el parche :-)

pregunta: interesa por aquí el tema del I2C en este router y algunos casos tipo leer un termómetro barómetro BMP085, un termómetro LM92, multiplexor de gpios y tal?

tengo hecho una cosa tipo estación meteorológica con monitorización de aviones y mostrado en un display usb de 320x200...

saludos!

Probé el fw en la versión de 8M y anda bien, no me da kernel panic ni nada, pero le faltó el paquete wireless-tools, solo eso.
Gracias por el feedback.
Se trataba de una compilación de prueba para confirmar que no había problemas en la versión americana, por lo que los paquetes no eran relevantes.

He mandado los parches: http://patchwork.openwrt.org/patch/3571/
Podéis bajaros mi repositorio de Github con los parches ya aplicados:
https://github.com/Noltari/openwrt/tree/ramips_asl26555
Código: [Seleccionar]
git clone git://github.com/Noltari/openwrt.git -b ramips_asl26555
Saludos.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #355 en: 22-04-2013, 17:02 (Lunes) »
He añadido al primer post mi repositorio para compilar el firmware con los parches DTS, así como el parche nesario para que funcione el ethernet en el modo failsafe (necesario para recuperarlo de una mala configuración sin disponer del UART).
También he añadido el repositorio para ramips en el hilo del tutorial de compilación de OpenWrt.

buen trabajo y gracias por la mención en el parche :-)

pregunta: interesa por aquí el tema del I2C en este router y algunos casos tipo leer un termómetro barómetro BMP085, un termómetro LM92, multiplexor de gpios y tal?

tengo hecho una cosa tipo estación meteorológica con monitorización de aviones y mostrado en un display usb de 320x200...

saludos!
Al César lo que es del César ;). El parche estaba basado en tu trabajo, así que obviamente también has participado en el parche.

Saludos!

zoylorino

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #356 en: 24-04-2013, 15:14 (Miércoles) »
Hola. Efectivamente en algunos de ellos no estaba ativa la region 1. Los he flasheado sin problemas. Gracias por vuestras respuestas y enhorabuena por el foro.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #357 en: 25-04-2013, 21:26 (Jueves) »
Router integrado en el repositorio oficial de OpenWrt: https://dev.openwrt.org/changeset/36433

Gracias a todos los que habéis hecho esto posible, pero sobre todo a gmtii ;D.

P.D: blogic también ha integrado mi parche para el ethernet en el modo failsafe: https://dev.openwrt.org/changeset/36434. En cuanto pueda borraré los branches de Github, ya que no son necesarios.
P.D2: AA 12.09 release https://forum.openwrt.org/viewtopic.php?pid=199599#p199599 :D :D :D

Saludos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #358 en: 26-04-2013, 08:20 (Viernes) »
Estupendas noticias (todas)  >:( >:( >:(
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

trujo

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #359 en: 26-04-2013, 10:34 (Viernes) »
Estoy intentando instalar el ultimo firmware (openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade_dts_rc.bin, que es el primero que intento) y no me funciona.
Los errores son:
muchos: jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at
y al final:
 66.930000] jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
[   66.950000] jffs2: empty_blocks 29, bad_blocks 0, c->nr_blocks 231
[   66.960000] VFS: Cannot open root device "(null)" or unknown-block(31,5): error -5
[   66.970000] Please append a correct "root=" boot option; here are the available partitions:
[   66.990000] 1f00             192 mtdblock0  (driver?)
[   67.000000] 1f01              64 mtdblock1  (driver?)
[   67.010000] 1f02              64 mtdblock2  (driver?)
[   67.020000] 1f03           15872 mtdblock3  (driver?)
[   67.030000] 1f04            1088 mtdblock4  (driver?)
[   67.040000] 1f05           14784 mtdblock5  (driver?)
[   67.050000] 1f06              64 mtdblock6  (driver?)
[   67.060000] 1f07              64 mtdblock7  (driver?)
[   67.070000] 1f08              64 mtdblock8  (driver?)
[   67.080000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,5)

¿Podéis darme norte?

Perdón esto me paso con la opción 2, con la opción 1 todo ha ido bien.
Perfecto y muchas gracias
« Última modificación: 26-04-2013, 11:02 (Viernes) por trujo »

//FINAL Y MÁS DOS RESPUESTAS