Autor Tema: [Desarrollo] OpenWrt en Observa Telecom VH4032N  (Leído 134091 veces)

0 Usuarios y 1 Visitante están viendo este tema.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #280 en: 28-04-2016, 12:12 (Jueves) »
Excelente trabajo Tki2000. Es difícil darse cuenta de pequeños errores como ese.

Sobre el wifi, habría que añadir creo el sprom fixup, no sé si se había comentado antes cuando se intentó el soporte para CC.

En los parches, yo añadiría un comentario al lado del ephy_reset_gpio, indicando que es un workaround para el USB, de otra forma podría dar lugar a equívocos en un futuro.

Una vez solucionado lo del wifi, diría que es viable solicitar soporte oficial con los parches que propones.



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1939
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #281 en: 28-04-2016, 12:30 (Jueves) »
Excelente trabajo Tki2000. Es difícil darse cuenta de pequeños errores como ese.

Sobre el wifi, habría que añadir creo el sprom fixup, no sé si se había comentado antes cuando se intentó el soporte para CC.

En los parches, yo añadiría un comentario al lado del ephy_reset_gpio, indicando que es un workaround para el USB, de otra forma podría dar lugar a equívocos en un futuro.

Una vez solucionado lo del wifi, diría que es viable solicitar soporte oficial con los parches que propones.

Me has pillado haciendo una compilación para el fixup...  ;D
Luego comento resultados.
También pondré un comentario en lo del ephy_reset...
Para que aceptaran los parches habría que cambiar cosas. He puesto los datos en mitad de los definidos en lugar de en los últimos lugares, para evitar que al agregar más dispositivos, el parche deje de funcionar... Y cambiar la numeración de los parches del kernel, y a lo mejor unificar los dos parches en uno...
Conforme vaya terminando cosas, iré incorporando los cambios.

Gracias por tu ayuda, danitool. No hay nada, como tener el teléfono del que sabe, para hacer bien las cosas...  ;D

Edito:

Ya hay wifi, manquesea g...

Actualizados los parches, con lo que llevo hasta ahora realizado: https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg344567/#msg344567
« Última modificación: 28-04-2016, 13:15 (Jueves) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Ficht

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #282 en: 28-04-2016, 20:48 (Jueves) »
Excelente trabajo Tki2000. Es difícil darse cuenta de pequeños errores como ese.

Sobre el wifi, habría que añadir creo el sprom fixup, no sé si se había comentado antes cuando se intentó el soporte para CC.

En los parches, yo añadiría un comentario al lado del ephy_reset_gpio, indicando que es un workaround para el USB, de otra forma podría dar lugar a equívocos en un futuro.

Una vez solucionado lo del wifi, diría que es viable solicitar soporte oficial con los parches que propones.

Me has pillado haciendo una compilación para el fixup...  ;D
Luego comento resultados.
También pondré un comentario en lo del ephy_reset...
Para que aceptaran los parches habría que cambiar cosas. He puesto los datos en mitad de los definidos en lugar de en los últimos lugares, para evitar que al agregar más dispositivos, el parche deje de funcionar... Y cambiar la numeración de los parches del kernel, y a lo mejor unificar los dos parches en uno...
Conforme vaya terminando cosas, iré incorporando los cambios.

Gracias por tu ayuda, danitool. No hay nada, como tener el teléfono del que sabe, para hacer bien las cosas...  ;D

Edito:

Ya hay wifi, manquesea g...

Actualizados los parches, con lo que llevo hasta ahora realizado: https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg344567/#msg344567

Vaya Máquinas....   >:( >:(


Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1939
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #283 en: 29-04-2016, 12:37 (Viernes) »
Arregladas un par de cosas en los LEDes.
Los LEDes de power son activos en alto, resto en bajo.

Actualizados los parches, con lo que llevo hasta ahora realizado: https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg344567/#msg344567
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #284 en: 29-04-2016, 13:17 (Viernes) »
Lo que no veo es el status led definido, útil cuando se está inicidando el sistema y muestra el final del inicio al dejar de parpadear.

Sería añadir, ya que tiene dos leds de power, algo tal que así


Edito sí que está, que lo acabo de ver  >:D
Código: [Seleccionar]
VH4032N)
status_led="VH4032N:red:power"
status_led2="VH4032N:blue:power"
;;
en target/linux/brcm63xx/base-files/etc/diag.sh.
Ignoro si quedaría estéticamente bien definir dos status leds, ni idea de como es el parpadeo con dos. En caso de no quedar bien, pues define uno solo, el que se use para el power, que es lo que usa la mayoría.

Lo de usar el alias VH4032N en mayúsculas en los archivos que hacen operaciones en el arranque de Openwrt creo que sería mejor cambiarlo a minúsculas, por guardar coherencia con el resto de placas.
« Última modificación: 29-04-2016, 13:21 (Viernes) por danitool »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1939
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #285 en: 29-04-2016, 13:55 (Viernes) »
Lo que no veo es el status led definido, útil cuando se está inicidando el sistema y muestra el final del inicio al dejar de parpadear.

Sería añadir, ya que tiene dos leds de power, algo tal que así


Edito sí que está, que lo acabo de ver  >:D
Código: [Seleccionar]
VH4032N)
status_led="VH4032N:red:power"
status_led2="VH4032N:blue:power"
;;
en target/linux/brcm63xx/base-files/etc/diag.sh.
Ignoro si quedaría estéticamente bien definir dos status leds, ni idea de como es el parpadeo con dos. En caso de no quedar bien, pues define uno solo, el que se use para el power, que es lo que usa la mayoría.

Lo de usar el alias VH4032N en mayúsculas en los archivos que hacen operaciones en el arranque de Openwrt creo que sería mejor cambiarlo a minúsculas, por guardar coherencia con el resto de placas.

Lo de las mayúsculas no lo empecé yo. Lo he arrastrado del repositorio de gmtii... ¡Qué bueno eso de echarle la culpa a los demás!... Muhahaha  ;D

Luego voy arreglando todo eso, pero tiene que ser a partir del lunes. En breve, hago viaje para celebrar comuniones de familiares, y tal y cual...  ;)
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Ficht

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #286 en: 04-05-2016, 01:22 (Miércoles) »
Lo que no veo es el status led definido, útil cuando se está inicidando el sistema y muestra el final del inicio al dejar de parpadear.

Sería añadir, ya que tiene dos leds de power, algo tal que así


Edito sí que está, que lo acabo de ver  >:D
Código: [Seleccionar]
VH4032N)
status_led="VH4032N:red:power"
status_led2="VH4032N:blue:power"
;;
en target/linux/brcm63xx/base-files/etc/diag.sh.
Ignoro si quedaría estéticamente bien definir dos status leds, ni idea de como es el parpadeo con dos. En caso de no quedar bien, pues define uno solo, el que se use para el power, que es lo que usa la mayoría.

Lo de usar el alias VH4032N en mayúsculas en los archivos que hacen operaciones en el arranque de Openwrt creo que sería mejor cambiarlo a minúsculas, por guardar coherencia con el resto de placas.

Lo de las mayúsculas no lo empecé yo. Lo he arrastrado del repositorio de gmtii... ¡Qué bueno eso de echarle la culpa a los demás!... Muhahaha  ;D

Luego voy arreglando todo eso, pero tiene que ser a partir del lunes. En breve, hago viaje para celebrar comuniones de familiares, y tal y cual...  ;)



Hola..
Los led's de Power, a mi se me quedan apagados... la forma en que me encienden es poner el rojo en 1 y dejar el azul en 0; además de quitar la línea >> default-state = "on"; << [openwrt pacht (./target/linux/brcm63xx/dts/VH4032N.dts) ] Esta forma de arreglarlo, no creo que sea la adecuada, pero tal vez, me ayude a ver que es lo que se pisa

casi ningún cambio se guarda correctamente cuando intento configurar la wifi... esta solo la he podido activar "y muy inestable" con el driver kmod.brcm-wl; con el b43 fallan cosas que no se cuales son, me da la sensación que es alguna parte de código que no se borra nunca....

Al intentar levantar la wifi
Código: [Seleccionar]
[  111.597861] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[  111.667939] CPU 0 Unable to handle kernel paging request at virtual address 00000001, epc == 872aafb8, ra == 872ab040
[  111.678875] Oops[#1]:
[  111.681154] CPU: 0 PID: 1176 Comm: luci Not tainted 4.1.20 #4
  ...
[  111.899857] Call Trace:
[  111.902397] [<872aafb8>] b43_tx_resume+0x780/0x12b0 [b43]
[  111.907962] [<872ab040>] b43_tx_resume+0x808/0x12b0 [b43]
[  111.913487]
[  111.914995]
Code: 27bd0018  8ca20000  24060008 <a0400000> a0400001  8ca20000  8c840000  240500ff  08005368
[  111.926089] ---[ end trace ef6efa3af1f856b0 ]---


y por otra parte, como mas estable lo noto, es compilando en smp en vez de generic...

Pd: al final me funciona la wifi con el b43, pero solo en AP, como cliente no encuentro manera de conf.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1939
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #287 en: 04-05-2016, 08:51 (Miércoles) »
Lo que no veo es el status led definido, útil cuando se está inicidando el sistema y muestra el final del inicio al dejar de parpadear.

Sería añadir, ya que tiene dos leds de power, algo tal que así


Edito sí que está, que lo acabo de ver  >:D
Código: [Seleccionar]
VH4032N)
status_led="VH4032N:red:power"
status_led2="VH4032N:blue:power"
;;
en target/linux/brcm63xx/base-files/etc/diag.sh.
Ignoro si quedaría estéticamente bien definir dos status leds, ni idea de como es el parpadeo con dos. En caso de no quedar bien, pues define uno solo, el que se use para el power, que es lo que usa la mayoría.

Lo de usar el alias VH4032N en mayúsculas en los archivos que hacen operaciones en el arranque de Openwrt creo que sería mejor cambiarlo a minúsculas, por guardar coherencia con el resto de placas.

Lo de las mayúsculas no lo empecé yo. Lo he arrastrado del repositorio de gmtii... ¡Qué bueno eso de echarle la culpa a los demás!... Muhahaha  ;D

Luego voy arreglando todo eso, pero tiene que ser a partir del lunes. En breve, hago viaje para celebrar comuniones de familiares, y tal y cual...  ;)



Hola..
Los led's de Power, a mi se me quedan apagados... la forma en que me encienden es poner el rojo en 1 y dejar el azul en 0; además de quitar la línea >> default-state = "on"; << [openwrt pacht (./target/linux/brcm63xx/dts/VH4032N.dts) ] Esta forma de arreglarlo, no creo que sea la adecuada, pero tal vez, me ayude a ver que es lo que se pisa

casi ningún cambio se guarda correctamente cuando intento configurar la wifi... esta solo la he podido activar "y muy inestable" con el driver kmod.brcm-wl; con el b43 fallan cosas que no se cuales son, me da la sensación que es alguna parte de código que no se borra nunca....

Al intentar levantar la wifi
Código: [Seleccionar]
[  111.597861] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[  111.667939] CPU 0 Unable to handle kernel paging request at virtual address 00000001, epc == 872aafb8, ra == 872ab040
[  111.678875] Oops[#1]:
[  111.681154] CPU: 0 PID: 1176 Comm: luci Not tainted 4.1.20 #4
  ...
[  111.899857] Call Trace:
[  111.902397] [<872aafb8>] b43_tx_resume+0x780/0x12b0 [b43]
[  111.907962] [<872ab040>] b43_tx_resume+0x808/0x12b0 [b43]
[  111.913487]
[  111.914995]
Code: 27bd0018  8ca20000  24060008 <a0400000> a0400001  8ca20000  8c840000  240500ff  08005368
[  111.926089] ---[ end trace ef6efa3af1f856b0 ]---


y por otra parte, como mas estable lo noto, es compilando en smp en vez de generic...

Pd: al final me funciona la wifi con el b43, pero solo en AP, como cliente no encuentro manera de conf.

A mí no me peta la wifi con b43, y he podido usar el modo cliente para engancharme a otra red y salir a internet.
Prueba a hacer un make clean antes de compilar de nuevo.

Te pongo unas pruebas que he compilado, por si quieres echarles un vistazo: https://www.mediafire.com/?2wmxqbxnse3amxk.
El fichero de 16MB es para flashear a través de la web del CFE. El más pequeño es para flashear a través de luci/sysupgrade.

Con respecto a lo de los LEDes de power. Es la única manera de que al decirle al LED que se encienda, se encienda, y al decirle que se apague, se apague. Si lo defines como activo en bajo, al decirle que se encienda, se apaga, y al decirle que se apague, se enciende.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1939
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #288 en: 06-05-2016, 09:33 (Viernes) »
Le he remitido a danitool los parches, modificando las partes que pensamos que son problemáticas para que las acepten, porque están hechas a cañón, y pisarían los procedimientos de otros routers.
Más concretamente, la parte del pinmux, para que las luces del switch parpadeen con la actividad de la red, se han quitado, ya que formarán parte de otro arreglo a nivel general.

Hoy han salido a la luz parte de los parches para dar soporte a este router en la rama oficial de OpenWrt. Falta que los acepten, sin tiempo predefinido. https://patchwork.ozlabs.org/patch/618936/

De momento, si queréis que las luces del switch parpadeen, podéis utilizar el parche que tengo colgado unos posts antes.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

hawai50

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #289 en: 06-05-2016, 16:26 (Viernes) »
Es una buena noticia, espero que los incorporen pronto
Gracias por el trabajo

Ficht

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #290 en: 06-05-2016, 21:30 (Viernes) »
Le he remitido a danitool los parches, modificando las partes que pensamos que son problemáticas para que las acepten, porque están hechas a cañón, y pisarían los procedimientos de otros routers.
Más concretamente, la parte del pinmux, para que las luces del switch parpadeen con la actividad de la red, se han quitado, ya que formarán parte de otro arreglo a nivel general.

Hoy han salido a la luz parte de los parches para dar soporte a este router en la rama oficial de OpenWrt. Falta que los acepten, sin tiempo predefinido. https://patchwork.ozlabs.org/patch/618936/

De momento, si queréis que las luces del switch parpadeen, podéis utilizar el parche que tengo colgado unos posts antes.

Fantástico!!! Buen Trabajo!!!

danto

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #291 en: 13-05-2016, 17:18 (Viernes) »
Felicidades!

Con esto se evita la obsolescencia de mucho hardware. Un router con openwrt es un router para muchísimos años.

Un saludo.

kero18

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #292 en: 14-05-2016, 00:39 (Sábado) »
primero que todo quiero agradecerles a todos por todo el esfuerzo y tiempo que han invertido en este router, por que gracias a ustedes y a que conseguí uno de segunda mano me pude meter en el mundo de openwrt y aprender.

aclaro que de openwrt aun tengo muy poca idea pero me estoy haciendo.

y espero que pronto tengamos este router soportado oficialmente.


kero18

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #293 en: 14-05-2016, 19:29 (Sábado) »
Le he remitido a danitool los parches, modificando las partes que pensamos que son problemáticas para que las acepten, porque están hechas a cañón, y pisarían los procedimientos de otros routers.
Más concretamente, la parte del pinmux, para que las luces del switch parpadeen con la actividad de la red, se han quitado, ya que formarán parte de otro arreglo a nivel general.

Hoy han salido a la luz parte de los parches para dar soporte a este router en la rama oficial de OpenWrt. Falta que los acepten, sin tiempo predefinido. https://patchwork.ozlabs.org/patch/618936/

De momento, si queréis que las luces del switch parpadeen, podéis utilizar el parche que tengo colgado unos posts antes.



Perdona mi ignorancia pero para bajar el código fuente para compilar la versión 49199 como tú cómo puedo hacerlo? Por que intente bajar el código fuente pero al aplicar tus parches nose si hize algo mal pero no me apareció para compilar para este modelo, ni supe cómo ver que revisión fuentes de openwrt estaba bajando. Y estuve buscando pero no e ubicado la dirección de la revisión 49199 para aplicar correctamente tus parches así q intente con la última versión del trunk.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1939
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #294 en: 14-05-2016, 21:15 (Sábado) »
Le he remitido a danitool los parches, modificando las partes que pensamos que son problemáticas para que las acepten, porque están hechas a cañón, y pisarían los procedimientos de otros routers.
Más concretamente, la parte del pinmux, para que las luces del switch parpadeen con la actividad de la red, se han quitado, ya que formarán parte de otro arreglo a nivel general.

Hoy han salido a la luz parte de los parches para dar soporte a este router en la rama oficial de OpenWrt. Falta que los acepten, sin tiempo predefinido. https://patchwork.ozlabs.org/patch/618936/

De momento, si queréis que las luces del switch parpadeen, podéis utilizar el parche que tengo colgado unos posts antes.



Perdona mi ignorancia pero para bajar el código fuente para compilar la versión 49199 como tú cómo puedo hacerlo? Por que intente bajar el código fuente pero al aplicar tus parches nose si hize algo mal pero no me apareció para compilar para este modelo, ni supe cómo ver que revisión fuentes de openwrt estaba bajando. Y estuve buscando pero no e ubicado la dirección de la revisión 49199 para aplicar correctamente tus parches así q intente con la última versión del trunk.


¿Por qué no utilizas la prueba que compilé unos posts más atrás? A no ser que quieras meterle algo más, te puede ser de ayuda.
El repositorio lo tengo un poco parado. Hice una compilación con un disco duro virtual de 32GB y se me llenó, así que tengo que migrarlo a otro de más capacidad, y como tengo otras cosas que hacer, lo voy dejando. De todas formas espero tenerlo todo compilado en unos días.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Ficht

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #295 en: 14-05-2016, 23:25 (Sábado) »
Le he remitido a danitool los parches, modificando las partes que pensamos que son problemáticas para que las acepten, porque están hechas a cañón, y pisarían los procedimientos de otros routers.
Más concretamente, la parte del pinmux, para que las luces del switch parpadeen con la actividad de la red, se han quitado, ya que formarán parte de otro arreglo a nivel general.

Hoy han salido a la luz parte de los parches para dar soporte a este router en la rama oficial de OpenWrt. Falta que los acepten, sin tiempo predefinido. https://patchwork.ozlabs.org/patch/618936/

De momento, si queréis que las luces del switch parpadeen, podéis utilizar el parche que tengo colgado unos posts antes.



Perdona mi ignorancia pero para bajar el código fuente para compilar la versión 49199 como tú cómo puedo hacerlo? Por que intente bajar el código fuente pero al aplicar tus parches nose si hize algo mal pero no me apareció para compilar para este modelo, ni supe cómo ver que revisión fuentes de openwrt estaba bajando. Y estuve buscando pero no e ubicado la dirección de la revisión 49199 para aplicar correctamente tus parches así q intente con la última versión del trunk.


Hola... prueba hacerlo en este orden.

1 git repo trunk
2 compilar por ejemplo hg556a... (y no eliminar nada)
3 aplicar parches Tki2000  (los parches han de estar en el directorio openwrt)
4 eliminar la configuracion actual 
rm -rf .config .config.old
5 compilar VH4032N

De este modo, debería funcionar.

robhunter

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #296 en: 15-05-2016, 01:04 (Domingo) »
Buenas acabo de compilar mi propio kernel y ha flasheado correctamente pero no me escanea ninguna red :( algo me dejaría por el camino. Total, que me he bajado el compilado de más arriba de @Tki2000 y perfecto, ya escanea redes, pero tengo una duda, este router se supone que tenia 2.4 y 5 GHz, o al menos en su verisón de fabrica podía crear dos redes a dichas frecuencias.

En Openwrt no solo no me deja crear un wifi a 5 GHz, si no que tampoco me escanea redes a 5 GHz pera hacer un puente. La idea es hacer un puente entre el router malisimo de movistar ftth por los 5ghz de wifi y el vh4032n para que me lleguen velocidades decentes, ya que ahora tengo un wa830re y solo soporta 2.4, así que poca velocidad por wifi cojo.

Alguna pista sobre por qué ocurre esto?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1939
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #297 en: 15-05-2016, 08:03 (Domingo) »
Buenas acabo de compilar mi propio kernel y ha flasheado correctamente pero no me escanea ninguna red :( algo me dejaría por el camino. Total, que me he bajado el compilado de más arriba de @Tki2000 y perfecto, ya escanea redes, pero tengo una duda, este router se supone que tenia 2.4 y 5 GHz, o al menos en su verisón de fabrica podía crear dos redes a dichas frecuencias.

En Openwrt no solo no me deja crear un wifi a 5 GHz, si no que tampoco me escanea redes a 5 GHz pera hacer un puente. La idea es hacer un puente entre el router malisimo de movistar ftth por los 5ghz de wifi y el vh4032n para que me lleguen velocidades decentes, ya que ahora tengo un wa830re y solo soporta 2.4, así que poca velocidad por wifi cojo.

Alguna pista sobre por qué ocurre esto?

El router no tiene bien soportada la wifi, ya que es Broadcom, la compilacón tiene el
 driver b43, que sólo se puede utilizar en modo g.
Eres libre de compilar y probar otros drivers. Yo en su momento no conseguí hacerlos funcionar. Además, este router, con ese tipo de wifi, evidentemente no lo utilizo por su wifi.
Openwrt y wifi Broadcom es mala combinación. No esperes poder usarlo de repetidor.
De todas formas, si quieres probar con el driver propietario, cambia el b43 por el propietario de Broadcom.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

kero18

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #298 en: 15-05-2016, 11:26 (Domingo) »
Le he remitido a danitool los parches, modificando las partes que pensamos que son problemáticas para que las acepten, porque están hechas a cañón, y pisarían los procedimientos de otros routers.
Más concretamente, la parte del pinmux, para que las luces del switch parpadeen con la actividad de la red, se han quitado, ya que formarán parte de otro arreglo a nivel general.

Hoy han salido a la luz parte de los parches para dar soporte a este router en la rama oficial de OpenWrt. Falta que los acepten, sin tiempo predefinido. https://patchwork.ozlabs.org/patch/618936/

De momento, si queréis que las luces del switch parpadeen, podéis utilizar el parche que tengo colgado unos posts antes.



Perdona mi ignorancia pero para bajar el código fuente para compilar la versión 49199 como tú cómo puedo hacerlo? Por que intente bajar el código fuente pero al aplicar tus parches nose si hize algo mal pero no me apareció para compilar para este modelo, ni supe cómo ver que revisión fuentes de openwrt estaba bajando. Y estuve buscando pero no e ubicado la dirección de la revisión 49199 para aplicar correctamente tus parches así q intente con la última versión del trunk.


¿Por qué no utilizas la prueba que compilé unos posts más atrás? A no ser que quieras meterle algo más, te puede ser de ayuda.
El repositorio lo tengo un poco parado. Hice una compilación con un disco duro virtual de 32GB y se me llenó, así que tengo que migrarlo a otro de más capacidad, y como tengo otras cosas que hacer, lo voy dejando. De todas formas espero tenerlo todo compilado en unos días.


Exactamente por eso mismo creo necesitar compilarlo yo mismo, por que e probado tu compilación y va de maravillas y quería agregarle unas cosas más para unas pruebas que quiero hacer y no encontré otra forma de hacerlo que compilar yo mismo.
Ahora probare si logro hacer funcionar los parches que subiste haber si funca jej

Gracias!!

zoylorino

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #299 en: 15-05-2016, 20:16 (Domingo) »
Hola. He instalado el firmware puesto por tki200 y parece ir todo bien: wifi, usb switch... Pero no logro descargar nuevos paquetes, parece que openwrt ya no soporta http y por https el wget me da un error de ssl.
¿Le pasa a alguien?. Gracias