Autor Tema: [Desarrollo] OpenWrt en Huawei HG622  (Leído 49561 veces)

0 Usuarios y 1 Visitante están viendo este tema.

zorrua

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #60 en: 16-12-2013, 23:26 (Lunes) »
Buenas, gracias por responder.

Si, cuando decia lo del JTAG, me referia al serial, asi que seguire desmontado el router, xD.

En que repositorio has hecho los cambios? En el que esta en el primer post?

Gracias y hasta pronto.



Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #61 en: 17-12-2013, 00:13 (Martes) »
Buenas, gracias por responder.

Si, cuando decia lo del JTAG, me referia al serial, asi que seguire desmontado el router, xD.

En que repositorio has hecho los cambios? En el que esta en el primer post?

Gracias y hasta pronto.
En este:
https://github.com/Pteridium/Attitude-Adjustment-ARV4518PWR01
Para descargarlo seguro que ya sabes.  ;)

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1940
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #62 en: 01-01-2014, 22:47 (Miércoles) »
Hola.

Ya que éste es el hilo de desarrollo del HG622 a ver si alguien me puede responder a esto que me está volviendo loco:
El bootloader del HG622 tiene un timeout que hace que a los pocos segundos de haberlo parado se resetee y vuelva a ejecutarse la rutina de carga con lo que hacer algo en poco menos que 15 segundos es una odisea. ¿Alguien sabe cómo quitar ese timeout o watchdog o lo que sea?

Esto es lo que aparece al pulsar una tecla para parar la carga y cómo a los pocos segundos se resetea y vuelve a reiniciarse:

*** Press any key to stop auto run (3 seconds) ***
Auto run second count down: 1
web info: Waiting for connection on socket 0.
CFE>
CFE timeout,reboot

Resetting board...

CFE version 1.0.37-102.6 for BCM96368 (32bit,SP,BE)
Build Date: Mon May 30 22:11:43 CST 2011 (wangzhiquan@whg.build.huawei.com)

Parallel flash device: name AM29LV320MT, id 0x2201, size 16384KB
CPU type 0x2A031: 400MHz, Bus: 160MHz, Ref: 64MHz
CPU running TP0
Total memory: 33554432 bytes (32MB)
Boot Address 0xb8000000

« Última modificación: 01-01-2014, 22:48 (Miércoles) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1940
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #63 en: 02-01-2014, 13:50 (Jueves) »
Al fin he tenido éxito para flashear openWRT en un HG622.

Después de más de 30 intentos en que todas las transmisiones por TFTP se cortaban por el dichoso timeout he conseguido una transmisión completa y se ha puesto a quemar la flash. Mi miedo era que en mitad del quemado hiciera un timeout y mandara el router a hacer gárgaras, pero parece que al ponerse a quemar la flash el timeout no sucede.

No sé tampoco si tendrá que ver o no pero no he utilizado el comando "f" a secas, sino
"f 192.168.1.100:bcm963xx_fs_kernel" con en el que le podemos decir el servidor para conectarnos y el fichero a quemar (sí, ya sé que son los parámetros por defecto pero al ponérselos ha funcionado), por supuesto haciendo un corta pega en el Hyperterminal de Windows porque sino no da tiempo a teclear.

Ahora que tengo el openWRT en el router espero no tener que volver a utilizar este dichoso bootloader  :P
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

zorrua

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #64 en: 05-01-2014, 12:14 (Domingo) »
Al fin he tenido éxito para flashear openWRT en un HG622.

Después de más de 30 intentos en que todas las transmisiones por TFTP se cortaban por el dichoso timeout he conseguido una transmisión completa y se ha puesto a quemar la flash. Mi miedo era que en mitad del quemado hiciera un timeout y mandara el router a hacer gárgaras, pero parece que al ponerse a quemar la flash el timeout no sucede.

No sé tampoco si tendrá que ver o no pero no he utilizado el comando "f" a secas, sino
"f 192.168.1.100:bcm963xx_fs_kernel" con en el que le podemos decir el servidor para conectarnos y el fichero a quemar (sí, ya sé que son los parámetros por defecto pero al ponérselos ha funcionado), por supuesto haciendo un corta pega en el Hyperterminal de Windows porque sino no da tiempo a teclear.

Ahora que tengo el openWRT en el router espero no tener que volver a utilizar este dichoso bootloader  :P

Hola,

¿que version de OpenWRT has instalado? ¿la ultima de Noltari?

Si es asi, puedes subir la imagen para poder probarla?

Lo "malo" de este router es que es necesario abrir y conectar los cablecitos para poder flashear.

Gracias y hasta pronto.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1940
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #65 en: 05-01-2014, 14:32 (Domingo) »

Hola,

¿que version de OpenWRT has instalado? ¿la ultima de Noltari?

Si es asi, puedes subir la imagen para poder probarla?

Lo "malo" de este router es que es necesario abrir y conectar los cablecitos para poder flashear.

Gracias y hasta pronto.

Sí, es la que hay en el hilo Barrier Breaker 13.12 https://foro.seguridadwireless.net/openwrt/%28repositorio%29-barrier-breaker-13-12/

Hay un par de cosas que no me terminan de ir bien, como he comentado en ese hilo.
Si quieres probarla mándame un privado.

Un saludo.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

zorrua

  • Visitante
Re:
« Respuesta #66 en: 12-04-2014, 14:53 (Sábado) »
Buenas,

Alguien tiene alguna compilacion con 14.04? Dicen que en otros routers va muy bien.

Saludos.

cristian16291

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #67 en: 10-05-2014, 20:00 (Sábado) »
Buenas alguien sabes si es posible meter este firm desde windows de alguna manera ?? Tengo este router con jazztel y me gustaria tener mas opciones en el.Un saludo y gracias

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #68 en: 10-05-2014, 21:02 (Sábado) »
Buenas alguien sabes si es posible meter este firm desde windows de alguna manera ?? Tengo este router con jazztel y me gustaria tener mas opciones en el.Un saludo y gracias
Perderías el xDSL.

Saludos.

zorrua

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #69 en: 13-08-2014, 12:44 (Miércoles) »
Buenas,

¿Se sigue con el desarrollo de este router?

He visto que otros routers parecidos estan siendo añadidos al repositorio oficial de openwrt, pero de este hace mucho que no tengo noticias.

Saludos a todos.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #70 en: 13-08-2014, 23:10 (Miércoles) »
Sí, pero Noltari necesita un "conejillo de indias" para probar los parches.
Si todo va ok se añade (o ese es el plan, creo recordar).

zorrua

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #71 en: 14-08-2014, 23:20 (Jueves) »
Yo podria probar alguna imagen.

Los parches donde estan?

Saludos.

zorrua

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #72 en: 29-01-2015, 22:18 (Jueves) »
Sigo estando disponible para hacer de "conejillo de indias" para probar los parches.

Ya se ha añadido el codigo a OpenWRT?

Gracias por todo y hasta pronto.

Saludos.

zorrua

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #73 en: 31-01-2015, 21:21 (Sábado) »
Muy buenas,

Estoy intentando compilar una imagen para este router, lo he probado con este repositorio:

https://github.com/Pteridium/openwrt/tree/bcm63xx-r36529

Al hacer el "./scripts/feeds update -a" me da estos problemas con repositorios:

Código: [Seleccionar]
Updating feed 'luci' from 'git://github.com/Noltari/openwrt-luci.git;r9812' ...
Cloning into './feeds/luci'...
fatal: remote error:
  Repository not found.
failed.
Updating feed 'routing' from 'git://github.com/Noltari/openwrt-routing.git;b2ff4782d06d779c22e2b66f60afca3ece9261fe' ...
Cloning into './feeds/routing'...
warning: Could not find remote branch b2ff4782d06d779c22e2b66f60afca3ece9261fe to clone.
fatal: Remote branch b2ff4782d06d779c22e2b66f60afca3ece9261fe not found in upstream origin
failed.
Updating feed 'telephony' from 'git://github.com/Noltari/openwrt-telephony.git;facfafb4c6dba388dd44ccf76bc5917cc77bbbf2' ...
Cloning into './feeds/telephony'...
fatal: remote error:
  Repository not found.
failed.

Y al compilar me da este otro error:

Código: [Seleccionar]
 perl scripts/headers_install.pl /root/openwrt-abandoned-bcm63xx-r36529/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.8.11/user_headers/include/linux/wimax mips
  /root/openwrt-abandoned-bcm63xx-r36529/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.8.11/include/uapi/linux/wimax/i2400m.h ;
for F in ; do echo "#include <asm-generic/$F>" > /root/openwrt-abandoned-bcm63xx-r36529/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.8.11/user_headers/include/linux/wimax/$F;
done; touch /root/openwrt-abandoned-bcm63xx-r36529/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.8.11/user_headers/include/linux/wimax/.install
make[7]: execvp: /bin/sh: Argument list too long
make[7]: *** [/root/openwrt-abandoned-bcm63xx-r36529/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.8.11/user_headers/include/linux/.install] Error 127
make[6]: *** [linux] Error 2
make[5]: *** [headers_install] Error 2
make[5]: Leaving directory `/root/openwrt-abandoned-bcm63xx-r36529/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.8.11'
make[4]: *** [/root/openwrt-abandoned-bcm63xx-r36529/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.8.11/.configured] Error 2
make[4]: Leaving directory `/root/openwrt-abandoned-bcm63xx-r36529/target/linux/brcm63xx'
make[3]: *** [compile] Error 2
make[3]: Leaving directory `/root/openwrt-abandoned-bcm63xx-r36529/target/linux'
make[2]: *** [target/linux/compile] Error 2
make[2]: Leaving directory `/root/openwrt-abandoned-bcm63xx-r36529'
make[1]: *** [/root/openwrt-abandoned-bcm63xx-r36529/staging_dir/target-mips_uClibc-0.9.33.2/stamp/.target_compile] Error 2
make[1]: Leaving directory `/root/openwrt-abandoned-bcm63xx-r36529'
make: *** [world] Error 2

Despues he probado con este repositorio:

https://github.com/Pteridium/Attitude-Adjustment-ARV4518PWR01

Pero el compilar me da este otro error:

Código: [Seleccionar]
WARNING: skipping libipq -- package not selected
make[3]: Leaving directory `/root/Attitude-Adjustment-ARV4518PWR01-master/package/iptables'
make[2]: Leaving directory `/root/Attitude-Adjustment-ARV4518PWR01-master'
make[1]: *** [/root/Attitude-Adjustment-ARV4518PWR01-master/staging_dir/target-mips_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/root/Attitude-Adjustment-ARV4518PWR01-master'
make: *** [world] Error 2

¿Desde que repositorio puedo compilar? ¿Alguien tiene alguna imagen que le funcione?

Saludos.
« Última modificación: 01-02-2015, 11:56 (Domingo) por jar229 »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1940
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #74 en: 01-02-2015, 09:46 (Domingo) »
« Última modificación: 01-02-2015, 09:50 (Domingo) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

zorrua

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #75 en: 01-02-2015, 13:32 (Domingo) »
Intenta utilizar este: https://foro.seguridadwireless.net/openwrt/(repositorio)-barrier-breaker-13-12/msg298190/#msg298190

También puedes intentar este, aunque Noltari no dice expresamente si está soportado: https://foro.seguridadwireless.net/openwrt/(repositorio)-barrier-breaker-14-07-rc3/msg314613/#msg314613

Gracias, he descargado los dos repositorios y si hago un [grep -r "hg622" .], solo tengo codigo de este router en este repositorio:

git clone git://github.com/openwrt-es/barrier-breaker-openwrt.git -b barrier-breaker_13.12

En el otro repositorio no tnego nada.

Voy a compilar y a ver como va, os tendre informados.

Gracias por la ayuda.

Saludos.

zorrua

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #76 en: 01-02-2015, 15:01 (Domingo) »
Buenas, ya he compilado una imagen desde este repositorio:

git clone git://github.com/openwrt-es/barrier-breaker-openwrt.git -b barrier-breaker_13.12

El problema lo tengo para poder flashear desde el CFE. He configura el TFTP en el 192.168.1.100, pero cuando le doy al comando "f" me da esto:

Código: [Seleccionar]
CFE> f
Loading 192.168.1.100:bcm963xx_fs_kernel ...
Loading failed.: CFE error -21
*** command status = -21

He probado con otra imagen que existe en este post, pero me da el mismo error.

Si dejo que arranque me da esto:

Código: [Seleccionar]
CFE>
CFE timeout,reboot

Resetting board...

CFE version 1.0.37-102.6 for BCM96368 (32bit,SP,BE)
Build Date: Sun Jul 24 16:58:20 CST 2011 (wangxinfeng@build.huawei.com)
Copyright (C) 2000-2008 Broadcom Corporation.

Parallel flash device: name AM29LV320MT, id 0x2201, size 16384KB
CPU type 0x2A031: 400MHz, Bus: 160MHz, Ref: 64MHz
CPU running TP0
Total memory: 33554432 bytes (32MB)
Boot Address 0xb8000000


Board IP address                  : 192.168.1.1:ffffff00 
Host IP address                   : 192.168.1.100 
Gateway IP address                :   
Run from flash/host (f/h)         : f 
Default host run file name        : vmlinux 
Default host flash file name      : bcm963xx_fs_kernel 
Boot delay (0-9 seconds)          : 3 
Boot image (0=latest, 1=previous) : 0 
Board Id (0-5)                    : 96368MVWG_hg622 
Number of MAC Addresses (1-32)    : 11 
Base MAC Address                  : 00:e0:fc:xx:xx:xx  (lo oculto)
PSI Size (1-64) KBytes            : 64 
Main Thread Number [0|1]          : 0 

*** Press any key to stop auto run (3 seconds) ***
Auto run second count down: 0

 Support Double system.

Flash boot Flag:
Boot from main system!
Linux kernel CRC error.  Corrupted image? ../../../cfe/arch/mips/board/bcm63xx_ram/src/bcm63xx_cmd.c 749

 Image error !Entry address:0xffffffff puiCmpImage:0xb8010100

 Double system MAIN boot failed !

MAIND first Double Image is error boot failed !

System can not boot,go to CFE
web info: Waiting for connection on socket 0.

Me falta por configurar algo?

Gracias por todo y hasta pronto.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #77 en: 01-02-2015, 15:46 (Domingo) »
A mi me da la sensación que el problema está en tu ordenador. Funciona bien el servidor TFTP?

A veces podría ocurrir que si CFE no encuentra una imagen sana, éste se queda atontado y puede fallar a la hora de enviarle otros comandos, no es probable pero sí posible. Me ocurrió cierta vez con otro router diferente a este.

Supongo que este CFE no tiene interfaz web. He visto varios posts más atrás que tienes un adaptador JTAG que funciona con este router. Creo que podría compilar un CFE para esta placa  con interfaz web, si te interesa probar asumiendo los riesgos que implica jugar con el bootloader.

Saludos.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1940
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #78 en: 01-02-2015, 16:48 (Domingo) »
@zorrua: es curioso; tenemos el mismo bootloader 1.0.37-102.6, pero con ditinta fecha y compilación
Código: [Seleccionar]
Build Date: Mon May 30 22:11:43 CST 2011 wangzhiquan@whg.build.huawei.com
El caso es que mi bootloader se resetea en 15 segundos y apenas da tiempo a teclear nada antes de que se haga un reset. Cargar algo por TFTP es una carrera contrarreloj y muchas veces no me da tiempo a teclear el comando completo.  :-\
También me pasaba que openwrt sólo podía quemarlo a través del bootloader. Si lo intentaba a través de luci acababa en ladrillo y tenía que volver a quemar la misma imagen a través del CFE.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG622
« Respuesta #79 en: 01-02-2015, 20:48 (Domingo) »
Como andaba metido de lleno en el tema de CFE, decidí compilar uno para esta placa concreta con board ID 96368MVWG_hg622

https://drive.google.com/open?id=0B-EMoBe-_OdBSktXd0d5bHF6RGs&authuser=0

Está absolutamente sin testear. ¿Algún valiente?  ;D



También compilé una versión RAM la cual es inofensiva si se quiere probar:
https://drive.google.com/open?id=0B-EMoBe-_OdBSUdLelZmMHVIdzQ&authuser=0

Para ello bastaria con soltar el archivo en el directorio del server TFTP y ejecutar en CFE
Código: [Seleccionar]
r 192.168.1.100:cfe6368_ramSi podrá arrancar otro CFE, ni idea... y no, no sería indicativo de que la versión ROM CFE para flashear funcionase correctamente, pero habría muchas probabilidades.