Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1924397 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1640 en: 11-09-2013, 12:08 (Miércoles) »
Compilación r37937Kernel 3.10.10, FPU Emulation, LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, mountd (aumontaje de discos), transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, aircrack-ng, wireless-utils, Reaver (ataque al protocolo WPS), Bully (software alternativo a Reaver), htop, wavemon, cifsmount (montaje de carpetas compartidas en red), block-mount, screen, swap-utils, etc.

Debería funcionar en routers con chipset atheros o ralink, pero yo sólo he podido testearla en el primero  ^-^



eskasi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1641 en: 13-09-2013, 12:26 (Viernes) »
Me gustaria probar esa compilacion r37937 o cualquier otra reciente, pero siempre acabo flasheando el backport a backfire de danitool .

No conozco porque mi hg556a se resiste al flasheo, pero en el syslog he visto algo como que "cowardly refusing to erase jffs" ..y alguna linea antes de que no se encuentra el marker jffs.

Creo que alguien mas le paso. Alguna idea de como solucionarlo?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1642 en: 13-09-2013, 12:49 (Viernes) »
Me gustaria probar esa compilacion r37937 o cualquier otra reciente, pero siempre acabo flasheando el backport a backfire de danitool .

No conozco porque mi hg556a se resiste al flasheo, pero en el syslog he visto algo como que "cowardly refusing to erase jffs" ..y alguna linea antes de que no se encuentra el marker jffs.

Creo que alguien mas le paso. Alguna idea de como solucionarlo?

Como instalas el firmware ?

manuelacantasaetas

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1643 en: 13-09-2013, 15:07 (Viernes) »
http://wiki.openwrt.org/toh/huawei/hg556a

If after upgrading OpenWrt you get the message:

jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes

And you can't save changes. Enter OpenWrt failsafe mode if needed. Then execute this command:

mtd erase -r rootfs_data && reboot

eskasi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1644 en: 13-09-2013, 18:08 (Viernes) »
Muchas gracias. Probare y ya comentare el resultado.

Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1645 en: 16-09-2013, 08:02 (Lunes) »
Compilación r37937Kernel 3.10.10, FPU Emulation, LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, mountd (aumontaje de discos), transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, aircrack-ng, wireless-utils, Reaver (ataque al protocolo WPS), Bully (software alternativo a Reaver), htop, wavemon, cifsmount (montaje de carpetas compartidas en red), block-mount, screen, swap-utils, etc.

Debería funcionar en routers con chipset atheros o ralink, pero yo sólo he podido testearla en el primero  ^-^

Funcionando en un Atheros.

¿Podrías poner una pequeña introducción para usar Bully?

HE visto tu comando:
bully mon0 -b 38:72:C0:XX:XX:XX -e JAZZTEL_5782 -c 11

Donde está la MAC ¿Es la queremos atacar?,  el SSID y el canal de la red que quieres atacar pero no se que es mon0.

Yo he probado:

bully radio0 -b 00:26:0B:XX:XX:XX -e JAZZTEL_1234 -c 8

Y me dice:
Unable to get hardware MAC Address for 'radio0'
Please specify --source for the interface

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1646 en: 16-09-2013, 08:24 (Lunes) »
Para usar bully, necesitas una interfaz en modo monitor.

Puedes ponerla desde LuCi o desde putty:

Código: [Seleccionar]
airmon-ng start wlan0
Después de esto, tu interfaz en modo monitor será mon0

Para escanear redes con WPS activo:

Código: [Seleccionar]
wash -i mon0 -C
Y para lanzar el ataque:

Código: [Seleccionar]
bully mon0 -b 38:72:C0:XX:XX:XX -e JAZZTEL_5782 -c 11
-b: indicamos la MAC del AP
-e: el nombre de la red
-c: el canal

Hay muchísimas más opciones

Código: [Seleccionar]
root@OpenWrt:~# bully

  usage: bully <options> interface

  Required arguments:

      interface      : Wireless interface in monitor mode (root required)

      -b, --bssid macaddr    : MAC address of the target access point
   Or
      -e, --essid string     : Extended SSID for the access point

  Optional arguments:

      -c, --channel N[,N...] : Channel number of AP, or list to hop [b/g]
      -i, --index N          : Index of starting pin (7 digits)    [Auto]
      -l, --lockwait N       : Seconds to wait if the AP locks WPS   [43]
      -p, --pin N            : Starting pin number (7 digits)      [Auto]
      -s, --source macaddr   : Source (hardware) MAC address      [Probe]
      -v, --verbosity N      : Verbosity level 1-3, 1 is quietest     [3]
      -w, --workdir          : Location of pin/session files  [~/.bully/]
      -5, --5ghz             : Hop on 5GHz a/n default channel list  [No]
      -F, --fixed            : Fixed channel operation (do not hop)  [No]
      -S, --sequential       : Sequential pins (do not randomize)    [No]
      -T, --test             : Test mode (do not inject any packets) [No]

  Advanced arguments:

      -a, --acktime N        : Acknowledgement and pcap timeout (ms) [25]
      -r, --retries N        : Resend packets N times when not acked  [2]
      -m, --m13time N        : M1/M3/Initial beacon timeout (ms)   [2000]
      -t, --timeout N        : Timeout for Auth/Assoc/Id/M5/M7 (ms) [200]
      -1, --pin1delay M,N    : Delay M seconds every Nth nack at M5 [0,1]
      -2, --pin2delay M,N    : Delay M seconds every Nth nack at M7 [5,1]
      -A, --noacks           : Disable ACK check for sent packets    [No]
      -C, --nocheck          : Skip CRC/FCS validation (performance) [No]
      -D, --detectlock       : Detect WPS lockouts unreported by AP  [No]
      -E, --eapfail          : EAP Failure terminate every exchange  [No]
      -L, --lockignore       : Ignore WPS locks reported by the AP   [No]
      -M, --m57nack          : M5/M7 timeouts treated as WSC_NACK's  [No]
      -N, --nofcs            : Packets don't contain the FCS field [Auto]
      -P, --probe            : Use probe request for nonbeaconing AP [No]
      -R, --radiotap         : Assume radiotap headers are present [Auto]
      -W, --windows7         : Masquerade as a Windows 7 registrar   [No]
      -h, --help             : Display this help information


Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1647 en: 16-09-2013, 08:43 (Lunes) »
Hago eso y ya empieza el ataque pero siempre está probando con el mismo pin '35187585'. Lleva un rato y no cambia.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1648 en: 16-09-2013, 09:43 (Lunes) »
Hago eso y ya empieza el ataque pero siempre está probando con el mismo pin '35187585'. Lleva un rato y no cambia.

Eso puede ser debido a muchísimas cosas ... problemas de señal, alguna medida de protección del AP, etc.

En la compilación tienes incluído reaver, por si quieres probarlo.

Tanto de bully, como de reaver, tienes muchísima información en el foro  ;)


Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1649 en: 16-09-2013, 10:03 (Lunes) »
OK. Seguiré bicheando.

Gran

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #1650 en: 16-09-2013, 10:28 (Lunes) »
Tras un fin de semana trasteando con el HG556a, no consigo solucionar el problema. Hago la consulta después de leer y releer, y no  encontrar solución.

He conseguido instalar openwrt en el hg556a con chip ralink. El firmware que he metido r37180, el primero del hilo (compilado gracias a los foreros).
Quiero poner el hg556a en modo cliente de mi router principal. Quiero recoger señal por tarjeta usb y repartirla por wifi con el hg556, a modo de punto de acceso.

El caso es que no me reconoce el chip interno wifi del hg556a, no me aparece radio, ni siquiera la pestaña wifi dentro de network (en LuCI).
Sin embargo cuando conecto una tarjeta inalambrica por usb (alfa con chip rtl8187), me la reconoce perfectamente y funciona. Es decir, haciendo pruebas, consigo poner el hg556a en modo cliente recibiendo wifi por la tarjeta usb y salida como punto acceso via ethernet. Funcionando perfectamente.

Se os ocurre algo? Puede ser problema de la compilación que he instalado?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #1651 en: 16-09-2013, 11:19 (Lunes) »
Tras un fin de semana trasteando con el HG556a, no consigo solucionar el problema. Hago la consulta después de leer y releer, y no  encontrar solución.

He conseguido instalar openwrt en el hg556a con chip ralink. El firmware que he metido r37180, el primero del hilo (compilado gracias a los foreros).
Quiero poner el hg556a en modo cliente de mi router principal. Quiero recoger señal por tarjeta usb y repartirla por wifi con el hg556, a modo de punto de acceso.

El caso es que no me reconoce el chip interno wifi del hg556a, no me aparece radio, ni siquiera la pestaña wifi dentro de network (en LuCI).
Sin embargo cuando conecto una tarjeta inalambrica por usb (alfa con chip rtl8187), me la reconoce perfectamente y funciona. Es decir, haciendo pruebas, consigo poner el hg556a en modo cliente recibiendo wifi por la tarjeta usb y salida como punto acceso via ethernet. Funcionando perfectamente.

Se os ocurre algo? Puede ser problema de la compilación que he instalado?

Pues con esa compilación debería funcionarte. Pero ... postea un dmesg a ver si vemos algo raro.

Te muevo el post al hilo del hg556a.

Gran

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1652 en: 16-09-2013, 13:16 (Lunes) »
Gracias jar229

No me colguéis aún :-[ pero nunca he hecho dmesg y no se como hacerlo para facilitártelo.

Rebuscando por el foro, veo que accediendo al router via telnet se puede hacer:
telnet 192.168.x.x
dmesg > /www/dmesg.txt
Después desde el navegador:
http://192.168.x.x/dmesg.txt para copiar el archivo. ¿Es correcto?

Primer problema que se me plantea, no puedo acceder de manera local al router vía telnet, en realidad nunca lo he hecho por no hacerme falta.
Lo que hago es llamar al router desde símbolo de sistema, así:
telnet 192.168.2.1, ya que le puse esta ip a la lan de mi router.
¿La tarjeta red de mi ordenador tiene que tener ip tipo 192.168.2.x o una pública tipo 192.168.0.1? He intentado todas las combinaciones y no hay manera.

Disculpad si esta consulta es muy básica para este hilo, pero aún estoy familiarizándome con todo esto que es nuevo para mi.

Por último y amparándome en mi ignorancia, ¿es pósible hacer dmesg de otra manera? ¿quizás facilitarte los datos desde la interfaz LuCI?

Gracias de nuevo por tu ayuda.

Gran

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1653 en: 16-09-2013, 14:04 (Lunes) »
Gracias jar229

No me colguéis aún :-[ pero nunca he hecho dmesg y no se como hacerlo para facilitártelo.

Rebuscando por el foro, veo que accediendo al router via telnet se puede hacer:
telnet 192.168.x.x
dmesg > /www/dmesg.txt
Después desde el navegador:
http://192.168.x.x/dmesg.txt para copiar el archivo. ¿Es correcto?

Primer problema que se me plantea, no puedo acceder de manera local al router vía telnet, en realidad nunca lo he hecho por no hacerme falta.
Lo que hago es llamar al router desde símbolo de sistema, así:
telnet 192.168.2.1, ya que le puse esta ip a la lan de mi router.
¿La tarjeta red de mi ordenador tiene que tener ip tipo 192.168.2.x o una pública tipo 192.168.0.1? He intentado todas las combinaciones y no hay manera.

Disculpad si esta consulta es muy básica para este hilo, pero aún estoy familiarizándome con todo esto que es nuevo para mi.

Por último y amparándome en mi ignorancia, ¿es pósible hacer dmesg de otra manera? ¿quizás facilitarte los datos desde la interfaz LuCI?

Gracias de nuevo por tu ayuda.

Edito lo expuesto anteriormente.
He conseguido acceder via telnet. Al parecer el problema era que intentaba acceder por el puerto 23 y en la configuración del router viene por defecto el 22, lo he cambiado y listo. Consigo comunicación!

Lo que no consigo es sacar el dmesg.
Sigo buscando por el foro e intentando.
Agradezco vuestro soporte.

mojopicon

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1654 en: 16-09-2013, 14:14 (Lunes) »
He conseguido acceder via telnet. Al parecer el problema era que intentaba acceder por el puerto 23 y en la configuración del router viene por defecto el 22, lo he cambiado y listo. Consigo comunicación!

¿Pero haciendo eso llegas a ver la pantalla de bienvenida de OpenWRT que tiene una pinta tal que asi?


Es que si estás usando telnet desde una ventana de comandos de Windows, acceder por el puerto 22 no es buena idea ya que este puerto es el reservado para SSH. Lo que debes hacer es utilizar un programa cliente SSH en lugar del telnet simple. No se si este es tu problema...

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1655 en: 16-09-2013, 14:15 (Lunes) »
Desde LuCi, con el router recién iniciado: Estado, Registro del kernel.

Gran

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1656 en: 16-09-2013, 15:34 (Lunes) »
He conseguido acceder via telnet. Al parecer el problema era que intentaba acceder por el puerto 23 y en la configuración del router viene por defecto el 22, lo he cambiado y listo. Consigo comunicación!

¿Pero haciendo eso llegas a ver la pantalla de bienvenida de OpenWRT que tiene una pinta tal que asi?


Es que si estás usando telnet desde una ventana de comandos de Windows, acceder por el puerto 22 no es buena idea ya que este puerto es el reservado para SSH. Lo que debes hacer es utilizar un programa cliente SSH en lugar del telnet simple. No se si este es tu problema...

Efectivamente no lo he hecho correctamente porque esa no es la apariencia que tiene la consola cuando conecta. ¿Que programa me recomendáis instalar para el acceso SSH y poder seguir investigando?

Desde LuCi, con el router recién iniciado: Estado, Registro del kernel.

Este es el registro del Kernel, recién iniciado, con la configuración que tengo y sin conectar la tarjeta usb externa alfa:

[    0.000000] Linux version 3.9.8 (noltari@skynet) (gcc version 4.6.4 20121210 (prerelease) (OpenWrt/Linaro GCC 4.6-2012.12 r37179) ) #1 Fri Jul 5 16:16:57 CEST 2013
[    0.000000] Detected Broadcom 0x6358 CPU revision a1
[    0.000000] CPU frequency is 300 MHz
[    0.000000] 64MB of RAM installed
[    0.000000] registering 40 GPIOs
[    0.000000] board_bcm963xx: Boot address 0xbe000000
[    0.000000] board_bcm963xx: CFE version: d081.5003
[    0.000000] bcm63xx_nvram: nvram checksum failed, contents may be invalid (expected 33313330, got ce4cc1e2)
[    0.000000] No bcm_tag found!
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a010 (Broadcom BMIPS4350)
[    0.000000] board_bcm963xx: board name: HW556_A
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 802e0a80, node_mem_map 81000000
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
[    0.000000] Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc:
  • 0

[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Memory: 61436k/65536k available (2357k kernel code, 4100k reserved, 613k data, 228k init, 0k highmem)
[    0.000000] NR_IRQS:128
[    0.032000] Calibrating delay loop... 299.26 BogoMIPS (lpj=598528)
[    0.036000] pid_max: default: 32768 minimum: 301
[    0.040000] Mount-cache hash table entries: 512
[    0.048000] NET: Registered protocol family 16
[    0.064000] registering PCI controller with io_map_base unset
[    0.084000] bio: create slab <bio-0> at 0
[    0.092000] PCI host bridge to bus 0000:00
[    0.096000] pci_bus 0000:00: root bus resource [mem 0x30000000-0x37ffffff]
[    0.100000] pci_bus 0000:00: root bus resource [io  0x8000000-0x800ffff]
[    0.104000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.108000] pci 0000:00:01.0: [1814:3592] type 00 class 0x028000
[    0.108000] pci 0000:00:01.0: reg 10: [mem 0xffff0000-0xffffffff]
[    0.120000] pci 0000:00:01.0: PME# supported from D0 D3hot D3cold
[    0.120000] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.120000] pci 0000:00:01.0: BAR 0: assigned [mem 0x30000000-0x3000ffff]
[    0.124000] Switching to clocksource MIPS
[    0.140000] NET: Registered protocol family 2
[    0.144000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.152000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.156000] TCP: Hash tables configured (established 512 bind 512)
[    0.164000] TCP: reno registered
[    0.168000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.176000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.180000] NET: Registered protocol family 1
[    0.188000] PCI: CLS 0 bytes, default 16
[    0.192000] audit: initializing netlink socket (disabled)
[    0.196000] type=2000 audit(0.195:1): initialized
[    0.204000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.208000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.220000] msgmni has been set to 119
[    0.224000] io scheduler noop registered
[    0.228000] io scheduler deadline registered (default)
[    0.236000] bcm63xx_uart.0: ttyS0 at MMIO 0xfffe0100 (irq = 10) is a bcm63xx_uart
[    0.244000] console [ttyS0] enabled, bootconsole disabled
[    0.260000] physmap platform flash device: 02000000 at 1e000000
[    0.268000] physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000c2 Chip ID 0x00227e
[    0.280000] physmap-flash.0: Found an alias at 0x1000000 for the chip at 0x0
[    0.280000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.284000]   Amd/Fujitsu Extended Query version 1.3.
[    0.288000] number of CFI chips: 1
[    0.292000] bcm63xxpart: CFE boot tag found with version 8 and board type HW556
[    0.300000] bcm63xxpart: Partition 0 is CFE offset 0 and length 20000
[    0.308000] bcm63xxpart: Partition 1 is kernel offset 20100 and length 11ff00
[    0.316000] bcm63xxpart: Partition 2 is rootfs offset 140000 and length da0000
[    0.324000] bcm63xxpart: Partition 3 is cal_data offset ee0000 and length 20000
[    0.328000] bcm63xxpart: Partition 4 is nvram offset fe0000 and length 20000
[    0.336000] bcm63xxpart: Partition 5 is linux offset 20000 and length ec0000
[    0.344000] bcm63xxpart: Spare partition is offset 460004 and length a7fffc
[    0.352000] 6 bcm63xxpart partitions found on MTD device physmap-flash.0
[    0.360000] Creating 6 MTD partitions on "physmap-flash.0":
[    0.364000] 0x000000000000-0x000000020000 : "CFE"
[    0.372000] 0x000000020100-0x000000140000 : "kernel"
[    0.380000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.396000] 0x000000140000-0x000000ee0000 : "rootfs"
[    0.404000] mtd: partition "rootfs" set to be root filesystem
[    0.412000] mtd: partition "rootfs_data" created automatically, ofs=460000, len=A80000
[    0.420000] 0x000000460000-0x000000ee0000 : "rootfs_data"
[    0.428000] 0x000000ee0000-0x000000f00000 : "cal_data"
[    0.436000] 0x000000fe0000-0x000001000000 : "nvram"
[    0.448000] 0x000000020000-0x000000ee0000 : "linux"
[    0.460000] bcm63xx-spi bcm63xx-spi: at 0xfffe0800 (irq 9, FIFOs size 542)
[    0.476000] libphy: bcm63xx_enet MII bus: probed
[    0.484000] b53_common: found switch: BCM5325, rev 0
[    0.488000] bcm63xx_enet bcm63xx_enet.1: attached PHY at address 0 [Broadcom B53 (1)]
[    0.504000] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    0.520000] TCP: cubic registered
[    0.524000] NET: Registered protocol family 17
[    0.528000] 8021q: 802.1Q VLAN Support v1.8
[    0.548000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    0.556000] Freeing unused kernel memory: 228k freed
[    3.560000] SCSI subsystem initialized
[    3.780000] usbcore: registered new interface driver usbfs
[    3.788000] usbcore: registered new interface driver hub
[    3.792000] usbcore: registered new device driver usb
[    3.980000] Button Hotplug driver version 0.4.1
[    4.968000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.980000] ehci-platform: EHCI generic platform driver
[    4.984000] ehci-platform ehci-platform: EHCI Host Controller
[    4.992000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    5.000000] ehci-platform ehci-platform: irq 18, io mem 0xfffe1300
[    5.016000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00, overcurrent ignored
[    5.024000] hub 1-0:1.0: USB hub found
[    5.028000] hub 1-0:1.0: 2 ports detected
[    5.352000] Initializing USB Mass Storage driver...
[    5.360000] usbcore: registered new interface driver usb-storage
[    5.364000] USB Mass Storage support registered.
[    5.376000] input: gpio-keys-polled as /devices/platform/gpio-keys-polled.0/input/input0
[    5.556000] usb 1-2: new high-speed USB device number 2 using ehci-platform
[    5.984000] hub 1-2:1.0: USB hub found
[    5.992000] hub 1-2:1.0: 4 ports detected
[    7.720000] eth0: link UP - 100/full - flow control off
[    9.616000] jffs2: notice: (248) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 7 of xref (0 dead, 0 orphan) found.
[    9.852000] eth0: link DOWN
[   13.896000] Loading modules backported from Linux version master-2013-06-27-0-gdcfa6d5
[   13.904000] Backport generated by backports.git backports-20130617-4-ge3220f5
[   14.092000] cfg80211: Calling CRDA to update world regulatory domain
[   14.104000] cfg80211: World regulatory domain updated:
[   14.108000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   14.116000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   14.124000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   14.132000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   14.140000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   14.148000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   14.512000] NET: Registered protocol family 10
[   14.840000] lib80211: common routines for IEEE802.11 drivers
[   14.844000] lib80211_crypt: registered algorithm 'NULL'
[   14.848000] lib80211_crypt: registered algorithm 'WEP'
[   14.852000] lib80211_crypt: registered algorithm 'CCMP'
[   14.852000] lib80211_crypt: registered algorithm 'TKIP'
[   16.268000] usbcore: registered new interface driver usb8xxx
[   16.544000] usbcore: registered new interface driver rt2500usb
[   16.696000] usbcore: registered new interface driver rt73usb
[   16.860000] usbcore: registered new interface driver rtl8187
[   17.264000] PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
[   17.272000] rt2800pci 0000:00:01.0: setting latency timer to 64
[   17.272000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'rt2x00.eeprom'.
[   17.284000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Error - EEPROM file size is invalid, it should be 512 bytes
[   17.296000] rt2800pci: probe of 0000:00:01.0 failed with error -22
[   17.312000] usbcore: registered new interface driver rt2800usb
[   17.904000] PPP generic driver version 2.4.2
[   17.924000] usbcore: registered new interface driver p54usb
[   18.336000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   18.372000] xt_time: kernel timezone is -0000
[   18.648000] NET: Registered protocol family 24
[   18.832000] nf_conntrack version 0.5.0 (963 buckets, 3852 max)
[   20.320000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   20.688000] usbcore: registered new interface driver ath9k_htc
[   20.836000] usbcore: registered new interface driver carl9170
[   20.964000] usbcore: registered new interface driver zd1201
[   21.132000] usbcore: registered new interface driver zd1211rw
[   24.536000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   25.912000] eth0: link UP - 100/full - flow control off
[   25.916000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   26.796000] device eth0.1 entered promiscuous mode
[   26.800000] device eth0 entered promiscuous mode
[   26.812000] br-lan: port 1(eth0.1) entered forwarding state
[   26.816000] br-lan: port 1(eth0.1) entered forwarding state
[   26.916000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   28.000000] eth0: link UP - 100/full - flow control off
[   28.820000] br-lan: port 1(eth0.1) entered forwarding state

Hacia el final del registro veo un error en lo que me parece el chip wifi.
A ver si detectáis cual puede ser mi problema.

Muchas gracias a jar229 y a mojopicón por orientarme.

mojopicon

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1657 en: 16-09-2013, 15:41 (Lunes) »
¿Que programa me recomendáis instalar para el acceso SSH y poder seguir investigando?

El que yo uso es Bitvise SSH Client, gratuito para uso privado:
http://www.bitvise.com/ssh-client-download
« Última modificación: 16-09-2013, 15:42 (Lunes) por mojopicon »

Gran

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1658 en: 16-09-2013, 15:49 (Lunes) »
¿Que programa me recomendáis instalar para el acceso SSH y poder seguir investigando?

El que yo uso es Bitvise SSH Client, gratuito para uso privado:
http://www.bitvise.com/ssh-client-download

Gracias lo descargaré y probaré a ver que tal.
Por cierto, en mac osx, basado en unix también podría usar un cliente SSH o acceder via el terminal?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1659 en: 16-09-2013, 16:09 (Lunes) »
Código: [Seleccionar]
[   17.284000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Error - EEPROM file size is invalid, it should be 512 bytes
[   17.296000] rt2800pci: probe of 0000:00:01.0 failed with error -22

Ahí está el error.

Dice que el tamaño de la EEPROM es inválido  ^-^

Antes de instalar este firmware, tenías el 'oficial' ?