Autor Tema: [Desarrollo] OpenWrt en Comtrend VR-3025u  (Leído 129623 veces)

0 Usuarios y 1 Visitante están viendo este tema.

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #300 en: 27-11-2016, 13:34 (Domingo) »
Buenas, antes de nada agradecer a los desarrolladores de OpenWRT por su trabajo.

Ahora, solicito ayuda, pues creo que he brickeado mi router. He estado trasteando con la instalación de OpenWRT, volviéndome loco para hacerlo funcionar en Bridge. Bien, pues resulta que al instalar uno de los frimwares, me ha dejado el router totalmente inservible. No hay forma de acceder a la configuración en 192.168.1.1. Incluso en el modo "CFE" manteniendo presionado el botón reset mientras se enciende, hasta que se queda el led de Power en Rojo, pero nada, imposible "No se ha podido acceder al sitio",  he probado a borrar el caché, en otro PC, con otros cables.... No sé. ¿Alguien tiene alguna idea?

¡Gracias!

PD: Concretamente flasheé ESTE: https://downloads.openwrt.org/snapshots/trunk/brcm63xx/smp/openwrt-VR-3025u-squashfs-cfe.bin


« Última modificación: 27-11-2016, 14:25 (Domingo) por WiFlash »

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #301 en: 27-11-2016, 15:06 (Domingo) »
Buenas, antes de nada agradecer a los desarrolladores de OpenWRT por su trabajo.

Ahora, solicito ayuda, pues creo que he brickeado mi router. He estado trasteando con la instalación de OpenWRT, volviéndome loco para hacerlo funcionar en Bridge. Bien, pues resulta que al instalar uno de los frimwares, me ha dejado el router totalmente inservible. No hay forma de acceder a la configuración en 192.168.1.1. Incluso en el modo "CFE" manteniendo presionado el botón reset mientras se enciende, hasta que se queda el led de Power en Rojo, pero nada, imposible "No se ha podido acceder al sitio",  he probado a borrar el caché, en otro PC, con otros cables.... No sé. ¿Alguien tiene alguna idea?

¡Gracias!

PD: Concretamente flasheé ESTE: https://downloads.openwrt.org/snapshots/trunk/brcm63xx/smp/openwrt-VR-3025u-squashfs-cfe.bin

Habría que poner alguna advertencia en algún sitio que a partir de Chaos Calmer evitar instalar versiones trunk de Openwrt y en su lugar usar las de LEDE

https://downloads.lede-project.org/snapshots/targets/

ya que la mayoría de desarrolladores se pasaron LEDE, y OpenWrt está sin mantenimiento al menos en bcm63xx

Uno de los problemas graves que se comentó con el HG556a era que las versiones trunk de Openwrt al flashear con CFE, éste interpretaba mal el firmware y se borraba a si mismo, brickeando totalmente el router. Imagino que en tu caso pueda haber pasado algo parecido.

La única forma de recuperarlo en este caso es usando un adptador JTAG y software soportado por el mismo ya sea zjtag o UrJTAG. Y por supuesto hace falta una copia del bootloader original. Muy fácil de obtener en un router vivo con Openwrt instalado, si gentilmente alguien en el foro hiciese el favor.

Código: [Seleccionar]
dd if=/dev/mtd0 of=/tmp/cfe-backup.bin
No sé si tu caso es problema de bootloader, pero tiene toda la pinta, si tienes adaptador de puerto serie, verás que no sale nada en consola.
« Última modificación: 27-11-2016, 15:19 (Domingo) por danitool »

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #302 en: 27-11-2016, 15:18 (Domingo) »
Buenas, antes de nada agradecer a los desarrolladores de OpenWRT por su trabajo.

Ahora, solicito ayuda, pues creo que he brickeado mi router. He estado trasteando con la instalación de OpenWRT, volviéndome loco para hacerlo funcionar en Bridge. Bien, pues resulta que al instalar uno de los frimwares, me ha dejado el router totalmente inservible. No hay forma de acceder a la configuración en 192.168.1.1. Incluso en el modo "CFE" manteniendo presionado el botón reset mientras se enciende, hasta que se queda el led de Power en Rojo, pero nada, imposible "No se ha podido acceder al sitio",  he probado a borrar el caché, en otro PC, con otros cables.... No sé. ¿Alguien tiene alguna idea?

¡Gracias!

PD: Concretamente flasheé ESTE: https://downloads.openwrt.org/snapshots/trunk/brcm63xx/smp/openwrt-VR-3025u-squashfs-cfe.bin

Habría que poner alguna advertencia en algún sitio que a partir de Chaos Calmer evitar instalar versiones trunk de Openwrt y en su lugar usar las de LEDE

https://downloads.lede-project.org/snapshots/targets/

ya que la mayoría de desarrolladores se pasaron LEDE, y OpenWrt está sin mantenimiento al menos en bcm63xx

Y uno de los problemas graves que se comentó con el HG556a era que las versiones trunk de Openwrt se cepillaban el bootloader, brickeando totalmente el router. Imagino que en tu caso pueda haber pasado algo parecido.

La única forma de recuperarlo en este caso es usando un adptador JTAG y software soportado por el mismo ya sea zjtag o UrJTAG. Y por supuesto hace falta una copia del bootloader original. Muy fácil de obtener en un router vivo con Openwrt instalado, si gentilmente alguien en el foro hiciese el favor.

Código: [Seleccionar]
dd if=/dev/mtd0 of=/tmp/cfe-backup.bin
No sé si tu caso es problema de bootloader, pero tiene toda la pinta, si tienes adaptador de puerto serie, verás que no sale nada en consola.

Muchas gracias por tu respuesta. Ni sabía de la existencia de LEDE, si no habría empezado por ahí xD.
Así que es un Brick de los guapos. ¿En vez de usar un adaptado JTAG, puedo usar una Raspberry Pi?

En algo que me he fijado esque los leds, cuando arranca el router normal, hace lo mismo que hacía cuando funcionaba bien con OpenWRT: con las luces de LAN1 y power al principio y luego solo Power. En fin... la que he liado, no sé si servirá de algo

Gracias,

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #303 en: 27-11-2016, 15:27 (Domingo) »
Muchas gracias por tu respuesta. Ni sabía de la existencia de LEDE, si no habría empezado por ahí xD.
Así que es un Brick de los guapos. ¿En vez de usar un adaptado JTAG, puedo usar una Raspberry Pi?

En algo que me he fijado esque los leds, cuando arranca el router normal, hace lo mismo que hacía cuando funcionaba bien con OpenWRT: con las luces de LAN1 y power al principio y luego solo Power. En fin... la que he liado, no sé si servirá de algo

Gracias,

Si las luces responden en la arrancada de forma normal entonces puede que el router esté todavía vivo, ya que el bootloader CFE es el que se encarga de gestionarlos.

La forma de comprobarlo es conectando un adaptador serie TTL UART, podría ser que tenga la NVRAM corrupta sin IP ni board ID, para arreglarlo en este caso hay que entrar por consola serie.

En cuanto al JTAG, sí podrías usar la rpi, hay un software llamado tjtagPi que parece ser funciona. El tema es que tengas pines JTAG accesibles en la placa, sin esos pines nada sería posible ya que no habría donde conectar el adaptador JTAG. Si es el caso de que necesites esta opción, para localizarlo puedo echar una mano si haces unas buenas fotos de la placa de los dos lados para poder intentar adivinar donde estarían los pines.

Saludos

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #304 en: 27-11-2016, 15:45 (Domingo) »
Muchas gracias por tu respuesta. Ni sabía de la existencia de LEDE, si no habría empezado por ahí xD.
Así que es un Brick de los guapos. ¿En vez de usar un adaptado JTAG, puedo usar una Raspberry Pi?

En algo que me he fijado esque los leds, cuando arranca el router normal, hace lo mismo que hacía cuando funcionaba bien con OpenWRT: con las luces de LAN1 y power al principio y luego solo Power. En fin... la que he liado, no sé si servirá de algo

Gracias,

Si las luces responden en la arrancada de forma normal entonces puede que el router esté todavía vivo, ya que el bootloader CFE es el que se encarga de gestionarlos.

La forma de comprobarlo es conectando un adaptador serie TTL UART, podría ser que tenga la NVRAM corrupta sin IP ni board ID, para arreglarlo en este caso hay que entrar por consola serie.

En cuanto al JTAG, sí podrías usar la rpi, hay un software llamado tjtagPi que parece ser funciona. El tema es que tengas pines JTAG accesibles en la placa, sin esos pines nada sería posible ya que no habría donde conectar el adaptador JTAG. Si es el caso de que necesites esta opción, para localizarlo puedo echar una mano si haces unas buenas fotos de la placa de los dos lados para poder intentar adivinar donde estarían los pines.

Saludos

Son buenas noticias, pues, no es tan grave! El caso esque aún no tengo Raspberry Pi. Llevo tiempo echando ojo al Orange Pi y he observado que tiene pines específicos para TTL UART, por lo que creo que sí serviría para hacer JTAG Debug. En la wiki de OpenWRT aparece una imagen donde se ven los pines:



Supongo que sería conectar los pines del router al Orange Pi, y desde el Orange Pi acceder por consola. Otr a última duda. ¿Los cables para esta conexión son normales de cobre, o son algún tipo especial? Es una duda que he tenido siempre ante estas conexiones

« Última modificación: 27-11-2016, 15:46 (Domingo) por WiFlash »

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #305 en: 27-11-2016, 15:58 (Domingo) »
Sobre el puerto serie hay un hilo dedicado a ello

https://foro.seguridadwireless.net/openwrt/(tutorial)-puerto-serie-como-acceder/

Los cables da igual del material que sean, el único requisito es que han de conducir la electricidad, normalmente cualquier metal tiene esta propiedad, cobre, acero, aluminio, etc.

Una rpi sirve para consola serie, pero también serviría cualquier router con puerto serie al que le pudiesemos instalar Openwrt si le deshabilitamos la consola del kernel para poder acceder con screen por ejemplo.

Desde luego lo más sencillo y cómodo es usar un usb UART, tipo cp2102, que por poco más de un euro los venden por ejemplo en eBay.

Ojo que el puerto serie UART nada tiene que ver con JTAG, son pines totalmente diferentes, y software para manejarlo totalmente diferente.

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #306 en: 27-11-2016, 18:00 (Domingo) »
Sobre el puerto serie hay un hilo dedicado a ello

https://foro.seguridadwireless.net/openwrt/(tutorial)-puerto-serie-como-acceder/

Los cables da igual del material que sean, el único requisito es que han de conducir la electricidad, normalmente cualquier metal tiene esta propiedad, cobre, acero, aluminio, etc.

Una rpi sirve para consola serie, pero también serviría cualquier router con puerto serie al que le pudiesemos instalar Openwrt si le deshabilitamos la consola del kernel para poder acceder con screen por ejemplo.

Desde luego lo más sencillo y cómodo es usar un usb UART, tipo cp2102, que por poco más de un euro los venden por ejemplo en eBay.

Ojo que el puerto serie UART nada tiene que ver con JTAG, son pines totalmente diferentes, y software para manejarlo totalmente diferente.

Gracias por tu paciencia. Es por eso por lo que quiero usar Orange Pi. En caso de que sea error en el Bootloader o no, podré usar Orange Pi, ya sea mediante conexión UART o JTAG, si no, tendré que comprar dos diferentes  :-\. Podría usar otro router. Pero creo que es el único que tengo compatible con OpenWRT. Tenía también un Vodafone pero *creo* que se lo dí a un tío mio

La cosa es que sí, bien, es error del bootloader, tendré que flashear una copia de seguridad de la misma, pero si como bien dices, no es la partición bootloader si no que es la NVRAM que está corrupta. ¿Qué debería flashear? ¿Con un .bin de OpenWRT serviría?

EDITO: Mágicamente lo he ido a probar y todo funciona correctamente! Ya me deja subir el BIN!!

Gracias por todo!!
« Última modificación: 27-11-2016, 18:49 (Domingo) por WiFlash »

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #307 en: 27-11-2016, 19:57 (Domingo) »
Me alegro que no haya sido nada, a veces pasa que lo mejor es apagar todo, tomarte un tiempo y cuando vuelves a conectar el tinglado todo funciona normalmente. Quien sabe, tablas arp envenenadas, cachés de navegadores corruptas,  o gremlins mordisqueando los cables  >:D

El caso es que hay que andar con ojo con esto que comenté anteriormente, lo edité a posteriori, pero el fallo es más bien del propio CFE, que se borra a si mismo cuando la información de la cabecera del firmware es incorrecta y por ejemplo tiene información de flasheo en un bloque que pertenece a CFE. No debería ocurrir, CFE debería tener un mecanismo para evitarlo, de hecho creo que lo tiene por defecto. Pero en el caso de los Huawei al menos, resulta que estos chinos son muy bromistas y me da que modificaron cosas que no deberían, de ahí los bricks en el HG556a.

Pienso que no debería haber más routers afectados que los Huawei. De todas formas usando LEDE no hay problema ya que este error en la cabecera del firmware fue corregido hace tiempo.

Nota: para evitarte estos problemas de saber si tienes un brick o no, ten una consola a serie a mano preparada..

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #308 en: 27-11-2016, 20:08 (Domingo) »
Me alegro que no haya sido nada, a veces pasa que lo mejor es apagar todo, tomarte un tiempo y cuando vuelves a conectar el tinglado todo funciona normalmente. Quien sabe, tablas arp envenenadas, cachés de navegadores corruptas,  o gremlins mordisqueando los cables  >:D

El caso es que hay que andar con ojo con esto que comenté anteriormente, lo edité a posteriori, pero el fallo es más bien del propio CFE, que se borra a si mismo cuando la información de la cabecera del firmware es incorrecta y por ejemplo tiene información de flasheo en un bloque que pertenece a CFE. No debería ocurrir, CFE debería tener un mecanismo para evitarlo, de hecho creo que lo tiene por defecto. Pero en el caso de los Huawei al menos, resulta que estos chinos son muy bromistas y me da que modificaron cosas que no deberían, de ahí los bricks en el HG556a.

Pienso que no debería haber más routers afectados que los Huawei. De todas formas usando LEDE no hay problema ya que este error en la cabecera del firmware fue corregido hace tiempo.

Nota: para evitarte estos problemas de saber si tienes un brick o no, ten una consola a serie a mano preparada..

Pues muchas gracias por todo. Como bien dices, a veces lo mejor es dejar los aparatos descansar xD. Ahora intentaré instalarle LEDE, no sin antes hacer un Backup, por si las moscas

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4584
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #309 en: 30-11-2016, 10:50 (Miércoles) »


Habría que poner alguna advertencia en algún sitio que a partir de Chaos Calmer evitar instalar versiones trunk de Openwrt y en su lugar usar las de LEDE

https://downloads.lede-project.org/snapshots/targets/

ya que la mayoría de desarrolladores se pasaron LEDE, y OpenWrt está sin mantenimiento al menos en bcm63xx

Uno de los problemas graves que se comentó con el HG556a era que las versiones trunk de Openwrt al flashear con CFE, éste interpretaba mal el firmware y se borraba a si mismo, brickeando totalmente el router. Imagino que en tu caso pueda haber pasado algo parecido.

danitool, si me mandas por privado un pequeño texto explicando el tema, lo pongo en los hilos pertinentes y directamente en un nuevo hilo de advertencia.

Saludos
Valoraciones positivas en compra/venta:
129 en Htcmania
165 en Har2mano
20 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #310 en: 30-11-2016, 15:04 (Miércoles) »


Habría que poner alguna advertencia en algún sitio que a partir de Chaos Calmer evitar instalar versiones trunk de Openwrt y en su lugar usar las de LEDE

https://downloads.lede-project.org/snapshots/targets/

ya que la mayoría de desarrolladores se pasaron LEDE, y OpenWrt está sin mantenimiento al menos en bcm63xx

Uno de los problemas graves que se comentó con el HG556a era que las versiones trunk de Openwrt al flashear con CFE, éste interpretaba mal el firmware y se borraba a si mismo, brickeando totalmente el router. Imagino que en tu caso pueda haber pasado algo parecido.

danitool, si me mandas por privado un pequeño texto explicando el tema, lo pongo en los hilos pertinentes y directamente en un nuevo hilo de advertencia.

Saludos

El único problema esque LEDE viene sin LuCi

zorrua

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #311 en: 30-11-2016, 15:17 (Miércoles) »


Habría que poner alguna advertencia en algún sitio que a partir de Chaos Calmer evitar instalar versiones trunk de Openwrt y en su lugar usar las de LEDE

https://downloads.lede-project.org/snapshots/targets/

ya que la mayoría de desarrolladores se pasaron LEDE, y OpenWrt está sin mantenimiento al menos en bcm63xx

Uno de los problemas graves que se comentó con el HG556a era que las versiones trunk de Openwrt al flashear con CFE, éste interpretaba mal el firmware y se borraba a si mismo, brickeando totalmente el router. Imagino que en tu caso pueda haber pasado algo parecido.

danitool, si me mandas por privado un pequeño texto explicando el tema, lo pongo en los hilos pertinentes y directamente en un nuevo hilo de advertencia.

Saludos

El único problema esque LEDE viene sin LuCi
Me imagino que cuando saquen versiones estables, los dejaran con Luci.

Las versiones disponibles de ahora son snapshoot, y es normal que traigan lo minimo para arrancar.

Saludos.

chevi

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #312 en: 04-12-2016, 10:41 (Domingo) »
La última versión funciona perfectamente sin tener que hacer ningún cambio a mano:

https://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/smp/openwrt-15.05.1-brcm63xx-smp-VR-3025u-squashfs-cfe.bin

Gracias, he flasheado esta. Tengo el router conectado por cable al del ISP sirviendo wifi en el piso de arriba. El wifi no es N por lo que veo, es BG, no sé si tengo que configurar algo más. Los LED de la LAN venían sin configurar.
La verdad es que se nota que este router va sueltecito, la interfaz se mueve rápido. Tengo un Comtrend AR-5387un también y se mueve más pedorro.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1946
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #313 en: 05-12-2016, 16:11 (Lunes) »
La última versión funciona perfectamente sin tener que hacer ningún cambio a mano:

https://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/smp/openwrt-15.05.1-brcm63xx-smp-VR-3025u-squashfs-cfe.bin

Gracias, he flasheado esta. Tengo el router conectado por cable al del ISP sirviendo wifi en el piso de arriba. El wifi no es N por lo que veo, es BG, no sé si tengo que configurar algo más. Los LED de la LAN venían sin configurar.
La verdad es que se nota que este router va sueltecito, la interfaz se mueve rápido. Tengo un Comtrend AR-5387un también y se mueve más pedorro.

Si quieres wifi n tienes que cambiar el driver de openwrt, por el propietario de Broadcom, y aún así, no sé si funcionaría. El driver de código abierto, sólo tiene modo b/g, como ya has averiguado.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #314 en: 05-12-2016, 17:07 (Lunes) »
La última versión funciona perfectamente sin tener que hacer ningún cambio a mano:

https://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/smp/openwrt-15.05.1-brcm63xx-smp-VR-3025u-squashfs-cfe.bin

Gracias, he flasheado esta. Tengo el router conectado por cable al del ISP sirviendo wifi en el piso de arriba. El wifi no es N por lo que veo, es BG, no sé si tengo que configurar algo más. Los LED de la LAN venían sin configurar.
La verdad es que se nota que este router va sueltecito, la interfaz se mueve rápido. Tengo un Comtrend AR-5387un también y se mueve más pedorro.

Si quieres wifi n tienes que cambiar el driver de openwrt, por el propietario de Broadcom, y aún así, no sé si funcionaría. El driver de código abierto, sólo tiene modo b/g, como ya has averiguado.

En anteriores páginas (14 creo) había una compilación de un usuario con un driver alternativo que parecía funcionar correctamente con Wi-Fi N, lo dejo como dato.

Caso aparte. He compilado LEDE, con LuCi para este router, lo dejo por aquí: https://mega.nz/#!rAN1DDyZ!I7UzNWAYO6QoYpNWIRnHudWdd2-L264whyOE0_C-7S8

Tengo un problema, y esque no puedo instalar ningún paquete de Atheros, y por tanto no puedo inicializar mi TP-LINK WN722N en este router. Este frim es hasta ahora el único que me ha devuelto resultados con "lsusb", ya que en otros frims me daba un error "-99" al iniciar ese comando (y sí, el paquete estaba instalado".

Entonces, lsusb me reconoce mi Atheros, pero faltan los drivers (ath). Al instalarlos me salta un error de este tipo:

Código: [Seleccionar]
satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ath9k-htc:
kernel (= 3.10.49-1-0114c71ed85677c9c1e4911437af4743) *
opkg_install_cmd: Cannot install package kmod-ath9k-htc.

Si alguien se le ocurre algo, sería de gran ayuda. Gracias!

Ficht

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #315 en: 05-12-2016, 17:40 (Lunes) »
La última versión funciona perfectamente sin tener que hacer ningún cambio a mano:

https://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/smp/openwrt-15.05.1-brcm63xx-smp-VR-3025u-squashfs-cfe.bin

Gracias, he flasheado esta. Tengo el router conectado por cable al del ISP sirviendo wifi en el piso de arriba. El wifi no es N por lo que veo, es BG, no sé si tengo que configurar algo más. Los LED de la LAN venían sin configurar.
La verdad es que se nota que este router va sueltecito, la interfaz se mueve rápido. Tengo un Comtrend AR-5387un también y se mueve más pedorro.

Si quieres wifi n tienes que cambiar el driver de openwrt, por el propietario de Broadcom, y aún así, no sé si funcionaría. El driver de código abierto, sólo tiene modo b/g, como ya has averiguado.

En anteriores páginas (14 creo) había una compilación de un usuario con un driver alternativo que parecía funcionar correctamente con Wi-Fi N, lo dejo como dato.

Caso aparte. He compilado LEDE, con LuCi para este router, lo dejo por aquí: https://mega.nz/#!rAN1DDyZ!I7UzNWAYO6QoYpNWIRnHudWdd2-L264whyOE0_C-7S8

Tengo un problema, y esque no puedo instalar ningún paquete de Atheros, y por tanto no puedo inicializar mi TP-LINK WN722N en este router. Este frim es hasta ahora el único que me ha devuelto resultados con "lsusb", ya que en otros frims me daba un error "-99" al iniciar ese comando (y sí, el paquete estaba instalado".

Entonces, lsusb me reconoce mi Atheros, pero faltan los drivers (ath). Al instalarlos me salta un error de este tipo:

Código: [Seleccionar]
satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ath9k-htc:
kernel (= 3.10.49-1-0114c71ed85677c9c1e4911437af4743) *
opkg_install_cmd: Cannot install package kmod-ath9k-htc.

Si alguien se le ocurre algo, sería de gran ayuda. Gracias!

Mira esto, seguro te ayuda.

https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Kernel_Deps

crislgga

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #316 en: 05-12-2016, 18:19 (Lunes) »
La última versión funciona perfectamente sin tener que hacer ningún cambio a mano:

https://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/smp/openwrt-15.05.1-brcm63xx-smp-VR-3025u-squashfs-cfe.bin

Gracias, he flasheado esta. Tengo el router conectado por cable al del ISP sirviendo wifi en el piso de arriba. El wifi no es N por lo que veo, es BG, no sé si tengo que configurar algo más. Los LED de la LAN venían sin configurar.
La verdad es que se nota que este router va sueltecito, la interfaz se mueve rápido. Tengo un Comtrend AR-5387un también y se mueve más pedorro.

Si quieres wifi n tienes que cambiar el driver de openwrt, por el propietario de Broadcom, y aún así, no sé si funcionaría. El driver de código abierto, sólo tiene modo b/g, como ya has averiguado.

En anteriores páginas (14 creo) había una compilación de un usuario con un driver alternativo que parecía funcionar correctamente con Wi-Fi N, lo dejo como dato.

Caso aparte. He compilado LEDE, con LuCi para este router, lo dejo por aquí: https://mega.nz/#!rAN1DDyZ!I7UzNWAYO6QoYpNWIRnHudWdd2-L264whyOE0_C-7S8

Tengo un problema, y esque no puedo instalar ningún paquete de Atheros, y por tanto no puedo inicializar mi TP-LINK WN722N en este router. Este frim es hasta ahora el único que me ha devuelto resultados con "lsusb", ya que en otros frims me daba un error "-99" al iniciar ese comando (y sí, el paquete estaba instalado".

Entonces, lsusb me reconoce mi Atheros, pero faltan los drivers (ath). Al instalarlos me salta un error de este tipo:

Código: [Seleccionar]
satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ath9k-htc:
kernel (= 3.10.49-1-0114c71ed85677c9c1e4911437af4743) *
opkg_install_cmd: Cannot install package kmod-ath9k-htc.

Si alguien se le ocurre algo, sería de gran ayuda. Gracias!
Yo estuve en tiempo trasteando con este router, y he de decir, que probé las supuestas compilaciones que traian el driver alternativo para wifi N, pero muchas de las compilaciones, aunque aseguraban eso, traia el b/g, y si te ponias a desinstalar e instalar el N, son muchos problemas, tanto BB como CC y en la Lede tambien, es muy porculero y aunque un tiempo pueda parecer estable, no lo es, ya que depende de la configuración de como y donde la hagas(luci, ssh, tftp), peta por un sitio u otro, probe una ultima Lede, y es lo mismo, es decir, lo tengo como cliente de otro router, y bien, pero la wifi N tiene que ser a 150mbps, si no peta, o reducir el rango de potencia de emision, son cuestiones muy quisquillonas pero la verdad es que en general NO FUNCIONA BIEN, deberá ser pulido y dudo que en el futuro pueda ser mas estable que ahora
saludos

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #317 en: 05-12-2016, 19:13 (Lunes) »
Citar

Mira esto, seguro te ayuda.

https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Kernel_Deps

He probado con --force-deps y ha instalado. Pero el router reinicia cada vez que conecto mi TP-WN722N. Crashea cada vez que inicializa el driver.

¿Alguna solución a esto?

Ficht

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #318 en: 05-12-2016, 21:15 (Lunes) »
Citar

Mira esto, seguro te ayuda.

https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Kernel_Deps

He probado con --force-deps y ha instalado. Pero el router reinicia cada vez que conecto mi TP-WN722N. Crashea cada vez que inicializa el driver.

¿Alguna solución a esto?

La verdad, yo no se muy bien como solucionarlo, creo que sería útil tener conectado un adaptador de puerto serie, y ver que mensajes salen en la consola justo al conectar el usb y a partir de ahí, ver si tiene o no solución...
También desde una consola, puedes monitorearlo así.
Código: [Seleccionar]
logread -f

La solución creo que empieza por  montar el driver apropiado... (pero claro ... )
Yo lo dejaría siempre conectado... y ver como funciona de manera habitual durante unos días, creo que es bastante esperado la inestabilidad del router. (yo no suelo usar pinchos mas que para pruebas)

WiFlash

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend VR-3025u
« Respuesta #319 en: 08-12-2016, 01:46 (Jueves) »
¡¡Exito!! Por fin he conseguido compilar un frimware OpenWRT que fuera capaz de reconocer mi TP-LINK Wn722N, y también mi RT3070!! De esta forma he conseguido que el router funcione como repetidor  >:(

Si os interesa el firm, lo paso