Autor Tema: [AYUDA] Problemas con servidor DLNA y routers en modo cliente  (Leído 1607 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Prody

  • Visitante
Muy buenas, antes que nada agradecer su dedicación a todos los que hacen posible este foro.

Os explico, tengo un problema que me lleva de cabeza desde hace un tiempo, he buscado mil tutoriales y foros (en este he encontrado un hilo de un usuario que tiene un problema muy parecido al mio pero finalmente no pudo acabar con el problema).

En una habitación tengo un router ZXHN H218N de Jazztel (IP 192.168.1.1) el cual me da servicio a internet y es el principal, en el tengo conectado un NAS y un PC directamente por cable.

En el el comedor tengo una TV PANASONIC que tiene el servicio DLNA, esta TV está conectada a un router Comtrend AR-5387un en modo cliente con Openwrt (IP 192.168.2.1).

Esta TV no tiene ningún problema para acceder a internet pero si intento acceder al servidor DLNA (sea PLEX o otro servicio) no lo encuentra.

He probado cambiar la IP de la LAN del Comtrend por la misma LAN que el del router principal, pero si hago esto pierdo toda la conectividad a internet.

Tengo entendido que es debido a que para acceder al servidor DLNA la TV hace un broadcast y de ahí viene el problema, ya que este no se enruta.

También encontré un wiki de openwrt donde se accedia a un comando para habilitar el broadcast pero sigo sin poder ver el servidor DLNA.

Os dejo capturas de todo por si puede ser de ayuda.















Muchas gracias de nuevo!!!  ;)



Ficht

  • Visitante
Re: [AYUDA] Problemas con servidor DLNA y routers en modo cliente
« Respuesta #1 en: 27-11-2016, 00:01 (Domingo) »
Muy buenas, antes que nada agradecer su dedicación a todos los que hacen posible este foro.

Os explico, tengo un problema que me lleva de cabeza desde hace un tiempo, he buscado mil tutoriales y foros (en este he encontrado un hilo de un usuario que tiene un problema muy parecido al mio pero finalmente no pudo acabar con el problema).

En una habitación tengo un router ZXHN H218N de Jazztel (IP 192.168.1.1) el cual me da servicio a internet y es el principal, en el tengo conectado un NAS y un PC directamente por cable.

En el el comedor tengo una TV PANASONIC que tiene el servicio DLNA, esta TV está conectada a un router Comtrend AR-5387un en modo cliente con Openwrt (IP 192.168.2.1).

Esta TV no tiene ningún problema para acceder a internet pero si intento acceder al servidor DLNA (sea PLEX o otro servicio) no lo encuentra.

He probado cambiar la IP de la LAN del Comtrend por la misma LAN que el del router principal, pero si hago esto pierdo toda la conectividad a internet.

Tengo entendido que es debido a que para acceder al servidor DLNA la TV hace un broadcast y de ahí viene el problema, ya que este no se enruta.

También encontré un wiki de openwrt donde se accedia a un comando para habilitar el broadcast pero sigo sin poder ver el servidor DLNA.

Os dejo capturas de todo por si puede ser de ayuda.

Muchas gracias de nuevo!!!  ;)

Hola Prody.

Yo tengo una configuración muy similar a tu grafico y el dlna me trabaja muy bien...
lo tengo así.

1 El router openwrt, tiene asignada ip fija en el router principal.
2 El router openwrt mascara de red 255.255.0.0 también el router principal
3 El router openwrt tiene como getway Ipv4 y DNS la ip del router principal.
4 El router openwrt tiene otra interface mas con protocolo relayd (con igual ip del router, aunque se aconseja distinta)
5 El router openwrt tiene desactivado el firewall (hay mas firewall antes de este router, por ejemplo el del principal)
6 El router openwrt tiene el DHCP desactivado (lo maneja el router principal)

y así de memoria, no recuerdo mas...  (hay otras formas de configurar todo esto... no es la única manera.)
Suerte.
« Última modificación: 27-11-2016, 00:03 (Domingo) por Ficht »

Prody

  • Visitante
Re: [AYUDA] Problemas con servidor DLNA y routers en modo cliente
« Respuesta #2 en: 27-11-2016, 08:44 (Domingo) »
Muy buenas, antes que nada agradecer tu respuesta.

Perdona mi ignorancia pero tengo algunas dudas a lo que me comentas, en el punto 1 dices: El router openwrt, tiene asignada ip fija en el router principal.
No lo entiendo, en el principal tengo asociada la MAC del openwrt para que este haga de cliente. No se si te refieres a eso.
En el punto 2 dices: 2 El router openwrt mascara de red 255.255.0.0 también el router principal. Te refieres a montar una red /16 en vez de /24?

Muchas gracias de nuevo. ;)

Prody

  • Visitante
Re: [AYUDA] Problemas con servidor DLNA y routers en modo cliente
« Respuesta #3 en: 28-11-2016, 22:37 (Lunes) »
Me cito para comentar que finalmente lo he conseguido montando un relayd. ;D

Os dejo un enlace al tutorial que he seguido por si a alguien le sirve de ayuda.

https://wiki.openwrt.org/doc/recipes/relayclient

//FINAL Y MÁS DOS RESPUESTAS