Autor Tema: [Ayuda] Modo repetidor por cable  (Leído 10287 veces)

0 Usuarios y 1 Visitante están viendo este tema.

cokete

  • Visitante
[Ayuda] Modo repetidor por cable
« en: 24-05-2013, 22:05 (Viernes) »
Hola chicos!

Mi problema principal es la terminología. Seguro que está posteado, pero no habré dado con la búsqueda adecuada.

Mi problema es el siguiente. En el salón no me llegaba el wifi, y me he comprado un PLC para el AppleTV. Ahora quiero en el PLC que sale en el salón conectar un router con OpenWRT via cable y que este router haga de switch y me replique la misma red de wifi por la zona del salón.

Mi idea es que sea con el mismo nombre y password y que el dispositivo elija a cual conectarse.

Alguien podría ayudarme a saber qué es lo que necesito?

Muchas gracias de antemano chicos!



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Ayuda] Modo repetidor por cable
« Respuesta #1 en: 24-05-2013, 22:14 (Viernes) »
Tienes que configurar el apartado LAN en la misma subred del router principal, desactivarle el DHCP, configurar la wifi en modo AP (asociada a la parte LAN) y desactivarle el firewall (esto último no sería totalmente necesario).
« Última modificación: 24-05-2013, 22:24 (Viernes) por jar229 »

danitool

  • Visitante
Re: [Ayuda] Modo repetidor por cable
« Respuesta #2 en: 24-05-2013, 23:47 (Viernes) »
Esto es lo que se llamaría un Dumb AP
http://wiki.openwrt.org/doc/recipes/dumbap

Es lo más sencillo que existe. Simplemente consiste tal y como viene por defecto Openwrt, desactivar el dhcp y activar el wifi. Ah y tener cuidado de que 192.168.1.1 no sea la ip del router que provee internet, si es así basta con cambiarla a cualquier otra en openwrt.

todoen

  • Visitante
Re: [Ayuda] Modo repetidor por cable
« Respuesta #3 en: 23-03-2014, 14:44 (Domingo) »
Hola. Solicito de vuestra colaboración, dado que mi experiencia en redes es casi nula ( ^-^)

El esquema de mi red es el siguiente:

El router 1 (Firm.  v2.0.0.51B_ESv6) es el que me da el proveedor con su firmware, tal cual.

"Problemas por desconocimiento":

A. El router 3 (firm OpenWrt Backfire 10.03.1: openwrt-96348GW-generic-squashfs-cfe.bin) lo he configurado gracias al excelente manual https://foro.seguridadwireless.net/openwrt/(tutorial)-modo-clienterepetidor-openwrt/ en Modo Cliente Enrutado(Parte 1), que es lo que creí que yo necesitaba, pero me gustaría que las direcciones estuviesen en la misma red del primero, es decir, en la 192.168.1.x. y no en la 192.168.2.x ¿es posible?

ACTUALIZACION: He probado, en el item "2.- Cambiar la subred de la interfaz LAN del router a una distinta a la del router principal" en darle la 192.168.1.100 y efectivamente la asume, pero aunque los equipos conectados quedan con direcciones 192.168.1.x, al hacer ping hacia los equipos que se conectan al amper no los ve, ni viceversa, es decir, un equipo conectado al amber no hace ping al equipo de esa red. Lo que necesito es que todos esten en la misma red..... ??? ??? ??? De hecho, desde los equipos conectados por cable no puedo acceder al router que provee internet.


B. Ahora bien, el router 2 lo tengo instalado en modo DumpAP y me da tanto wifi como acceso a la red , simplemente instalando el openwrt, conectando el cable y configurando una nueva wifi (dhcp desactivado).
a) Tengo activada una interfaz WAN creada por default ¿debería eliminarla?
b) Me gustaría que las direcciones de ese router fuesen 192.168.3.x ¿es posible? ¿como?
c) Ya para complicar, ¿podría dar direcciones 192.168.1.x en los puertos de red para cable de ese router y 192.168.3.x sobre el wifi? ¿como?

Gracias de antemano por vuestra colaboración
« Última modificación: 23-03-2014, 20:15 (Domingo) por todoen »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re:
« Respuesta #4 en: 23-03-2014, 19:13 (Domingo) »
Para que todos los equipos estén en la misma subred, debes usar relayd en el que tienes como cliente WiFi (mirate el post recopilatorio de hilos relevantes).

Con lo que respecta a que los equipos conectados por WiFi estén en una subred distinta, me imagino que es para habilitar una red de invitados o algo así. Mira por el foro, creo recordar que había un tema dedicado a ello.

Enviado desde mi CUBOT GT99

todoen

  • Visitante
Re: [Ayuda] Modo repetidor por cable
« Respuesta #5 en: 23-03-2014, 19:45 (Domingo) »
Gracias por la pronta respuesta, me pongo en la búsqueda inmediatamente

https://foro.seguridadwireless.net/openwrt/instalando-openwrt-en-comtrend/msg297126/#msg297126
« Última modificación: 23-03-2014, 20:15 (Domingo) por todoen »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Ayuda] Modo repetidor por cable
« Respuesta #6 en: 23-03-2014, 20:49 (Domingo) »
Gracias por la pronta respuesta, me pongo en la búsqueda inmediatamente

https://foro.seguridadwireless.net/openwrt/instalando-openwrt-en-comtrend/msg297126/#msg297126

No había caído en que en ese Comtrend puedes usar el driver propietario de broadcom, con lo que no necesitas usar relayd  ;)

todoen

  • Visitante
Re: [Ayuda] Modo repetidor por cable
« Respuesta #7 en: 24-03-2014, 02:57 (Lunes) »
Gracias por tu ayuda inmediata. Por ahora la cosa va así:

He sustituido el Router2 como menciono en este post y me ha gustado por ahora la interfaz del gargoyle (muy sencilla) y sus prestaciones. Con esto resuelvo por ahora el a) pues aquí se necesita la interfaz wan, el b) direcciones en otra red (192.168.2.1) con clientes aislados y quedo pendiente de revisar lo que mencionaste de la red de invitados. A ver si lo encuentro.

Mañana o pasado a por el router3.
« Última modificación: 24-03-2014, 11:19 (Lunes) por todoen »

todoen

  • Visitante
Re: [Ayuda] Modo repetidor por cable
« Respuesta #8 en: 26-03-2014, 17:06 (Miércoles) »
Hola. Solicito de vuestra colaboración, dado que mi experiencia en redes es casi nula ( ^-^)

El esquema de mi red es el siguiente:

El router 1 (Firm.  v2.0.0.51B_ESv6) es el que me da el proveedor con su firmware, tal cual.

"Problemas por desconocimiento":

A. El router 3 (firm OpenWrt Backfire 10.03.1: openwrt-96348GW-generic-squashfs-cfe.bin) lo he configurado gracias al excelente manual https://foro.seguridadwireless.net/openwrt/(tutorial)-modo-clienterepetidor-openwrt/ en Modo Cliente Enrutado(Parte 1), que es lo que creí que yo necesitaba, pero me gustaría que las direcciones estuviesen en la misma red del primero, es decir, en la 192.168.1.x. y no en la 192.168.2.x ¿es posible?

ACTUALIZACION: He probado, en el item "2.- Cambiar la subred de la interfaz LAN del router a una distinta a la del router principal" en darle la 192.168.1.100 y efectivamente la asume, pero aunque los equipos conectados quedan con direcciones 192.168.1.x, al hacer ping hacia los equipos que se conectan al amper no los ve, ni viceversa, es decir, un equipo conectado al amber no hace ping al equipo de esa red. Lo que necesito es que todos esten en la misma red..... ??? ??? ??? De hecho, desde los equipos conectados por cable no puedo acceder al router que provee internet.


B. Ahora bien, el router 2 lo tengo instalado en modo DumpAP y me da tanto wifi como acceso a la red , simplemente instalando el openwrt, conectando el cable y configurando una nueva wifi (dhcp desactivado).
a) Tengo activada una interfaz WAN creada por default ¿debería eliminarla?
b) Me gustaría que las direcciones de ese router fuesen 192.168.3.x ¿es posible? ¿como?
c) Ya para complicar, ¿podría dar direcciones 192.168.1.x en los puertos de red para cable de ese router y 192.168.3.x sobre el wifi? ¿como?

Gracias de antemano por vuestra colaboración

Se que no es sano autocitarse, pero tengo que dar las gracias a:
jar229 (el primer implicado en ayudarme), danitool, noltari y a todos los demás participantes de este foro que de una u otra manera enriquecen con conocimientos el mismo.

Complemento la solución temporal final obtenida:

1. El router1 como mencionaba, es el del proveedor de internet. Allí he tenido que hacer una modificación que luego documento para el relayd del router 3

2. Para el router2, conectado por cable, he utilizado un router TPLINK TL-WR741ND v2.4 con la configuración que menciono aquí, conectando el cable desde el router amber 26555 al puerto WAN azul del TPLink. Asi, las direcciones están bajo la subred?? 192.168.2.1 que no corresponde con la gráfica original. Tanto el router como todos los clientes ethernet y wifi conectados a él son invisibles desde la red principal y viceversa. Luego probare un portal captative y otras locuras...

3. Para el router3, he utilizado un Comtrend CT5361 de los blancos de Movistar, con OpenWRT Backfire 10.03.1 usando relayd. Llevo cuatro días trasnochando y luchando con el hijo de putty WinSCP, el telnet, la com-****-ción (o era com-pila-ción??  ^-^ ) con el driver privativo y nada (y eso que reitero que sin vuestra ayuda no lo habría logrado). Al final, he utilizado una mezcla de dos manuales:
A. Primero, he realizado los pasos indicados por Noltari en la parte 1 del Modo cliente enrutado (Routed Client Mode).
B. Cuando lo he tenido conectado al internet, he descargo el relayd por dentro de Luci y le he colocado el pass de administrador
C. Con la Putty y el WinSCP he ido desarrollando la sección de Configuration, donde me he encontrado, por ejemplo, que el iwlist scan no me funcionaba, pero no lo necesitaba pues ya estaba detectada la wifi cuando hice el paso de Noltari indicado en A. Así que he ido realizando los cambios indicados del Step 1 al Step7, he realizado el "Apply Changes", luego he "Enable access from main network" y todo funcionando
D. Por ultimo, en el router1 del proveedor de internet, he asignado la Mac address de la interfaz wwan a la IP asignada del stabridge para que siempre sea la misma, pues es posible que lo apague en las noches. (You should make sure the main router is statically assigning the relay router the same IP address all the time).

Quien desee, puedo compartir los archivos de configuración /etc/config/network, /etc/config/wireless, /etc/config/firewall y /etc/config/dhcp, pues en todos han quedado reflejados los cambios o puedo ayudarlo con este modelo de router...

Ahora, ya que me ha quedado un CT5361, seguiré con danitool en otras locuras

Adicionalmente, a resolver los problemas con el DLNA/UPNP
« Última modificación: 26-03-2014, 23:02 (Miércoles) por todoen »

todoen

  • Visitante
Re: [Ayuda] Modo repetidor por cable
« Respuesta #9 en: 16-04-2014, 02:35 (Miércoles) »
Quiero expresar que gracias a vosotros y al foro de openwrt, por ahora tengo configurado el Comtrend CT5361 blanco de movistar con firmware Backfire conectado por cable (Router 2 en la gráfica arriba) al router del proveedor de internet (router 1 de la citada gráfica) con la siguiente configuración tomada de aquí:

network
Código: [Seleccionar]
config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'

config 'interface' 'lan'
option 'type' 'bridge'
option 'ifname' 'eth1'
option 'proto' 'static'
option 'netmask' '255.255.255.0'
#option 'nat' '1'
option 'ipaddr' '192.168.1.2'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config interface 'wifi'
        option ifname 'radio0'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option defaultroute '0'

wireless:

Código: [Seleccionar]
config 'wifi-device' 'radio0'
option 'type' 'mac80211'
option 'channel' '11'
option 'macaddr' '05:17:2z:3e:1f:d8'
option 'hwmode' '11g'
option 'txpower' '20'
option 'country' 'ES'

config 'wifi-iface'
option 'device' 'radio0'
option 'network' 'wifi'
option 'mode' 'ap'
option 'encryption' 'psk2'
option 'key' 'clave'
option 'ssid' 'OpenWrt'

dhcp
Código: [Seleccionar]
config dnsmasq
option domainneeded 1
option boguspriv 1
option filterwin2k 0  # enable for dial on demand
option localise_queries 1
option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
option rebind_localhost 1  # enable for RBL checking and similar services
#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain     '64.94.110.11'

config dhcp lan
option interface lan
option ignore 1

config dhcp wifi
        option interface        wifi
        option start    100
        option limit    150
        option dynamicdhcp      1
        option leasetime        12h

config dhcp wan
option interface wan
option ignore 1

firewall
Código: [Seleccionar]
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
        option masq             1

config zone
        option name             wifi
        option network          'wifi'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config forwarding
        option src              wifi
        option dest             lan

config include
        option path /etc/firewall.user

lo cual me permite el objetivo inicial, es decir, mantener la lan con las mismas ip's que el router principal, pero la wifi sobre otro rango de direcciones independiente.

Ahora lo que busco es reemplazar el Comtrend por el TpLink TL-WR741ND con firmware Attitude, el cual tiene un puerto WAN que voy a utilizar como entrada e intentar separar las ip's de la lan y las de la wifi. Si alguien me puede colaborar...

MODIFICACIÓN: Bien, he realizado una ligera modificación de la anterior para el Tp-Link mencionado y ha funcionado a la primera. Os dejo copia por si le pudiese interesar a alguien o encontrasen algo que no deba ir. Acepto sugerencias o recomendaciones. Gracias por todo

network
Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'

config interface 'wan'
option type 'bridge'
option ifname 'eth1'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'

config interface 'wifi'
        option ifname 'radio0'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option defaultroute '0'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 3 4'

wireless:

Código: [Seleccionar]
config wifi-device  radio0
option type     mac80211
option channel  11
option macaddr f4:em:38:fn:ba:56
option hwmode 11ng
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1

config wifi-iface
option device   radio0
option network  wifi
option mode     ap
option ssid     'laquetesalgadeloshue'
option encryption 'none'


dhcp
Código: [Seleccionar]
config dnsmasq
option domainneeded 1
option boguspriv 1
option filterwin2k 0  # enable for dial on demand
option localise_queries 1
option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
option rebind_localhost 1  # enable for RBL checking and similar services
#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain     '64.94.110.11'

config dhcp lan
option interface lan
option start 100
option limit 150
option leasetime 12h

config dhcp wan
option interface wan
#option ignore 1

config dhcp wifi
        option interface        wifi
        option start    100
        option limit    150
        option dynamicdhcp      1
        option leasetime        12h

firewall
Código: [Seleccionar]
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name lan
option network 'lan'
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq             1

config zone
option name wan
option network 'wan'
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

config zone
        option name             wifi
        option network          'wifi'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config forwarding
option src lan
option dest wan

config forwarding
        option src              wifi
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4

# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fe80::/10
option src_port 547
option dest_ip fe80::/10
option dest_port 546
option family ipv6
option target ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT

# include a file with users custom iptables rules
config include
option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT

# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT

# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP

# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp

# allow IPsec/ESP and ISAKMP passthrough
#config rule
# option src wan
# option dest lan
# option protocol esp
# option target ACCEPT

#config rule
# option src wan
# option dest lan
# option src_port 500
# option dest_port 500
# option proto udp
# option target ACCEPT

### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT

#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp

Si mi terminología de redes no es la más adecuada, es por mi falta de conocimiento  ;) ;D

NOTA: Se han ajustado algunas "recetas" en el wiki del OpenWrt, como el dump, muy interesante para DLNA...


MODIFICACION B: (en proceso) Bien, he seguido utilizando el TP-Link TL-WR741ND v2.4 con openwrt attitude_adjustment para mantener el DumpAP por cable. He decidido configurar:
a) Un puente entre los puertos lan wan para que el rango de direcciones de los equipos sea el mismo de la red principal cableada. Me he guiado por:
http://wiki.openwrt.org/doc/recipes/dumbap
http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd
b) Deshabilitar el switch vlan (guias idem al anterior)
c) Mantener una wifi privada (las guias anteriores y mis configuraciones)
d) Crear una wifi de invitados
http://wiki.openwrt.org/doc/recipes/guest-wlan
http://wiki.openwrt.org/doc/recipes/guest-wlan-webinterface

Comienzo los nuevos archivos de configuración:

Network: Para la red cableada, puedo conectar el cable desde el router de acceso a internet por el puerto wan o por el puerto lan sin problemas y también puedo conectar el ordenador al puerto lan o al puerto wan
Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0 eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'

config switch
option name 'eth0'
option reset '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 3 4 5t'
option vid '1'

wireless
Código: [Seleccionar]
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option macaddr 'f4:em:38:fa:bz:5n'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option country 'ES'
option txpower '20'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'ndlhPrivada'
option key 'jajaja25'
option encryption 'psk2'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'mode' 'ap'
        option 'network' 'wifi'
        option 'ssid' 'PC'
        option key 'jaja25'
option encryption 'psk2'

Problemas:
A) Desconozco si la configuración es "óptima" (no creo) y si esta "bien" configurado para evitar redundancias
B) Me gustaría resolver el problema de la wifi, que solo me acepta el acceso a internet cuando conecto el  cable desde el router de acceso a internet por el puerto wan
« Última modificación: 21-04-2014, 00:22 (Lunes) por todoen »