Autor Tema: Wifislax 2.4 NO arranca modo gráfico  (Leído 1981 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado 3x1Mn76

  • **
  • Mensajes: 7
Wifislax 2.4 NO arranca modo gráfico
« en: 30-04-2021, 04:45 (Viernes) »
Arranco live cd, instalo el sistema, reinicio y no arranca modo gráfico. Puedo iniciar session con root/toor y ejecutar comandos pero no el modo gráfico.

Probado con virtual box y VMware, no arranca el modo gráfico.




@USUARIONUEVO come here


« Última modificación: 30-04-2021, 04:46 (Viernes) por 3x1Mn76 »

Desconectado ea1kt

  • **
  • Mensajes: 7
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #1 en: 30-04-2021, 18:57 (Viernes) »
despues de todo eso usa:      startx

Desconectado 3x1Mn76

  • **
  • Mensajes: 7
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #2 en: 30-04-2021, 19:09 (Viernes) »
despues de todo eso usa:      startx

Tampoco funciona.
USUARIONUEVO hay un bug en vuestro sistema, necesito ayuda.




Desconectado CristianEdgardo

  • ****
  • Mensajes: 65
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #3 en: 30-04-2021, 21:07 (Viernes) »
Descarga de nuevo y verifica la iso.. capaz que por alguna razon oscura de internet no se descargo bien y hubo problemas al descargar...
En virtualbox, en windows, ni te molestes, no es vbix ni las iso, es windows 10 el que da problemas... pero la 2.4 arranca bien, la que no pude hacer aqrrancar en es la version con plasma 5, que vbox y linux arranca lo mas bien.

Desconectado 3x1Mn76

  • **
  • Mensajes: 7
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #4 en: 30-04-2021, 22:12 (Viernes) »
Descarga de nuevo y verifica la iso.. capaz que por alguna razon oscura de internet no se descargo bien y hubo problemas al descargar...
En virtualbox, en windows, ni te molestes, no es vbix ni las iso, es windows 10 el que da problemas... pero la 2.4 arranca bien, la que no pude hacer aqrrancar en es la version con plasma 5, que vbox y linux arranca lo mas bien.
He descargado la iso dos veces, ambos iso pesaban lo mismo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #5 en: 30-04-2021, 22:19 (Viernes) »
Un bug dice , ... el mensjae mas claro no puede ser , si le faltan librerias como va a arrancar ...

O la particion que tienes para instalar es muy pequeña o alguno modulo cuando arrancas te dice error y no lo ves  ...

No esta bien instalada , y eso es todo , asi que repasa que la particion es ext4 , tiene mas de 10 gigas en limpio , y si le añades extras necesitara mas espacio , .


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #6 en: 30-04-2021, 22:20 (Viernes) »
Descarga de nuevo y verifica la iso.. capaz que por alguna razon oscura de internet no se descargo bien y hubo problemas al descargar...
En virtualbox, en windows, ni te molestes, no es vbix ni las iso, es windows 10 el que da problemas... pero la 2.4 arranca bien, la que no pude hacer aqrrancar en es la version con plasma 5, que vbox y linux arranca lo mas bien.
He descargado la iso dos veces, ambos iso pesaban lo mismo.

que pesen lo mismo no quiere decir que estn bien descargadas , en todo caso si arranca en live esta ok , asi que algo pasa al instalar.

¿cuanta memoria tiene ese pc?

pfffffffffffffffffffff  vmware  ,  vbox etc ....  BUENA SUERTE CON ESO AMIGO.

No se si el instalador es capaz de darse cuenta que le falta espacio en una maquina virtual ... ademas casi seguro el fallo es que tiene poca ram asignada y el proceso de instalacion necesita que al menos tengas 1 giga de ram , ya que la instalacion alcanza picos de 700 y 800 megas al descomprimir los modulos al hdd.
« Última modificación: 30-04-2021, 22:22 (Viernes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #7 en: 30-04-2021, 22:25 (Viernes) »
El fascinante mundo de las maquinas virtuales y como hechar a perder el rendimiento de un sistema  ;D

Vale mas la pena que la uses solo como live desde un pincho usb antes que instalada en virtual , yo de maquina virtual 0 , asi que solo te puedo decir eso , que algo falla al instalar , o la particion que le das no es de 10 gigas o mas, o la ram que le asignas es menos de 1 giga.

por defecto crean hdd de 8 gigas y ram 512 , asi que a menos que lo cambies tendras mal las dos cosas , pero el bug es el sistema  ;D

Desconectado 3x1Mn76

  • **
  • Mensajes: 7
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #8 en: 30-04-2021, 23:43 (Viernes) »
El fascinante mundo de las maquinas virtuales y como hechar a perder el rendimiento de un sistema  ;D

Vale mas la pena que la uses solo como live desde un pincho usb antes que instalada en virtual , yo de maquina virtual 0 , asi que solo te puedo decir eso , que algo falla al instalar , o la particion que le das no es de 10 gigas o mas, o la ram que le asignas es menos de 1 giga.

por defecto crean hdd de 8 gigas y ram 512 , asi que a menos que lo cambies tendras mal las dos cosas , pero el bug es el sistema  ;D


¿Por qué deberían faltarme librerias? La ISO es original.
La partición es de 100 GB y ext4
Mi pc tiene 16 GB de ram, le he asignado a la maquina virtual 1GB. Acabo de probar con 6GB y tampoco arranca el modo gráfico.

Ahora he instalado esta versión https://foro.seguridadwireless.net/live-wifislax/enlaces-wifislax-4-12/ y funciona, sin embargo veo que la última versión de 64 bits tiene mas programas ¿no?

¿Puedes ayudarme estimado y amado USUARIONUEVO?  >:(

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #9 en: 01-05-2021, 02:22 (Sábado) »
no puedo ayudarte por que no uso maquina virtual , buena suerte.

la libreias faltan por que  o no se han copiado , o la iso aunque sea ORIGINAL, puede estar corrupta ,¿has mirado el md5?

La verdad , paso bastante de maquinas virtuales.  ;D
« Última modificación: 01-05-2021, 02:25 (Sábado) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #10 en: 01-05-2021, 03:06 (Sábado) »
Me he animado a mirar a ver ....

No se por que , le asigno 2 gigas de ram , y solo muestra libres 65 megas  ;D

Usando el comando

Citar
free

mientras no veas en la parte que pone free al menos 1 giga de ram libre no podras instalarlo  , lo raro es que si le asigno 4 gigas de ram , entonces muestra libres 2 gigas.


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #11 en: 01-05-2021, 03:08 (Sábado) »
si tu pc tiene 16 gigas de ram , configura la maquina para darle 4 , y antes de ponerte a instalar , comprueba con el comando

free

que la maquina dispone de al menos 1 gigas libre en el apartado que se llama igual que el comando. en free debe tener al menos 1 giga ,si no , la instalacion no sera completa y luego no arrancara.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #12 en: 01-05-2021, 04:10 (Sábado) »
conclusiones ,  ejecutando free , debemos tener al menos 1 giga de ram libre ...

en maquina virtual , el gasto de memoria se dispara ademas que el kernel usa la memoria para cachear todo lo que puede ,con lo que se suman demasiadas cosas.

He hecho una instalacion con exito en virtualbox , configurandole 2 gigas ... pero liberandole las caches antes de lanzar el instalador.

Código: [Seleccionar]
sync; echo 3 > /proc/sys/vm/drop_caches
Aqui es un poco complicacdo que decidir hacer , por que esta bien que el sistema cachee , para que las cosas cada vez vayan mas rapido ... abrir navegador y demas , eso es capaz de manejarlo y soltar dinamicamente ram si se necesita ,  pero con el instalador no , por lo que lo unico razonable que se me ocurre es en el instalador , como primer paso antes de ir a instalar, hacer que limpie las caches para recuperar toda la ram posible.

Pensaba mirar la config del kernel , pero es que cuando lo instalas al hdd , esa mejora de cachear se nota mucho , sobretodo si tienes un hdd mecanico.

Desconectado 3x1Mn76

  • **
  • Mensajes: 7
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #13 en: 01-05-2021, 04:55 (Sábado) »
Ha funcionado, gracias  :-* He instalado el sistema con 4GB de ram en lugar de 1GB




Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #14 en: 01-05-2021, 04:59 (Sábado) »
Voy a poner antes de que arranque el sistema y llegue a escritorio que vacie las caches , y tambien al lanzar el instalador.

en modo live contra mas ram libre mejor , en hdd ya no importa tanto.

en todo caso y para futuro , comprobar antes con free , si se tiene 1 giga de ram libre para la instalacion.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #15 en: 01-05-2021, 05:00 (Sábado) »
una vez ya en el hdd, si quieres puedes dejarle 2 gigas de ram a la maquina virtual.

intentare mirar algun mecanismo en el instalador que haga como con el tamaño de la particion , que si no es de 10 gigas o mas te para el proceso , pues algo asi con la ram ... ;)
« Última modificación: 01-05-2021, 05:01 (Sábado) por USUARIONUEVO »

Desconectado 3x1Mn76

  • **
  • Mensajes: 7
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #16 en: 01-05-2021, 05:21 (Sábado) »
¿La versión 2.4 tiene menos herramientas o es que no alcanzo a ver la pantalla completa? Estoy instalando las vmware tools pero no funcionan



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #17 en: 01-05-2021, 05:29 (Sábado) »
lo de siempre ...veo pocas cosas en el menu ..es que no hay tools.

por ejemplo en la seccion wps ...para que quieres las entradas de menu de reaver o wash ....

las herramientas estan.

sobre el problema de la ram , ya tengo la variable para el instalador

Citar
MEM=$(cat /proc/meminfo|grep MemFree|rev|cut -d ' ' -f2|rev)

if [ $MEM -lt 1024000 ]; then
      yad --on-top --center \
          --width 500 \
          --height 190 \
          --gtkrc="$THEME" \
          --title "$TITULO" \
          --window-icon "$LOGO" \
          --image "$LOiGO_STOP"  \
          --button "gtk-ok:0" \
          --text-align "center" \
          --text "\n\n\n    El sistema debe tener al menos 1GB de ram libre.  \n"
      exit
fi

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15503
Re:Wifislax 2.4 NO arranca modo gráfico
« Respuesta #18 en: 01-05-2021, 05:29 (Sábado) »
Como el tema inicial esta mas que despejado , se cierra , y si tienes mas cosas abres hilos nuevos.