Autor Tema: Wicd con rtl8187 no conecta con WPA  (Leído 6981 veces)

0 Usuarios y 1 Visitante están viendo este tema.

soios

  • Visitante
Wicd con rtl8187 no conecta con WPA
« en: 30-08-2013, 22:53 (Viernes) »
Saludos a todos. Soy nuevo en el foro, aunque lo he seguido mucho para resolver dudas. Tengo que decir que es un gran trabajo el que estáis haciendo muchos de vosotros para que esta distribución funcione tan bien.  >:(

Y después de haceros un poco la pelota :-P. Quería preguntaros algo que posiblemente se haya tratado ya pero yo no logro de encontrar la solución, y es que cuando me conecto a una red WPA con el wicd me autentifica bien e incluso me dice "Done Connection" pero inmediatamente después se desconecta. ¿hay alguna solución o es solo algo que me pasa a mi?  

GRACIAS


« Última modificación: 30-08-2013, 22:54 (Viernes) por soios »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8420
Re: Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #1 en: 31-08-2013, 02:23 (Sábado) »
Si usas la 4.5 pasa a la 4.6

Si no es eso es preciso que des mas detalles y si es posible sin paja jejejejwjwj

De 10 lineas (en el móvil) hablas de caso en 2 lo demás no importa .   

Las 3  C.  Claro , conciso, y corto

Saludos

soios

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #2 en: 31-08-2013, 18:07 (Sábado) »
Tengo la 4.6 y esta instalada en una partición del disco. Hasta ahora me conectaba a una red con cifrado WEB y me ha ido bastante bien, pero ahora necesito conectar con una red WPA-PSK del tipo WLAN_XXXX, que tiene bastante calidad de señal (mas del 70%) la contraseña esta bien apuntada y el wicd se conecta, pero se desconecta inmediatamente después. Y desde windows se conecta sin problemas.

De todas formas si me dices que es algo que solo me pasa a mi... intentare conectarme a otra red WPA a ver que pasa.

Perdona si he escrito mucho. Intentare las próximas veces aplicarme lo de las 3 C.

alist3r

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #3 en: 31-08-2013, 19:44 (Sábado) »
- el cifrado web no existe xD
- necesitarias un kernel mas nuevo, pues se ha avanzado bastante en el uso de tarjetas realtek con cifrados WPA/WPA2. es cierto que se "descuelgan" esporádicamente. a veces hay que jugar con los parámetros del "módulo" (del "driver").

he tenido que subir a 3.10.10 para que la realtek de uno de mis portatiles sea medio estable conectando a un router que tiene a dos metros por WPA2.  en mi caso, mejora bastante con estos parámetros:
ips=0 swlps=0 fwlps=0

una pena pero asi son las cosas con algunas realtek.
« Última modificación: 31-08-2013, 19:48 (Sábado) por alister »

alist3r

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #4 en: 31-08-2013, 19:53 (Sábado) »
PD: wicd no tiene la culpa. comprobado mil veces en las mailing lists de desarrollo de los drivers realtek. de hecho, si probases la alternativa (el Network-Manager que viene de serie en gnome), te iria mucho peor.

soios

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #5 en: 31-08-2013, 21:22 (Sábado) »
Perdonar mi ignorancia, pero como se cambian esos parámetros?. Me gustaría probar.

alist3r

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #6 en: 31-08-2013, 21:36 (Sábado) »
los parametros que he comentado, son para el rtl8192se.
acabo de comprobar que no tienes esas opciones en rtl8187, así que para tu caso particular, descarta lo que propuse, sorry.
tu opción más sencilla es subir la versión de la distribucion linux, para así poder probar con un kernel superior y ver si tienes mejores resultados.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14484
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #7 en: 31-08-2013, 21:55 (Sábado) »
lo de subir d ekernel , va a estar complicado.

estoy ATASCADISIMO , en las ramas 3,6 y 3,7    ....de hay hacia arriba no consigo que ningun kernel me funcione perfecto para auditar.


tipico cartelito de fix channel -1




alist3r

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #8 en: 31-08-2013, 22:00 (Sábado) »
lo de subir d ekernel , va a estar complicado.

estoy ATASCADISIMO , en las ramas 3,6 y 3,7    ....de hay hacia arriba no consigo que ningun kernel me funcione perfecto para auditar.


tipico cartelito de fix channel -1


sáltate el 3.8 y prueba con el 3.10, pero sin tratar de superponer ningun stack wireless encima. de todos modos el resultado será totalmente actualizado.


a las malas, compila el ultimo aircrack con soporte para --ignore-negative-one

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14484
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #9 en: 31-08-2013, 22:12 (Sábado) »
lo de aircrack , ya lo tengo mas que actualizado , pero las guis no saben que es ignore-negative .

ademas no se si te habras fijado , pero aunque tu ignores el mnsaje , no puedes hacer nada , por que el driver directamente se niega.



si quieres debatir , abrimos un post en desarrollo de nuestras lives.

El principal problema radica en el hecho de que necesito que todo funcione , con las interfaces arriba..."up" , ya que las ralink por ejemplo no inyectan pins en reaver si no esta la interface real arriba.


lo de superponer stacks wireless, hace mucho que se dejo de hacer ... desde que yo hago los kerneles , eso ya no s ehace mas.

para tener drivers nuevos , lo mejor es KERNEL NUEVO.





« Última modificación: 31-08-2013, 22:21 (Sábado) por USUARIONUEVO »

alist3r

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #10 en: 31-08-2013, 22:41 (Sábado) »
lo de aircrack , ya lo tengo mas que actualizado , pero las guis no saben que es ignore-negative .

ademas no se si te habras fijado , pero aunque tu ignores el mnsaje , no puedes hacer nada , por que el driver directamente se niega.



si quieres debatir , abrimos un post en desarrollo de nuestras lives.

El principal problema radica en el hecho de que necesito que todo funcione , con las interfaces arriba..."up" , ya que las ralink por ejemplo no inyectan pins en reaver si no esta la interface real arriba.


lo de superponer stacks wireless, hace mucho que se dejo de hacer ... desde que yo hago los kerneles , eso ya no s ehace mas.

para tener drivers nuevos , lo mejor es KERNEL NUEVO.


estos parches resolverán tu atascamiento
https://foro.seguridadwireless.net/live-wifislax/parches-que-vais-a-necesitar-en-3-8-en-adelante/msg285243

soios

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #11 en: 31-08-2013, 23:10 (Sábado) »
Ojala podáis ponerle el nuevo kernel...

Esperare a nuevas versiones de wifislax.

Saludos

alist3r

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #12 en: 01-09-2013, 04:50 (Domingo) »
ya le estamos partiendo la cara al 3.10.10
tranquilos, la cabezoneria tiene premio.

salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14484
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #13 en: 01-09-2013, 05:18 (Domingo) »
ya le estamos partiendo la cara al 3.10.10
tranquilos, la cabezoneria tiene premio.

salu2

llevo ya muchos meses anclado , ojala sea verdad que machaquemos un 3.10 a lo grande.

soios

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #14 en: 29-09-2013, 21:26 (Domingo) »
Pero que grandes sois!!.

Con el nuevo kernel 3.10.10, mi adactador rtl8187l por fin se conecta a redes con WPA perfecto.

Perdonar que haya reabierto el tema, era para aclarar que ya se ha solucionado.

Gracias.

alist3r

  • Visitante
Re: Wicd con rtl8187 no conecta con WPA
« Respuesta #15 en: 29-09-2013, 21:28 (Domingo) »
jajajaja! creo que te van a perdonar porque es para poner un comentario positivo y un agradecimiento xD