Autor Tema: Sin acceso a internet por wifi. Cosa rara.  (Leído 7301 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Vins

  • Visitante
Sin acceso a internet por wifi. Cosa rara.
« en: 13-06-2013, 17:26 (Jueves) »
Hola, acabo de registrarme y quieros agradeceros a todos el trabajo que hacéis con el wifislax.
He estado usando el programa desde un USB durante tiempo sin problemas.
El otro día decidí instalarlo en mi eeepc desde dónde lo usaba, quitando el xp de las narices :)
Después de algún problemilla lo instalé en el HD y todo perfecto pero...

- No tengo acceso a internet con Wifi (No he probado por cable)
- No veo ningún dispositivo de mi red
- Desde firefox accedo al los routers de la red introduciendo la IP pero no a sitios de internet (No es problema de DNS)

Estoy bastante perdido ¿Alguna idea de dónde puede estar el problema?



SpanishGroove

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #1 en: 13-06-2013, 17:41 (Jueves) »
Pues en principio parecen problemas de instalación... Dices que te ocurrió un problemilla, que ocurrió?

El problema es que se conecta a la red pero no hay trafico, no?

A que te refieres con que no ves ningun dispositivo en tu red?

Vins

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #2 en: 13-06-2013, 18:54 (Jueves) »
Gracias por responderme.
Los problemas que tuve en la instalación fueron:

Le di a instalar wifislax al HD y al llegar a la instalación del gestor de arranque me dió error, resultó que no había formateado el HD en ext
Volví a instalar y todo bien aunque no me aparecía la tarjeta wifi, me di cuenta que la tenía desactivada en la bios, por más que intenté no conseguí que el sistema la reconociese así que nuevo formateo y reinstalación.

Ya parecía que iba todo pero...
Veo redes wifi
Me conecto a mi wifi sin problemas
En firefox pongo 192.168.1.4 y accedo a mi router ADSL, pongo 192....8 y accedo al router Wifi
Pongo cualquier dirección web y no carga la página
Pongo la web directamente por IP y tampoco carga
Voy al gestor de archivos, le doy a red y no aparece nada (Hay los dos routers y un ordenador con W2003 Server con un directorio compartido, tengo más cosas pero en este momento estan desconectadas, como la impresora por ejemplo)
Si intento crear un enlace al directorio compartido del windows tampoco lo encuentra.

Da la impresión como si hubiese algún firewall bloqueando las conexiones. No se me ocurre qué más probar.

SpanishGroove

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #3 en: 13-06-2013, 18:58 (Jueves) »
En los dos intentos tuviste que activar el wifi desde la bios?

Podrias probar la red desde Live USB o CD para descartar la bios?

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8415
Re: Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #4 en: 13-06-2013, 18:59 (Jueves) »
Hola

Entiendo que wicd muestra tu red y al realizar la conexión te otorga ip y muestra conectad ¿verdad?

Si esto es así y no tienes salida a internet es posible que uno de los dos routers te este bloqueando cosa que seria rara si conectas otros equipos normalmente, sin configurar nada

Saludos

Vins

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #5 en: 13-06-2013, 19:42 (Jueves) »
En los dos intentos tuviste que activar el wifi desde la bios?

Podrias probar la red desde Live USB o CD para descartar la bios?

Solo tuve que activar el wifi en la bios la primera vez.

Acabo de probar desde el CD y resulta que me da "Bad Password", osea que no me deja conectar, lo he probado 4 o 5 veces y nada.
El router usa OpenWrt con "Encryption: WPA2 PSK (CCMP)"
Uso para conectar WPA 1/2 Passphrase.
Desde la instalación del HD sí que me conecta con la misma configuración pero no navega.
 ??? ??? ???

Vins

  • Visitante
Re: Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #6 en: 13-06-2013, 19:43 (Jueves) »
Hola

Entiendo que wicd muestra tu red y al realizar la conexión te otorga ip y muestra conectad ¿verdad?

Si esto es así y no tienes salida a internet es posible que uno de los dos routers te este bloqueando cosa que seria rara si conectas otros equipos normalmente, sin configurar nada

Saludos

Parece que has acertado, pero es muy extraño, si lees lo que le he respondido a FAZE-O...

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8415
Re: Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #7 en: 13-06-2013, 19:49 (Jueves) »
Mata wicd y vuelve a levantarlo.  A mi ayer me hizo lo mismo de hecho hubo un momento que no me daba ip, por que se había desactivado el dhcp, lo active y se soluciono, pero en tu caso no sabría decirte y menos si llevas openwrt, que no tengo ni idea de como va pero puede ser ese el que te este cortando la salida.

Conecta directamente al router dsl a ver si te da salida si es así ya estaría mas acotado el tema y habría que llamar a los chicos de openwrt a ver que opinan

Saludos

SpanishGroove

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #8 en: 13-06-2013, 20:04 (Jueves) »
Jejeje, por ahora voy ganando!  >:(

Bueno, volvamos al tema:

Tienes mas dispositivos que se conectan a los routers y pueden acceder a internet, no?

A ver... OpenWrt... La verdad es que no tengo ninguna experiencia con el "SO". Pero en teoria debe ser igual que linux.

Que te parece si haces lo que te dice Sanson, o en su defecto... auditarla por si se le ha ido la pinza...

Tambien ayudaria, que accedieras al router y miraras su configuración. Por si tienes MAC bloqueada o algo, los puertos... etc.

Tambien mirar el DHCP por si hay alguien conectado... Ya que pueden estar jugando, aunque no lo creo.

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8415
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #9 en: 13-06-2013, 20:14 (Jueves) »


comprueba la configuracion de wicd tambien ( que hay veces que se le va la hoya)

clip derecho sobre el icono de la barra de notificacion y lo miras

route table flushing  ........automatic
wire link detectioni  ..........automatic
dhcp client   .....................DHCPCD


wpa supplicant drivers.......  wext
dackent...............................  external



salduos

Vins

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #10 en: 13-06-2013, 20:45 (Jueves) »


comprueba la configuracion de wicd tambien ( que hay veces que se le va la hoya)

clip derecho sobre el icono de la barra de notificacion y lo miras

route table flushing  ........automatic
wire link detectioni  ..........automatic
dhcp client   .....................DHCPCD


wpa supplicant drivers.......  wext
dackent...............................  external



salduos

Todo está como dices.

Respongo aquí para todos:

He estado haciendo pruebas y parece que hay algún tipo de incompatibilidad o mala configuración entre Wifislax y openwrt.
He probado a conectar a la wifi del vecino y ha ido bien.
Luego en la mía he puesto IP fija para que se salte el DHCP del router y también tengo acceso a internet
Sigo sin ver mi red, igual es que hago algo mal.

Lo extraño es que desde cualquier dispositivo, incluido el movil con Android me conecto sin ningún problema, por lo que supongo que hay algo en wifislax que choca con el router y eso que todo es Linux  >:D

Chumpy

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #11 en: 14-06-2013, 02:35 (Viernes) »
Prueba con otro PC, que los móviles hacen cosas raras por su cuenta.

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8415
Re: Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #12 en: 14-06-2013, 08:04 (Viernes) »
Hola

En el navegador de android en las opciones elige vista de escritorio y prueba de nuevo, que android no utiliza el mismo puerto para salir a internet

Mas que incompatibilidad parece problema en la configuración de firewal de openwrt

Saludos

SpanishGroove

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #13 en: 14-06-2013, 13:09 (Viernes) »
Que te parece probar ubuntu Live? O tambien existe por ahí un pequeño windows 7 portable para USB, en el cual puedes navegar y demas; Pruebalo y si sigue fallando, problema de puertos... Tendrias que abrirlos todos. (si no los tienes ya... Claro)

Sino... recompilar OpenWrt y listo.

Vins

  • Visitante
Re: Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #14 en: 14-06-2013, 15:34 (Viernes) »
Hola

En el navegador de android en las opciones elige vista de escritorio y prueba de nuevo, que android no utiliza el mismo puerto para salir a internet

Mas que incompatibilidad parece problema en la configuración de firewal de openwrt

Saludos

Diría que el amigo sanson ha vuelto a dar en el clavo, estás hecho un crack  >:(
La cuestión es que no  se dónde puñetas está el problema.
Adjunto una imagen de la config del firewall del Operwrt por si se os ocurre algo:



Un enlace directo para ver la imagen mejor:

http://usuarios2.arsystel.com/vitete/Openwrt-1.jpg

Vins

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #15 en: 14-06-2013, 16:31 (Viernes) »
Solucionado el acceso a internet  >:( >:( >:( >:( >:( >:(

Al parecer el openwrt interpreta los paquetes de wifislax como inválidos  ??? ??? ???

He desactivado "Drop invalid packets" y parece que ya funciona.

Ahora me falta poder ver lo que hay dentro de mi red.

¿Sigo aquí o abro un nuevo tema?
« Última modificación: 14-06-2013, 16:39 (Viernes) por Vins »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8415
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #16 en: 14-06-2013, 18:35 (Viernes) »
hola


 >:( >:( >:(


sigue ya que estamos ejeje

saludos

pd si no lo ves es por que tienes configuradas dos subredes, comprueba las ips
« Última modificación: 14-06-2013, 18:37 (Viernes) por sanson »

Vins

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #17 en: 14-06-2013, 18:53 (Viernes) »
No, solo tengo una red.
Al lio  ;D

Primero, lo que quiero es acceder a un ordenador con w2008 a un directorio compartido y si de paso se ve el resto bien, sino me da igual.

Voy al gestor de archivos (Dolphin)
Le doy a Red
Me aparecen "MTP Devices" "Recursos compartidos Samba" "Red" y "Añadir carpeta de red"
Pincho sobre MTP y me pone: "No se pudo iniciar el proceso... Error al cargar kio_mtp
Pincho sobre Samba y me pone: "No se pudo iniciar el proceso... Error al cargar kio_smb
Pincho sobre Red y no aparece nada
Pincho sobre Añadir carpeta de red, selecciono disco de red de windows y allí pongo - Nombre: Compartido - Servidor: 192.168.1.3 - Carpeta: Descargas...
Le doy a guardar y conectar y pone: No ha sido posible conectar con el servidor. Compruebe sus preferencias y vuelva a intentarlo

¿Qué estoy haciendo mal?


Nota:

192.168.1.1 - vacío
192.168.1.2 - ordenador con w2003 sin carpetas compartidas
192.168.1.3 - ordenador con w2008 con carpeta compartida
192.168.1.4 - Router ADSL con wifi desactivada y sin DHCP
192.168.1.5 - Una tele Samsung con linux
192.168.1.6 - Un router wifi (Actualmente apagado)
192.168.1.7 - Una impresora (Actualmente apagada)
192.168.1.8 - Router Wifi con Openwrt y Luci.
« Última modificación: 14-06-2013, 19:02 (Viernes) por Vins »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8415
Re: Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #18 en: 14-06-2013, 19:10 (Viernes) »
Madre mía y ¿como lo tienes conectado?  Me explico ¿que va a cada router?

Je je hay sobran cacharros fijo

Saludos

Vins

  • Visitante
Re: Sin acceso a internet por wifi. Cosa rara.
« Respuesta #19 en: 14-06-2013, 19:17 (Viernes) »
Pues si no recuerdo mal los dos ordenadores y la tele van al router ADSL y este y el resto de cosas a un Switch.