Autor Tema: problemas para arrancar wifislax 4.6: error en linea de comandos  (Leído 5448 veces)

0 Usuarios y 1 Visitante están viendo este tema.

gino76

  • Visitante
Hola amigos. En primer lugar me gustaria daros las mil gracias por hacer este gran trabajo y deciros que el mundo no seria el mismo sin ustedes. >:(  En segundo lugar debo reconocer que soy muy verde en este mundillo tan interesante y la verdad que lo estoy padeciendo bastante. A la hora de solucionar dudas, a veces me salen bien pero la mayoria de las veces, buscando respuestas en vez de solucionarlas, surgen 20 dudas mas. La clave esta en la perseverancia y por eso acudo a ustedes como ultimo recurso. Llevo un tiempo trasteando con el wifislax 4,3 en un portatil Compaq con algunos añitos, y mas o menos le habia pillado el truquillo pero por desgracia hace una semana me robaron el portatil del coche. Asi que me vi obligado comprarme uno nuevo que es un notebook HP Envy 15- j008ss con Windows 8, 64bit. Normalnente usaba el Wifislax instalado en un pendrive, que en el anterior portatil funcionaba de fabula pero en este se niega rotundamente. A la hora de arrancar van corriendo las lines de comanos y se para. El mensaje es el siguente:
                                         linux: exec: line 421: bin/chroot: not found
    Debo decir que he intentado arrancarlo tambien con una grabadora externa y me da el mismo fallo. He bajado la ultima version, la 4,6 y tengo el mismo problema. Tambien lo he probado con Wifiway 4,3 y sin exito. Todas las versiones las he probado instalandolas "a pelo" y tambien con ayuda del Yumi, ya no se que hacer. He tratado de buscar respuestas relacionadas en el foro pero no tuve mucha suerte. Les ruego disculpen mi torpeza pero si hay alguien que sepa ayudarme se lo pido por favor ya que me gustaria poder seguir disfrutando de esta gran maravilla de programa. Muchisimas gracias de antemano. Un saludo
PD. si el post donde he publicado el mensaje no es el adecuado ruego disculpas al sr administrador


« Última modificación: 07-09-2013, 12:32 (Sábado) por gino76 »

alist3r

  • Visitante
Re: problemas para arrancar wifislax 4.6: error en linea de comandos
« Respuesta #1 en: 07-09-2013, 17:59 (Sábado) »
has comprado un PC que tiene la nueva tecnología UEFI: "Universal Extendible Firmware Interface".
UEFI sustituye a lo que tradicionalmente llamábamos BIOS. Es una supuesta mejora en la misma, pero que rompe la compatibilidad con las versiones anteriores de todo lo conocido. Incluso en el formato de las tablas de particiones de los discos duros.

para que wifi{slax,way} arranquen en un PC moderno 100% UEFI, necesita modificaciones profundas:
- cambio de bootloader por rEFInd, por GRUB-EFI, eLILO o cualquier otro compatible con UEFI
- cambio de formato del sistema de ficheros tabla de partición a la hora de volcarlo a un pendrive
- opcionalmente, unas claves criptográficas emitidas por MS para sortear el "secure-boot" de UEFI en el caso que no pueda desactivarse en la bios.

- opcionalmente, se puede intentar arrancar con lo que se llama un "pre-bootloader", que es un sistema de arranque compatible con UEFI y que sabe "encadenar" y pasarle el testigo ordenadamente a un sistema operativo de tipo BIOS, que esté en un archivo ISO dentro del mismo pendrive. El cargador de arranque UEFI-MULTI hace este tipo de cosas


en caso de que tu pc sea híbrido (se puede configurar para pasar a modo bios tradicional), entonces todo lo que tienes que hacer es eso, entrar en la configuracion de la placa y cambiar a "legacy mode"

PD: "aplicaciones y diccionarios linux" es para aplicaciones generadoras de diccionarios que se ejecutan en plataformas linux, no para este tipo de cosas
« Última modificación: 07-09-2013, 18:03 (Sábado) por alister »

gino76

  • Visitante
Re: problemas para arrancar wifislax 4.6: error en linea de comandos
« Respuesta #2 en: 07-09-2013, 18:37 (Sábado) »
mil disculpas por haber colocado mal el mensaje y muchisimas gracias. un cordial saludo

alist3r

  • Visitante
Re: problemas para arrancar wifislax 4.6: error en linea de comandos
« Respuesta #3 en: 07-09-2013, 18:41 (Sábado) »
mil disculpas por haber colocado mal el mensaje y muchisimas gracias. un cordial saludo

ya te lo moverá un admin cuando pueda.

por lo que respecta a tu problema, si nadie te aporta una teoria menos negra (estoy 80% convencido que es culpa de UEFI pero quizas otro compañero tenga otra teoria), me temo que tendrás que pasarte a debian, ubuntu o derivadas de estas puesto que son las mas compatibles con UEFI en este momento.

eso, o tener un nivel de conocimientos en sistemas linux muy superior a la media, y hacer un sistema de precarga UEFI por tí mismo (no encuentro manuales decentes para este tema a dia de hoy)
« Última modificación: 07-09-2013, 18:41 (Sábado) por alister »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8405
Re: Re: problemas para arrancar wifislax 4.6: error en linea de comandos
« Respuesta #4 en: 07-09-2013, 19:37 (Sábado) »
Hola

Lo que te dice alister es lo acertado , con una  salvedad .  Si accedes a tu BIOS y tiene la opción de desactivar UEFI , haz lo y arrancara sin problemas .  Para volver a win tendrás que hacer el proceso inverso.

Saludos

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14683
Re: problemas para arrancar wifislax 4.6: error en linea de comandos
« Respuesta #5 en: 07-09-2013, 21:23 (Sábado) »
si fuese el UEFI , no llegaria hasta aqui

 linux: exec: line 421: bin/chroot: not found

ya que ni siquiera empezaria el arrnca.



DESCARGA CORRUPTA.

Los md5 estan para algo.

alist3r

  • Visitante
Re: problemas para arrancar wifislax 4.6: error en linea de comandos
« Respuesta #6 en: 09-09-2013, 10:46 (Lunes) »
si fuese el UEFI , no llegaria hasta aqui

 linux: exec: line 421: bin/chroot: not found

ya que ni siquiera empezaria el arrnca.



DESCARGA CORRUPTA.

Los md5 estan para algo.

me alegra estar equivocado.

alist3r

  • Visitante
Re: Re: problemas para arrancar wifislax 4.6: error en linea de comandos
« Respuesta #7 en: 09-09-2013, 10:47 (Lunes) »
Hola

Lo que te dice alister es lo acertado , con una  salvedad .  Si accedes a tu BIOS y tiene la opción de desactivar UEFI , haz lo y arrancara sin problemas .  Para volver a win tendrás que hacer el proceso inverso.

Saludos

eso es lo que queria decir con este parágrafo:

Citar
en caso de que tu pc sea híbrido (se puede configurar para pasar a modo bios tradicional), entonces todo lo que tienes que hacer es eso, entrar en la configuracion de la placa y cambiar a "legacy mode"
aunque como no he visto muchos de esos, no se si además de llamarlo "legacy mode", en otras máquinas simplemente lo llaman "desactivar UEFI"

//FINAL Y MÁS DOS RESPUESTAS