Autor Tema: Problemas con intel pro wireless 2200BG y wifislax 4.5  (Leído 4629 veces)

0 Usuarios y 1 Visitante están viendo este tema.

albertodecai

  • Visitante
Problemas con intel pro wireless 2200BG y wifislax 4.5
« en: 20-07-2013, 20:57 (Sábado) »
Hola, me descarge la version 4.5 final de wifislax y la inicio en livecd, el arranque va perfecto, pero al lanzar el reaver no me monta la tarjeta en modo monitor, la primera vez si que la monto pero las sucesivas no la detecta y me obliga a cerrar. Yo utilizo un toshiba satellite con windows XP y con la intel pro wireless 2200 BG. La verdad es que no volvi a usar wifislax desde la version 3.1 y la verdad es que sorprende y en gran medida las mejoras que se les a metido y lo sencillo del manejo, sois geniales. Bueno lo dicho, cual puede ser el motivo por el que no me monta la tarjeta en modo monitor.
Un saludo y gracias por las molestias.


« Última modificación: 20-07-2013, 20:59 (Sábado) por albertocm »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #1 en: 20-07-2013, 21:40 (Sábado) »
La tarjeta siempre la tienes que montar TU en modo monitor.

A menos que uses alguna herramienta que ya lo haga ella sola.


reaver no lo hace ...pero si usas wpspingenerator el lo hara por ti , .. o minidwep , o fedingbottle ...


pero reaver a solas NO.


para saber si tu tarjeta es reconbocida por el sistema usa en una terminal

Código: [Seleccionar]
iwconfig

albertodecai

  • Visitante
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #2 en: 20-07-2013, 21:54 (Sábado) »
Muchas gracias por la respuesta Usuarionuevo, lo cierto es que intento montar la tarjeta en modo monitor de forma manual desde la konsola con el airmon-ng, pero no me sale la tarjeta, solo los espacios en blanco. Respecto a lo de reaver, toda la razon, sospecho que ahi me equivoque un poco, al abrir el wpspingenerator es cuando me dice que no se detecta tarjeta. Lo de lanzar el reaver fue otra opcion a la desesperada al ver que no me funcionaba el wpspingenerator por si solo, hacerlo de forma manual, pero no tengo forma de arrancarla. Pero hare el consejo que me has dado acerca de comprobar si la tarjeta es reconocida con el codigo que me has aportado.
Mil gracias.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #3 en: 20-07-2013, 22:04 (Sábado) »
¿ tu tarejeta no sera de esas que lleva un boton para encenderla ?


de ser asi , deberas antes encenderla con rfkill o fsam , que estan en

wifislax -->> hardwrae-tools

albertodecai

  • Visitante
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #4 en: 20-07-2013, 23:02 (Sábado) »
En primer lugar, hice lo que me dijiste, poner iwcofig, pero no sigue poniendo que no encuentra la tarjeta.
En segundo lugar si, mi tarjeta es una de esas del botoncito, intente activarla con fsam y me da como que esta activa, pero al ir al goyscrip nada, sigue igual, lo intente con el rffill7440 con el comando de unblock, pero aun asi tampoco. Al poner en el fsam el estado de la tarjeta me pone "on" pero aun asi nada, no puedo. Esto me esta poniendo a prueba jmm, pero espero dar con la tecla.
Una pregunta ¿Un formateo del ordenador podria solucionar algo? ???

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #5 en: 20-07-2013, 23:32 (Sábado) »
no , formatear no arreglara nada.


aunque la tarjeta este encendida , puede que la radio NO

mira a ver ..tras encender la tarjeta en iwconfig aparecera .. ( tal vez como eth , o como wlan ) , intenta poner en modo monitor


airmon-ng start "tu tarjeta"

albertodecai

  • Visitante
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #6 en: 21-07-2013, 00:45 (Domingo) »
De verdad, muchisimas gracias, eres increible, se nota que te curras el programa de forma inmejorable. Despues de marearme un poco mirando el rfkill y el fsam pude montar la tarjeta en modo monitor.  >:(
La pequeña pega ahora (presiento ser un toca-narices) es que al abrir el goyscrip, ahora si lo puedo arrancar normalmente, lo unico es que nunca se asocia :P , ni tampoco lo hace wpspingenerator, ni el reaver en modo manual. Esto va para nota. ¿Que puede ser lo que sucede? Lo estoy haciendo todo como explicais en los tutoriales y lo que he leido de otros usuarios, soy un pupilo aplicado.

Cuando realizo la consulta de la tarjeta con iwconfig me sale esto:
 eth0      IEEE 802.11bg  ESSID:off/any 
          Mode:Monitor  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate=0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0 
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:3   Missed beacon:0

(Tarjeta modo monitor ok, al fin) Aun asi me sigue dando quebraderos de cabeza.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #7 en: 21-07-2013, 01:04 (Domingo) »
puede que esa tarjeta no soporte wps.


de todas formas haz esto,,,

lanza los ataques..

y cuando ves que no asocia

abre un terminal y escribe

Código: [Seleccionar]
ifconfig eth0 up
y esperas unos segundos a ver si asocia..si no asocia

Código: [Seleccionar]
ifconfig eth0 down

fijate que es ifconfig , y no iwconfig


si con ninguna d elas dos ordenes asocia, ..esque no vale tu tarjeta para wps.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #8 en: 21-07-2013, 01:07 (Domingo) »
wifislax-4.5   tiene un bug grave con reaver.

en la seccion desarrollo live podras bajar la 4.6-rc1 que trabaja perfecta con reaver

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #9 en: 21-07-2013, 01:26 (Domingo) »
he googleado un poco buscando el listado de chips NO VALIDOS para reaver..y aqui esta.


la ipw2200  NO ES VALIDA

CHIPSETS NO SOPORTADOS:

iwl4965
RT3070L  --->>  ESTA SI LEVANTAMOS LA INTERFACE SI
Netgear WG111v3
rt2800usb (RTL3070) --->>  ESTA SI LEVANTAMOS LA INTERFACE SI
rt2500
rt2570
Ipw2200
RT73usb
BCM4322
zd1211usb

albertodecai

  • Visitante
Re: Problemas con intel pro wireless 2200BG y wifislax 4.5
« Respuesta #10 en: 21-07-2013, 15:39 (Domingo) »
Pues vaya suerte la mia, con lo contento que estoy yo con mi portatil y lo bien que pinta el programa... pero bueno ya lo lanzare en live usb en otro ordenador.
Muchas gracias por la atencion y la ayuda y sobre todo por lo que os currais no solo el foro si no el programa. ;)
Un saludo.