Autor Tema: Problemas Atheros AR9485 en wifislax 4.7.2  (Leído 12207 veces)

0 Usuarios y 1 Visitante están viendo este tema.

goatransbreak

  • Visitante
Problemas Atheros AR9485 en wifislax 4.7.2
« en: 09-01-2014, 17:36 (Jueves) »
Primero que nada me presento, mi nombre es Mario Gutiérrez, soy de México...

Espero no ser molesto, he buscado en el foro y solo he encontrado un tema referente a mi tarjeta de red (Atheros AR9485) y es del 2007, momento en el cual aun el kernel no incorporaba los controladores del mismo, vi que alguien pregunto algo al respecto en marzo 2013 pero Sansón pidio no revivir post antiguos.

Mi problema es que WifiSlax 4.7.2 en LiveUSB no me reconoce mi tarjeta de red, al ingresar el comando ¨iwconfig¨ solo me regresa lo siguiente: ¨- lo no extensions, - eth0 no extensions¨.

Tengo entendido, por lo que he podido leer en internet que los controladores ath9k fuero integrados al kernel en su version 2.6.27 y posteriormente actualizados en la 2.6.39, por ello es que no entiendo por que aun en 3.10.18 (creo que es el de el actual WifiSlax), no puedo utilizar mi tarjeta...

No soy ni de lejos un usuario avanzado, de hecho hace muchos años que me había retirado de los temas informáticos, simplemente me había dedicado a usar mi equipo para lo mas básico, pero ahora que intento regresar, parece que no doy pie con bola.

Alguien podría orientarme? de antemano mil gracias!


« Última modificación: 09-01-2014, 18:03 (Jueves) por goatransbreak »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8402
Re: Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #1 en: 09-01-2014, 18:27 (Jueves) »
Hola

El chip ar9285 , no presenta ningún problema en wifislax desde su version 4.0 , ni en wifiway desde su versión 2.0.1 en adelante. 

¿tu maquina tiene botón físico para encender la interface WiFi? 

Puedes poner en consola

Código: [Seleccionar]
lspci
Y pon por aquí el resultado. 

Pero primero que nada mira lo del botón físico

Saludos

goatransbreak

  • Visitante
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #2 en: 09-01-2014, 19:37 (Jueves) »
Hola

El chip ar9285 , no presenta ningún problema en wifislax desde su version 4.0 , ni en wifiway desde su versión 2.0.1 en adelante. 

¿tu maquina tiene botón físico para encender la interface WiFi? 

Puedes poner en consola

Código: [Seleccionar]
lspci
Y pon por aquí el resultado. 

Pero primero que nada mira lo del botón físico

Saludos

Muchas gracias por tu pronta respuesta, solo que creo que hay un problema, mi red es un chip AR9485 no un 9285... supongo que la diferencia es poca, ay que segun yo es con el mismo controlador Ath9k...
Con relación al botón fisico, no, mi equipo no cuenta con uno, solo tiene una tecla de función dedicada, de las mismas de F1, F2, Fx...

Lo del comando lspci lo probare llegando a casa, ya que en este momento no me encuentro en donde mismo que mi portatil.

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8402
Re: Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #3 en: 09-01-2014, 19:54 (Jueves) »
Hola

Aaaaaa. Perdon la costumbre de ver el ar9285 me hizo ver lo que no era.

Pues ese no sabría decirte amigo , luego cuando llegue a casa miraré si encuentro algo.

Saludos

Fr3dY

  • Visitante
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #4 en: 09-01-2014, 20:12 (Jueves) »
Según la doc., el driver actual ath9k debería soportarlo (http://wireless.kernel.org/en/users/Drivers/ath9k)

Citar
Any distribution shipping a kernel >= 2.6.27 will have ath9k present but the ath9k driver on 2.6.32 is the oldest one recommended, anything older than that is completely unsupported.

The latest ath9k driver can be obtained from backports (http://drvbp1.linux-foundation.org/~mcgrof/rel-html/backports/)

goatransbreak

  • Visitante
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #5 en: 09-01-2014, 21:13 (Jueves) »
Según la doc., el driver actual ath9k debería soportarlo (http://wireless.kernel.org/en/users/Drivers/ath9k)

Citar
Any distribution shipping a kernel >= 2.6.27 will have ath9k present but the ath9k driver on 2.6.32 is the oldest one recommended, anything older than that is completely unsupported.

The latest ath9k driver can be obtained from backports (http://drvbp1.linux-foundation.org/~mcgrof/rel-html/backports/)

Gracias por el comentario, pero eso es justo lo que he mencionado al abrir el tema, se supondría, por lo poco que alcanzo a entender que ya esta suportado y que es completamente estable, pero no logro hacerle funcionar, no he probado aun el comando mencionado por Sansón, supongo que será para verificar si el sistema lo reconoce o no, y posteriormente poder activarlo de ser necesario.
Caso contrario no se que podría hacer...
De cualquier forma probaré con otras distros de Linux que ya he descargado, tengo en mi poder Back-Track 5 R3 (kernel 3.2.6) y Kali (kernel 3.7.2)…

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15364
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #6 en: 09-01-2014, 22:11 (Jueves) »
si estas en maquina virtual ,NO PUEDES USARALA.


si estas desde un cd/pendrive  ...

abre una shell ...

y a ver si pone algo de firmwares


Código: [Seleccionar]
dmesg | grep -i firmware

y un

Código: [Seleccionar]
lspci

tampoco vendria mal.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15364
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #7 en: 09-01-2014, 22:25 (Jueves) »
He rebuscado un poco ,

si no estas bajo maquina virtual...

añade este fichero a la carpeta modules..y dime que tal.


por lo visto el driver acer-wmi  causa algun problema.


blacklist-acer-9485.xzm (4 KB)   http://www.multiupload.nl/WYOFSWC5F2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15364
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #8 en: 09-01-2014, 22:30 (Jueves) »
si no funcionase

me pasa un

Código: [Seleccionar]
lsmod

cuando ejecutas comandos, si quieres se pueden salvar directamente a ficheros de texto ...te sera mas comodo...y para mi tambien ya que queda escrito en ficheros, ...


por ejemplo

Código: [Seleccionar]
lsmod >> /root/Desktop/lsmod.txt

pecholobo2001

  • Visitante
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #9 en: 09-01-2014, 23:11 (Jueves) »
Bueno yo con la versión 4.7.2 también he tenido problemas con la wifi del portátil HPcompaq nx7400 con la Intel PRO/3945ABG (con las versiones anteriores no me pasaba) al arrancar desde USB cuando carga los driver me aparece algo de que no me conecta la wifi,  "Operation not possible due to RF-kill" o algo así, cuando intento ejecutar algún Goyscript al iniciar la tarjeta wifi me da un error de SIOCSIFFLAGS: (set bit rate) 8B20, Network is dow y no puede entrar en modo monitor.

Mi wifi si está activada, y la correspondiente luz encendida, pero cuando inicio en windows7 me jode la wifi y no me puedo conectar tampoco en Windows, mismo problema, así que descubrí la solución por casualidad  leyendo y leyendo por san GOOGLE.

Se resuelve ejecutando los siguientes comandos abriendo una sección de consola nueva:

escribe: rfkill list

Responde el mensaje:

0: hp-wifi: Wireless LAN
           Soft blocked: yes
           Hard blocked: no
1: phy0: Wireless LAN
           Soft blocked: yes
           Hard blocked: yes

como veis tenemos bloqueada la Wireles LAN, solución:

Esto de desbloquea con:

Escribe: sudo rfkill unblock 0
Escribe: sudo rfkill unblock 1

Y Listo, asunto arreglado.

Para comprobar de nuevo si ya esta desbloqueada volvemos a comprobar

escribe: rfkill list

Responde el mensaje:

0: hp-wifi: Wireless LAN
           Soft blocked: no
           Hard blocked: no
1: phy0: Wireless LAN
           Soft blocked: no
           Hard blocked: no

como veis tenemos desbloqueada la Wireles LAN y todo funcionará perfectamente como en versiones anteriores y además perfecto también en windows7

Espero os sirva esta solución, ya me contareis.


Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8402
Re: Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #10 en: 09-01-2014, 23:23 (Jueves) »
Hola

Este no es el caso

Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15364
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #11 en: 09-01-2014, 23:28 (Jueves) »
lo del rfkill , tambien se ha respondido aqui muchisimas veces.


lo de rfkill es un problema asociado a los portatiles con el dichoso botoncillo de apagar/encender wifi.

muchos , aunque encienden la wifi , no activan las radio ...

en este caso nos dijo el usuario que no hay boton ,asi que la cosa va por otro sitio.

de todas formas gracias.
« Última modificación: 09-01-2014, 23:29 (Jueves) por USUARIONUEVO »

goatransbreak

  • Visitante
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #12 en: 09-01-2014, 23:32 (Jueves) »
Muchas gracias a todos por su apoyo, he hecho ha lo recomendado por USUARIONUEVO, el txt ha sido algo extenso para sólo copiar y pegar directo en el foro, por lo que mejor lo subo a dropbox y pasó el link.

https://www.dropbox.com/s/l4k1oblc9abvihy/konsole.txt

Gracias por el tiempo invertido, y una disculpa por la tardanza en responder.

goatransbreak

  • Visitante
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #13 en: 10-01-2014, 01:56 (Viernes) »
En este momento haciendo pruebas me soy cuenta de que había omitido el comando ldmod, y al volver a probar ingresando el módulo proporcionado por USUARIONUEVO ya me muestra wlan0 en iwconfig... Espero que ha con esto quedo solucionado, cualquier cosa les mantendré al tanto.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15364
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #14 en: 10-01-2014, 02:01 (Viernes) »
En este momento haciendo pruebas me soy cuenta de que había omitido el comando ldmod, y al volver a probar ingresando el módulo proporcionado por USUARIONUEVO ya me muestra wlan0 en iwconfig... Espero que ha con esto quedo solucionado, cualquier cosa les mantendré al tanto.

osea que el modulo lo resuelve ... ¿ verdad ?

google sabe mucho   ;D

Código: [Seleccionar]
blacklist acer-wmi
 ;) :D
« Última modificación: 10-01-2014, 02:02 (Viernes) por USUARIONUEVO »

goatransbreak

  • Visitante
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #15 en: 10-01-2014, 02:08 (Viernes) »
A partir de la integración del módulo puedo verlo en iwconfig, pero no puedo establecer modo monitor, ni levantarlo...
Código: [Seleccionar]
wifislax - # iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
Set failed on device wlan0 ; Device or resource busy.

Código: [Seleccionar]
wifislax - #iwconfig wlan0 up
Iwconfig: unknown command "up"

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15364
Re: Problemas Atheros AR9485 en wifislax 4.7.2
« Respuesta #16 en: 10-01-2014, 02:16 (Viernes) »
A partir de la integración del módulo puedo verlo en iwconfig, pero no puedo establecer modo monitor, ni levantarlo...
Código: [Seleccionar]
wifislax - # iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
Set failed on device wlan0 ; Device or resource busy.

Código: [Seleccionar]
wifislax - #iwconfig wlan0 up
Iwconfig: unknown command "up"

claro que no , por que lo estas haciendo todo mal.

no es iwconfig up  ,si no


ifconfig


y para monitor es


airmon-ng start wlan0


cierro el tema, ya que esta resuelto , y lo que te falta ahora es o aprender , o si ya sabias ponerte al dia, los comandos que pones no son correctos ninguno de los dos.


nunca se pasa la interface real , directamente a monitor ,si no que se genera la interface monX ,o las aplicaciones la mitad no te funcionaran.


« Última modificación: 10-01-2014, 02:17 (Viernes) por USUARIONUEVO »