Autor Tema: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4  (Leído 7562 veces)

0 Usuarios y 1 Visitante están viendo este tema.

linesguapo

  • Visitante
Yo también tengo problemas con el arranque dual con w7 y ya he probado el update-grub pero me da el siguiente error:


Os doy más detalles de como he echo la instalación:

Tenia instalado anteriormente wifislax 4.3r3 junto con w7 el primero en sda1 y el segundo en sda3 y el grub me daba la opción de elegir con que sistema arrancar. Bueno he formateado sda1 en ext2 y he instalado wifislax 4.4

Luego ejecuto grub2-installer:





Pero cuando reinicio me da este error



Si ejecuto el grub de wifislax 4.3.r2 me aparece el menú dual pero solo me permite arrancar w7 con wifislax me sigue sin dejar. Que hago mal?

Enviado desde mi GT-I9100 usando Tapatalk 2


« Última modificación: 02-06-2013, 14:00 (Domingo) por linesguapo »

sol666

  • Visitante
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #1 en: 02-06-2013, 14:08 (Domingo) »
de momento la particion para wifislax la has hecho mal,tiene que estar en ext3 o ext4,de momento prueba asi.
« Última modificación: 02-06-2013, 14:10 (Domingo) por sol666 »

linesguapo

  • Visitante
Re: Error 7 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #2 en: 02-06-2013, 15:59 (Domingo) »
Ya he probado con ext3 y ext4 y lo mismo. Gracias por contestar

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #3 en: 02-06-2013, 17:55 (Domingo) »
Hola, solo hay que ejecutar "update-grub" una vez estés dentro de Wifislax instalado para que te reconozca la partición de Windows, tu lo estás ejecutando en modo live, por eso te da ese error.

En cuando al error de arranque, prueba a ejecutar esto:

Código: [Seleccionar]
ms-sys -z /dev/sda
Y después ejecuta el instalador del grub.

P.D: ¿Supongo que ya has comprobado que el md5 de la iso es correcto no? Si no lo has hecho, hazlo antes de nada.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14918
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #4 en: 02-06-2013, 18:18 (Domingo) »
a mi ese error de stage 1.5

me suena al grub 0.97  :-\

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #5 en: 02-06-2013, 20:32 (Domingo) »
a mi ese error de stage 1.5

me suena al grub 0.97  :-\

Exacto  ;)

Por eso le he dicho que ejecute "ms-sys -z /dev/sda" para limpiar el MBR, porque creo que tiene restos del grub antiguo.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

linesguapo

  • Visitante
La última imagen es el grub de wifislax 4.3.r2 lo he utilizado provisionalmente para resucitar el Windows mientras se arregla la instalación de la 4.4
He realizado el comando y reinstalado el grub de la 4.4 pero en el arranque ahora solo aparece el cursor parpadeando y de hay no pasa y ahora tampoco me funciona con el grub del 4.3.r2
Os adjunto algunas imágenes del instalador del grub parece que da un error






Enviado desde mi GT-I9100 usando Tapatalk 2

linesguapo

  • Visitante
Re: Error 7 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #7 en: 02-06-2013, 22:02 (Domingo) »


Esta es imagen de las particiones que tengo.
 Esto es la comprobación del md5 el mensaje indica que esta mal?


wifiandroid

  • Visitante
antes de mnt falta uba barra invertida


/

http://m.seguridadwireless.net

linesguapo

  • Visitante
Lo he echo desde el directorio fonde tengo la iso y lo mismo



Bajare una nueva a ver, pero no creo que sea eso ya que he intentado instalar el wifislax 4.3.r2 que ese estoy seguro que funcionaba y el mismo resultado. Por favor ayuda que no puedo acceder al Windows y tengo que hacer cosas con el.

Mil gracias de antemano

Enviado desde mi GT-I9100 usando Tapatalk 2

Chumpy

  • Visitante
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #10 en: 03-06-2013, 13:46 (Lunes) »
Lo primero que tienes que hacer es descargarte la última versión, comprobar el md5 instalarla correctamente y ejecutar update-grub. (deja de utilizar versiones anteriores y remiendos por que nos vas a volver locos y te vamos a volver loco nosotros a ti)

Se me ocurre, como solución temporal que quites la versión de wifislax que tengas instalada ahora mismo y hagas el update-grub, eso debería devolver el arranque de Windows.


PD: Recuerda siempre, SIEMPRE, formatear las particiones/memorioas usb antes de volver a meter un linux, por que si no pueden quedar restos de las versiones anteriores que impidan que funcione correctamente.
« Última modificación: 03-06-2013, 13:47 (Lunes) por Chumpy »

linesguapo

  • Visitante
Chumpy gracias por responder.  Y por tus consejos.

Ahora he intentado instalar la 4.4.3 he formateado previamente la participación sda1 y he realizado la instalación.  He cargado el instalador del grub  que por defecto me lo instala en sda. He reiniciado y ahora me sale esto

Por cierto tengo una duda con lo que me comentas del grub update. En un mensaje anterior me han indicado que el grub update hay que ejecutarlo desde wifislax instalado, y no desde la live. Como voy ha ejecutarlo tal como me indicas, si no me deja cargar wifislax?

Lo dicho gracias a todos por el tiempo que me estais dedicado a Ayudarme.

Enviado desde mi GT-I9100 usando Tapatalk 2

warcry

  • Visitante
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #12 en: 03-06-2013, 19:39 (Lunes) »
primero yo me centraría en recuperar el windows.

haz exactamente lo que te pone el aviso, introduce el disco de instalación, si no lo tienes bájate cualquier iso que contenga tu sistema operativo y no te preocupes por que no tengas licencia, ya que no lo vas a instalar sino que vas a recuperar el que ya tienes instalado y licenciado.

y luego despues de recuperar el windows, ya vuelves a la carga con la instalación de wifislax 4.4.2

para lo cual primero eliminaria las particiones existentes, excepto la que contiene el windows y empezaria desde cero

https://foro.seguridadwireless.net/wifislax/instalar-wifislax-en-hd/

y si aun así la lias parda como wifiandroid, siempre puedes seguir sus pasos para salir del atolladero, pero yo por mas que le leo no me entero de na

https://foro.seguridadwireless.net/live-wifislax/consejos-instalacion-wifislax-4-4-en-disco-duro/


linesguapo

  • Visitante
Como estoy desesperado hacer que esto funcione se me ha ocurrido (antes de warcry escribiera el último mensaje) cambiar la particion de arranque y quitársela al Windows sda3. Formatear sda1 ponerla como partición de  arranque borrar cualquier res resto de grub he incluso borrar y crear de nuevo ka swap .

Después de instalar. Hombre! ! Parece que arraca el wifislax. Algo es algo... bueno ahora si grub-update, reconce la particion Windows uff vamos bien.
 Reinicio y aparece el grub, por cierto muy chulo, bueno a elegir el Windows que el wifislax ya se que funciona.  Y zas en toda la boca me sale esto


Pa mi que ahora si que la he jodido.  Por lo menos los datos siguen en el hd alguna idea antes de tirar la toalla salvar datos y reinstalar Windows. >:(

Enviado desde mi GT-I9100 usando Tapatalk 2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14918
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #14 en: 03-06-2013, 20:37 (Lunes) »
Si te sirve de consuelo casi todos hemos pasado por cosas asi ,las primeras veces que instalas un Linux, hasta que le pilllas el royo y después todo va con lo ojos cerrados.


linesguapo

  • Visitante
Ja ja ya te digo lo terrible es que no es la primera vez el anterior wifislax si que me lo instalo bien pero en fin cosas que pasan.

Enviado desde mi GT-I9100 usando Tapatalk 2

DJROCKER

  • Visitante
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #16 en: 03-06-2013, 20:52 (Lunes) »
Al final se sabe la solución?¿
Porque yo ya lo deje pasar, pero si ya lo sabeís comentar y lo volvere a intentar

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8393
Hola

Ese ultimo error es por que has jodido el arranque de windows (otra vez).

Si haces lo que te ha dicho Warcry es muy probable que lo recuperes luego formatea todo menos wim y empieza de nuevo.

Realmente es muy muy sencillo si todo se hace bien, hacer dos particiones y seguir la instrucciones no hay mas.  Yo siempre sigo el orden de las particiones, que aun que dicen que no importa yo si lo sigo y nunca tuve un rpoblema .


Edito

Este manual es viejuno pero para ver los conceptos sobra.  Haz lo mismo pero con el gestor de particiones que prefieras o con gparted (incluido en wifislax)

https://foro.seguridadwireless.net/index.php?topic=32514.0

linesguapo

  • Visitante
Re: Error 15 en grub con arranque dual ya probé el update-grub wifislax 4.4
« Respuesta #18 en: 05-06-2013, 22:33 (Miércoles) »
Bueno ya esta reinstalado de nuevo el Windows, ya he seguido los pasos como siempre y perfecto a la primera, lo mas probable era lo que decía geminis-daemon restos de grub del antiguo wifislax. En fin borrón y cuenta nueva. Muchas gracias a todos por contestar y ayudarme este es un foro genial.