Autor Tema: Bugs actualizando Wifislax 3.1  (Leído 636 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Zup

  • **
  • Mensajes: 10
Bugs actualizando Wifislax 3.1
« en: 29-05-2022, 17:18 (Domingo) »
Buenas

Por fin he tenido algo de tiempo para jugar con Wifislax 3.1, así que aquí van unos cuantos problemas que me he encontrado. Estos bugs han sido comprobados usando Wifislax 3.1 desde un pendrive y también con la distribución instalada en máquina virtual.

- Al actualizar la lista de paquetes de slackware, la entrada en el menú dice "Actualizar lista de paquetes y crear un módulo xmz".

- Al actualizar la lista de paquetes de paquetes de slackware o crear un módulo xzm con los módulos descargados, el módulo no se crea correctamente (escupe un fichero de 4K que está vacío). Ambos bugs confirmados tanto desde USB como desde HDD (aunque desde HDD no sirva para mucho) y supongo que están relacionados. Al parecer, busca los ficheros descargados en /var/slapt-get cuando debería buscarlos en /var/cache/slapt-get (el script txz2xzm sí funciona correctamente).

- Wifislax Updater GUI ha perdido su barra de progreso. Verificado desde USB y desde HDD. En la versión 2.4, la ventana mostraba una barra de progreso que indicaba por qué paquete iba.

- Wifislax Updater GUI nunca termina. Verificado desde USB y desde HDD. En principio parece que compila correctamente todo (y si se le indica, crea los xzm), pero la ventana se queda "colgada" con el mensaje "Ejecutando actualizaciones seleccionadas" aunque ya haya terminado todos los procesos.

- Los actualizadores no detectan los paquetes instalados. Verificado desde USB, funciona bien desde HDD. Al ejecutar a mano un actualizador (por ejemplo el de Wireshark), indica que la versión actual es NO INSTALADA.

Al margen de esto, sugiero que nano se incluya en la ISO (¿hay algún otro editor de consola aparte de vim?). Ya sé que kwrite está incluido, pero...



Desconectado Garcad

  • Colaborador
  • *
  • Mensajes: 49
  • Yo solo se, que no se nada.
Re:Bugs actualizando Wifislax 3.1
« Respuesta #1 en: 30-05-2022, 20:23 (Lunes) »
El frontend, hace varias versiones que me he dado cuenta que no funciona como debe, y cuando se selecciona que cree un modulo diferente, a *.xmz, no lo hace como debe.

Pero tienes la posibilidad de usar los script, de UsuarioNuevo, que si crean correctamente los archivos *.xzm y se puede usar el script log2xxx para crear el paquete que necesites.

Lamentablemente no he tenido el tiempo necesario, para dedicar a buscar una solución.

@UsuarioNuevo es al día de hoy, la única persona que esta colaborando a tener esta gran distribución, actualizada, lastima que alguna cosa que otra, no funciona bien, por falta de colaboración.

A todos, yo me incluyo, se nos llena la boca, para reportar errores, que van saliendo, y no damos soluciones a ellos.

Si, alguien lee esto, no estaría mal y nunca de menos, para buscar soluciones, a los problemas que se van encontrando.

Una persona, sola, por mucho que quiera o no quiera, no puede dar todo el tiempo del mundo, para crear la distribución perfecta.

Con lo que estoy diciendo, espero que no impida, volver a abrir un Tema nuevo, ya que cualquier duda, o problema, que surja, por mi parte es bienvenido.

Escribe sin comillas "log2" y pulsa en tabulador, si sigues, las indicaciones del script, podrás obtener un paquete, de cualquier cosa que este instalada en la distribución, independientemente de estar instalado en el HDD, o en LIveUSB.
« Última modificación: 30-05-2022, 20:32 (Lunes) por Garcad »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Bugs actualizando Wifislax 3.1
« Respuesta #2 en: 30-05-2022, 20:30 (Lunes) »
la gui te dice las actualizaciones..lugo a mano lanza los scripts para lo que quieras actualizar.

la gui ya hace tiempo que no va bien , y no consigo arreglarla...es lo que tiene cuando el codigo es de otro es mas complicado.

respecto a slapt-src y la ruta de los scripts eso ya lo he corregido aunque no sirve de mucho ...

guardar la lista de paquetes si mañana hay actualizacion ya no vale la lista de paquetes.  ;D

Pero bueno , eso si lo puedo arreglar , de las 4 o 5 entras de gestor de paquete , solo una es la gui gslapt ..las demas son scripts que hay que corregir.

Lo de que te dice wireshark no instalado ...hay ya tu sabras que has tocado.

Desconectado Garcad

  • Colaborador
  • *
  • Mensajes: 49
  • Yo solo se, que no se nada.
Re:Bugs actualizando Wifislax 3.1
« Respuesta #3 en: 30-05-2022, 20:41 (Lunes) »
la gui te dice las actualizaciones..lugo a mano lanza los scripts para lo que quieras actualizar.

Es lo que suelo hacer, veo que actualización dice, y a razón de lo que necesito, ejecuto el script, que no falla, crack.

Cita de: USUARIONUEVO
la gui ya hace tiempo que no va bien , y no consigo arreglarla...es lo que tiene cuando el código es de otro es mas complicado.

Ni que lo jures, mira que se me da bien leer el código, sea el que sea, y entender sus entresijos, pero este se me traba, me tendré que poner mas en serio con el, destrozarlo, y ver las capas de cebolla, que lo envuelven, para poder entenderlo.

Cita de: USUARIONUEVO
respecto a slapt-src y la ruta de los scripts eso ya lo he corregido aunque no sirve de mucho ...

Un día de estos, si podemos, hablar, me gustaría entender porque te gusta tanto lapt-src, y gracias por tu esfuerzo.

Killo, si tienes que darme caña, para ponerme las pilas, aquí estamos.

Si es necesario aprender cualquier código nuevo, estoy dispuesto.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Bugs actualizando Wifislax 3.1
« Respuesta #4 en: 30-05-2022, 20:42 (Lunes) »
Lo de la barra de progreso que te listaba las cosas ... la gui ahora usa gtk3 , los dialogos y funciones han cambiado  ... asi que mas de los mismo.

Me gustaria saber hacerlo todo , pero no es el caso , y cosas vanales como estas no les doy ninguna prioridad ya que o son esteticas o no las usa nadie o se pueden remedia lanzando el script desde el menu actualizadores.

De hecho , hay una funcion de blacklistear , para las cosas que NO quieres que te muestre las actualizaciones.

Lo que si mantengo son los scripts directos ... me gusta mucho mas ver todo el proceso.

Un problema en un script de actualizacion lo puedo arreglar , la gui ya es mas complicado por que no tengo ni idea casi de como funciona YAD , y mucho menos desde que paso a gtk3 , y gracias que el instalador al hdd mas o menos lo pude dejar bien , aunque tampoco esta perfecto , en algun boton puede que salga algo asi como

ok-gtk o similar, por que antes asi era cono se ponia un boton de @ok@   y ahora ya no va asi y sale el texto  ;D , cosas esteticas en las que no me he calentado mucho.

Desconectado Garcad

  • Colaborador
  • *
  • Mensajes: 49
  • Yo solo se, que no se nada.
Re:Bugs actualizando Wifislax 3.1
« Respuesta #5 en: 30-05-2022, 20:45 (Lunes) »
Lo dicho aquí estamos para ayudar, en la medida de lo posible. Con mis limitaciones.


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Bugs actualizando Wifislax 3.1
« Respuesta #6 en: 30-05-2022, 20:48 (Lunes) »
slapt-src  me gusta por que resuelve automaticamente las dependencias cuando compilas algo de slackbuilds.

aunque no es una tool perfecta , ..sbopkg por ejemplo para que resuelva , tienes que ir por consola y usar otra tool antes

Código: [Seleccionar]
sqg
slpkg , mas de lo mismo , no resuelve.

la unica aparte de slapt-src que si resuelve es "sboui"

slapt-src te permite por ejemplo cada semana actualizar las cosas de slackbuilds.

slapt-src -u    -->  actualiza lista
slapt-src -U    --> muestra que cosas de slackbuilds tienen actualizaciones y si hay dependencias nuevas


pero no es perfecta , por ejemplo no ve las builds incrementales...

paquete-1.0-1sbo    si por ejemplo es la misma version "1.0"  pero con algun parche , se incrementa el build

paquete-1.0-2sbo   esto slapt-src no lo ve pero sbopkg si

Al final para segun que cosas uso uno u otro , no hay ninguno que de por si solo sea perfecto , por eso tengo varias tools de gestion de paquetes.

Desconectado Garcad

  • Colaborador
  • *
  • Mensajes: 49
  • Yo solo se, que no se nada.
Re:Bugs actualizando Wifislax 3.1
« Respuesta #7 en: 30-05-2022, 20:48 (Lunes) »
Ya estoy mayor a mis 47 años.

jajajajaja   ^-^ ^-^ ^-^ ^-^ >:D >:D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Bugs actualizando Wifislax 3.1
« Respuesta #8 en: 30-05-2022, 20:52 (Lunes) »
slapt-src ademas te deja los paquetes en categorias y asi ya sabes a que modulo debes actualizar o incluir
los scripts de actualizacion tambien usan la lista de slapt-src para saber las categorias de las dependencias.

/usr/src/slapt-src/Multimedia/paquete

esta tool  slapt-src   es especialmente util , como quitas todos los extras y recompilas todo , por que el proceso esta relativamente automatizado , o por ejemplo cuando necesitas algo de perl o python y resulta que hay 7 u 8 dependencias que a su vez necesitan otras dependencias y slapt-src las resuelve todas.

Desconectado Garcad

  • Colaborador
  • *
  • Mensajes: 49
  • Yo solo se, que no se nada.
Re:Bugs actualizando Wifislax 3.1
« Respuesta #9 en: 30-05-2022, 20:53 (Lunes) »
slapt-src  me gusta por que resuelve automaticamente las dependencias cuando compilas algo de slackbuilds.

aunque no es una tool perfecta , ..sbopkg por ejemplo para que resuelva , tienes que ir por consola y usar otra tool antes

Código: [Seleccionar]
sqg
slpkg , mas de lo mismo , no resuelve.

la unica aparte de slapt-src que si resuelve es "sboui"

slapt-src te permite por ejemplo cada semana actualizar las cosas de slackbuilds.

slapt-src -u    -->  actualiza lista
slapt-src -U    --> muestra que cosas de slackbuilds tienen actualizaciones y si hay dependencias nuevas


pero no es perfecta , por ejemplo no ve las builds incrementales...

paquete-1.0-1sbo    si por ejemplo es la misma version "1.0"  pero con algun parche , se incrementa el build

paquete-1.0-2sbo   esto slapt-src no lo ve pero sbopkg si

Al final para segun que cosas uso uno u otro , no hay ninguno que de por si solo sea perfecto , por eso tengo varias tools de gestion de paquetes.

Lo voy a leer varias, veces, para intentar entenderlo.

Pero no puedo evitarlo, me encanta la consola, por mi, no exisitira, ni escritorio, ni manejador de ventanas.
El código, y las matemáticas, son lo mio, aun sin conocer el código, me dan satisfacción.
Todo con lógica, llega a dar un sentido.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Bugs actualizando Wifislax 3.1
« Respuesta #10 en: 30-05-2022, 20:53 (Lunes) »
No me importa explicar cosas a gente curiosa , siempre que me pregunten de buenas  ;)

Desconectado Garcad

  • Colaborador
  • *
  • Mensajes: 49
  • Yo solo se, que no se nada.
Re:Bugs actualizando Wifislax 3.1
« Respuesta #11 en: 30-05-2022, 20:57 (Lunes) »
Killo, que puedo ser un poco incordio, me encanta aprender cosas nuevas, y soy muy cabezón, hasta que no lo consigo no paro.

Como se suele decir, cualquier defecto se puede convertir en una cualidad, por lo que yo cambio, Cabezón por constante.

Estoy disponible, una esponja, a tu disposición.
« Última modificación: 30-05-2022, 20:59 (Lunes) por Garcad »

Desconectado Zup

  • **
  • Mensajes: 10
Re:Bugs actualizando Wifislax 3.1
« Respuesta #12 en: 04-06-2022, 08:55 (Sábado) »
Buenas

Siento no poder contestar, pero entre semana no tengo tiempo de parar junto a un ordenador.

respecto a slapt-src y la ruta de los scripts eso ya lo he corregido aunque no sirve de mucho ...

guardar la lista de paquetes si mañana hay actualizacion ya no vale la lista de paquetes.  ;D
Es cierto no sirve de mucho para los usuarios que instalan la distribución en disco duro, pero los que utilizamos la distribución desde un USB no tenemos otra manera de hacer actualizaciones persistentes.

Creo que el de la lista de paquetes es el mismo script que luego se encarga de generar un xzm con los paquetes descargados (las actualizaciones de slapt-get), a ver si puedo probarlo este fin de semana. ¿La actualización está con los updaters o hay que hacer algo especial para conseguirla?

la gui te dice las actualizaciones..lugo a mano lanza los scripts para lo que quieras actualizar.

la gui ya hace tiempo que no va bien , y no consigo arreglarla...es lo que tiene cuando el codigo es de otro es mas complicado.
Quizás entonces la solución sea sustituir la GUI por un script que liste los paquetes actualizables. Así será mucho más fácil de mantener.

Lo de que te dice wireshark no instalado ...hay ya tu sabras que has tocado.
No he tocado NADA. Yo utilizo la distribución desde el pendrive, tal cual viene "de fábrica". Cuando lo instalo en disco duro los updaters funcionan bien... probaré arrancando una máquina virtual desde ISO a ver si reproduzco el problema.

Gracias por todas las correcciones.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Bugs actualizando Wifislax 3.1
« Respuesta #13 en: 04-06-2022, 10:09 (Sábado) »
No sirve de mucho ni para los que instalan ni para el modo live , si hoy guardas el modulo de las lista y mañana la lista a cambiado ¿de que te sirce?  ....de nada , tendras que actualizar la lista tanto si estas en hdd como si estas en live

 ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D


No hay mucho que yo pueda hacer , solo los scripts se autoactualizan , los updaters vamos , lo demas no.

Respecto a que solo se informe de las actualizaciones en la gui , estamos igual ... no es mi codigo y no se como va la vaina , asi que yo lo uso asi ahora...miro las actualizaciones de la gui , y luego de los scripts lanzo los que me interesa ,  los que no quiero actualizar o no me interesan se pueden blacklistear , con la tool que dice blacklistear actualizadores.
« Última modificación: 04-06-2022, 10:09 (Sábado) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Bugs actualizando Wifislax 3.1
« Respuesta #14 en: 04-06-2022, 11:46 (Sábado) »
YA HE ENCONTRADO EL PROBLEMA

en el fichero

/usr/bin/WifislaxUpdaterGUI

cambia todos los
Código: [Seleccionar]
--multi-progress
por
Código: [Seleccionar]
--progress