Autor Tema: Ayuda para crear modulo de driver nvidia 304.88 en wifislax 4.10  (Leído 4327 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Douglas001

  • Visitante
Buenas, mi placa de video es GeForce 6150SE nForce 430 intente arrancar live usb con los drivers de wifislax 4.10 pero esa version de drivers no es compatible con mi placa, la unica que es compatible es el driver 304.88, asi que intente crear el driver pero me genera errores al instalarlo como el de "unable to build the nvidia kernel module" nose como solucionar ese problema ya que he revisado los foros y aparece un modulo para instalar drivers nvidia el cual no he podido descargar.

los comandos que realice para instalar el driver despues de solucionar el problema del noveau con el blacklistnoveau.xzm en base, fueron

chmod -R ugo=rwx /mnt/sdb1/NVIDIADRIVER.run

/mnt/sdb1/NVIDIADRIVER.r

abre el archivo. carga unos datos, los terminos de uso y antes de instalar me lanza el error "unable to build the nvidia kernel module"  :'(





pastilla

  • Visitante
Re: Ayuda para crear modulo de driver nvidia 304.88 en wifislax 4.10
« Respuesta #2 en: 30-12-2014, 19:40 (Martes) »
PRIMERA PARTE,


wifislax / # sh /NVIDIA-Linux-x86-173.14.39-pkg1.run -a -z -Z -no-x-check -b
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 173.14.39...
./nvidia-installer: unrecognized option: "-Z"

Invalid commandline, please run `./nvidia-installer --help` for usage
information.


wifislax / # sh /NVIDIA-Linux-x86-173.14.39-pkg1.run -a -z -no-x-check -b
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 173.14.39...



                     NVIDIA Accelerated Graphics Driver for Linux-x86 (173.14.39)


  Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so
  that the NVIDIA X driver will be used when you restart X?  Any pre-existing X configuration file will
  be backed up.                                                                                          
          
                                            Yes           No                                            
 
Your X configuration file has been successfully updated.  Installation of the NVIDIA Accelerated      
  Graphics Driver for Linux-x86 (version: 173.14.39) is now complete.

                                                    OK
                                                    
                                                    
                                                    
 wifislax / # startx -----> PANTALLA NEGRA Y SISTEMA BLOQUEADO.
.
 
 SEGUNDA_PARTE (con los modulos creados de los slackbuilds y sus instrucciones de uso),
 
 nvidia-legacy173-kernel-173.14.38_3.12.35_pae_wifislax-x86-1_SBo.xzm

 nvidia-legacy173-driver-173.14.38-x86-1_SBo.xzm
 
 xf86-video-nouveau-blacklist-noarch-1.xzm
 
  
  wifislax sbin # nvidia-switch --nvidia

  Switching to nvidia-driver files!

Make sure the nvidia driver is ENABLED in /etc/X11/xorg.conf.
Otherwise, this may lead to improperly working drivers.

wifislax sbin # startx
xauth:  file /root/.serverauth.2194 does not exist


X.Org X Server 1.15.2
Release Date: 2014-06-27
X Protocol Version 11, Revision 0
Build Operating System: Slackware 14.2 Slackware Linux Project
Current Operating System: Linux wifislax 3.12.35-pae-wifislax #1 SMP Thu Dec 11 09:10:02 CET 2014 i686
Kernel command line: initrd=/boot/initrd.xz vga=788 nomodeset noload=000-Ker;012-X;013-W;015-D;029-D autoexec=vesa-mode;startx   BOOT_IMAGE=/boot/vmlinuz2
Build Date: 25 August 2014  01:23:41PM
 
Current version of pixman: 0.32.6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Dec 30 17:51:58 2014
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Parse error on line 87 of section Files in file /etc/X11/xorg.conf
        Ignoring obsolete keyword "RgbPath".
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
================ WARNING WARNING WARNING WARNING ================
This server has a video driver ABI version of 15.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI  



TERCERA PARTE PARA ACABAR EL PASTELITO,



Linux Display Driver - x86
 
Versione:    173.14.39
Fecha de publicación:    2013.12.6
Sistema operativo:    Linux 32-bit
Idioma:    Español (España)
Tamaño:    
   
Descargar Ahora    

Aspectos destacados de la versión
Productos soportados
Más informacion

    Se ha añadido soporte para la versión ABI 15 de xserver X.org (xorg-server 1.15).
    Se ha actualizado nvidia-installer de forma que considere que el módulo cargable de extensión de X "libglamoregl.so" entra en conflicto con el controlador de NVIDIA para OpenGL. Este módulo puede hacer que la librería libGL de NVIDIA se cargue en el mismo proceso (el servidor X) que el módulo de extensión libglx.so, una posibilidad que no está admitida.

-----------------

Modulo instalado en wifislax 4.10 del Xorg server: xorg-server-1.15.2-i486-2.xzm


Pues hay queda el trabajito.


Un saludo

« Última modificación: 30-12-2014, 20:54 (Martes) por pastilla »