Autor Tema: actualizacion metasploit ¿Problemas?  (Leído 3150 veces)

0 Usuarios y 1 Visitante están viendo este tema.

fdogr

  • Visitante
actualizacion metasploit ¿Problemas?
« en: 17-09-2014, 16:09 (Miércoles) »
Despues de instalar metasploit en Wifislax y probarlo un par de dias aun me entero de poco, pero en fin, vamos poquito a poquito. El caso es que actualice metasploit con el comando mfsupdate y parecio ir bien la cosa excepto algun directorio que me faltaba. Pero ahora no me carga metasploit segun arranca Wifislax. No hay mayor problema pues me basta con arrancarlo en consola para que armitage funcione (aun no lo he probado pero parece que va bien) Me he cargado algo que no debia? Me estoy volviendo loco intentando solucionarlo, mas que nada porque odio dejar algo atras que deberia saber. Seguro que la solucion es sencilla pero no se me ocurre nada. Se me ocurre hacer un paquete xzm nuevo con grep pero no se si sere capaz de no dejarme ningun archivo por ahi bailando.

Por cierto mfsupdate para el que no lo sepa realmente actualiza metasploit para kali, parece ser que al hacerlo le faltan un par de directorios a wifislax para este tipo de actualizacion pero sin embargo parece funcionar. Espero que no se pierdan vinculos. En caso de que no funcionase correctamente ¿tendria que borrar el modulo del sistema antes de reinstalar la version antigua? Seria un problema pues no tengo ni idea de donde anda

Gracias de antemano

PD: Se que tengo un cacao mental impresionante pero intento ponerme al dia tras un monton de años sin estar con estos sistemas.
PD2: Como consejo, olvidaros del Win que atonta ;)



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: actualizacion metasploit ¿Problemas?
« Respuesta #1 en: 17-09-2014, 16:48 (Miércoles) »
no se muy bien como va lo de msfupdate

pero recuerdo haber pasado por lo mismo y la solucion facil , es directamente borrarlo, y volve al ESTABLE ...cuando usais msfupdate se os actualiza SI , pero a versiones de desarrollo ...

fdogr

  • Visitante
Re: actualizacion metasploit ¿Problemas?
« Respuesta #2 en: 18-09-2014, 11:24 (Jueves) »
Gracias Usuarionuevo, de momento voy a probarlo asi, si no encuentro ningun problema en el uso asi se quedara. Aun no he probado mas que el arranque, de hecho ahora mismo voy a ello, primero a estudiarlo un poco y despues a probarlo. El problema es que me fastidia no entender algo.
Salu2.
EDITO: Bueno, como informacion que puede interesar a alguien funciona correctamente, funciona CASI todo lo que he probado, PERO no funciona la opcion check exploits, aunque funcionan los exploits uno a uno, asi que supongo que o aprendo saber para que es cada exploit y me dedico a ir probando o borro esta actualizacion y pongo la ultima estable con armitage. De momento me dedicare a buscar informacion e ir aprendiendo, me gusta mas la via dificil que no que lo haga la maquina todo.
Mas salu2
« Última modificación: 18-09-2014, 12:19 (Jueves) por fdogr »

fdogr

  • Visitante
Re: actualizacion metasploit ¿Problemas?
« Respuesta #3 en: 20-09-2014, 09:15 (Sábado) »
Edito 2: Check exploits funcionando correctamente.

jacksql

  • Visitante
Re: actualizacion metasploit ¿Problemas?
« Respuesta #4 en: 27-12-2015, 14:12 (Domingo) »
yo tengo mizimo problema

Parando Metasploit Framework...

worker is stopped
metasploit is stopped
prosvc is stopped
nginx is stopped
/opt/metasploit/postgresql/scripts/ctl.sh : postgresql could not be stopped

Esperando a PostgreSQL para terminar...

/etc/rc.d/rc.metasploit: línea 15: /opt/metasploit/ctlscript.sh: No existe el fichero o el directorio