Autor Tema: [SOLUCIONADO]Problema Grub en la 4.4 final  (Leído 2692 veces)

0 Usuarios y 1 Visitante están viendo este tema.

crislomal11

  • Visitante
[SOLUCIONADO]Problema Grub en la 4.4 final
« en: 25-05-2013, 11:32 (Sábado) »
Hola ha todos, resulta de que tenia instalado la 4.3 y la grub iba perfecta, pero ahora que he instalado la 4.4 final en la grub solo me aparece Windows 7, cuando instalo la grub me dice que la instala en sda cuando en la 4.3 me la instalaba donde se encuentra Wifislax, que era la sda4.


« Última modificación: 28-05-2013, 09:03 (Martes) por crislomal11 »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8384
Re: Re: Problema Grub en la 4.4 final
« Respuesta #1 en: 25-05-2013, 13:03 (Sábado) »
Hola

Joder pues ya sois dos los que OS sucede lo mismo.

Lo que dices no es correcto, el grub siempre se instala en sda, nunca en la partición que este wifislax sino en el disco físico en el que este wifislax

Saludos

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: Problema Grub en la 4.4 final
« Respuesta #2 en: 25-05-2013, 15:24 (Sábado) »
Hola. Arranca en modo live y entra en la partición donde instalaste Wifislax, dentro del directorio "/boot", dime si está el kernel con el nombre "vmlinuz-3.7.10-pae-wifislax" o "vmlinuz-3.7.10-wifislax".

Puede que el kernel no se esté copiando correctamente, y si no hay kenrel el grub no detectará ningún sistema operativo.
« Última modificación: 25-05-2013, 15:26 (Sábado) por geminis_demon »

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

crislomal11

  • Visitante
Re: Problema Grub en la 4.4 final
« Respuesta #3 en: 26-05-2013, 23:21 (Domingo) »
Pues esto es lo que hay dentro de boot.

Gracias a los que ayudan.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: Problema Grub en la 4.4 final
« Respuesta #4 en: 27-05-2013, 15:24 (Lunes) »
Ok, era lo que yo pensaba, el kernel no está ahí, tienes que copiar el kernel a ese directorio.

El kernel está en la iso dentro del directorio "/boot" con el nombre "vmlinuz" (kernel normal) o "vmlinuz2" (kernel pae), tienes que copiarlo al directorio "/boot" dentro de la partición donde tienes instalado Wifislax, una vez que lo copies le cambias el nombre a "vmlinuz-3.7.10-wifislax" (si lo instalaste con el kernel normal) o "vmlinuz-3.7.10-pae-wifislax" (si lo instalaste con el kernel pae).

Después de copiar el kernel y cambiarle el nombre, vuelves a instalar el grub (solo el grub, no el sistema entero), el instalador del grub está en la categoría "Sistema" junto al instalador de Wifislax.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

crislomal11

  • Visitante
Re: Problema Grub en la 4.4 final
« Respuesta #5 en: 27-05-2013, 17:43 (Lunes) »
Ok muchas gracias en un rato lo pruebo que no tengo el PC a mano ;D.
No es nada complicado.

crislomal11

  • Visitante
Re: Problema Grub en la 4.4 final
« Respuesta #6 en: 27-05-2013, 19:22 (Lunes) »
Ok, todo perfecto, ya me aparece en la grub.

Ya la he editado y todo, la he puesto para que me arranque mi windows 7 primero.

MUCHAS GRACIAS POR LA AYUDA

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: Problema Grub en la 4.4 final
« Respuesta #7 en: 27-05-2013, 19:36 (Lunes) »
De nada, para eso estamos  ;)

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

//FINAL Y MÁS DOS RESPUESTAS