Autor Tema: [RESUELTO] entorno grafico en wifislax instalado en hd (se queda en negro)  (Leído 6249 veces)

0 Usuarios y 1 Visitante están viendo este tema.

camel65

  • Visitante
Hola, antes de nada decir que soy novato y no tengo mucha experiencia.Mi problema es el siguiente: tengo instalado el wifislax en el disco duro y el grub, el problema es que al arrancar wifislax la pantalla se queda en negro o con rayas .He probado a configurar el grub con todas las opcciones posibles standart,640*480*32k,etc y no hay manera.Cuando lo arrancaba desde Live Cd lo ponia en modo grafico Vesa y funcionaba perfecto.He estado leyendo y no he visto nada.Agradeceria a ver si me pueden ayudar un poco

Un saludo


« Última modificación: 22-03-2013, 00:04 (Viernes) por USUARIONUEVO »

Tifro

  • Visitante
Poco creo que has leido,mira unos cuantos post mas abajo en uno que abri yo hace unos dias y igual se soluciona tu problema. ;)
« Última modificación: 21-03-2013, 13:47 (Jueves) por Tifro »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14453
este problema es diferente ..


lo arreglaremos todo arrancando en modo live

una vez en modo live ,.. buscamos en el disco duro donde la hemos instalado y que no arranca...


buscamos en


/boot/grub/menu.lst


buscamos la entrada de wifislax..que sera parecida a esto

Código: [Seleccionar]
# Comienzo de la configuracion del grub para Wifislax-4.X
  title Wifislax 4.x
  root (hd0,0)
  kernel /boot/vmlinuz root=/dev/sda1 ro vga=788
# Configuracion del grub para Wifislax-4.x terminada

la linea que nos interesa es la de opciones de arranque....

  kernel /boot/vmlinuz root=/dev/sda1 ro vga=788



y ahora miramos  en las carpetas del livecd , en boot ....   la configuracion del kernel ...que pondra algo asi como

kernel-normal.cfg

y buscamos la entrada de opcion "vesa"

veremos algo parecido a esto

Código: [Seleccionar]
LABEL vesa
MENU LABEL Wifislax Modo Grafico Vesa
KERNEL /boot/vmlinuz
APPEND initrd=/boot/initrd.xz nomodeset noload=013-Wifi*;000-PAE*;012-xfce* autoexec=vesa-mode;startx
TEXT HELP



de hay lo importante es

nomodeset
autoexec=vesa-mode;startx



que si nos fijamos en nuestro grub , no estan esos parametros..asi que en mi caso ..en mi menu.lst de grub ..deberia dejarlo asi


Código: [Seleccionar]
kernel /boot/vmlinuz root=/dev/sda1 ro vga=788 nomodeset autoexec=vesa-mode;startx






camel65

  • Visitante
Gracias por la ayuda USUARIONUEVO,problema resuelto

Saludos

lafulillo

  • Visitante
Mi problema es el mismo que el de camel 65, solo que yo arrancaba en el live usb en modo auto (acpi=off)

Como debo configurar menu.lst????


lafulillo

  • Visitante
Re: [RESUELTO] entorno grafico en wifislax instalado en hd (se queda en negro)
« Respuesta #5 en: 16-04-2013, 14:10 (Martes) »
Resuelto  ;D