Autor Tema: Problema Grub, instalado Ubuntu, Windows 10 y Slackware  (Leído 151 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Garcad

  • ****
  • Mensajes: 88
Problema Grub, instalado Ubuntu, Windows 10 y Slackware
« en: 17-11-2018, 11:15 (Sábado) »
Enlace foro PowerShell o CMD

¿Cuando en Ubuntu no cambio la resolución del grub y actualizo el mismo, si quiero arrancar en modo seguro Windows 10 no se ve nada....

El problema radica en la resolución del grub, dependiendo de la resolución puedo o no veo nada del modo seguro de Windows 10.

Ni pulsando F8 y 5, como usando bcedit

Actualmente en Windows 10 estoy usando la resolución automática 1366x768

Actualmente en Ufbuntu 18.10 estoy usando la resolución automática 1366x768



La resolución en grub esta controlada desde Ubuntu.

Y me veo obligado a cambiar la resolución del grub a vga para poder arrancar en modo seguro de Windows 10

~$ sudo nano /etc/default/grub





Si dejo el archivo del grub por defecto, me pasa lo siguiente en modo de arranque seguro de Windows 10



Se podria instalar Ext2Fsd, para montar las participaciones Ext...

Y modificar el archivo en cuestión, pero podria Haber Una solución, más limpia.

¿Alguien sabe como puedo modificar la resolución desde Windows?

Saludos


« Última modificación: 17-11-2018, 15:06 (Sábado) por Garcad »
"He sido un hombre afortunado en la vida: nada me fue fácil"

Sigmund Freud

Desconectado crash

  • *****
  • Mensajes: 140
Re:Problema Grub, instalado Ubuntu, Windows 10 y Slackware
« Respuesta #1 en: 17-11-2018, 16:04 (Sábado) »
en vez de comentar la linea GRUB_GFXMODE=800x600
lo que debes hacer es ponerle la resolución que tienes
GRUB_GFXMODE=1366x768
luego de eso haces un sudo update-grub && sudo update-grub2 para que se actualice el grub.

y otra cosa para tener wlan0 en vez de las wlxXXXXXXXXXXXX
la linea que te tienes en blanco GRUB_CMDLINE_LINUX=""
pon esto antes de actualizar el grub
net.ifnames=0 dentro de las comillas, despues actualizas el grub, y cuando vuelvas a arrancar ubuntu ya te saldra eth0 y wlan0

así:
GRUB_CMDLINE_LINUX="net.ifnames=0"
« Última modificación: 17-11-2018, 16:11 (Sábado) por crash »

Desconectado Garcad

  • ****
  • Mensajes: 88
Re:Problema Grub, instalado Ubuntu, Windows 10 y Slackware
« Respuesta #2 en: 19-11-2018, 00:29 (Lunes) »
en vez de comentar la linea GRUB_GFXMODE=800x600
lo que debes hacer es ponerle la resolución que tienes
GRUB_GFXMODE=1366x768
luego de eso haces un sudo update-grub && sudo update-grub2 para que se actualice el grub.

y otra cosa para tener wlan0 en vez de las wlxXXXXXXXXXXXX
la linea que te tienes en blanco GRUB_CMDLINE_LINUX=""
pon esto antes de actualizar el grub
net.ifnames=0 dentro de las comillas, despues actualizas el grub, y cuando vuelvas a arrancar ubuntu ya te saldra eth0 y wlan0

así:
GRUB_CMDLINE_LINUX="net.ifnames=0"

Gracias veré que tal sale y cuento.
"He sido un hombre afortunado en la vida: nada me fue fácil"

Sigmund Freud