Autor Tema: Problemas al reconocer mi adaptador atheros en vmware  (Leído 5245 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Juanjo94

  • Visitante
Problemas al reconocer mi adaptador atheros en vmware
« en: 13-12-2015, 12:51 (Domingo) »
Muy buenas a todos, de antemano os agradezco entrar en el tema.

Recientemente he decidido cambiar mi programa de virtualización de virtualbox a VMware, me he descargado la ultima versión de wifislax que hay en la web titulada "WifiSlax 4.11.1 VMware Edition con vmware-tools incluidas".

Lo primero que hago es crear la maquina virtual, insertar la ISO en el disco y arrancar, en esta maquina virtual ni si quiera he probado ha instalar en wifislax en hdd por que como dice el titulo ya pone que esta instaladas las vmware tools que supongo que sera como las guessadition de virtual box que es lo que hace que reconozca los usbs y las carpetas compartidas y demas, y ya una vez encendida la maquina es cuando me dispongo a conectar el usb. Primero añado un "USB controller" a la maquina virtual

y ya me aparece abajo a la derecha el USB de atheros tal que así


le doy a connect y espero unos segundos.

Tras esto en el primer sitio donde miro es aquí sin ningún resultado



y tras ver que no cambia absolutamente nada, lo miro en la herramienta airoscrip y nuevamente ningun cambio



Gracias por gastar vuestro tiempo en ayudarme, un saludo



Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #1 en: 14-12-2015, 21:50 (Lunes) »
Lo primero que hago es crear la maquina virtual, insertar la ISO en el disco y arrancar, en esta maquina virtual ni si quiera he probado ha instalar en wifislax en hdd por que como dice el titulo ya pone que esta instaladas las vmware tools que supongo que sera como las guessadition de virtual box que es lo que hace que reconozca los usbs

Los USB los reconoce sin necesidad de las vmware-tools, en VMware las tools lo que hace es mejorar los gráficos, permitir arrastrar archivos entre los escritorios de la máquina Host y la virtual, compartir carpetas y otras opciones avanzadas que no son necesarias para ejecutar Wifislax.

Citar
una vez encendida la maquina es cuando me dispongo a conectar el usb. Primero añado un "USB controller" a la maquina virtual

no tienes que añadir ningún USB controler, solo tienes que conectar el USB y desde el menú VM activarlo.

   

   


saludos


« Última modificación: 14-12-2015, 22:02 (Lunes) por drvalium »

Juanjo94

  • Visitante
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #2 en: 15-12-2015, 14:19 (Martes) »
claro drvalium pero para que te salga todo eso necesitas tener un para que te reconozca el adaptador no? si no es que ni me sale

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #3 en: 15-12-2015, 19:48 (Martes) »
cuando creas la máquina se crea uno por defecto, con ese ya te vale, no es necesario crear ningún otro USB controller. No se necesita uno para cada USB, con el que crea por defecto ya vale para todo lo que conectes.

si creas otro lo que haces es "volver loco" al gestor de redes, seguramente si entras en la configuración podrás configurarlo para que te funcione ese que creas, pero como te digo no es necesario.

si estas arrancando Wifislax con el USB conectado es posible que no te lo detecte, primero inicia Wifislax y luego pincha el USB, también si lo estas usando en un puerto USB 3.0 asegurate de configurarlo en la máquina virtual.

   


un saludo
« Última modificación: 15-12-2015, 19:54 (Martes) por drvalium »

pastilla

  • Visitante
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #4 en: 04-01-2016, 00:22 (Lunes) »
Y cuando te detecta el usb vmware como en mi caso y cuando le das a conectar al usb wireless en el modo que se sea briget, nat y te saca este mensaje que hay que hacer?,

the connection for the usb device Realtek rtl 8187 wireless lan adapter was unsuccessful

Driver error.


esto lo escribo en modo nat con vmware player12 y windows 10 con el chrome  de wiifislax vmware, del modo monitor me puedo olvidar  no lo detecta la distro con el iwconfig pero estoy navegando, incluso la actualiza con el geminis auditor, se me ha bloqueado con unos paquetes que repite pero pienso que al bajarlos creando los modulos  e instalandolos en disco duro ya no lo hara,

paquetes con error wifislax updater gui 2.4

 • pygobject3
 • gst-python

desea escanear el sistema en busca de paquetes rotos?

se pone a correr y sale verde el logo del updater al final sin ningun mensaje.

Y otra vez de nuevo a instalar esos 4 paquetes de 38 que dice, solo selecciona estos 4 :aircrack-ng y 3 de python cuando lo arranco en vwmware

le he dicho de crear modulo y los he instalado a mano en disco duro, estos dos:

aircrack-ng-1.2_rc3_r2807-i586-1sw.xzm

python-requests-Compilar-i586-1sw.xzm


Un saludo



 


« Última modificación: 04-01-2016, 00:29 (Lunes) por pastilla »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #5 en: 04-01-2016, 02:13 (Lunes) »
NO entiendo nada ???

Y cuando te detecta el usb vmware como en mi caso y cuando le das a conectar al usb wireless en el modo que se sea briget, nat y te saca este mensaje que hay que hacer?

the connection for the usb device Realtek rtl 8187 wireless lan adapter was unsuccessful

Driver error.

¿exactamente donde configuras el USB como NAT, Bridget, etc...?

esa configuración es para la tarjeta de red ethernet y no para los USB.

Citar
esto lo escribo en modo nat con vmware player12 y windows 10 con el chrome  de wiifislax vmware, del modo monitor me puedo olvidar  no lo detecta la distro con el iwconfig pero estoy navegando

estas navegando a través de la tarjeta de red ethernet del pc y no del WiFi USB.

no se puede navegar con un USB puesto en modo monitor.

Citar
incluso la actualiza con el geminis auditor, se me ha bloqueado con unos paquetes que repite pero pienso que al bajarlos creando los modulos  e instalandolos en disco duro ya no lo hara,

paquetes con error wifislax updater gui 2.4

 • pygobject3
 • gst-python

desea escanear el sistema en busca de paquetes rotos?

se pone a correr y sale verde el logo del updater al final sin ningun mensaje.

Y otra vez de nuevo a instalar esos 4 paquetes de 38 que dice, solo selecciona estos 4 :aircrack-ng y 3 de python cuando lo arranco en vwmware

le he dicho de crear modulo y los he instalado a mano en disco duro, estos dos:

aircrack-ng-1.2_rc3_r2807-i586-1sw.xzm

python-requests-Compilar-i586-1sw.xzm

esto mejor pregúntalo en la zona de desarrollo, el problema no tiene que ver con VMware.

   https://foro.seguridadwireless.net/colaboracion-y-desarrollo-de-nuestras-lives/wifislax-updater-gui/


Un saludo

pastilla

  • Visitante
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #6 en: 04-01-2016, 04:06 (Lunes) »
Bueno en si el problema es que vmware me reconoce esto en su log y despues da "driver error" al cargarlo con removable devices lo hace con todo lo que encuentra en el host anfitrion,

vmware.log

2016-01-03T21:05:02.038+01:00| vmx| I125: USB: Found device [name:Validity\ Sensor\ (VFS491) vid:138a pid:003d path:1/1/0/0 speed:full family:vendor instanceId:USB\\VID_138A&PID_003D\\0020DAEEE18C serialnum:0020DAEEE18C arbRuntimeKey:1 version:3]

2016-01-03T21:05:02.038+01:00| vmx| I125: USB: Found device [name:Realtek\ RTL8187_Wireless_LAN_Adapter vid:0bda pid:8187 path:1/0/3 speed:high family:vendor,other instanceId:USB\\VID_0BDA&PID_8187\\001AEF27A859 serialnum:001AEF27A859 arbRuntimeKey:6 version:3]

2016-01-03T21:05:02.038+01:00| vmx| I125: USB: Found device [name:Chicony\ HP\ HD\ Webcam\ [Fixed] vid:04f2 pid:b2ef path:1/1/0/2 speed:high family:unknown,imaging instanceId:USB\\VID_04F2&PID_B2EF\\SN0001 serialnum:SN0001 arbRuntimeKey:2 version:3]

2016-01-03T21:05:02.038+01:00| vmx| I125: USB: Found device [name:Hewlett-Packard\ HP\ hs2350\ HSPA+\ MobileBroadband vid:03f0 pid:3d1d path:1/1/0/4 speed:high family:comm instanceId:USB\\VID_03F0&PID_3D1D\\ED52B0344222FDM0 serialnum:ED52B0344222FDM0 arbRuntimeKey:3 version:3]

2016-01-03T21:05:02.038+01:00| vmx| I125: USB: Found device [name:Broadcom\ BCM20702A0 vid:0a5c pid:21e1 path:1/2/0/5 speed:full family:vendor,bluetooth instanceId:USB\\VID_0A5C&PID_21E1\\F4B7E2FE5A8E serialnum:F4B7E2FE5A8E arbRuntimeKey:4 version:3]

-----------------------

Cuando le doy a conectar en removable devices con lo que ha detectado me da este resultado,

the connection for the usb device Realtek rtl 8187 wireless lan adapter was unsuccessful

Driver error.


Y asi con todos los que detecta del anfitrion


Un saludo

PD: ya encontre el error mira que me daba mal rollito el windows 10 lo mirare a ver como lo soluciono y sino le creo la maquina virtual en kubuntu que sino cree la maquina virtual en kubuntu es porque no encontraba manuales.

https://communities.vmware.com/thread/516795?start=0&tstart=0
« Última modificación: 04-01-2016, 06:06 (Lunes) por pastilla »

pastilla

  • Visitante
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #7 en: 04-01-2016, 17:07 (Lunes) »
Ya lo he resuelto, a groso modo fue que cuando hice la instalacion del vmware player no trastee en la bios instalando las funciones que hay de virtualizacion, con lo que al instalarlo en un principio el vmware no me encontraba los usb en su apartado de" removable devices", lo hice despues lo de la bios y entonces me daba el problema de "driver error" el programa al detectarlos.

Pasos que he echo:

Instalar la virtualizacion en la bios

Desinstalar el vmware mal instalado y volverlo a instalar pero dandole funciones de instalar como administrador en las propiedades del ejecutable y desbloqueando el apartado de seguridad del ejecutable por si acaso tambien en el apartado de propiedades del windows 10.

Por ultimo he arrancado wifislas y he instalado el parche-inicio-tools.xzm a traves del instalador de modulos en HDD por si se me habia olvidado.

Y ya funciona el bichito.

Un saludo





 
« Última modificación: 04-01-2016, 17:10 (Lunes) por pastilla »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #8 en: 04-01-2016, 22:16 (Lunes) »
Hi

Me alegra ver que lo has solucionado, no encontraba información al respecto.

No me queda claro si la BIOS que has configurado es la del PC o la de VMware.


Saludos

pastilla

  • Visitante
Re: Problemas al reconocer mi adaptador atheros en vmware
« Respuesta #9 en: 06-01-2016, 02:01 (Miércoles) »
Hola! Pues mira me resulto imposible entrar en la bios del vmware player 12 dandole a la tecla esc le daba pero no conseguia que se abriese, solo me salia la bienvenida de wifislax con las dos opciones de entrada.. es que utilizo el vmware 12 player tengo que seguir investigando, lo que hice fue entrar en la bios del portatil Hp alli hay variios apartados sobre la virtulizaciom elegi unos que asi de memoria se llamaban Vt-x y otro Vt-d (que me parece que este ultimo hablaba de instrucciones de entrada y salida) y con eso vi que el vmware me reconocia los usb de la maquina anfitrion pero dandome el problema del driver.volviendolo a instalar de cero lo resolvi.

Despues en el apartado de los procesadores del vmware he visto que hay dos casilleros de virtualizacion de la maquina y los he marcado ahora, todo va bien por eso.

He ido asi a lo bestia porque hacia tiempo habia trasteado programas de virtualizacion y no lo he echo bien desde un principio ahora.

Me entretendre a intentar abrir la bios del programa ¿si consigo abrirla toco los apartados de virtualizacion tambien?

Repasare tus manuales de nuevo.

Mira ahora lo he instalado en kubuntu con el ejecutable que lleva que acaba en bundle la extension y al final su instalacion es sencilla con un doble click siendo root, me ha pedido el gnu c compiler he mirado en ubuntu lo he instalado con un paquete que lleva se llama build-essentials o algo parecido mas las instrucciones que hay para compilar el gcc del paquete.

Lo he empezado a pulir el vmware para la instalacion de wifislax esta vez hasta con la swap y como me recordaba de lo que toque de la bios del portatil esta vez no lo he puesto en automatico de la casilla de la virtualizacion de los procesadores del vmware sino que he marcado lo que se me asemejaba a mi bios.

Pues ahora corre mas rapido que el kubuntu mismo ja,ja,ja (ya te lo avisa por eso). A ver si es estable y va bien tan rapido.

Un saludo
« Última modificación: 06-01-2016, 05:11 (Miércoles) por pastilla »