Autor Tema: Problema: modo monitor falla con cable extension USB (activo)  (Leído 3695 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Max.Horkheimer

  • Visitante
Uso la nueva version de Wifislax edicion VMware, instalado en un MacBook Pro utilizando Parallels Desktop.
Todo va bien en general, mi adaptador de wifi es la Alfa AWUS036NH.

Pero cuando intento connectar un cable de USB de 10m, activo, el modo monitor deja de funconar depues de unos minutos, cuando uso Reaver o captura de paquetes.
Si miro airodump-ng, no indica redes, aunque iwconfig todavia indica el mon0 por un rato.
Despues unos minutos mas el airmon-ng avisa:

read failed: Network is down
Interface mon0:
ioctl(SIOCGIFINDEX) failed: No such device
Can't reopen mon0

No encuentro nada de esto problema por google. Alguien sabe que puedo hacer? He probado dos cables diferentes, las dos son de marca barato.
No tengo una workstation para probar si funcionaria con otro puerto de USB, eso podria ser, y claro, seria bien probarlo en una maquina no virtual.
 
Pero que me extrana es que funciona bien un rato y deja de funcionar, por eso suspecho que se trata de un problema de software.
Que se podria arreglar de alguna manera.


And the same again in English:
I am using the latest version of Wifislax, VMWare edition, installed on a MacBook Pro using Parallels Desktop.
Everything works fine, my USB Wifi Adaptor is the Alfa AWUS036NH.
But when I try to add a 10 m USB extension cable, which is active, the monitor mode stops working after a short while.
If I check airodump-ng, which works for a while after connecting, it suddenly shows no networks any more, even though iwconfig still indicates that the monitor mode is active.
After a while airmon-ng gives the output:
   
read failed: Network is down
Interface mon0:
ioctl(SIOCGIFINDEX) failed: No such device
Can't reopen mon0

And mon0 disappears from iwconfig.

I could not find anything about this problem searching the internet. Does anyone have a solution? It could be a problem with the cable, but I
tried 2 different ones, and the problem persists with both of them.
I know that Alfa sells active cables for their antennas, so in principle it should be possible to use, my cables are both rather *** no-name brands.
I should maybe try if it would work on a rear USB port of a Desktop PC, but I don't have one, or on a proper installation of Wifislax not on a a virtual machine (which I also don't have).
But as the cable works for a short time, I think it's a software issue and I hope there is a fix for it.



Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problema: modo monitor falla con cable extension USB (activo)
« Respuesta #1 en: 12-12-2015, 18:14 (Sábado) »
Hi

el problema es de Hardware y no de Software.

los cables esos son para adaptadores de potencia estandar (máximo 100mw) tu usas un adaptador de alta potencia y por eso se desconecta, los puertos USB no dan suficiente energía para poder usar esos cables con adaptadores de 1w o mas.



un saludo

Max.Horkheimer

  • Visitante
Re: Problema: modo monitor falla con cable extension USB (activo)
« Respuesta #2 en: 12-12-2015, 19:46 (Sábado) »
Gracias por tu respuesta. Entonces nadie puede usar un cable de extension USB con su adaptador wifi? Me parece raro porque he leido de gente que lo hacen y lo recomiendan en varios foros.

Me equivoque con la marca de mi cable: Lo compré en una tienda que lo promovia como  "AWUS036H CABLE PROLONGADOR USB 10MT". I parece que es el cable Alfa AUSBC-10M,  genuino de Alfa. Como puede ser que esto no funcione en nivel hardware.

 

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problema: modo monitor falla con cable extension USB (activo)
« Respuesta #3 en: 13-12-2015, 00:48 (Domingo) »
Yo no he dicho que no se pueda usar, he dicho que no se puede con adaptadores de alta potencia. A mi también me pasa con un cable de 10 metros

si le conectas un WiFi USB normal ya veras como si funciona.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 14462
Re: Problema: modo monitor falla con cable extension USB (activo)
« Respuesta #4 en: 13-12-2015, 01:24 (Domingo) »
hay cables activos que son una chapuza.

no estoy muy puesto en tema de cabls, pero es seguro ese el problema , lo hemos visto ya muchas veces.


habia un post , no recuerdo de quien , donde se comparaban cables "ACTIVOS" , donde no todos daban lo que deberian dar...de hecho algunos no conseguian porner en marcha los dispositivos  ;D