Autor Tema: wifislax x64 rc1  (Leído 46349 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14482
Re: wifislax x64 rc1
« Respuesta #60 en: 18-05-2012, 01:40 (Viernes) »
A lo mejor lo que voy a decir es una burrada, pero si tu haces un botón que abre una consola (lanzar reaver) y otro que cierra una consola (stop) si no abres primero la consola no hay ninguna consola abierta, y cerrará lo primero que pille.

pues acabo de ver que no  abre ninguna shell ...o no le dio ni tiempo ..por que era un pin 12345670 tardo 0 segundos..

no la añadio a historical tampoco...



Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8423
Re: wifislax x64 rc1
« Respuesta #61 en: 18-05-2012, 01:44 (Viernes) »
Hola


Citar
dale a refrescar escritorio , la primera vez siempre pasa eso.


Correcto arreglado

Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14482
Re: wifislax x64 rc1
« Respuesta #62 en: 18-05-2012, 01:48 (Viernes) »
Hola


Citar
dale a refrescar escritorio , la primera vez siempre pasa eso.


Correcto arreglado

Saludos

solo es la primera vez...creo que ya no necesitaras mas veces de refrescar.
si es en live si , ...cada vez que arranquemos.

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: wifislax x64 rc1
« Respuesta #63 en: 18-05-2012, 11:07 (Viernes) »
Hola


Citar
Sin embargo he quitado la TV por HDMI y he conectado un monitor normal por VGA y los resultados son:

Bueno esto cambia el cuento....aventurandome a equivocarme, ya me corregirá usuarionuevo si eso, tu tienes dos problemas.

Por un lado el Mio que es un problema con la tarjeta gráfica, en mi caso una Intel

Y por otro es la salida hdmi, no se asta que punto los controladores gráficos de wifislax y wifiway están preparados para activar la salida hdmi en las gráficas o que el sistema te permita activarla manualmente ya que esta salida por defecto suele estar desactivada y se activa Manualmente, bien con una combinación de teclas, o bien en la configuración de la tarjeta.

Y imagino que en slax no estará preparado para que arranque por defecto con hdmi  activo y de ahí lo de no hay señal que no es lo mismo que me pasa ami que sale el cursor y el puntero del ratón pero la pantalla en negro.

¿Has probado ha hacer lo que te dije pero con el vga? Ya que lo otro es otro problema.

Si la tele es una Samsung también tiene conector para vga, o al menos la mía si lo tiene, también podrías probar con esa.

Saludos
Vale, he quitado el cable HDMI, he conectado un VGA normal y corriente a la TV Samsung SyncMaster 933HD y los resultados son los mismos:

A pelo sin ningún modulo:

Modo Auto - Pantalla negra pero se escucha que arranca, y no me ha funcionado los del las teclas Fn+Esc.
Modo Vesa - O.K. pero con iconos enormes y no me deja cambiar la resolución.

Con Modulo Nvidia:

Modo Auto - No funciona, parpadea el cursor y tampoco funciona lo de las teclas Fn+Esc.
Modo Vesa - No funciona, parpadea el cursor y tampoco funciona lo de las teclas Fn+Esc.

Parece ser que solo me funciona bien con un monitor standard y en Modo Auto sin modulo Nvidia.

Un saludo.
« Última modificación: 18-05-2012, 11:08 (Viernes) por pepe10000 »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8423
Re: Re: wifislax x64 rc1
« Respuesta #64 en: 18-05-2012, 11:13 (Viernes) »
Hola

Lo de la combinacion de teclas no tiene por que ser en tu caso como el mio.

Tiene que buscar la combinacion que cierra sesoon o bloquea la pantalla.

En mi caso es fn+la tecla que tiene una luna dibujada en azul.

Aunque tambien puede ser otro problema, pero por lo que comentas parece el mismo qie el mio.

Pruba con todas las f a ver si alguna te lo pone en reposo, escucharas un sonido , como que se cierra

Saludos

si sale este mensaje, es que estoy en el movil

Chumpy

  • Visitante
Re: wifislax x64 rc1
« Respuesta #65 en: 18-05-2012, 11:21 (Viernes) »
En lugar de una luna tambien pueneen ser unas Zz

supremo12345

  • Visitante
Re: wifislax x64 rc1
« Respuesta #66 en: 18-05-2012, 15:16 (Viernes) »
Respecto al instalador, esta noxe si quieres en un rato y me pongo a modificar las 2 cosas que comentais, por una parte las letras y un solo logo, mas ordenado, y por otra la barra que llegue a 100% cuando copia/instala.

Por otra parte, reaver no lanza ni shell ni leches, es todo interno a la GUI. Pero tranquilidad....
YA HE DETECTADO Y FIXEADO EL BUG (incluso sin reproducirlo xD).

antes
Código: [Seleccionar]
bool reaver::stop()
{
    logThread::addLog("Reaver: Stopping sending signal CTRL-C", logInfo::MAIN);

    // to save session sending CTRL-C
    attack->sendSignalToProcess(2);
    if (attack->isRunning()) {
        sleep(1);
        attack->stop();
        toThisLog("Process stopped");
    }


    this->setStatus(STOPPED);
    return true;
}

DESPUES DE FIXEAR
Código: [Seleccionar]
bool reaver::stop()
{
    logThread::addLog("Reaver: Stopping sending signal CTRL-C", logInfo::MAIN);
    if (attack->isRunning()) {
        // to save session sending CTRL-C
        attack->sendSignalToProcess(2);
        sleep(1);
        attack->stop();
        toThisLog("Process stopped");
    }


    this->setStatus(STOPPED);
    return true;
}

Acabo de subir al subversion el cambio. No se si sacare version... tengo muchos cambios hechos pero 3 pendientes. Si usais la version del subversion el bug esta fixeado.

El problema es que estamos calculando el pid y enviando una señal a un proceso que no existe (aun), algunos sistemas pueden manejar esto (ubuntu puede, linux mint pùede) pero al parecer otros sistemas petan.


edito: si no pasa nada este find saco la 1.1.0... que esta tardando mas de la cuenta. me guardo el ultimo cambio para el ultimo commit que desbloqueara el ataque automatico m4  ;D
« Última modificación: 18-05-2012, 15:23 (Viernes) por supremo12345 »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8423
Re: wifislax x64 rc1
« Respuesta #67 en: 18-05-2012, 15:24 (Viernes) »
Hola


Ok a la noche o mañana instalo esa a ver que tal.....

A ver si para la final, te diese tiempo a las dos pendientes que tienes en la actual.....el ataque automático h la obtención del HadsHake

Salidos

supremo12345

  • Visitante
Re: wifislax x64 rc1
« Respuesta #68 en: 18-05-2012, 15:28 (Viernes) »
Hola


Ok a la noche o mañana instalo esa a ver que tal.....

A ver si para la final, te diese tiempo a las dos pendientes que tienes en la actual.....el ataque automático h la obtención del HadsHake

Salidos

en la 1.1.0 estaran tanto la captura del handshake como el ataque automatico.
Esta nueva version es la que mas cambios va a tener respecto a cambios de versiones anteriores. Otra cosa way que ya esta hecha es la autodeteccion de la tarjeta en modo monitor (se eliminan eth0, lo, etc), o el rediseño de la interfaz de airmon-ng, otra mejora es que ahora ya se guarda la clave WPA en la tabla historical, etc...
« Última modificación: 18-05-2012, 15:30 (Viernes) por supremo12345 »

Chumpy

  • Visitante
Re: wifislax x64 rc1
« Respuesta #69 en: 18-05-2012, 17:22 (Viernes) »
Otra cosa way que ya esta hecha es la autodeteccion de la tarjeta en modo monitor (se eliminan eth0, lo, etc), o el rediseño de la interfaz de airmon-ng,

Cuidado con esto, que hay tarjetas que hacen cosas raras y se detectan como eth0 y cosas así, intententa dejar siempre que sea posible al menos una opción manual o un "Volver a buscar con las que se han eliminado?"



Salidos

Que ataque más gratuito no?  :P

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: Re: wifislax x64 rc1
« Respuesta #70 en: 18-05-2012, 18:11 (Viernes) »
Hola

Lo de la combinacion de teclas no tiene por que ser en tu caso como el mio.

Tiene que buscar la combinacion que cierra sesoon o bloquea la pantalla.

En mi caso es fn+la tecla que tiene una luna dibujada en azul.

Aunque tambien puede ser otro problema, pero por lo que comentas parece el mismo qie el mio.

Pruba con todas las f a ver si alguna te lo pone en reposo, escucharas un sonido , como que se cierra

Saludos

si sale este mensaje, es que estoy en el movil
Quitando de nuevo el cable HDMI y usando el cable VGA con la TV he probado la tecla Fin+Todas las F.
Todas las F sueltas.
Y la única que me ha dado el sonido como si se cerrara es la "Sleep", que me deja el ordenador con los LED laterales parpadeando, si pulso una tecla o pico el ratón se enciende de nuevo pero sigue sin mostrar nada en pantalla.
Por lo que deduzco que el problema debe ser otro.
De todas formas se que con un monitor normal y en modo Auto me funciona bien.
Un saludo.

supremo12345

  • Visitante
Re: wifislax x64 rc1
« Respuesta #71 en: 18-05-2012, 18:14 (Viernes) »
Otra cosa way que ya esta hecha es la autodeteccion de la tarjeta en modo monitor (se eliminan eth0, lo, etc), o el rediseño de la interfaz de airmon-ng,

Cuidado con esto, que hay tarjetas que hacen cosas raras y se detectan como eth0 y cosas así, intententa dejar siempre que sea posible al menos una opción manual o un "Volver a buscar con las que se han eliminado?"



Salidos

Que ataque más gratuito no?  :P

No se eliminan por nombre, sino por si son wireless o no. He dixo eth0 y lo porque generalmente estas nunca son wireless, son ethernet y loop. Pero si tu añades una interfaz WIRELESS que se llame eth6, o pepitoInterfaz, te la detecta xD. Gracias por el apunte >:(

triver

  • Visitante
Re: wifislax x64 rc1
« Respuesta #72 en: 18-05-2012, 20:08 (Viernes) »
vamos a probarlo gracias

Serch

  • Visitante
Re: wifislax x64 rc1
« Respuesta #73 en: 18-05-2012, 20:43 (Viernes) »
Me lo estoy bajando pero una pregunta chorra. Si mi sistema NO es de 64 bits, funcionará??

Gracias

Chumpy

  • Visitante
Re: wifislax x64 rc1
« Respuesta #74 en: 18-05-2012, 21:17 (Viernes) »
Otra cosa way que ya esta hecha es la autodeteccion de la tarjeta en modo monitor (se eliminan eth0, lo, etc), o el rediseño de la interfaz de airmon-ng,

Cuidado con esto, que hay tarjetas que hacen cosas raras y se detectan como eth0 y cosas así, intententa dejar siempre que sea posible al menos una opción manual o un "Volver a buscar con las que se han eliminado?"



Salidos

Que ataque más gratuito no?  :P

No se eliminan por nombre, sino por si son wireless o no. He dixo eth0 y lo porque generalmente estas nunca son wireless, son ethernet y loop. Pero si tu añades una interfaz WIRELESS que se llame eth6, o pepitoInterfaz, te la detecta xD. Gracias por el apunte >:(

A veces me olvido de lo profesionales que sois algunos!! Siempre haces un trabajo supremo! XDD

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14482
Re: wifislax x64 rc1
« Respuesta #75 en: 18-05-2012, 22:42 (Viernes) »
Me lo estoy bajando pero una pregunta chorra. Si mi sistema NO es de 64 bits, funcionará??

Gracias

dispones de version de 32 y de 64 bits ...en wifislax obviamente he puesto la de 64 bits.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14482
Re: wifislax x64 rc1
« Respuesta #76 en: 19-05-2012, 03:19 (Sábado) »
añado en el primer post 3 fixes   >:(

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8423
Re: wifislax x64 rc1
« Respuesta #77 en: 19-05-2012, 10:36 (Sábado) »
Hola


Citar
si es un portatila a bateria, la pantalla iniciara con el brillo un poco mas bajo para ahorrar pero tampoco se os apagara por inactividad, ademas si quereis podeis subirle el brillo ,mediante la tecla de funcion de vuestro portatil.

Pues en mi caso si se apaga por inactividad, solo la pantalla no el sistema.

Las teclas del brillo no funcionan, parpadea la pantalla, como si hiciese algo, pero no lo hace.

Samsung r519


Saludos

supremo12345

  • Visitante
Re: wifislax x64 rc1
« Respuesta #78 en: 19-05-2012, 11:24 (Sábado) »
añado en el primer post 3 fixes   >:(

Eres una makina  >:(

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8423
Re: Re: wifislax x64 rc1
« Respuesta #79 en: 19-05-2012, 12:36 (Sábado) »
Hola

Le tienes que decir al jefe que te suba el sueldo a 1euro jeje

Saludos

si sale este mensaje, es que estoy en el movil