Autor Tema: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?  (Leído 12416 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« en: 10-09-2013, 06:06 (Martes) »
Bueno , no voy a explicar mucho.

USANDO LA ISO DEL DIA 09092013 -->> http://www.downloadwireless.net/isos-fase-testing/wifislax-current/wifislax-4.6-09092013.iso

Bajais este xzm  http://www.multiupload.nl/J2348SSCMD

y lo poneis en modules.


En el menu de arranque inicial elegid ..arancar en modo texto

y cuando os quedeis con la shell esperando ..pues


root/toor


PERO NO ARRANQUEIS

ejecutad

/root/Desktop/NVIDIA.run

Aparecera el instalador nvidia , seguida las instrucciones del instalador...

y cuando acabe ya entonces si


"startx"


cuando entreis a wifislax ...

nos vamos a

/mnt/live/memory/changes

click derecho sobre changes , crear xzm ... esperais a que acabe ..

pasais el xzm  , al pendrive o aun disco duro ...


___________

El mismo proceso con kernel normal ..y despues con pae , y me poneis los dos xzm ,yo ya hare el resto.


A ver si alguien se enrolla un poco algun dia ... y aprende el proceso completo , por que no es nada complicado.



« Última modificación: 10-09-2013, 06:07 (Martes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #1 en: 10-09-2013, 06:11 (Martes) »
Si quereis, podeis arrancar con el modulo hashcat tambien dentro ...el nuevo

http://www.downloadwireless.net/modulos/wifislax-4-6/022-Hashcat_gui-0.5.2_2013.08.27-i486-1sw.xzm


y probais si el driver es valido para hashcat.


eso si , cread el xzm antes ...y ya despues si quereis haceis pruebas con hashcat.

en principio debe servir por que es de la rama 319.XX que es lo requerido en la nueva version de hashcat.

Habian driver nvidia 325.XX ,pero como hashcat pide 319.xx , prefiero ir sobre seguro.


_____________________________________________________________

El driver seleccionado admite todo esto

GeForce 700M series:
GTX 780M, GTX 770M, GTX 765M, GTX 760M, GT 755M, GT 750M, GT 745M, GT 740M, GT 735M, GT 730M, GT 720M, 710M

GeForce 700 series:
GTX TITAN, GTX 780, GTX 770, GTX 760

GeForce 600 series:
GTX 690, GTX 680, GTX 670, GTX 660 Ti, GTX 660, GTX 650 Ti BOOST, GTX 650 Ti, GTX 650, GT 645, GT 640, GT 630, GT 620, GT 610, 605

GeForce 600M series:
GTX 680MX, GTX 680M, GTX 675MX, GTX 675M, GTX 670MX, GTX 670M, GTX 660M, GT 650M, GT 645M, GT 640M LE, GT 640M, GT 635M, GT 630M, GT 625M, GT 620M, G610M

GeForce 500 series:
GTX 590, GTX 580, GTX 570, GTX 560 Ti, GTX 560 SE, GTX 560, GTX 555, GTX 550 Ti, GT 545, GT 530, GT 520, 510

GeForce 500M series:
GTX 580M, GTX 570M, GTX 560M, GT 555M, GT 550M, GT 540M, GT 525M, GT 520MX, GT 520M

GeForce 400 series:
GTX 480, GTX 470, GTX 465, GTX 460 v2, GTX 460 SE v2, GTX 460 SE, GTX 460, GTS 450, GT 440, GT 430, GT 420, GT 415, 405

GeForce 400M series:
GTX 485M, GTX 480M, GTX 470M, GTX 460M, GT 445M, GT 435M, GT 425M, GT 420M, GT 415M, 410M

GeForce 300 series:
GT 340, GT 330, GT 320, 315, 310

GeForce 300M series:
GTS 360M, GTS 350M, GT 335M, GT 330M, GT 325M, GT 320M, 320M, 315M, 310M, 305M

GeForce 200 series:
GTX 295, GTX 285, GTX 280, GTX 275, GTX 260, GTS 250, GTS 240, GT 240, GT 230, GT 220, G210, 210, 205

GeForce 200M series:
GTX 285M, GTX 280M, GTX 260M, GTS 260M, GTS 250M, GT 240M LE, GT 240M, GT 230M, GT 220M, G210M

GeForce 100 series:
GT 140, GT 130, GT 120, G 100

GeForce 100M series:
GTS 160M, GTS 150M, GT 130M, GT 120M, G 110M, G 105M, G 103M, G 102M

GeForce 9 series:
9800 GX2, 9800 GTX+, 9800 GTX/GTX+, 9800 GT, 9600 GT, 9600 GSO 512, 9600 GSO, 9600 GS, 9500 GT, 9500 GS, 9400 GT, 9400, 9300 SE, 9300 GS, 9300 GE, 9300 / nForce 730i, 9300, 9200, 9100

GeForce 9M series:
9800M GTX, 9800M GTS, 9800M GT, 9800M GS, 9700M GTS, 9700M GT, 9650M GT, 9650M GS, 9600M GT, 9600M GS, 9500M GS, 9500M G, 9400M G, 9400M, 9300M GS, 9300M G, 9200M GS, 9100M G

GeForce 8 series:
8800 Ultra, 8800 GTX, 8800 GTS 512, 8800 GTS, 8800 GT, 8800 GS, 8600 GTS, 8600 GT, 8600 GS, 8500 GT, 8400 SE, 8400 GS, 8400, 8300 GS, 8300, 8200, 8100 / nForce 720a

GeForce 8M series:
8800M GTX, 8800M GTS, 8700M GT, 8600M GT, 8600M GS, 8400M GT, 8400M GS, 8400M G, 8200M G, 8200M

NVS Series:
NVS 510, NVS 310, NVS 300

Quadro series:
K5000, 7000, 6000, 600, 5000, 410, 4000, 400, 2000D, 2000

Quadro FX series:
FX 5800, FX 580, FX 570, FX 5600, FX 5500, FX 4800, FX 4700 X2, FX 4600, FX 380 LP, FX 3800, FX 380, FX 370 Low Profile, FX 3700, FX 370, FX 3400/4400, FX 1800, FX 1700, CX

Quadro Notebook series:
K5000M, K4000M, K3000M, K2000M, K1000M, 5010M, 5000M, 4000M, 3000M, 2000M, 1000M

Quadro FX Notebook series:
FX 880M, FX 770M, FX 570M, FX 380M, FX 3800M, FX 370M, FX 3700M, FX 360M, FX 3600M, FX 2800M, FX 2700M, FX 1800M, FX 1700M, FX 1600M

Quadro NVS series:
NVS 450, NVS 420, NVS 295, NVS 290

Quadro NVS Notebook series:
NVS 5400M, NVS 5200M, NVS 4200M, NVS 320M, NVS 160M, NVS 150M, NVS 140M, NVS 135M, NVS 130M

Quadro Plex series:
Model IV, Model II, D Series, 7000

Quadro Sync series:
Sync, G-Sync II

Quadro SDI series:
Quadro SDI

ION series:
ION LE, ION

C-Class Processors:
Tesla C870, Tesla C2075, Tesla C2070, Tesla C2050, Tesla C1060, T10 Processor

M-Class Processors:
Tesla M2090, Tesla M2075, Tesla M2070-Q, Tesla M2070, Tesla M2050, Tesla M1060

X-Class Processors:
Tesla X2090

S-Class Systems:
Tesla S2050

K-Series Processors:
Tesla K20Xm, Tesla K20m, Tesla K20c, Tesla K10


Desconectado pepe10000

  • *******
  • Mensajes: 576
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #2 en: 10-09-2013, 08:39 (Martes) »
Me ha sido imposible hacerlos, me da un error, imágenes (picar en los  enlaces para visualización):

http://www.subeimagenes.com/img/imagen1-740587.html

http://www.subeimagenes.com/img/imagen2-740591.html

Incluso he intentado añadir el modulo disable-nouveau.xzm por si acaso, pero tampoco.

Un saludo.
« Última modificación: 10-09-2013, 14:26 (Martes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #3 en: 10-09-2013, 08:52 (Martes) »
El disable nouveau ya lo lleva el xzm que prepare.


los errores que muestras son chorras.


el primero dice que no puede crear el directorio , por que ya existe ...

y el segundo dice algo de la "doc"  ...documentacion ... que nos da igual esa parte.


¿ si aceptas no te deja seguir ?

Desconectado pepe10000

  • *******
  • Mensajes: 576
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #4 en: 10-09-2013, 10:31 (Martes) »
El disable nouveau ya lo lleva el xzm que prepare.


los errores que muestras son chorras.


el primero dice que no puede crear el directorio , por que ya existe ...

y el segundo dice algo de la "doc"  ...documentacion ... que nos da igual esa parte.


¿ si aceptas no te deja seguir ?

Que va, si acepto vuelve a salirme el error de la primera imagen.
Si le digo que "No" se sale del instalador y ya no puedo ni acceder a la interfaz grafica con "startx", salen un motón de errores y tengo que reiniciar.
Un saludo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #5 en: 10-09-2013, 12:33 (Martes) »
BIEN , acabo de revisar.lo que ocurre es justo al reves..

el directorio no existe y pasa de crearlo el.


asi que hazlo tu , antes de ejecutar el instalador.


Código: [Seleccionar]
mkdir -p /usr/share/doc
asi ya tendra su directorio de documentacion.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #6 en: 10-09-2013, 12:35 (Martes) »
pfffffffff

jodder, espra que revise, algo no va bien.


dice que el directorio existe ,pero ES MENTIRA , y tampoco deja crearlo ...por eso falla.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #7 en: 10-09-2013, 12:37 (Martes) »
ale ya esta claro...


1 -
Código: [Seleccionar]
rm -Rf /usr/share/doc2 -
Código: [Seleccionar]
mkdir -p /usr/share/doc3 -
Código: [Seleccionar]
/root/Desktop/NVIDIA.run

procurare generar ese directorio en la iso ..aunque este vacio ...por que si no los instaladores dan fallo...algunos.

alist3r

  • Visitante
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #8 en: 10-09-2013, 12:53 (Martes) »
te acuerdas cuando te comenté algunas desventajas de no activar el "inode mmaping" en aufs?

algunos programas intentarán ir a crear carpetas en las ramas aufs, y trataran posteriormente de comprobar si se han creado los ficheros...
en ese segundo paso (comprobarlo), te fallaran.

intenta mantener todas las estructuras del "File System Hierarchy" para evitar esto al máximo, y asegúrate de que tienes todas las opciones avanzadas de aufs activas, aunque penalicen un poquito el rendimiento.

alist3r

  • Visitante
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #9 en: 10-09-2013, 12:54 (Martes) »
cuál estais compilando? yo tengo los 319.49

Código: [Seleccionar]
root@engetsu:~# ls /var/lib/dkms/nvidia/ -l
total 4
drwxr-xr-x 4 root root 4096 sep  4 01:14 319.49
...
« Última modificación: 10-09-2013, 12:55 (Martes) por alister »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #10 en: 10-09-2013, 13:00 (Martes) »
pues esos , justo ...

pero recuerda que si no estan sacados en la misma iso ,aunque tengas mismo kernel no valen.


hay que crearlos en wifislax.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #11 en: 10-09-2013, 13:14 (Martes) »
El problema a venido por algo un poco desconcertante.


SIEMPRE , mantengo la gerarquia de estructura basica ... ( menos la carpeta home por que en wifislax solo hay root )

Pero no me preguntes por que ..el modulo core , que es el base de sistema..

cree que tiene esa ruta

/usr/sahre/doc

yo miro y no la veo ...

si intento mover un estructura de carptas con esa ruta para añadirla ,me dice que si..que la carpeta esta..PERO NO ESTA...


1 - descomprimo 001-core
2 - cd /root/Desktop/001-core
3 - rm Rf ./usr/share/doc
4 - mkdir -p ./usr/share/doc

y ya esta ya veo la carpoeta y de vuelta a la normalidad.

un bug chorra ...que no se muy bien como a pasado ,pero bueno ..reparado queda.

me planteo incluso crear la "home"  , no sea que alguien quiera añadir un user basico al sistema y no pueda por no tener la dichosa ruta.


Para quien no lo sepa,. en home , se alamcenan las configs de lo diferentes usuarios de un sistema linux


por ejemplo

/home/rafa/./config
/home/rafa/.kde

para que el usuario rafa *** que puede ser un usuario limitado **** , tenga hay sus configs personales , diferenciasdas de root o de cualquier otro user del sistema.

lo mismo si ademas de rafa esta antonio habria un

/home/rafa
/home/antonio

y asi sucesivamente.

Desconectado pepe10000

  • *******
  • Mensajes: 576
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #12 en: 10-09-2013, 13:18 (Martes) »
ale ya esta claro...


1 -
Código: [Seleccionar]
rm -Rf /usr/share/doc2 -
Código: [Seleccionar]
mkdir -p /usr/share/doc3 -
Código: [Seleccionar]
/root/Desktop/NVIDIA.run

procurare generar ese directorio en la iso ..aunque este vacio ...por que si no los instaladores dan fallo...algunos.

Yaaaata, ahora me ha dejado:

http://www.multiupload.nl/B33PZ539PK

Espero que te sirvan.

Un saludo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #13 en: 10-09-2013, 13:20 (Martes) »
un bug miserable, que puede salir muy caro , como hemos visto.

alist3r

  • Visitante
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #14 en: 10-09-2013, 13:23 (Martes) »
intenta mantener la estructura FHS. no te hará mal, y su ausencia sí que puede darte por saco.

por otro lado, todas las carpetas que se intersectan justo en un cruce de branches de aufs tendrán comportamientos anómalos según y como traten de ser leídas o escritas.
la única opcion es decirle a aufs que detecte escrituras y lecturas directas en las ramas separadas, y que plasme el reflejo en el aufs unificado.

en la config de aufs del kernel encontrarás una opcion para eso.
« Última modificación: 10-09-2013, 13:25 (Martes) por alister »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #15 en: 10-09-2013, 13:34 (Martes) »
intenta mantener la estructura FHS. no te hará mal, y su ausencia sí que puede darte por saco.

por otro lado, todas las carpetas que se intersectan justo en un cruce de branches de aufs tendrán comportamientos anómalos según y como traten de ser leídas o escritas.
la única opcion es decirle a aufs que detecte escrituras y lecturas directas en las ramas separadas, y que plasme el reflejo en el aufs unificado.

en la config de aufs del kernel encontrarás una opcion para eso.

Siempre respeto la estructura básica ...SIEMPRE.

Lo que a pasado no tiene nada que ver con aufs.

El sistema creía que tenia la carpeta , cuando no era asi ...nada mas...yo no la borre ni nada por el estilo ...solo eso ...el sistema creía tenerla..y no era asi.

Por eso tampoco dejaba crearla, por que para el ya existía.

DESDE HD , nada de aufs ..

Ha sido un bug en el 001-core , miserable ...pero un bug a fin de cuentas.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #16 en: 10-09-2013, 13:35 (Martes) »
modulo

http://www.multiupload.nl/KMMQH5K2SI

o


http://www.downloadwireless.net/modulos-fase-testing/wifislax-current/029-Driver_nvidia-319.49_wifislax_4.7-i486-1sw-BETA.xzm


Supongo que debe funcionar a la primera.

De ser asi , pues ya probarlo con el hashcat de agosto ,,el nuevo.
« Última modificación: 10-09-2013, 14:25 (Martes) por USUARIONUEVO »

alist3r

  • Visitante
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #17 en: 10-09-2013, 13:56 (Martes) »
pues @USUARIONUEVO, lo que dices es mucho más WTF todavia
que el installer no maneje bien eso...... tiene miga.

pero bueno, todos los problemas fueran tan faciles de resolver.

PD: agh! es verdad, el tema del aufs no afecta aqui, solo en escrituras directas sobre las ramas separadas, y tal como está montado wifislax, /usr/share/doc no es rama directa sino unificada. forget it!

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14692
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #18 en: 10-09-2013, 14:11 (Martes) »
pues @USUARIONUEVO, lo que dices es mucho más WTF todavia
que el installer no maneje bien eso...... tiene miga.

pero bueno, todos los problemas fueran tan faciles de resolver.

PD: agh! es verdad, el tema del aufs no afecta aqui, solo en escrituras directas sobre las ramas separadas, y tal como está montado wifislax, /usr/share/doc no es rama directa sino unificada. forget it!

claro que es un WTF¡¡¡  , como el sistema dice qu el directorio existe , si noe s asi ..el instalador intenta crearlo , pero al existir "supuestamente" , pues tampoco puede crearlo.

un instalador nunca hara un rm -Rf ...  por que se carga todo lo que haya en esa ruta , en wifislax, esa carpeta esta vacia por que la doc ocupa bastante ... pero las rutas aunque vacias ,las suelo dejar , por eso mismo de que algunos instaladores si no pueden poner la doc, se niegan a instalar el resto , me parece estudipo por que si la dicumentacion el programa o librería funciona igual..pero como la Shell retorna error,pues game over.

WTF X 10  ;D

Desconectado pepe10000

  • *******
  • Mensajes: 576
Re: Vamos alla ,con los drivers NVIDIA , ¿voluntarios?
« Respuesta #19 en: 10-09-2013, 15:15 (Martes) »
Esto ya funciona.
No hay problemas con la resolución ni el refresco de la TV que está conectada por HDMI, pero paso a comentar algunas cosas:


029-Driver_nvidia-319.49_wifislax_4.7-i486-1sw-BETA.xzm + 022-Hashcat_gui-0.5.2_2013.04.25-i486-1sw.xzm = O.K., unas 16800/s.
Ha mejorado en velocidad con respecto a los drivers 304.88 que llegaban a unas 13500/s.


029-Driver_nvidia-319.49_wifislax_4.7-i486-1sw-BETA.xzm + 022-Hashcat_gui-0.5.2_2013.08.27-i486-1sw.xzm = O.K., unas 13200/s.
Ha empeorado y además no se si os lo vais a creer pero se escucha un ruidito cuando pongo a trabajar el Hascat, sin embargo con la versión anterior no se escucha nada.
Además sale un warning:

http://www.subeimagenes.com/img/imagen3-1-740695.html



Un saludo.

Pd. El centro de control de Nvidia no aparece en el menú del sistema como en los drivers antiguos, aunque eso es lo de menos ya que es plenamente funcional.
« Última modificación: 11-09-2013, 02:50 (Miércoles) por Hwagm »

//FINAL Y MÁS DOS RESPUESTAS