Autor Tema: TESTING Drivers ATI para wifislax  (Leído 14651 veces)

0 Usuarios y 1 Visitante están viendo este tema.

trax69

  • Visitante
TESTING Drivers ATI para wifislax
« en: 30-10-2015, 09:21 (Viernes) »
Hola, me encuentro en una parte de testeo ya que no dispongo de ningún PC con tarjeta grafica ATI -.-....

Trato al igual que ya he hecho con Nvidia crear un script de actualización pero en este caso para ATI.

El script técnicamente debería estar salvo unos retoques.

Sin entrar en detalles técnicos oficialmente ATI no da soporte mas hallá del kernel de linux 3.19 por lo que hacen falta parches, parches que he aplicado al updater (gracias a archilinux y en especial los que los han creado).

Ademas ATI dejo de dar soporte a ciertas gráficas ya versiones atrás, en este enlace os dejo las gráficas que están soportadas y por tanto también con este modulo:
http://support.amd.com/en-us/download/desktop?os=Linux+x86  (​​​​Supported Products)

Técnicamente debería funcionar ya que he revisado y creo que está todo en su sitio.

Necesito que carguéis el modulo metiendolo en wifislax/modules/ que os pongo a continuación iniciando Wifislax en modo Live USB (para evitar cargarnos el sistema en caso de que algo falle)

Y una vez arranquéis con el modulo ya metido me describáis si sale algún error. Si el escritorio os ha iniciado etc...
Si la primera vez no arranca probad una segunda y en el segundo menú del boot (después de elegir con que kernel arrancar) pulsar el tabulador y escribir "nomodeset" (sin las comillas y que haya 1 espacio despues del ultimo comando)
Si os a iniciado el escritorio  probad a ejecutar desde terminal el comando "amdcccle" o desde la entrada al menú que debería haberse creado iniciar el programa de ATI en caso de que funcione deberiais ver algo parecido a esto:


Foto obtenida de google imagenes

Toda documentación sobre los errores es importante, foto, captura de pantalla, todo

Enlace modulo a probar: https://mega.nz/#!BV4zBDaB!olPvVpTm_ef1eZkGi0iip6NrBOC9CIVKsmtohqArAm8
modulo generado con script v0.1


Lo siento USUARIONUEVO soy muy tozudo -.-

Y gracias a todos aquellos que quieran colaborar


« Última modificación: 30-10-2015, 09:37 (Viernes) por trax69 »

sol666

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #1 en: 30-10-2015, 13:18 (Viernes) »
bien,yo tengo una ati,la gigabyte 7750,esta noche me pongo a ello,¿lo pruebo con la 4.11.1 o con una de desarrollo?

trax69

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #2 en: 30-10-2015, 13:29 (Viernes) »
Prueba con la DEV 26102015 es decir la ultima en desarrollo en caso de funcionar entonces pasar a probarlo a la wifislax 4.1.11, en ese orden.

Muchas gracias será de gran ayuda para poder terminar el script y corregirlo si fuese necesario
Por si las moscas hazlo todo en modo live
« Última modificación: 30-10-2015, 13:30 (Viernes) por trax69 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14432
Re: TESTING Drivers ATI para wifislax
« Respuesta #3 en: 30-10-2015, 13:30 (Viernes) »
30102015

se esta subiendo , y tardara un buen rato

pesa 1.2 gigas

cuando se acabe de subir me paso y comento para que no bajes a medias la iso

esta ya lleva los cambios de slackware de ayer (mas de 150 updates)


Por cierto , lleva el modulo de drivers de impresoras , ajustado a  lo minmo necesario ya que muchos paquetes entraron a formar parte de la iso oficial.

testea si te va la impresora por favor.
« Última modificación: 30-10-2015, 13:31 (Viernes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14432
Re: TESTING Drivers ATI para wifislax
« Respuesta #4 en: 30-10-2015, 15:52 (Viernes) »
YA esta subida la iso entera.

trax69

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #5 en: 30-10-2015, 16:02 (Viernes) »
Me la descargo y pruebo el script de ATI para ver si rompe al compilar o a ver si le pica algo aunque en teoría los parches son para 4.1.x etc creo .

Creo que habra que sacar en breve la 4.12, no? El otro día me dio por testear algunas cosas en la 4.11.1 y al arrancar... Un huevo de actualizaciones y lo ya conocido de los updaters que han estado gente posteando

sol666

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #6 en: 30-10-2015, 22:58 (Viernes) »
hablando de ati,estoy descargando la ultima iso y voy a probarlo junto a este modulo,parece interesante,sirve para modificar la frecuencia y velocidad del ventilador de la grafica,a ver si funciona.

http://sourceforge.net/projects/amdovdrvctrl/

trax69

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #7 en: 30-10-2015, 23:11 (Viernes) »
Cuidadito con los valores que das y la velocidad del ventilador...

Estoy probando los drivers Nvidia del script con la nueva build y retocando el script de ATI para optimizarlo.

Edito : pensé que el script estaría para esta versión xD menos mal que lo publique si no me corto los testiculos por que se me olvidó guardar copia. Siguen funcionando a ver el compañero que nos dice de estos de ATI
« Última modificación: 30-10-2015, 23:33 (Viernes) por trax69 »

sol666

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #8 en: 30-10-2015, 23:34 (Viernes) »
pues me espero o pruebo el que has puesto?

trax69

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #9 en: 30-10-2015, 23:45 (Viernes) »
pues me espero o pruebo el que has puesto?

Prueba el modulo que puse en el primer post.

De lo que hablaba en el anterior mensaje era sobre Nvidia xD que pense  que para esta version DEV 30/10/2015 lo habria incluido USUARIONUEVO perdón por la confusion.


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14432
Re: TESTING Drivers ATI para wifislax
« Respuesta #10 en: 30-10-2015, 23:52 (Viernes) »
pues me espero o pruebo el que has puesto?

Prueba el modulo que puse en el primer post.

De lo que hablaba en el anterior mensaje era sobre Nvidia xD que pense  que para esta version DEV 30/10/2015 lo habria incluido USUARIONUEVO perdón por la confusion.



estoy esperando a que digas "ya esta"  ...   ;D

como has dicho varias veces, voy a retocar ..pues ya no se si ya esta o no.

sol666

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #11 en: 31-10-2015, 00:14 (Sábado) »
en la 4.11.1 no va bien,al abrir dolphin o una consola despues no se puede cerrar porque no sale la x y aparte no se abre ninguna aplicacion voy a probar con la de desarrollo y pruebo tambien la impresora.
« Última modificación: 31-10-2015, 00:15 (Sábado) por sol666 »

sol666

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #12 en: 31-10-2015, 01:04 (Sábado) »
en la de desarrollo igual,dolphin y la consola no se pueden cerrar y ademas ninguna aplicacion arranca con el driver.
@usuarionuevo lo de las impresoras funciona o por lo menos mi epson dx4000 la reconoce fuera de esto,con la grafica que tengo ahora gigabyte 7750 sin ningun driver me arranca tanto la de desarrollo como la 4.11.1 con unos graficos fatales tanto en normal como en vesa,esto antes con la 5770 no me pasaba  ???
Retiro lo dicho,con la de desarrollo me arrancan bien los graficos pero con la 4.11.1 no.
« Última modificación: 31-10-2015, 01:16 (Sábado) por sol666 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14432
Re: TESTING Drivers ATI para wifislax
« Respuesta #13 en: 31-10-2015, 01:31 (Sábado) »
la de desarrollo , acaba de recibir actualizaciones al respecto de drivers , es normal que vayan mejor.


ademas , quite lo de forzar vga=788  , que creo beneficia en todos los sentidos.

trax69

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #14 en: 31-10-2015, 02:32 (Sábado) »
en la de desarrollo igual,dolphin y la consola no se pueden cerrar y ademas ninguna aplicacion arranca con el driver.
@usuarionuevo lo de las impresoras funciona o por lo menos mi epson dx4000 la reconoce fuera de esto,con la grafica que tengo ahora gigabyte 7750 sin ningun driver me arranca tanto la de desarrollo como la 4.11.1 con unos graficos fatales tanto en normal como en vesa,esto antes con la 5770 no me pasaba  ???
Retiro lo dicho,con la de desarrollo me arrancan bien los graficos pero con la 4.11.1 no.

Con el modulo ? es decir funciona ? unas capturitas no estaria mal :$ sobre todo ejecutar la aplicacion de ATI desde terminal que ahi suelen saltar los errores si algo no carga bien, moverte por los menus y tocar cosas para ver si algo "salta"
pues me espero o pruebo el que has puesto?

Prueba el modulo que puse en el primer post.

De lo que hablaba en el anterior mensaje era sobre Nvidia xD que pense  que para esta version DEV 30/10/2015 lo habria incluido USUARIONUEVO perdón por la confusion.



estoy esperando a que digas "ya esta"  ...   ;D

como has dicho varias veces, voy a retocar ..pues ya no se si ya esta o no.
Pues si te soy sincero ... ahora mismo ya no me acuerdo si lo retoque o no xDDD hahaha ahora te aviso en el hilo de Updaters para no liar aqui mismo voy a mirar si hice los cambios >.<
« Última modificación: 31-10-2015, 03:14 (Sábado) por trax69 »

sol666

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #15 en: 31-10-2015, 09:44 (Sábado) »
te dejo una captura donde sale un warning


trax69

  • Visitante
Re: TESTING Drivers ATI para wifislax
« Respuesta #16 en: 31-10-2015, 10:07 (Sábado) »
Te deja usar oclhashcat con ATI ? es decir detecta los drivers y hace uso de la GPU ?

entonces funciona, solo faltara ver ese error si hay solución y depurar el script. Aparentemente funciona  >:( >:( >:(

me acabo de dar cuenta pensé que el modulo lo habrías metido en el arranque. ^-^

He estado buscando y técnicamente no es un error es una advertencia avisa de que el perfil sRGB no esta bien ya sea por que es antiguo o está mal configurado 8) por lo tanto no es mayor problema
« Última modificación: 31-10-2015, 10:17 (Sábado) por trax69 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14432
Re: TESTING Drivers ATI para wifislax
« Respuesta #17 en: 31-10-2015, 13:37 (Sábado) »
No le salen los marcos de las ventanas, asi que yo no cantaria victoria.

abre una ventana, e intenta moverla rapido , si va a pedales , es que el fglrx.ko no esta cargado.



no funciona , no se crea el fichero fglrx.ko , por lo que no hay driver que montar  ^-^


« Última modificación: 31-10-2015, 13:46 (Sábado) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14432
Re: TESTING Drivers ATI para wifislax
« Respuesta #18 en: 31-10-2015, 13:51 (Sábado) »
script  ati_rebuild .. que esta en /opt/wifislax-scriipts    y es el que se encarga de compilar el fglrx.ko si no hay para el kernel que esta arrancando.


Código: [Seleccionar]
#!/bin/bash

cd /lib/modules/fglrx/build_mod/2.6.x/
make clean
make
cd /lib/modules/fglrx/build_mod/
./make.sh
cd /lib/modules/fglrx/
./make_install.sh
aticonfig --adapter=all --initial

# Si el proceso acabo bien salvamos un xzm
if [ -f /lib/modules/$(uname -r)/kernel/drivers/char/drm/fglrx.ko ]; then
mkdir -p /root/Desktop/Ati_kernel_$(uname -r)/lib/modules/$(uname -r)/kernel/drivers/char/drm/
cp -f /lib/modules/$(uname -r)/kernel/drivers/char/drm/fglrx.ko /root/Desktop/Ati_kernel_$(uname -r)/lib/modules/$(uname -r)/kernel/drivers/char/drm/
dir2xzm  /root/Desktop/Ati_kernel_$(uname -r) /root/Desktop/Ati_kernel_$(uname -r).xzm
rm -rf /root/Desktop/Ati_kernel_$(uname -r)
mv -f /root/Desktop/Ati_kernel_$(uname -r).xzm /root/Desktop/015-Driver_Ati_kernel_$(uname -r).xzm
fi




cd /lib/modules/fglrx/build_mod/2.6.x/


si no dejas las sources ..como vas a compilar el driver ?¿

ademas debes dejarl las sources con los parches ya aplicados.


en la seccion de modulos , esta el 15.9 de wifislax-4.11.1  que sigue valiendo ,por mantener la rama 4.1.X

Y el cual se ajustara al nuevo kernel que haya en desarrollo , ...  si pasaramos a un kernel 4.2 , entonces deberia aplicar los parches a las sources que ya estan en el mismo modulo ...   parches y fuera..


el mismo modulo servira por mucho tiempo ... si se aplican los parches necesarios.

es mas , podria aplicarle los parches 4.2  por si alguien lo compila..que le siga valiendo el mismo modulo  ;D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14432
Re: TESTING Drivers ATI para wifislax
« Respuesta #19 en: 31-10-2015, 13:52 (Sábado) »
de todas formas creo que en noviembre liberaban otro ...y seguramente ya no necesite parches.