Autor Tema: Script multiuso en bash, airgeddon  (Leído 469723 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado pepe10000

  • Colaborador
  • *
  • Mensajes: 729
Re:Script multiuso en bash, airgeddon
« Respuesta #720 en: 23-04-2022, 17:44 (Sábado) »
Hola.

He estado haciendo algunas pruebas sobre WifiWay64 donde la versión anterior funciona correctamente.

En esta nueva he observado un mensajito raro supuestamente de la línea 117:



Un saludo.


« Última modificación: 23-04-2022, 17:44 (Sábado) por pepe10000 »

Desconectado v1s1t0r

  • *****
  • Mensajes: 170
Re:Script multiuso en bash, airgeddon
« Respuesta #721 en: 04-05-2022, 18:30 (Miércoles) »
Qué raro... lo miraré. Es la línea 117 pero no de airgeddon, sino del script que se genera para lanzar la ventana de control. Habrá que verlo en detalle e intentar reproducirlo... si no consigo reproducirlo no podré arreglarlo. ¿Alguna cosa especial que hicieras? ¿pasa siempre? ¿a veces? porque yo lo lanzo y no me ocurre.... ¿sistema operativo? (parece wifislax claro...) ¿version? supongo que 11.01 , chipset y tarjeta usada?

Gracias.

Desconectado pepe10000

  • Colaborador
  • *
  • Mensajes: 729
Re:Script multiuso en bash, airgeddon
« Respuesta #722 en: 04-05-2022, 18:43 (Miércoles) »
Hola.

Nada especial.

Siempre.

WifiSlax y WifiWay.

Ocurre con la 11.01, la 11.02 Dev y la 11.02 Dev de hoy (acabo de probarla).

Wifistation con chipset Atheros AR9271.

En la versión 11.0 Dev no ocurre.

Editado.

En las dos últimas versiones el mensaje ha cambiado un poco, pero ocurre en la misma línea y sale algo de que se esperaba un operador binario si mal no recuerdo.

Un saludo.
« Última modificación: 04-05-2022, 19:02 (Miércoles) por pepe10000 »

Desconectado v1s1t0r

  • *****
  • Mensajes: 170
Re:Script multiuso en bash, airgeddon
« Respuesta #723 en: 16-06-2022, 11:21 (Jueves) »
Siento haber tardado un millón de años en contestar... he podido reproducir el error y lo voy a mirar. Gracias.

Desconectado v1s1t0r

  • *****
  • Mensajes: 170
Re:Script multiuso en bash, airgeddon
« Respuesta #724 en: 16-06-2022, 12:16 (Jueves) »
Arreglado!! si te bajas la versión 11.02 de la rama dev de Github podrás comprobar como ya no salen los mensajes de error. Aunque eran solo mensajes y todo funcionaba bien mostrando clientes conectados y mostrando el portal cautivo, todo funcionaba pero quedaba feo con unos errores ahí mostrados... ahora ya está como tiene que ser. Muchas gracias por el report. Lo de que me dijeses que en la versión 11.0 no pasaba fue vital para ir sobre mis pasos y ver en qué commit lo fastidié... y efectivamente lo encontré. Gracias!

Desconectado pepe10000

  • Colaborador
  • *
  • Mensajes: 729
Re:Script multiuso en bash, airgeddon
« Respuesta #725 en: 16-06-2022, 12:20 (Jueves) »
Hola.

Estupendo, voy a a bajarla y espero poder probar la nueva versión esta tarde,  ;)  ;)  ;)

De nada, a mandar,  >:(  >:(  >:(

Editado:

Probada y todo O.K.

Un modulito para que los más vagos la prueben:

https://www.mediafire.com/file/e8abof3yiu2vsz4/airgeddon-11.02.2-wifislax.xzm/file

Un saludo.
« Última modificación: 16-06-2022, 18:14 (Jueves) por pepe10000 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:Script multiuso en bash, airgeddon
« Respuesta #726 en: 17-06-2022, 05:17 (Viernes) »
Buenas noticias entonces, me alegro , no se si actualizar la iso a una version dev o esperar a una nueva release.  ;) >:(

Desconectado v1s1t0r

  • *****
  • Mensajes: 170
Re:Script multiuso en bash, airgeddon
« Respuesta #727 en: 20-06-2022, 11:23 (Lunes) »
No es un fallo importante ya que todo funcionaba igualmente aunque se mostrase un error. Yo esperaría, ya tampoco quedda mucho para una nueva release, pero como veas.