Autor Tema: No funciona el instalador de wine en wifislax_24_01_2016_actualizada  (Leído 8857 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pastilla

  • Visitante
He instalado wifislax desarrollo con fecha 24-01-21016 y el paquete wine no se consigue instalar con los updaters y con la iso actualizada, como veo que no se menciona nada en los cambios de las nuevas isos aqui pongo el error del updater:

       ******************************
           Actualizador/Instalador    
           Paquete: wine
                                    
           www.seguridadwireless.net  
        ******************************

Version Script: 16/11/2015

La version del sistema es...NO INSTALADA

__________________________________________

La version mas nueva en su pagina web es...wine-

Pulsa ENTER si deseas actualizarla


/opt/wifislax-updaters/Funciones/funciones_updater: línea 140: [: NO INSTALADA: se esperaba un operador unario

Descargando sources de wine-
[#f60de8 0B/0B CN:1 DL:0B]                                                                                                                          
02/11 15:29:49 [ERROR] CUID#7 - Download aborted. URI=http://sourceforge.net/projects/wine/files/Slackware%20Packages//i486/wine--i486-1sg.txz
Exception: [AbstractCommand.cc:350] errorCode=3 URI=https://sourceforge.net/projects/wine/files/Slackware%20Packages//i486/wine--i486-1sg.txz
  -> [HttpSkipResponseCommand.cc:216] errorCode=3 Recurso no encontrado

02/11 15:29:49 [NOTICE] Download GID#f60de89ec422e258 not complete:

Resultados de la descarga:
gid   |stat|avg speed  |path/URI
======+====+===========+=======================================================
f60de8|ERR |       0B/s|http://sourceforge.net/projects/wine/files/Slackware%20Packages//i486/wine--i486-1sg.txz

Leyenda:
(ERR):a ocurrido un error.

Si reinicia la transferencia, aria2 continuará con la descarga.
Compruebe el archivo de registro si se producen errores. Para más información vea la opción '-l' en las páginas help/man.
wifislax Sistema #

----------------------------

Un saludo


« Última modificación: 11-02-2016, 15:43 (Jueves) por pastilla »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #1 en: 11-02-2016, 22:26 (Jueves) »
no hace mucho lo instale, pero ,... estoy viendo estos dias que muchas url de los updaters estan migrando de


http --> https


muchos funcionan con solo cambiar es , aunque aqui el problema parce otro.

voy a probar.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #2 en: 11-02-2016, 22:30 (Jueves) »
pues justo ... añadiendo la s , en los http , se solventa.

acabao de subir el script arreglado , se actualizara el solo.  ;)

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #3 en: 11-02-2016, 22:38 (Jueves) »
acabo de pasar el tester de updaters y estan fallando todos estos ... por el cambio a https
los corregire a lo largo de esta noche y subire a github





Código: [Seleccionar]
Angry_ip_scanner
NetworkMiner
WebSploit-Framework
brutalchess
codeblocks
crunch
cryptopp
docutils
dosbox
dvdauthor
dvdstyler
ffmpegyag
filezilla
fpc
gambas
libdnet
libfilezilla
libquicktime
metasploit
mjpegtools
ms-sys
muse
netactview
numpy
openoffice
pentbox
pokerth
qtractor
twolame
unetbootin
wxGTK3
wxHexEditor
wxsvg
xampp
yad


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #4 en: 11-02-2016, 23:06 (Jueves) »
todos reparados y subidos a github ...deberian actualizarse ellos solos a si mismos.  ;)

pastilla

  • Visitante
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #5 en: 12-02-2016, 00:46 (Viernes) »
Gracias ya se ha arreglado, incluso se han solucionado 4 paquetes rotos que arrastraba, estos:

ffmpeg-2.8.5-i586-2sw
gambas-3.8.4-i586-1sw
graphviz-2.38.0-i586-6sw
gst-plugins-bad-1.6.2-i586-1sw

No es posible reparar los paquetes rotos

........................

Y despues se ha actualizado y he instalado el wiine:

Se han actualizado 35 updaters

Angry_ip_scanner_updater
NetworkMiner_updater
crunch_updater
netactview_updater
codeblocks_updater
fpc_updater
gambas_updater
wxHexEditor_updater
yad_updater
filezilla_updater
xampp_updater
brutalchess_updater
pokerth_updater
cryptopp_updater
docutils_updater
libdnet_updater
libfilezilla_updater
libquicktime_updater
mjpegtools_updater
twolame_updater
wxGTK3_updater
wxsvg_updater
dvdauthor_updater
dvdstyler_updater
ffmpegyag_updater
muse_updater
qtractor_updater
openoffice_updater
WebSploit-Framework_updater
metasploit_updater
pentbox_updater
dosbox_updater
ms-sys_updater
unetbootin_updater
wine_updater

---------------

Un saludo
« Última modificación: 12-02-2016, 00:51 (Viernes) por pastilla »

pastilla

  • Visitante
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #6 en: 21-03-2016, 16:06 (Lunes) »
!Hola! pues se soluciono en un principio pero despues no se actualizaba, entonces lo que hice fue con el programa pkgtool desinstalar el modulo de wine para ver si podia al menos instalar el ultimo wine y esta es la respuesta partiendo de cero de nuevo,


        ******************************
           Actualizador/Instalador   
           Paquete: wine
                                   
           www.seguridadwireless.net 
        ******************************

Version Script: 11/02/2016

La version del sistema es...NO INSTALADA

__________________________________________

La version mas nueva en su pagina web es...wine-1.9.6

Pulsa ENTER si deseas actualizarla



Descargando sources de wine-1.9.6
[#76e358 0B/0B CN:1 DL:0B]                                                                                                                         
03/21 15:59:10 [ERROR] CUID#7 - Download aborted. URI=https://sourceforge.net/projects/wine/files/Slackware%20Packages/1.9.6/i486/wine-1.9.6-i486-1sg.txz
Exception: [AbstractCommand.cc:345] errorCode=3 URI=https://sourceforge.net/projects/wine/files/Slackware%20Packages/1.9.6/i486/wine-1.9.6-i486-1sg.txz
  -> [HttpSkipResponseCommand.cc:219] errorCode=3 Recurso no encontrado

03/21 15:59:10 [NOTICE] Download GID#76e358cc097b4abe not complete:

Resultados de la descarga:
gid   |stat|avg speed  |path/URI
======+====+===========+=======================================================
76e358|ERR |       0B/s|https://sourceforge.net/projects/wine/files/Slackware%20Packages/1.9.6/i486/wine-1.9.6-i486-1sg.txz

Leyenda:
(ERR):a ocurrido un error.

Si reinicia la transferencia, aria2 continuará con la descarga.
Compruebe el archivo de registro si se producen errores. Para más información vea la opción '-l' en las páginas help/man.
wifislax Sistema #

-------------------------------------------------------------------

Un saludo


pastilla

  • Visitante
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #7 en: 22-03-2016, 23:31 (Martes) »
Pues ya he instalado el ultimo wine en wifislax y encima esta vez me lo ha dejado en la ventana principal de los programas con su nombre, antes sabia que estaba instalado pero no salia, ¿y como?: hacemos un copy paste del instalador del update con el error anterior de la descarga y lo agregamos al navegador,

https://sourceforge.net/projects/wine/files/Slackware%20Packages/1.9.6/i486/wine-1.9.6-i486-1sg.txz

Cuando entramos con el navegador vemos que dice que no existe el paquete pero nos deja en la pagina de wine, de ahi pasamos a los paquetes de wine en slackware y miramos en la rama i486 descargandonos el ultimo, en mi caso: "wine-1.9.6-i486-2sg.txz"  lo descargamos y despues con la opcion del boton derecho del raton le decimos de: instalar/desinstalar paquete slackwware.

Una vez instalado descargamos el ejecutable del windows que deseamos e instalamos con la opcion de boton derecho del raton y abrir con wine, entonces lo detectara el wine que hemos instalado y nos dira que falta el paquete mono del wine, acabamos de instalar ese paquete y ya tenemos el ultimo wine funcionando.

El winetricks si que lo descarga bien desde la base en wifislax.

Sigue dando el wine como paquete roto la distro pero esta instalado.

Un saludo
« Última modificación: 22-03-2016, 23:36 (Martes) por pastilla »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #8 en: 22-03-2016, 23:38 (Martes) »
Hi

es un problema de codificación de caracteres, el navegador entiende un espacio en blanco como %20, por eso es mejor usar siempre los guiones bajos ( _ ) que los espacios en blanco cuando se pone un enlace.

Si te fijas en la barra de direcciones verás que el enlace es:

   https://sourceforge.net/projects/wine/files/Slackware Packages/

y eso no suele funcionar


un saludo
« Última modificación: 22-03-2016, 23:41 (Martes) por drvalium »

pastilla

  • Visitante
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #9 en: 22-03-2016, 23:46 (Martes) »
Hi

es un problema de codificación de caracteres, el navegador entiende un espacio en blanco como %20, por eso es mejor usar siempre los guiones bajos ( _ ) que los espacios en blanco cuando se pone un enlace.

Si te fijas en la barra de direcciones verás que el enlace es:

   https://sourceforge.net/projects/wine/files/Slackware Packages/

y eso no suele funcionar


un saludo

Pero si ese error en el enlace me lo da el instalador del update por consola, mira que lo he puesto antes, mi ultimo post ha sido una solucion en plan borrico, lo he puesto para que la gente vea que a las malas se pueden descargar e instalar cuando dan errores los instaladores.

Un saludo

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #10 en: 22-03-2016, 23:57 (Martes) »
el error es que la web ha cambiado ... ya lo mirare.

seguramente bastara con  cambiar en el campo WEB= O en DOWNLOAD=

pastilla

  • Visitante
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #11 en: 23-03-2016, 00:17 (Miércoles) »
¡Hola! Pues a ver si miras que cuadre el sistema con el wine, aun sigo con la distro de desarrollo del hilo de este tema, me puso tan nervioso el wicd con la historia del tipo de clave que le tienes que poner para conectar que no lo quiero ni ver, por ahora me va bien con el networkmanager y la distro se actualiza bien hasta la fecha, solo arrastra estos paquetes rotos,

ultima actualizacion 22-03-2016

las operaciones han finalizado con errores, los siguientes paquetes no han podido actualizarse

 • chromaprint
 • ffmpeg
 • wxsvg
 • yelp-xsl
 • google-chrome
 • flashplayer-plugin

 Buscando paquetes rotos...
 
 Se encontraron 5 paquetes rotos:
 
ffmpeg-2.8.5-i586-2sw
gambas-3.8.4-i586-1sw
graphviz-2.38.0-i586-6sw
gst-plugins-bad-1.6.2-i586-1sw
wine-1.9.6-i486-2sg

.........................

Un saludo



« Última modificación: 23-03-2016, 00:18 (Miércoles) por pastilla »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #12 en: 23-03-2016, 00:21 (Miércoles) »
no puedo mantener una iso de desarrollo de enero.


para que te jagas una idea, chrome , esta blacklisteado en el updater gui actualmente,m por que ya no hay mas de 32 bits ..

te seguira saliendo el aviso por la eternidad si no lo blacklisteas.

de lo demas ni idea ... ffmpeg en desarrollo llevo la 3.0.0 ...  y asi con los demas.

podrias ejecutar uno a uno ,para ver por consola lo que pasa ... pero vamos , tiene mal asunto.

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #13 en: 23-03-2016, 00:26 (Miércoles) »
Pero si ese error en el enlace me lo da el instalador del update por consola, mira que lo he puesto antes, mi ultimo post ha sido una solucion en plan borrico, lo he puesto para que la gente vea que a las malas se pueden descargar e instalar cuando dan errores los instaladores.

Ante todo se agradece que hayas informado del problema y que hayas compartido la solución del mismo.

En ningún momento he pretendido recriminarte nada ni me he puesto a la defensiva, solo trataba de explicarte a que se debe ese problema, pero creo que no se me ha entendido.

en la web de ellos han puesto un espacio en el enlace:

  

Sin embargo debido a la codificación de caracteres de la consola o el navegador o de Wifislax, al intentar actualizarte ese enlace se traduce a:

   https://sourceforge.net/projects/wine/files/Slackware%20Packages/1.9.6/i486/wine-1.9.6-i486-1sg.txz

Debido a esa "traducción" que hace el actualizador surge el problema.

Poner espacios en blanco en una dirección Web no es lo habitual ya que ocasionan este tipo de problemas, sobre todo si las cosas están alojadas en servidores FTP. Si te fijas en las webs que visites podrás comprobar que casi nunca se ven espacios en blanco en las direcciones Web.


un saludo

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #14 en: 23-03-2016, 00:31 (Miércoles) »
%20   es equivalente a un espacio

grrr..ya me cabreado , voy a mirarlo ..jajaja

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #15 en: 23-03-2016, 00:40 (Miércoles) »
Los que han roto el estándar son ellos

El código porciento, también llamado código URI o código URL, se usa en Internet para escribir los identificadores de nombres (URN) y ubicaciones (URL). Consta de 2 grupos diferentes de caracteres, los no reservados y los reservados. Los no reservados incluyen a las letras mayúsculas y minúsculas del alfabeto sin signos diacríticos, los números de 0 a 9, más los signos "-", "_", "." y "~". Los caracteres reservados pueden tener significados especiales, caso en que se representan por un número hexadecimal precedido del carácter "%". Esta codificación, dada en la tabla siguiente,1 consiste habitualmente en el signo "%" seguido del número hexadecimal ASCII correspondiente al carácter codificado.

Los de la Wiki también lo rompen usando acentos en las direcciones web por eso en vez de código en el enlace de la cita sale C%C3%B3digo, siendo %C3%B3 el equivalente a la ó
« Última modificación: 23-03-2016, 00:44 (Miércoles) por drvalium »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #16 en: 23-03-2016, 00:42 (Miércoles) »
y aqui el problema, ..como ya imaginaba , es el link ,nada que ver con lso espacios..


el updater trata de bajar esto

Descargando sources de wine-1.9.6
--2016-03-23 00:38:59--  https://sourceforge.net/projects/wine/files/Slackware%20Packages/1.9.6/i486/wine-1.9.6-i486-1sg.txz


y no existe , existe el 2
https://sourceforge.net/projects/wine/files/Slackware%20Packages/1.9.6/i486/wine-1.9.6-i486-2sg.txz



con lo cual es un problema del updater al buscar el paquete a descargar...es facil arrreglarlo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #17 en: 23-03-2016, 00:44 (Miércoles) »
culpable ...

   if [ ! -f $PRGNAM-$VERSION-$ARCH-1sg.txz ]; then
   echo ""
   echo "$CYAN"Descargando sources de $PRGNAM-$VERSION"$CIERRE"
   sleep 1
   wget -c ${WEB}$VERSION/$ARCH/$PRGNAM-$VERSION-$ARCH-1sg.txz
   fi

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #18 en: 23-03-2016, 00:46 (Miércoles) »
Entonces Wifislax lo traduce bien ;)

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14691
Re: No funciona el instalador de wine en wifislax_24_01_2016_actualizada
« Respuesta #19 en: 23-03-2016, 00:57 (Miércoles) »
Entonces Wifislax lo traduce bien ;)
SI

%20  = espacio

o usas comillas n la url

"slackware packages"

pero si copias el url y pegas en la shell , aparece el 20%  para unir el espacio entre palabras.


____________________________________________

ahora se grepea tambein el numero de build ... para que no vuelva a pasar.  ;D

a este updater le tengo que dar mas cambios ..tiene la arquitectura de los paquetes de forma explicita, y no me vale en el sistema de 64 bits, la arquitectura debe ser dinamica y definin acorde al sistema... cuando este lo subire a github ,ya os aparecera que hay version nueva del updater este.

Código: [Seleccionar]
F_download(){
BUILD=`curl -s ${WEB}$VERSION/$ARCH/|grep -o [0-9]sg|tail -1`
if [ ! -f $PRGNAM-$VERSION-$ARCH-$BUILD.txz ]; then
echo ""
echo "$CYAN"Descargando sources de $PRGNAM-$VERSION"$CIERRE"
sleep 1
wget -N -L -c -q --show-progress ${WEB}$VERSION/$ARCH/$PRGNAM-$VERSION-$ARCH-$BUILD.txz
fi
« Última modificación: 23-03-2016, 00:59 (Miércoles) por USUARIONUEVO »

//FINAL Y MÁS DOS RESPUESTAS