Autor Tema: Detectado problema Grave en minidwep-gtk ( solucion )  (Leído 2918 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14444
Detectado problema Grave en minidwep-gtk ( solucion )
« en: 11-07-2013, 15:45 (Jueves) »
Bien , el tema es que anoche estube probando toda mi artilleria de chipsets y me quede muy alucinado cuando  usando minidwep  ( solo ocurria en esta aplicacion ) , los chips ar9271 atacando wep , tras escanear , ...al darle a lanzar ataque , era como si no viesen el ap ..como si no escaneasen .... ???


Probando todas las demas herramientas vi como funcionaban perfectamente , asi que era obvio que algo no andaba bien en minidwep.


Se comporta de la siguiente manera , cuando escanea crea la interface monitor , y cuando ataca limpia y la genera de nuevo ...

y aqui el problema ....


fichero
/usr/local/bin/minileafdwep/minidwep-gtk.sh

en la linea 324 del script ...vemos la orden de montar en monitor ...


Código: [Seleccionar]
airmon-ng start $interface $ch
atencion al final ..que le dice $ch  ... channel ...

despues de un escaneo con salto de canales , la interface puede haber acabado en channel 5 ...pues si atacamos un ap en el channel 6 ..como al montar en monitor se le dice el channel ..pillaria el 5

NUNCA AL MONTAR EN MONITOR SE ESPECIFICA UN CANAL..NUNCA.


con lo que editamos el script y dejamos la linea de montar en monitor sin la orden de pillar   channel...


Código: [Seleccionar]
airmon-ng start $interface

et voila ....ya funcionan bien los chips ar9271 , ....el resto de chips funcionaban bien ...pero este en concreto NO , es una estupidez ENORME montar en monitor especificando un canal ....por que al atacar a un ap ..ya le damos el canal y si no coinciden , podriamos quedarnos con la ventana de airodump-ng VACIA.

Si teneis minidwep en otras distros , RECOMENDABLE , el cambio que aqui describo ...solo buscad la linea de airmon-ng start $interface y quitad el $ch.


« Última modificación: 11-07-2013, 16:58 (Jueves) por USUARIONUEVO »

Desconectado lupox

  • Colaborador
  • *
  • Mensajes: 531
  • volver....
Re:
« Respuesta #1 en: 12-07-2013, 18:05 (Viernes) »
Me lo anoto.
Con ese chipset tb presenta un bug con la nueva versión de goyscript. 2.7
E n las linea de macchanger. Y se queda colgado sin encontrar el chipset.

Enviado con Tapatalk