Autor Tema: Ayuda con un updater  (Leído 2159 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14464
Ayuda con un updater
« en: 02-07-2015, 00:22 (Jueves) »
este updater esta gafado  ;D


¿por que no puede bajar el tar.gz ?¿?¿

baja algo , pero no es el .tar.gz , ya que es un fichero de solo unos poco kas ...

hay dos sitios de donde poder pillarlo ..

sourceforge  que no se que pasa no el link no va, alli no hay forma de pillarlo.

y el oro sitio es fosshub ,.,,que es con el que tengo problemas...



dejo los campos completo ...

ariac2 , no es capaz de bajar el fichero correctamente ni wget ..algo hago mal.



_____________________________________________________________________________________________


Código: [Seleccionar]
F_variables() {
PRGNAM=avidemux
echo -ne "\033]2;${PRGNAM}_updater\007"
WEB=http://fixounet.free.fr/avidemux/download.html
VERSION=`curl -s $WEB | grep .tar.gz | head -1 | cut -d _ -f2 | cut -d t -f1 | sed "s/.$//g"`
DOWNLOAD=http://www.fosshub.com/Avidemux.html/${PRGNAM}_${VERSION}.tar.gz
}

# Si el paquete no existe se descargara de internet
F_download(){
if [ ! -f ${PRGNAM}_${VERSION}.tar.gz ]; then
echo
echo "$CYAN"Descargando sources de $PRGNAM-$VERSION"$CIERRE"
sleep 1
aria2c -x 3 $DOWNLOAD
fi
}



Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14464
Re: Ayuda con un updater
« Respuesta #1 en: 02-07-2015, 00:27 (Jueves) »
si analizo el link del fosshub , sale esto ..parece algun tipo de proteccion..

<a href="#clickToStartDownload" rel="nofollow" class="dwl-link xlink" file="avidemux_2.6.10.tar.gz" data="http://download.fosshub.com/Protected/expiretime=1435789853;badurl=aHR0cDovL3d3dy5mb3NzaHViLmNvbS9BdmlkZW11eC5odG1s/f557c8a34ae86bd05a15b1332ff80c53403a5586648079ad96e189a5c62fd2ed/Avidemux/avidemux_2.6.10.tar.gz">
                <strong>Download
                    <span>Avidemux </span> source</strong>[/url]


Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14464
Re: Ayuda con un updater
« Respuesta #2 en: 02-07-2015, 01:07 (Jueves) »
DE MOMENTO , me quedo con lo que se puede descargar de sourceforge , mirando en latest ..y punto


en sourceforge , buscando , esta la entrada de la 2.6.10  ---> pero no lleva a ningun sitio ... ya lo arreglaran si quieren.



Código: [Seleccionar]
PRGNAM=avidemux
echo -ne "\033]2;${PRGNAM}_updater\007"
WEB=http://sourceforge.net/projects/avidemux/files/avidemux/
VERSION=`curl -s $WEB | grep /latest | cut -d '/' -f 8 | cut -d ":" -f 1 | cut -d '-' -f 2`
DOWNLOAD=${WEB}${VERSION}/${PRGNAM}_${VERSION}.tar.gz/download

vk496

  • Visitante
Re: Ayuda con un updater
« Respuesta #3 en: 02-07-2015, 02:14 (Jueves) »
Código: [Seleccionar]
aria2c -x3 `curl -s http://www.fosshub.com/Avidemux.html/avidemux_2.6.10.tar.gz | grep tar\.gz -m1 | grep -Po 'src="\K.*(?=">)'`
 :D

Salu2

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14464
Re: Ayuda con un updater
« Respuesta #4 en: 02-07-2015, 02:40 (Jueves) »
muchas gracias, me ha valido ...aunque no pude hacerlo como el standard con un campo

DOWNLOAD=



ASI QUE ELIMINE ESE CAMPO ..y donde comprueba si exsiste el fichero y si no lo descargara de internet...


Código: [Seleccionar]
aria2c -x3 `curl -s http://www.fosshub.com/Avidemux.html/${PRGNAM}_${VERSION}.tar.gz | grep tar\.gz -m1 | grep -Po 'src="\K.*(?=">)'`