Autor Tema: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack  (Leído 453628 veces)

0 Usuarios y 1 Visitante están viendo este tema.

semola

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #580 en: 15-01-2016, 17:43 (Viernes) »
A lo breve, breve, tu mismo preguntas y te contestas, sólo es cuestión de leer  >:(



Pedro24

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #581 en: 31-01-2016, 13:35 (Domingo) »
Buenos dias,

He intentado instalarlo en ubuntu 14.04 y despues de instalar las librerias y seguir todos estos pasos  
@EUSKOGUDARI, prueba esto :

ESTO ES PARA KALI LINUX, DESCONOZCO SI EN OTRAS DISTROS SERIA LA SOLUCION

Lo primero instalar dependencias necesarias (todo lo vamos a hacer desde la terminal)
Código: [Seleccionar]
apt-get install intltool libpcap0.8-dev libsqlite3-dev libxmu-headers libxmu-dev

A continuación descargamos programas necesarios
Código: [Seleccionar]
wget https://gtkdialog.googlecode.com/files/gtkdialog-0.8.3.tar.gz
wget http://downloads.sourceforge.net/project/pixiescript/PixieScript_v2.6.3.tar.gz
wget http://sourceforge.net/projects/yad-dialog/files/yad-0.28.1.tar.xz

Una vez descargados, descomprimimos
Código: [Seleccionar]
tar xvzf gtkdialog-0.8.3.tar.gz
tar xf yad-0.28.1.tar.xz
tar xvzf PixieScript_v2.6.3.tar.gz

Bien, vamos a instalar gtkdialod
Código: [Seleccionar]
cd gtkdialog-0.8.3/
./configure
make
make install

Ahora instalamos yad
Código: [Seleccionar]
cd ..
cd yad-0.28.1/
./configure
make
make install

Ahora desde la consola
Código: [Seleccionar]
dpkg-reconfigure dash
Te hará una pregunta, contestas que NO

Y ahora ...
Código: [Seleccionar]
cd ..
cd PixieScript_v2.6.3/
chmod +x INSTALADOR
./INSTALADOR

Y listo, ya te debería de iniciar  
NOTA : Si te dan problemas algún script por haber hecho el dpkg-reconfigure , simplemente volviendolo a hacer y diciendo que SI, dejamos todo como estaba.

Suerte y ya dirás ...








Edito; He instalado el reaver modificado pero aún me dice que falta una dependencia de pixiescript que no tengo ni idea de cual es;



Se  queda todo el rato como descargando pero no descarga nada.
Alguna idea ?

   Un saludo.





  
« Última modificación: 31-01-2016, 15:56 (Domingo) por Pedro34 »

Pedro24

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #582 en: 02-02-2016, 22:12 (Martes) »
Se ve que no interesa que funcione en ubuntu, solo es wifislax.  Por mi parte podeis borrar el post cuando querais.

   

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15450
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #583 en: 04-02-2016, 22:13 (Jueves) »
Se ve que no interesa que funcione en ubuntu, solo es wifislax.  Por mi parte podeis borrar el post cuando querais.

   

si te dice que te falta pixiewps , y no sabes leer no es cualpa de nadie, ¿ok?

busca como instalar pixiewps en ubuntu , o el sistema que tengas.

cambio y corto.

HououjiAyumu

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #584 en: 09-02-2016, 07:13 (Martes) »
nuevos modems de fibra optica de temex infinitum Alcatel lucent vulnerables

f4:c6:13:xx:xx:xx
18:4a:6f:xx:xx:xx

513RR4

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #585 en: 10-02-2016, 06:57 (Miércoles) »
hace tiempo descargue e instale este script en wifislax y nunca tuve ningún problema al utilizarlo.

ahora quiero instalarlo en kali 2.0 x64 siguiendo todos los pasos que menciona su creador 5.1 y tengo el siguiente error.

DEPENDENCIAS GLOBALES

COMPROBANDO DEPENDENCIA GTKDIALOG .... OK
COMPROBANDO DEPENDENCIA YAD .......... OK
COMPROBANDO DEPENDENCIA AIRCRACK-NG... OK
COMPROBANDO DEPENDENCIA CURL ......... OK
COMPROBANDO DEPENDENCIA MACCHANGER ... OK
COMPROBANDO DEPENDENCIA gksudo ....... OK


HERRAMIENTAS

COMPROBANDO DEPENDENCIA MOD_REAVER ... FALTA
        DESCARGANDO REAVER, ESPERA ... OK
        APLICANDO PARCHE REAVER ...... OK
        COMPILANDO REAVER, ESPERA .... OK
        LIMPIANDO .................... OK
COMPROBANDO DEPENDENCIA PIXIEWPS ..... FALTA
        DESCARGANDO PIXIEWPS, ESPERA . OK
        APLICANDO PARCHE PIXIEWS ..... ERROR

he intentado ver el código  del archivo INSTALADOR y supongo que se ejecuta hasta la línea 162
"patch -Np1 -i ../MOD_PIXIEWPS.patch &> /dev/null || ErroresDependencias 1"

solo por curiosidad elimine las líneas 160,162 y 163 y se instalo sin problemas pero cuando lo utilizo ya en la interfaz grafica me sale un error en el ultimo paso al tratar de recuperar la clave.

por favor alguien puede ayudarme.

tkme

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #586 en: 24-02-2016, 20:21 (Miércoles) »
Los Asus N55U también son vulnerables:  D8:50:E6
Gracias por el script.

lolote

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #587 en: 27-02-2016, 00:27 (Sábado) »
nuevos modems de fibra optica de temex infinitum Alcatel lucent vulnerables

f4:c6:13:xx:xx:xx
18:4a:6f:xx:xx:xx

Disculpa como lo hiciste funcionar ya que a mi me marca sending... error timeout con las mismas alcatel lucent f4:c6 infinitumxxxx

Mendez

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #588 en: 27-02-2016, 08:35 (Sábado) »
Se ve que no interesa que funcione en ubuntu, solo es wifislax.  Por mi parte podeis borrar el post cuando querais.

   

si te dice que te falta pixiewps , y no sabes leer no es cualpa de nadie, ¿ok?

busca como instalar pixiewps en ubuntu , o el sistema que tengas.

cambio y corto.


https://github.com/wiire/pixiewps

Ahí estan los comandos para instalar pixiewps...

4TL4S

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #589 en: 03-03-2016, 20:06 (Jueves) »


@EUSKOGUDARI, prueba esto :

ESTO ES PARA KALI LINUX, DESCONOZCO SI EN OTRAS DISTROS SERIA LA SOLUCION

Lo primero instalar dependencias necesarias (todo lo vamos a hacer desde la terminal)
Código: [Seleccionar]
apt-get install intltool libpcap0.8-dev libsqlite3-dev libxmu-headers libxmu-dev

A continuación descargamos programas necesarios
Código: [Seleccionar]
wget https://gtkdialog.googlecode.com/files/gtkdialog-0.8.3.tar.gz
wget http://downloads.sourceforge.net/project/pixiescript/PixieScript_v2.6.3.tar.gz
wget http://sourceforge.net/projects/yad-dialog/files/yad-0.28.1.tar.xz

Una vez descargados, descomprimimos
Código: [Seleccionar]
tar xvzf gtkdialog-0.8.3.tar.gz
tar xf yad-0.28.1.tar.xz
tar xvzf PixieScript_v2.6.3.tar.gz

Bien, vamos a instalar gtkdialod
Código: [Seleccionar]
cd gtkdialog-0.8.3/
./configure
make
make install

Ahora instalamos yad
Código: [Seleccionar]
cd ..
cd yad-0.28.1/
./configure
make
make install

Ahora desde la consola
Código: [Seleccionar]
dpkg-reconfigure dash
Te hará una pregunta, contestas que NO

Y ahora ...
Código: [Seleccionar]
cd ..
cd PixieScript_v2.6.3/
chmod +x INSTALADOR
./INSTALADOR

Y listo, ya te debería de iniciar 
NOTA : Si te dan problemas algún script por haber hecho el dpkg-reconfigure , simplemente volviendolo a hacer y diciendo que SI, dejamos todo como estaba.

Suerte y ya dirás ...

Hola a tod@s

me acabo de unir al foro y en primer lugar me gustaría felicitaros por el trabajo didáctico que hacéis y por ayudarnos a hacer más seguras nuestras redes de casa.

Hace un tiempo que vengo intentando romper la seguridad de mi WIFI y de momento aguanta, cruzo los dedos porque tengo vecinos revoltosos...

De momento, creo, estoy protegido contra Linset y ahora estoy intentando ver cómo afecta esta herramienta a mi red.

El caso es que he seguido las instrucciones para instalarla en la última versión de Kali y me da un error al hacer el configure del gtkdialog.

checking for pkg-config... no
checking for GTK... no
configure: error: in `/root/tmp/gtkdialog-0.8.3':
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see <http://pkg-config.freedesktop.org/>.
See `config.log' for more details


Por favor, me podéis ayudar?

Gracias

4TL4S

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #590 en: 03-03-2016, 20:24 (Jueves) »
Actualizo:

Esto ya lo he resuelto con:

apt-get install pkg-config
apt-get install libgtk2.0-dev

Ya tengo instalado el dialog, ahora tengo el error en YAD:

root@Linux:~/tmp/yad-0.28.1# make
make  all-recursive
make[1]: se entra en el directorio '/root/tmp/yad-0.28.1'
Making all in src
make[2]: se entra en el directorio '/root/tmp/yad-0.28.1/src'
  CCLD     yad
yad-icons.o: En la función `handle_stdin':
/root/tmp/yad-0.28.1/src/icons.c:161: referencia a `strip_new_line' sin definir
yad-list.o: En la función `handle_stdin':
/root/tmp/yad-0.28.1/src/list.c:369: referencia a `strip_new_line' sin definir
yad-notification.o: En la función `handle_stdin':
/root/tmp/yad-0.28.1/src/notification.c:269: referencia a `strip_new_line' sin definir
collect2: error: ld returned 1 exit status
Makefile:410: fallo en las instrucciones para el objetivo 'yad'
make[2]: *** [yad] Error 1
make[2]: se sale del directorio '/root/tmp/yad-0.28.1/src'
Makefile:396: fallo en las instrucciones para el objetivo 'all-recursive'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio '/root/tmp/yad-0.28.1'
Makefile:337: fallo en las instrucciones para el objetivo 'all'
make: *** [all] Error 2

Lo pongo por si me podéis ayudar y, si lo resuelvo antes, por si a alguien más le pasa en el futuro.

4TL4S

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #591 en: 03-03-2016, 20:31 (Jueves) »
Resuelto con:

apt-get install yad

Siento el lio compañeros, pero al menos aqui queda por si alguien lo necesita, si no, por favor borradlo

eduardo_hene

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #592 en: 11-03-2016, 10:14 (Viernes) »
muy buen dia a todos... mi nombre es eduardo..
solo les  escribo para informar que he tenido resultados muy buenos con pixiescript en wifislax 4.11.1
sobre todo con routers ralink... y la gran sorpresa es que tengo cerca un router marca tenda y me ha dado el pin muy rapido asi que pueden agregar a la lista la MAC C8:3A:35...
sin embargo debo aclarar que tambien hay tres broadcom de los que no he podido dar con el dichoso pin... tal vez este haciendo algo mal, pero sigo en el intento...
un saludo a todos y perdon si soy muy ignorante en este tema...
 

juanjosecun

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #593 en: 23-04-2016, 01:06 (Sábado) »
Hola a todos los que conforman este foro. Les mando un saludo cordial desde la ciudad de cancun. por el momento soy nuevo en este campo. pero inicie con el wifislax y empece a probar kali linux. Bueno. el script me ha funcionado de maravilla. aca en. ( mexico ) hay diferentes compañias que prestan el servicio de internet. los de cable. optan por los modems harris. si tiene activado el wps. son presa facil. de igual manera algunos infinitum pero los nuevos modems de INFINITUM DE TELMEX. esos que son de fibra optica. y que terminan en 2.4 simplemente no son vulnerables a los ataques reaver despues de cierto tiempo usando otro tipo de ataques se protegen y entran en modo LOCK. ojala alguien  si supiera como vulnerar esa proteccion. lo he intentado con el Rvdk <-- espero haberlo escrito bien. y bueno. no han funcionado los ataques.
Antes que nada aclaro que esto lo hago de manera responsable. ayudo a mis vecinos auditando sus redes :D

onslaught

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #594 en: 29-04-2016, 10:02 (Viernes) »
Hola, solo quiero agradecer el aporte, la herramienta trabaja de manera maravillosa.  >:(

kuker

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #595 en: 05-07-2016, 22:10 (Martes) »
Hola buenas tardes, bueno pues miren aqui tengo algunas mac, que he tronado no son muchas pero pues quiza para alguien le pueda servir.
38:4C:90
90:1A:CA
38:4C:90
C8:3F:B4
38:4C:90
AC:EC:80
90:C7:92
AC:EC:80
E8:ED:05
00:AC:E0
AC:EC:80

he intentado tronar la
74:85:2A
pero solamente he podido decifrar con diccionarios digitos de 9 que he criado diccionario numericos de 270mil al 300mil pues trabajaba en Megacable externos y sabia mas omenos desde donde empezaban los primeros 4 digitos. pero no quiero usar diccionarios quiero tronarlos como he tronado las otras mac que les he pasado. ya lo uso como para matar el tiempo. los routers son Arris y el que quiero tronar son Cisco con 9 digitos nada mas que se me calienta mucho mi maquina, y con el programa pixie es mas rapido. solo que no me funciona xD para los cisco. ayuden compartan su experiencia

polo_40

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #596 en: 06-07-2016, 21:41 (Miércoles) »
Sencillamente los router Cisco no son vulnerables al ataque Pixie Dust, solo queda usar el diccionario.

genki

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #597 en: 18-07-2016, 06:06 (Lunes) »
que tal quisiera saber si tienen informacion de porque desde hace una semana ya no funciona este metodo en los routers arris de megacable ya no da ela clave ni el pin
- Fabricante : ARRIS
- Modelo : TG862G
- Numero de modelo : RT2860
- Numero de serie : 12345678
- Device Name : ARRIS TG862 Router
-

polo_40

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #598 en: 18-07-2016, 16:52 (Lunes) »
que tal quisiera saber si tienen informacion de porque desde hace una semana ya no funciona este metodo en los routers arris de megacable ya no da ela clave ni el pin
- Fabricante : ARRIS
- Modelo : TG862G
- Numero de modelo : RT2860
- Numero de serie : 12345678
- Device Name : ARRIS TG862 Router
-

El firmware se actualizó a la versión 9.1.103S1, por default el modo PIN de WPS está desactivado (solo queda activado el PBC) por lo que el router ya no es vulnerable al ataque Pixie Dust...
« Última modificación: 18-07-2016, 16:54 (Lunes) por polo_40 »

genki

  • Visitante
Re: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #599 en: 18-07-2016, 20:22 (Lunes) »
Muchas gracias ahora se puede atacar con algun metodo el PCB Push Button Configuration ?