Autor Tema: Problemas con D-link DWL G122  (Leído 3424 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Gendarmer

  • Visitante
Problemas con D-link DWL G122
« en: 03-08-2009, 00:08 (Lunes) »
Buenas!  antes tenia este  modelo Version C1 con Firmware 3.10, no tenia problemas, pero el pobre un dia decidio suicidarse y se tiro de cabeza al water. Ya no volvio a ser el mismo...

Entonces decidi comprar el mismo modelo, intente aplicar el modo monitor con Wway y se queda bloqueado, no reacciona, la unica forma de que el programa vuelva  a funcionar es quitandolo del conector Usb.

Asi que tras varios intentos y obtener el mismo resultado mire las especificaciones y comparandolo con el anterior vi que se diferenciaban en el Firmware.

El anterior es un  D-link DWL G122  ver. C1 (F/W 3.10)

y el actual es un  D-link DWL G122  ver. C1 (F/W 3.30)

Mi duda es si tiene algo que ver el Firmware para que se quede colgado el programa y no pueda ser aplicado el modo monitor.

Alguna idea?

Gracias!



Desconectado drvalium

  • Colaborador
  • *
  • Mensajes: 17378
  • Misántropo
Re: Problemas con D-link DWL G122
« Respuesta #1 en: 03-08-2009, 00:14 (Lunes) »
si que es posible que afecte, estaría bien saber que chip usan esos adaptadores, aun siendo el mismo modelo podrían estar usando otro chip.


saludos

Gendarmer

  • Visitante
Re: Problemas con D-link DWL G122
« Respuesta #2 en: 03-08-2009, 00:23 (Lunes) »
los chipsets son:

para el que tiene Firmware 3.10: RT2571wf    sk68190d0  08445T

para el que tiene Firmware 3.30: RT2571wf    sl19530e0   0911st

He desarmado ambos Usb y en el Cipset pone esas numeraciones.

Aun asi me parece extrañisimo que no funcione, me pareec increible, si son la misma version!


Desconectado drvalium

  • Colaborador
  • *
  • Mensajes: 17378
  • Misántropo
Re: Problemas con D-link DWL G122
« Respuesta #3 en: 03-08-2009, 01:31 (Lunes) »
prueba a cargar el driver de distintas formas, puedes hacerlo desde el asistente de chipsets forazndo el rt73 o escribiendo en la consola:

   ifconfig rausb0 up

también prueba a ponerla en modo monitor de estas dos maneras:

   airmon-ng start rausb0

   iwconfig rausb0 mode monitor

con esos sistemas haz todas las combinaciones posibles, con alguna de ellas seguro que funciona.



saludos


PD: no conectes el adaptador hasta que el sistema se haya iniciado.