Autor Tema: Thc-hydra  (Leído 898 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18225
Thc-hydra
« en: 27-12-2019, 17:51 (Viernes) »
Código: [Seleccionar]
svn co https://github.com/vanhauser-thc/thc-hydra
O wget
Código: [Seleccionar]
wget https://github.com/vanhauser-thc/thc-hydra/archive/v9.0.tar.gz
O git
Código: [Seleccionar]
git clone https://github.com/vanhauser-thc/thc-hydra
No creo necesario decir como entrar al directorio xd

Código: [Seleccionar]
./configure
make
make install

Si desea el módulo ssh, debe configurar libssh (¡no libssh2!)
En su sistema, consígalo en http://www.libssh.org, para soporte de ssh v1 también necesita agregar la opción
"-DWITH_SSH1 = On"
en la línea  de comando cmake.

Código: [Seleccionar]
wget https://www.libssh.org/files/0.9/libssh-0.9.4.tar.xz
Código: [Seleccionar]
git clone https://git.libssh.org/projects/libssh.git libssh


Para debian/Ubuntu

Código: [Seleccionar]
apt-get install libssl-dev libssh-dev libidn11-dev libpcre3-dev \
                 libgtk2.0-dev libmysqlclient-dev libpq-dev libsvn-dev \
                 firebird-dev libmemcached-dev libgpg-error-dev \
                 libgcrypt11-dev libgcrypt20-dev


« Última modificación: 01-09-2020, 04:18 (Martes) por Hwagm »

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18225
hydra
« Respuesta #1 en: 27-12-2019, 21:43 (Viernes) »
Step 1 :

Código: [Seleccionar]
apt install git build-essential libssl-dev libssh-dev libidn11-dev libpcre3-dev libgtk2.0-dev libmysqlclient-dev libpq-dev libsvn-dev firebird-dev libncurses5-dev
Step 2 :

Código: [Seleccionar]
cd ~
mkdir infosec
cd infosec
git clone https://github.com/vanhauser-thc/thc-hydra.git
cd thc-hydra
./configure
make
./hydra -h
./xhydra

Update and Upgrade

Código: [Seleccionar]
apt update
 apt dist-upgrade

cd ~/infosec/thc-hydra
git pull origin master
make clean
./configure
make
« Última modificación: 27-12-2019, 22:33 (Viernes) por Hwagm »