Autor Tema: Intento de ayuda para los que no podeis inyectar con minipci Broadcom  (Leído 9514 veces)

0 Usuarios y 1 Visitante están viendo este tema.

hrodgar

  • Visitante
Bueno, antes que nada, mi intención es de dejar unos apuntes de cómo mirar de solucionarlo, dado que mis conocimientos en cuanto a drivers, compilaciones y demás son muy escasos. Por lo tanto, las pruebas a realizar no son para principiantes como yo; simplemente he estado buscando por la red posibles soluciones para que algún entendido en la materia pueda mirar de solucionarlo.

Es posible que dado mis conocimientos, lo que diga aquí tenga poco sentido, no sea nuevo, o simplemente “flipo”. Tan solo miro de ayudar a solucionar un problema.

El primer paso es asegurarse del chip que tenemos; desde una ventana de consola, escribir:

Citar
lspci | grep Broadcom

En caso de varias pci (p.e. mi pc dispone de una de red normal broadcom ), fijaros en la que diga algo de wireless. En mi caso:

Citar
02:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 892.11g Wireless LAN Controler (rev 02)

En mi caso, con este chip y los drivers de wifislax/wifiway funcionan bien (managed (excepto con WPA), monitor y inyección). O sea que si teneis esta... leches! Leeros los post y no digáis que no funciona  >:(.....

Teóricamente, esto es así gracias el proyecto http://bcm43xx.berlios.de/ que desarrollaron el driver bcm43xx para linux (incluido en el kernel desde la 2.6.17), y posteriormente la inyeccion mediante el parche que hay en http://patches.aircrack-ng.org/bcm43xx-injection-linux-2.6.20.patch

Por suerte, tanto wifislax como wifiway llevan parcheados los driver. Es mas, sabreis que hay unos lanzadores para utilizar o el driver normal o el parcheado.

que pasa con los demas chips?, pues leeros esto:
http://bcm43xx.berlios.de/?go=devices

Vereis que incluso para la mía (4318) pone unstable, por lo que algunos funcionan y otros no... ves.... que le haremos  :'(

Que se puede hacer? pues aqui dejo cuatro cosas que habría que investigar:

Utilizar otro parche.-
En la web de aircrack he visto que disponen de 2 parches: el 2.6.20 que es el utilizado en estas distros (http://patches.aircrack-ng.org/bcm43xx-injection-linux-2.6.20.patch) y otro mas nuevo: http://patches.aircrack-ng.org/bcm43xx-injection-linux-2.6.22.patch
Desconozco si se ha probado y a funcionado. Alguno puede contestarlo? en caso contrario, creo que tan solo es seguir el manual de parchear el driver broadcom normal de esta casa ubicado en https://hwagm.elhacker.net/drivers-ng/driver-ng.htm , substituyendo el 2.6.20.patch por ...2.6.22.patch

Aplicar los parches sobre los “nuevos drivers”.-
...nuevos drivers broadcom para linux??... ??? pues eso me parece a mí, al fin y al cabo no he visto a nadie por aquí que lo comente ni en otros sitios...

Antes de continuar, a mi me parece una tonteria lo de aplicar parches para un driver a otro... pero por probar... mirar por que lo digo:

Vereis, resulta que entiendo que el proyecto bcm43xx de berlios.de finalizó con su inclusión en el kernel, pero si os fijais en la misma pagina web nos remiten a http://linuxwireless.org donde se habla de la nueva actualizacion o driver “b43”, concretamente la pagina es http://linuxwireless.org/en/users/Drivers/b43

Citar
b43 and b43legacy

The b43 drivers (bcm43xx in mainline kernels, b43 and b43legacy in wireless-2.6 and 2.6.24 and later) are drivers for the 802.11 B/G family of wireless chips Broadcom produces.
Citar
... supported
    * bcm4303 (802.11b-only chips)
    * bcm4306
    * bcm4311 rev 1 / bcm4312
    * bcm4311 rev 2 / bcm4312 (needs patches for 2.6.24)
    * bcm4318
unsupported
    * The 802.11a part of the 4309 and 4312 is not supported.
    * There is no support for any Draft 802.11n features. We are working on it.
    * BCM 4328/4329

A ver... no os hagais ilusiones... si, igual son nuevos drivers ... pero no soportan reinyección. Bueno, como los bcm43xx originales... pero salió un parche, no?

Así que:
... leeros las referencias que he dejado e investigad vosotros mismos...

... Probad a compilar los nuevos drivers; no reinyectareis, pero si os funcionan solo tendreis que estar atentos a que salga un parche (esperemos :-\)...

... si (aunque parezca una locura) alguno prueba los nuevos drivers con los parches antiguos (dado que por lo que he leido se trata de una re-escritura de los anteriores, los cuales usaban las librerias ieee80211 + softmac, y estos utilizan la API mac80211; por tanto, y según mis flojos conocimientos, no prodría funcionar?)

En fin... espero que sirva de guía para que gente con más conocimientos que yo consiga alguna forma para los que teneis broadcoms y no os funcionan para auditoria...

Saludos.

P.D.: no sabía se meterlo aquí, directamente en las secciones de las distros, en portatiles, ... así que si creeis oportuno moverlo, adelante. Y perdón por la longitud...


« Última modificación: 20-01-2008, 23:06 (Domingo) por hrodgar »