Autor Tema: Ayuda configuracion Linksys WRT54GL con DD-WRT para repetir señal  (Leído 8555 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ufychsormeer

  • Visitante
Buenos dias a todos!

Lo primero disculparme si no he publicado este post en el subforo correcto, no sabía donde publicarlo exactamente...

Os explico mi problema a ver si alguien me puede ayudar o aconsejar, es que no sé que hacer... Sé que es una parrafada descomunal, pero intento explicar mi problema con la mayor exactitud y cantidad de detalles que pueda. De antemano muchísimas gracias por vuestra atención ^^.

Objetivo a conseguir: A mi madre, que trabaja muchísimo, es la que paga y siempre llega muy cansada a casa, le gusta mucho la radio, y le hace mucha ilusión escuchar a sus locutores favoritos mientras hace sus tareas y sus cosas por toda la casa. El problema es que ahora éstos locutores se han cambiado de emisora, y esa emisora no se coge aquí en Lugo, por lo que se llevó una desilusión muy grande. Ahora tiene un Iphone 3, y podría escucharlos por internet, pero en casa hay mala cobertura y no puede conectarse a internet con él, así que pensé que podría escucharlos de nuevo si conecto el Iphone a internet a través de la wifi de casa, pero para que le sea útil necesito que la señal wifi esté por toda la casa.

Contexto: Acabo de cambiar la conexión de internet por cable a una de 50Mb de ancho de banda, y mi ISP me puso un router Hitron, creo que el BVW-3653, pero lo tengo alquilado y viene con el firmware de la compañia, por lo que no puedo cambiárselo, únicamente puedo cambiar las opciones de configuración, y tiene bloqueado el modo bridge.

Problema: El caso es que mi casa es de 100 metros cuadrados, pero es estrecha y muy alargada, y la señal tiene que atravesar varias paredes, algunas con armarios llenos de ropa, estantes con muchos libros, etc. Por si fuera poco el router está en un extremo de la casa y la señal wifi no llega al otro extremo, que es, además, donde mi madre se pasa la mayor parte del tiempo.

Opciones estudiadas: Estuve mirando la opción de usar PLCs, pero mi casa es bastante vieja y parece ser que la instalación eléctrica está dividida en 2 o algo así, una cosa rara, así que descarté esa idea. Le comenté a mi madre de pasar un cable de red por los tubos de cables eléctricos, pero que habría que llamar a un electricista porque yo de esas cosas ni idea, y por supuesto se negó en rotundo, por lo que sólo me queda usar wifi.
Antes de que me cambiaran el router, tenía un Thomson, creo que el TCW750, y me compré un Linksys WRT54GL para intentar establecer una conexión WDS, y aunque al Linksys le puse el DD-WRT 24 SP1, al usar WPA o WPA2 con cifradfo AES para mantener la wifi segura, fue imposible. Todo lo que conseguí fue establecer el Linksys en modo "Repeater bridge" y crear una 2º red. Con esta solución dí cobertura a toda la casa, pero no era útil para mi madre, ya que al ir de un lado a otro de la casa, perdía la conexión, ya que tenía que o bien conectarse al Linksys o bien al Thomson, y ella ni sabe ni quiere aprender a cambiar la configuración del Iphone para conectarse a una u otra red, además de que sería muy tedioso y aburrido tener que hacerlo todo el rato, así que decidió seguir sin escuchar la radio. Ahora, con el Hitron, no logro ni siquiera que esa configuración funcione, supongo que se debe a que tiene el modo bridge capado...

Estaba pensando en comprar un repetidor, pero por lo que estuve leyendo, me entran dudas de si ese repetidor únicamente me crearía una 2º red, y volvería a tener lo que tenía antes, lo que no vale para mi propósito... ¿A alguien se le ocurre alguna idea de qué podría hacer? No me importa comprar algún otro dispositivo si hace falta, mientras que no supere los 60-70€, que es mi presupuesto...


Una vez más, muchísimas gracias por vuestra atención, y perdón por la parrafada. Ojalá alguien me pueda ayudar...


« Última modificación: 20-08-2012, 03:13 (Lunes) por ufychsormeer »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #1 en: 17-08-2012, 14:39 (Viernes) »
Lo primero, bienvenido  ;)

En principio, teniendo el Linksys con DD-WRT no deberías necesitar más.
Debes configurarlo en modo 'Repetidor Puente': http://www.dd-wrt.com/wiki/index.php/Repetidor_Puente

Pero ... es posible (no se como funcionará en el iphone) que cuando 'salte' de un router a otro (de un lugar de la casa a otro), tendrá pequeños cortes.
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

ufychsormeer

  • Visitante
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #2 en: 19-08-2012, 13:42 (Domingo) »
Hola jar229 !

Muchas gracias por la bienvenida, por tu atención y por tu respuesta ^^.

No he contestado antes porque estaba probando la configuración que me recomendaste. La configuración funciona, pero no sé por qué, me va más lenta quer antes.

Antes, cuando tenía el router thomson, había hecho algo parecido, tenía el Linksys en modo "Repetidor Puente" pero en vez de tener una red, tenía 2 distintas, y, o bien me conectaba a través del Linksys (para lo cual tenía que elegir la red con el SSID del Linksys y ponerle al pc como puerta de enlace la ip del Linksys), o bien, me conectaba a la red del router Thomson directamente. Con esta configuración no lograba resolver el problema que comentaba en el 1º post, pero al menos daba cobertura a toda la casa (que ahora también). La diferencia es que antes, en mi PC, estando siempre conectado a través del Linksys, podía descargar a un máximo de 1.2 Mb/s más o menos, pero ahora, probando los velocímetros de por ahí me dan una tasa de bajada máxima de 4700 kbps, es decir, unos 580kB/s, y efectivamente no descargo nada a más de esa velocidad. Hice la configuración que ponía en el enlace que me pasaste, con la peculiaridad de que estoy usando el mismo SSID en el router y en el linksys (pensé que si ponía unos SSID diferentes no saltaría la conexión de uno a otro y tendría que hacerlo a mano).  Por otro lado, hay un parámetro de los que se explican en el enlace que no entendí muy bien, concretamente el siguente paso:

8. Abra la pestaña Setup -> Advanced Routing/Setup -> Ruteo Avanzado
    Change operating mode to/Modo de Operación : Router
    Save/Grabar Config.

Sin embargo, en el apartado específico para los Linksys pone:

"Finalmente, una vez y ÚNICAMENTE DESPUÉS de conectarse a su AP anfitrión, como paso final tendrá que ir a la pestaña Setup -> Advanced routing/Setup -> Ruteo Avanzada y cambiar la configuración de puerta de enlace al router. A continuación, habilitar el enrutamiento dinámico para ambas Lan y Wlan y aplicar los ajustes. "

La configuración que hice fue:
- Change operating mode to/Modo de Operación : Router
- habilitar el enrutamiento dinámico para ambas Lan y Wlan

Por defecto la opción "Change operating mode to/Modo de Operación" venía marcada como "Gateway". ¿Podría ser algo de esto o lo de estar usando el mismo SSID en el Hitron y en el Linksys lo que hace que me vaya más lento ahora que antes?
Una última cosa, ahora no me deja entrar al Linksys para ver y cambiar la configuración, aunque sí que me estoy conectando a través de él...¿Hay algún modo de acceder a él sin tener que hacer un hard reset y volver a configurar todo otra vez? Es que me da algo de perecilla XDDDD.

Un saludo y muchísimas gracias por tu atención!!!

Chumpy

  • Visitante
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #3 en: 19-08-2012, 14:56 (Domingo) »
No se exactamente que pasos habrás seguidos, pero en principio deberías haber asignado al repetidor una IP local (el manual creo que indica que pongas las 192.168.1.2, pero puedes haber puesto cualquiera), si la has fijado manualmente podrás acceder al router con esa ip igual que accedes al principal con la suya propia. Si no la has fijado manualmente estará asignada por el DHCP del principal y tendrás que, desde una consola, comprobar la IP  del equipo al que estás conectado y acceder con esa, además de cambiarla.

El principal y el repetidor están en el mismo canal?

PD.: Corrije el título que no es descriptivo.
« Última modificación: 19-08-2012, 15:04 (Domingo) por Chumpy »

ufychsormeer

  • Visitante
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #4 en: 19-08-2012, 15:38 (Domingo) »
Hola Chumpy!

Gracias por tu respuesta ^^. Tienes razón, estaba ingresando mal la ip del router Hitron y del Linksys en el navegador, fallo mío XD. Sí que puedo acceder a ambos. El Hitron usa la IP 192.168.0.1 y el Linksys la 192.168.0.2. El DHCP está activado en el Hitron. pero pongo IPs estáticas en los dispositivos para saber cual es cual, porque así, en la interfaz del Hitron me muestra todos los dispositivos que están accediendo a él y sé si me están chorizando o si no XD.
El canal es el 9 en los 2, porque miré con un programa qué canales estaban siendo usados en otras wifis cercanas y ninguna estaba usando el 9, así que pensé que era lo mejor.

A ver, los pasos que he seguido son éstos y en éste orden:

  • Hard reset or 30/30/30 en el Linksys.
  • Configuro la IP del portatil y lo conecto al Linksys por cable.
  • Accedo al Linksys (está con DD-WRT 24 SP2)
  • Voy a Setup -> Basic Setup
        - WAN Connection Type/Tipo de Conexión : Disabled/Desactivar
        - STP: Disabled/Desactivar
        - Local IP Address/IP Local (LAN) : 192.168.0.2
        - Subnet Mask/Máscara Subred : 255.255.255.0
        - Gateway/Puerta de Enlace: 192.168.0.1
        - DHCP Server/Servidor DHCP: Disable/Desactivar
        - Local DNS: 192.168.0.1
        - Marco Assign WAN Port to Switch/Assigar Puerto WAN Port a cambiar
        - Save/Grabar Config.
  • Voy a Wireless -> Basic Settings/Inalámbrico -> Config Básica
        En la sección Physical Interface
            - Wireless Mode/Modo Inalámbrico : Repeater Bridge
            - Wireless Network Mode/Modo de Red Wi-Fi : G only (OJO!!!! en el Hitron tengo N y G)
            - Wireless Network Name (SSID)/Nombre de Red Wi-Fi (SSID) : RTRN1
            - Wireless Channel/Canal Inalámbrico : 9 (el mismo que el del Hitron)
            - Wireless SSID Broadcast/Broadcast SSID Inalámbrico : Enable
            - Network Configuration : Bridged
            - Save/Grabar Config.
        En la sección Virtual Interfaces
            - Add/Añadir
            - Wireless Network Name (SSID)/Nombre de Red Wi-Fi (SSID) : RTRN2 (OJO!!! este no me aparece en ningún dispositivo como red a elegir, sólo me aparece RTRN1)
            - Wireless SSID Broadcast/Broadcast SSID Inalámbrico : Enable
            - AP Isolation/Aislamiento AP : Disable/Desactivado
            - Network Configuration : Bridged
            - Save/Grabar Config.
  • Voy a Wireless -> Wireless Security/Inalámbrico -> Seguridad Inalámbrica
        En la sección Physical Interface
            - Security Mode: WPA
            - WPA Algorithms/Algoritmos WPA  : AES
            - WPA Shared Key/Clave Compartida WPA : la misma que el Hitron
            - Key Renewal Interval (in seconds) : dejo por defecto
        En la sección Virtual Interfaces
            - Security Mode : WPA
            - WPA Algorithms/Algoritmos WPA  : AES
            - WPA Shared Key/Clave Compartida WPA : la misma que el Hitron
            - Key Renewal Interval (in seconds) : dejo por defecto
            - Save/Grabar Config.
  • Voy a Setup -> Advanced Routing/Setup -> Ruteo Avanzado
        - Change operating mode to/Modo de Operación : Router (OJO!!! Esta opción es a la que me refería antes, por defecto estaba como "Gateway")
        - Habilito el enrutamiento dinámico para ambas Lan y Wlan
        - Save/Grabar Config.
  • Abra la pestaña Services -> Services
        - DNSMasq : Disable/Desactivar
        - Save/Grabar Config.
  • Abra la pestaña Security -> Firewall
        - Desmarque todas las casillas...excepto Filter Multicast/Filtrado Multicast
        - Desactivo el Firewall.
        - Apply Settings/Aplicar
  • Reinicie el router

¿Hice algo mal? ¿Me salté algo?

Muchísimas gracias por vuestra ayuda!!!!
« Última modificación: 19-08-2012, 16:07 (Domingo) por ufychsormeer »

Chumpy

  • Visitante
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #5 en: 19-08-2012, 16:10 (Domingo) »
Pues yo lo veo bien, no se si otro te podrá decir algo. Haz otra prueba de velocidad, no vaya a ser que la primera diera un resultado demasiado bajo por algo.

Aún no has cambiado el título...

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #6 en: 19-08-2012, 16:13 (Domingo) »
No veo que hayas hecho nada mal.
Prueba, si puedes, a cambiar la configuración wifi del Hitron a "g".
De todas formas, el tema de la radio con el iphone te funciona ?
Y el tema de la velocidad ... ya lo he repetido varias veces, si hacemos que un dispositivo con una sola radio wifi, actué como si tuviera 2, la velocidad se va a resentir  >:D
Si quieres, podrías configurar el linksys en modo cliente, y poner otro router como AP, así, deberías notar mejoría.
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

ufychsormeer

  • Visitante
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #7 en: 19-08-2012, 17:45 (Domingo) »
Gracias por vuestras respuestas :)

Chumpy, ya he hecho varios test de velocidad y todos con el mismo resultado, a veces me indica unos 2300Mbps y otras veces 4700Mbps . Por cierto, no entiendo a qué te refieres con lo de "Aún no has cambiado el título...".

jar229, voy a probar a poner el Hitron en sólo g. Aún no he probado lo de la radio, pero sí que he hecho pruebas con mi movil, un Nokia Lumia 710, y con el portatil y los he conectado por wifi y los he llevado de un lado a otro de la casa y se conectan bien, abren bien las páginas web, y están a tope de cobertura en ambos extremos :D, así que supongo k el iphone no debería de dar problemas, cuando solucione lo del tema de la velocidad lo pruebo y os comento ;).

Por otro lado, el tema de la velocidad es el siguiente. Antes tenía un router thomson y tenía contratado un ancho de banda de 15Mb, y había creado una segunda red con el Linksys, y yo conectaba mi PC a través del Linksys, y mediante el JDownloader y el uTorrent bajaba como máximo a 1 MB/s más o menos, y desde el PC de mi padre, que está en la misma habitación que el router principal, el Thomson de aquellas, bajaba a un máximo de 1,5 MB/s más o menos. Ahora tenemos contratado un ancho de banda de 50Mb y nos cambiaron el router Thomson por un Hitron, porque el Thomson no soportaba ese ancho de banda. Para hacer una prueba de velocidad, conecté el portatil al Hitron por cable, y puse a bajar el Framework 3.5 de Microsoft desde la pagina web oficial con el JDownloader para acelerar la descarga, y estaba bajando a más de 3MB/s, por lo que entiendo que más o menos está bien. Si me conecto por wifi al Hitron desde el PC de mi padre, que está en la misma habitación, bajo a un máximo de 2.4MB/s, y entiendo que esa diferencia se debe a la wifi, y a que la tarjeta de red de mi padre es g y no n (el Hitron está configurado para emitir en g y n), de todas formas me parece una velocidad muy razonable :D.
Ahora, yo me sigo conectando a través del Linksys, con la configuración mencionada antes, y está en el mismo sitio que antes, y el Hitron está en el mismo sitio en el que estaba el Thomson. Lo que no entiendo es por qué, si antes bajaba a 1MB/s con el Thomson como router principal, con 15Mb de ancho de banda y con el Linksys, ahora bajo como mucho a 500 KB/s teniendo el Hitron como router principal, con 50 Mb de ancho de banda y el Linksys. Así que supongo que será porque he configurado algo mal. jar229, espero que sea lo que me comentabas de que igual el Linksys no coge bien la señal o algo debido a que está en modo g only y el Hitron en g y n. Voy a probar y os comento como fue....

Una duda que se me acaba de ocurrir, ¿podría ser cosa del canal o de una temperatura alta?, es que no veais el calor que está haciendo estos últimos días, unos 30 y pocos grados, y aquí en Lugo eso es mucho...

Una ves más muchísimas gracias por toda vuestra ayuda, me está siendo muy útil ^^.

ufychsormeer

  • Visitante
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #8 en: 19-08-2012, 18:35 (Domingo) »
Buenas otra vez!

Ya puse el Hitron en modo g only y de paso les cambié la conexión a ambos a WPA2, pero la cosa sigue igual.... ¿se os ocurre a qué se puede deber esto?

Por cierto, mirando el mapa de red que me pone el hitron, en mi PC pone "Teredo". Estuve mirando qué era eso y  encontré esto en la wikipedia: http://es.wikipedia.org/wiki/Teredo, el caso es que, que yo sepa, no estoy utilizando IPv6 en ningún dispositivo....podría ser esto lo que me da problemas¿?
« Última modificación: 19-08-2012, 18:43 (Domingo) por ufychsormeer »

Chumpy

  • Visitante
Re: Necesito ayuda/consejo para una configuracion
« Respuesta #9 en: 20-08-2012, 01:40 (Lunes) »
Por cierto, no entiendo a qué te refieres con lo de "Aún no has cambiado el título...".

Extraido de las Normas del foro

 Serán bloqueados y/o eliminados los temas y/o posts que:

    Los títulos no sean descriptivos en relación a la consulta efectuada.


El canal, las interferencias con otros equipos, potencias de emisión... pueden interferir en la velocidad de conexión. También lo hará el hecho de que esté funcionando en dos modos al mismo tiempo y, por supuesto, el tipo de encriptación que se esté utilizando. Es posible que si antes utilizabas otra encriptación se deba a eso la reducción de velocidad.

ufychsormeer

  • Visitante
Re: Ayuda configuracion Linksys WRT54GL con DD-WRT para repetir señal
« Respuesta #10 en: 20-08-2012, 03:35 (Lunes) »
Gracias por tu atención Chumpy.

A ver, antes, al igual que ahora, estaba utilizando WPA2 con cifrado AES, y el Linksys también estaba en modo Repeater Bridge, como ahora, aunque la configuracion era algo distinta porque me aparecían los 2 SSIDS, el del router principal y el del Linksys (ahora sólo me aparece el del router principal, pero casi a tope de intensidad de la señal por lo que sé que se está conectando a través del Linksys, porque la del Hitron casi no llega hasta mi cuarto)...pero no sé qué puede ser lo que hace que ahora vaya tan lento porque ni ahora ni antes toqué nada de la potencia de la señal, y el hitron que tengo ahora tiene igual o más potencia que el Thomson de antes. La cantidad de equipos que hay en mi casa es la misma que la de antes....es que no tengo ni idea....no sabreis de algún manual mas o menos sencillo que explique qué factores de configuración afectan a la velocidad no¿?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: Ayuda configuracion Linksys WRT54GL con DD-WRT para repetir señal
« Respuesta #11 en: 20-08-2012, 11:12 (Lunes) »
A mi lo que me despista, es que ambos tengan el mismo SSID ...
Mira a ver si bajando (momentaneamente) la seguridad de la red a WEP, consigues mejor velocidad ...  ^-^

Si no, al final tendrás que poner el linksys en modo cliente, y conectado a este otro router en modo AP ...  ^-^
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi