?>/script>'; } ?> The problem with updating software Widgets Magazine

Autor Tema: The problem with updating software  (Leído 7982 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Algierd

  • Visitante
The problem with updating software
« en: 12-12-2015, 22:54 (Sábado) »
Hello, I try to update Qbittorrent with a script in a folder Updates-Network. At first, I got an error "qmake not install", then I installed package qt5-5.5.1 and updated libtorrent-rasterbar to version 1.0.6. The script starts, but I anyway get an error:

Citar
configure: Running qmake to generate the makefile...
Project MESSAGE: Building translations
Project MESSAGE: Processing lang/qbittorrent_fr
/usr/lib/qt5/bin/lrelease: error while loading shared libraries: libicui18n.so.51: cannot open shared object file: No such file or directory
Project ERROR: Building translations failed, cannot continue

configure: error: Failed running /usr/lib/qt5/bin/qmake to generate the makefile

there are tips on how to fix it? ??? My system is WifiSLAX 4.11 with XFCE.

« Última modificación: 12-12-2015, 22:59 (Sábado) por Algierd »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15990
Re: The problem with updating software
« Respuesta #1 en: 12-12-2015, 23:33 (Sábado) »
./configure \
--prefix=/usr \
--with-qt4


Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15990
Re: The problem with updating software
« Respuesta #2 en: 12-12-2015, 23:34 (Sábado) »
your qt5 package is not working

/usr/lib/qt5/bin/lrelease: error while loading shared libraries: libicui18n.so.51: cannot open shared object file: No such file or directory

« Última modificación: 12-12-2015, 23:35 (Sábado) por USUARIONUEVO »

Algierd

  • Visitante
Re: The problem with updating software
« Respuesta #3 en: 13-12-2015, 00:05 (Domingo) »
./configure \
--prefix=/usr \
--with-qt4

Yes , it works.


Algierd

  • Visitante
Re: The problem with updating software
« Respuesta #4 en: 13-12-2015, 00:08 (Domingo) »
your qt5 package is not working

/usr/lib/qt5/bin/lrelease: error while loading shared libraries: libicui18n.so.51: cannot open shared object file: No such file or directory
Hmm... Where can I get a working qt5? This package could be in a future included in the system?

« Última modificación: 13-12-2015, 00:12 (Domingo) por Algierd »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15990
Re: The problem with updating software
« Respuesta #5 en: 13-12-2015, 00:18 (Domingo) »
qt5 is NOT a slackware package, is an extra 3rthd party package.


then , when slackware put up a new libraries, all the third party packages can go to broken.


You have 2 options ..

1 - recompile it yours , but is a very heavy task , .. in a quad core easy to go 4/5 hours compilation
http://slackbuilds.org/repository/14.1/libraries/qt5/

2 - try to use some "current"  , package ..for example taken to Alienb0b
http://alien.slackbook.org/ktown/current/testing/x86/deps/

scroll down and see qt-5.5.1  build date 22 NOV  ;)

here have other , 5.5.0  from ponce repo
http://ponce.cc/slackware/slackware-current/packages/


you can find , broken packages with

Código: [Seleccionar]
slackyd -d


Algierd

  • Visitante
Re: The problem with updating software
« Respuesta #6 en: 13-12-2015, 00:28 (Domingo) »
./configure \
--prefix=/usr \
--with-qt4

Assembled with qt4 qbittorrent not working :'(

« Última modificación: 13-12-2015, 00:31 (Domingo) por Algierd »

Algierd

  • Visitante
Re: The problem with updating software
« Respuesta #7 en: 13-12-2015, 00:49 (Domingo) »

2 - try to use some "current"  , package ..for example taken to Alienb0b
http://alien.slackbook.org/ktown/current/testing/x86/deps/

scroll down and see qt-5.5.1  build date 22 NOV  ;)

here have other , 5.5.0  from ponce repo
http://ponce.cc/slackware/slackware-current/packages/
I checked these two packages and everywhere I get an error libicui18n.so.56...


Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15990
Re: The problem with updating software
« Respuesta #8 en: 13-12-2015, 01:19 (Domingo) »
if qt5 are broken , then.

Código: [Seleccionar]
removepkg qt5
and try without qt5 in system.


i have 3.3.0 , working perfectly on qt4 slackware library.


« Última modificación: 13-12-2015, 01:19 (Domingo) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15990
Re: The problem with updating software
« Respuesta #9 en: 13-12-2015, 01:20 (Domingo) »
remove qt5 ..and try again..

that works , sure.

Código: [Seleccionar]
./configure \
--prefix=/usr \
--with-qt4


Algierd

  • Visitante
Re: The problem with updating software
« Respuesta #10 en: 13-12-2015, 01:30 (Domingo) »
remove qt5 ..and try again..

that works , sure.

Código: [Seleccionar]
./configure \
--prefix=/usr \
--with-qt4
s

What should be the version libtorrent-rasterbar? 1.0.7?

« Última modificación: 13-12-2015, 01:37 (Domingo) por Algierd »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15990
Re: The problem with updating software
« Respuesta #11 en: 13-12-2015, 01:32 (Domingo) »
yes , ..only work with 1.0.7 or newer.


see the qbittorrent page
http://www.qbittorrent.org/download.php


i see 3.3.1 is out ...  :D


Algierd

  • Visitante
Re: The problem with updating software
« Respuesta #12 en: 13-12-2015, 01:39 (Domingo) »
thanks! ;D

« Última modificación: 13-12-2015, 01:40 (Domingo) por Algierd »

Algierd

  • Visitante
Re: The problem with updating software
« Respuesta #13 en: 13-12-2015, 02:17 (Domingo) »
yes , ..only work with 1.0.7 or newer.
Where can I get package libtorrent-rasterbar 1.0.7? My computer is too long to build programs.