Autor Tema: TP-Link TL-WA701ND inservible  (Leído 3700 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jb61uk

  • Visitante
TP-Link TL-WA701ND inservible
« en: 07-04-2015, 10:57 (Martes) »
Hola.
Tengo un router de este modelo al que le instale una version compatible de openwrt.
No quede convencido con el resultado he intente volver al firmware orginal por medio de tftp, pero cometi el error de elegir mal el firmware. Era solo el backup de la configuracion original del router.
Atraves del puerto serial me arranca pero me tira el siguiente error:

U-Boot 1.1.4 (Feb 10 2011 - 10:13:52)

AP91 (ar7240) U-boot
DRAM:
sri
#### TAP VALUE 1 = 8, 2 = 8
32 MB
id read 0x100000ff
flash size 4194304, sector count = 64
Flash: 4 MB
Using default environment

In: serial
Out: serial
Err: serial
Net: ag7240_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7014
eth0: 00:03:7f:09:0b:ad
eth0 up
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Autobooting in 1 seconds
## Booting image at 9f020000 ...
Uncompressing Kernel Image ... Error: Bad gzipped data
GUNZIP ERROR - must RESET board to recover


¿Algun consejo de como reinstalar el firmware original?
gracias.



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2000
Re: TP-Link TL-WA701ND inservible
« Respuesta #1 en: 07-04-2015, 12:15 (Martes) »
Hola.
Tengo un router de este modelo al que le instale una version compatible de openwrt.
No quede convencido con el resultado he intente volver al firmware orginal por medio de tftp, pero cometi el error de elegir mal el firmware. Era solo el backup de la configuracion original del router.
Atraves del puerto serial me arranca pero me tira el siguiente error:

U-Boot 1.1.4 (Feb 10 2011 - 10:13:52)

AP91 (ar7240) U-boot
DRAM:
sri
#### TAP VALUE 1 = 8, 2 = 8
32 MB
id read 0x100000ff
flash size 4194304, sector count = 64
Flash: 4 MB
Using default environment

In: serial
Out: serial
Err: serial
Net: ag7240_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7014
eth0: 00:03:7f:09:0b:ad
eth0 up
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Autobooting in 1 seconds
## Booting image at 9f020000 ...
Uncompressing Kernel Image ... Error: Bad gzipped data
GUNZIP ERROR - must RESET board to recover


¿Algun consejo de como reinstalar el firmware original?
gracias.

Si lo has instalado montando el tinglado de tftp, simplemente vuélvelo a hacer con el firmware adecuado.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

jb61uk

  • Visitante
Re: TP-Link TL-WA701ND inservible
« Respuesta #2 en: 07-04-2015, 12:26 (Martes) »
Gracias por la respuesta.
No se mucho sobre el tema.
No tengo conexion con el router.
Encontre una pagina en la que indican una forma de reinstalar el firmware:

https://forum.openwrt.org/viewtopic.php?id=33906
El autoboot se reinicia cada segundo y no se como pararlo. Indican que hay que pulsar tpl pero no me funciona.


Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2000
Re: TP-Link TL-WA701ND inservible
« Respuesta #3 en: 07-04-2015, 18:35 (Martes) »
intente volver al firmware orginal por medio de tftp, pero cometi el error de elegir mal el firmware. Era solo el backup de la configuracion original del router.

Por lo que pones, se deduce que el procedimiento lo has hecho por TFTP, pero que te equivocaste de fichero al subirlo. Es decir ¿has conectado la consola por el puerto serie con un adaptador TTL/USB, montado el servidor TFTP en el PC, y pasado el fichero al router?
Si es eso lo que has hecho, hazlo otra vez con el firmware adecuado.
Si no es eso lo que has hecho, buscalo el firmware y monta el tinglado de TFTP.
Lo de 'tpl' lo tienes que teclear en menos de un segundo, así que te tienes que dar prisa para parar el arranque.

El firmware original lo puedes conseguir aquí: http://www.tp-link.com/en/search/?exact=1&q=TL-WA701ND
El procedimiento para TFTP lo puedes consultar aquí, (aunque no sea el mismo modelo, se le parece mucho) : http://wiki.openwrt.org/toh/tp-link/tl-wr741nd
Ten en cuenta que a lo mejor tienes que adaptar algún parámetro, aunque parece que el particionado de la flash es el mismo, y puede que no te haga falta.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

jb61uk

  • Visitante
Re: TP-Link TL-WA701ND inservible
« Respuesta #4 en: 10-04-2015, 18:07 (Viernes) »
Gracias Tki2000 por responder.

El problema que tengo y sigo sin poder resolver es poder parar el bootloader.
He hecho miles de intentos y nunca coincide.
Les mande una consulta a tpklink en España y me respondieron sobre la garantia!!
Tengo otro punto de acceso igual, por si pudiese hacer algo con el para pasr el firmware de uno a otro.
Mi pregunta es si hay otra forma de parar el arranque de router.

Un saludo.

500L

  • Visitante
Re: TP-Link TL-WA701ND inservible
« Respuesta #5 en: 10-04-2015, 20:31 (Viernes) »
Has probado de poner tu servidor tftp escuchando en la IP 192.168.0.66 y con el firm correcto?
Cable utp/ftp conectado directo al router, sin nada más conectado a éste.

Otra cosa, para la próxima: OpenWRT no sobreescribe el bootloader, así que para volver a un firm oem puedes hacerlo desde luci o desde ssh. No es necesario el tftp para ello.

Un saludo!

//FINAL Y MÁS DOS RESPUESTAS