Autor Tema: ARV7518 no consigo que el adsl funcione  (Leído 2459 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sputnik99

  • Visitante
ARV7518 no consigo que el adsl funcione
« en: 27-01-2014, 18:18 (Lunes) »
Hola,

No consigo hacer funcionar mi ARV7518. Le intalé la version attitude_adjustment/12.09-rc2/lantiq/danube y todo me funciona correctamente menos el adsl.

Mi conexión es adsl2+ de yacom (ahora Orange) con Ip fija.
He leido todo lo que he encontrado relacionado con el apartado adsl y no he conseguido nada.

Mi configuracion de /etc/config/network es esta:

Código: [Seleccionar]

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.20.98'
option netmask '255.255.255.0'
option gateway '192.168.20.98'
option dns '8.8.8.8'
option ifname 'eth0.1'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'

config adsl-device 'adsl'
option fwannex 'a2p'
# option annex 'a2p'

config atm-bridge 'atm'
option unit '0'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option vpi '8'


config interface 'wan'
option ifname 'nas0'
option proto 'pppoe'
option username 'usuario@yacomadsl'
option password 'password'

Si ejecuto ifconfig no aparece el nas0 por ningun lado.
Si ejecuto /etc/init.d/br2684ctl start y luego ifconfig aparece

Código: [Seleccionar]
root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 88:25:2C:8B:35:74
          inet addr:192.168.20.98  Bcast:192.168.20.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5982 errors:0 dropped:167 overruns:0 frame:0
          TX packets:7028 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:447233 (436.7 KiB)  TX bytes:953396 (931.0 KiB)

eth0      Link encap:Ethernet  HWaddr 88:25:2C:8B:35:74
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0.1    Link encap:Ethernet  HWaddr 88:25:2C:8B:35:74
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6025 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7066 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:447132 (436.6 KiB)  TX bytes:951197 (928.9 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2073 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2073 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:172188 (168.1 KiB)  TX bytes:172188 (168.1 KiB)

nas0      Link encap:Ethernet  HWaddr 00:00:01:00:00:00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:131 errors:0 dropped:0 overruns:0 frame:0
          TX packets:399 errors:360 dropped:0 overruns:360 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8516 (8.3 KiB)  TX bytes:16758 (16.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 88:25:2C:8B:35:75
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:80 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4335 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:6751 (6.5 KiB)  TX bytes:339461 (331.5 KiB)

En logread aparece esto:

Código: [Seleccionar]
Jan 20 20:47:37 OpenWrt local2.notice br2684ctl[1894]: Interface "nas0" created sucessfully
Jan 20 20:47:37 OpenWrt local2.notice br2684ctl[1894]: Communicating over ATM 0.8.32, encapsulation: LLC
Jan 20 20:47:37 OpenWrt local2.info br2684ctl[1894]: Interface configured
Jan 20 20:47:37 OpenWrt local2.info br2684ctl[1894]: RFC 1483/2684 bridge daemon started
Jan 20 20:47:39 OpenWrt daemon.info pppd[1914]: Plugin rp-pppoe.so loaded.
Jan 20 20:47:39 OpenWrt daemon.info pppd[1914]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jan 20 20:47:39 OpenWrt daemon.notice pppd[1914]: pppd 2.4.5 started by root, uid 0
Jan 20 20:47:45 OpenWrt kern.err kernel: [  139.248000] [DSL_BSP_Showtime 916]: Datarate US intl = 886857, fast = 0
Jan 20 20:47:47 OpenWrt user.notice root: Found no matching interface for DSL notification (UP)
Jan 20 20:47:54 OpenWrt daemon.warn pppd[1914]: Timeout waiting for PADO packets
Jan 20 20:47:54 OpenWrt daemon.err pppd[1914]: Unable to complete PPPoE Discovery
Jan 20 20:47:54 OpenWrt daemon.info pppd[1914]: Exit.
Jan 20 20:47:54 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Jan 20 20:47:54 OpenWrt daemon.info dnsmasq[1625]: reading /tmp/resolv.conf.auto
Jan 20 20:47:54 OpenWrt daemon.info dnsmasq[1625]: using nameserver 8.8.8.8#53
Jan 20 20:47:54 OpenWrt daemon.info dnsmasq[1625]: using local addresses only for domain lan
Jan 20 20:47:55 OpenWrt daemon.info pppd[1948]: Plugin rp-pppoe.so loaded.
Jan 20 20:47:55 OpenWrt daemon.info pppd[1948]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jan 20 20:47:55 OpenWrt daemon.notice pppd[1948]: pppd 2.4.5 started by root, uid 0
Jan 20 20:48:10 OpenWrt daemon.warn pppd[1948]: Timeout waiting for PADO packets
Jan 20 20:48:10 OpenWrt daemon.err pppd[1948]: Unable to complete PPPoE Discovery
Jan 20 20:48:10 OpenWrt daemon.info pppd[1948]: Exit.
Jan 20 20:48:10 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Jan 20 20:48:11 OpenWrt daemon.info pppd[1965]: Plugin rp-pppoe.so loaded.
Jan 20 20:48:11 OpenWrt daemon.info pppd[1965]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jan 20 20:48:11 OpenWrt daemon.notice pppd[1965]: pppd 2.4.5 started by root, uid 0
Jan 20 20:48:14 OpenWrt daemon.info dnsmasq[1625]: reading /tmp/resolv.conf.auto
Jan 20 20:48:14 OpenWrt daemon.info dnsmasq[1625]: using nameserver 8.8.8.8#53
Jan 20 20:48:14 OpenWrt daemon.info dnsmasq[1625]: using local addresses only for domain lan
Jan 20 20:48:26 OpenWrt daemon.warn pppd[1965]: Timeout waiting for PADO packets
Jan 20 20:48:26 OpenWrt daemon.err pppd[1965]: Unable to complete PPPoE Discovery
Jan 20 20:48:26 OpenWrt daemon.info pppd[1965]: Exit.
Jan 20 20:48:26 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Jan 20 20:48:27 OpenWrt daemon.info pppd[1982]: Plugin rp-pppoe.so loaded.
Jan 20 20:48:27 OpenWrt daemon.info pppd[1982]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jan 20 20:48:27 OpenWrt daemon.notice pppd[1982]: pppd 2.4.5 started by root, uid 0
Jan 20 20:48:29 OpenWrt daemon.info dnsmasq[1625]: reading /tmp/resolv.conf.auto
Jan 20 20:48:29 OpenWrt daemon.info dnsmasq[1625]: using nameserver 8.8.8.8#53
Jan 20 20:48:29 OpenWrt daemon.info dnsmasq[1625]: using local addresses only for domain lan
Jan 20 20:48:42 OpenWrt daemon.warn pppd[1982]: Timeout waiting for PADO packets
Jan 20 20:48:42 OpenWrt daemon.err pppd[1982]: Unable to complete PPPoE Discovery
Jan 20 20:48:42 OpenWrt daemon.info pppd[1982]: Exit.
Jan 20 20:48:42 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Jan 20 20:48:43 OpenWrt daemon.info pppd[1999]: Plugin rp-pppoe.so loaded.
Jan 20 20:48:43 OpenWrt daemon.info pppd[1999]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jan 20 20:48:43 OpenWrt daemon.notice pppd[1999]: pppd 2.4.5 started by root, uid 0
Jan 20 20:48:44 OpenWrt daemon.info dnsmasq[1625]: reading /tmp/resolv.conf.auto
Jan 20 20:48:44 OpenWrt daemon.info dnsmasq[1625]: using nameserver 8.8.8.8#53
Jan 20 20:48:44 OpenWrt daemon.info dnsmasq[1625]: using local addresses only for domain lan

Si ejecuto /sbin/dsl_cpe_control da error:

Código: [Seleccionar]
root@OpenWrt:~# /sbin/dsl_cpe_control
DSL_CPE: Device /dev/dsl_cpe_api opened successfully
[b]DSL_CPE: Could not unmask event(18) for device 0 (0)!
DSL_CPE:  open /opt/ifx/firmware/ModemHWE.bin failed.[/b]

DSL_CPE: terminated
EventHandler: exit(0)
DSL_CPE: User Thread Shutdown <tPipe_0> - no responce
DSL_CPE: User Thread Shutdown <tPipe_1> - no responce
DSL_CPE: CLI interface of DSL CPE API terminated.
DSL_CPE: Goodbye from DSL CPE API CLI interface

He buscado el error pero no encuentro info.

Lo que me sorprende es que si ejecuto /etc/init.d/dsl_control status aparece información:

Código: [Seleccionar]
root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:                Ifx-Danube 1.5
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              10.459 Mb/s / 886 Kb/s
Line Attenuation:       22.2dB / 16.7dB
Noise Margin:           9.1dB / 16.7dB
Line Uptime:            4m 44s

En el archivo de configuración he probado a descomentar y comentar en todas sus variantes posibles:

config adsl-device 'adsl'
   option fwannex 'a2p'
#   option annex 'a2p'

Pero no hay forma.

¿Alguna idea de como solucionar el problema?

Un saludo y muchas gracias



Pteridium

  • Visitante
Re: ARV7518 no consigo que el adsl funcione
« Respuesta #1 en: 28-01-2014, 20:15 (Martes) »
Mi configuracion de /etc/config/network es esta:

Código: [Seleccionar]

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.20.98'
option netmask '255.255.255.0'
option gateway '192.168.20.98'
option dns '8.8.8.8'
option ifname 'eth0.1'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'

config adsl-device 'adsl'
option fwannex 'a2p'
# option annex 'a2p'

config atm-bridge 'atm'
option unit '0'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option vpi '8'


config interface 'wan'
option ifname 'nas0'
option proto 'pppoe'
option username 'usuario@yacomadsl'
option password 'password'

He buscado el error pero no encuentro info.

Lo que me sorprende es que si ejecuto /etc/init.d/dsl_control status aparece información:

Código: [Seleccionar]
root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:                Ifx-Danube 1.5
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              10.459 Mb/s / 886 Kb/s
Line Attenuation:       22.2dB / 16.7dB
Noise Margin:           9.1dB / 16.7dB
Line Uptime:            4m 44s

En el archivo de configuración he probado a descomentar y comentar en todas sus variantes posibles:

config adsl-device 'adsl'
   option fwannex 'a2p'
#   option annex 'a2p'

Pero no hay forma.

¿Alguna idea de como solucionar el problema?

Un saludo y muchas gracias
Primero de todo hay que diferenciar entre sincronización y "negociación".
Si hay sincronismo, como es el caso, significa que el router y la central están conectados, pero nada más. Estos parámetros están correctos:
Código: [Seleccionar]
config adsl-device 'adsl'
option fwannex 'a2p'
# option annex 'a2p'
El siguiente paso es revisar el resto de los parámetros: vpi, vci, encapsulación, usuario, contraseña y si es pppoe o pppoa por estos mensajes horribles que te está soltando:
Código: [Seleccionar]
Jan 20 20:48:42 OpenWrt daemon.warn pppd[1982]: Timeout waiting for PADO packets
Jan 20 20:48:42 OpenWrt daemon.err pppd[1982]: Unable to complete PPPoE Discovery
Jan 20 20:48:42 OpenWrt daemon.info pppd[1982]: Exit.
Jan 20 20:48:42 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Estos mensajes indican que hay algo incorrecto y que no es capaz de entenderse con el servidor de yacom o de orange.
Otro detalle, aunque no debería estar relacionado, es que la siguiente línea sobra:
Código: [Seleccionar]
option gateway '192.168.20.98'También puedes añadir más servidores dns por si el que has puesto cae.

Aunque supongo que los datos de tu conexión ya los conoces y casi seguro que están correctos, échale un ojo al siguiente link:
http://www.adslayuda.com/Generico-datosdeconexion.html

Detalle adicional para los que quieran jugar con el sincronismo:
https://forum.openwrt.org/viewtopic.php?pid=222065
« Última modificación: 28-01-2014, 20:17 (Martes) por Pteridium »

espeltron

  • Visitante
Re: ARV7518 no consigo que el adsl funcione
« Respuesta #2 en: 01-02-2014, 16:37 (Sábado) »
Lo que me sorprende es que si ejecuto /etc/init.d/dsl_control status aparece información:

Código: [Seleccionar]
root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:                Ifx-Danube 1.5
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              10.459 Mb/s / 886 Kb/s
Line Attenuation:       22.2dB / 16.7dB
Noise Margin:           9.1dB / 16.7dB
Line Uptime:            4m 44s

En el archivo de configuración he probado a descomentar y comentar en todas sus variantes posibles:

config adsl-device 'adsl'
   option fwannex 'a2p'
#   option annex 'a2p'

Pero no hay forma.

¿Alguna idea de como solucionar el problema?

Un saludo y muchas gracias
Solo te queda arreglar un bug que habia en esas versiones y en las antertiores con el "Anexo A" y el "Anexo B" del firmware.
Por defecto solo se metio el archivo .bin del anexo b, y de nada sirve que configures el router con las opciones del anexo a, ya que por defecto no existe este firmware.
El archivo binario .bin con el firmware del "anexo a" tienes que copiarlo al router:
- Usando winscp, sftp, scp, etc. y reemplazando el archivo del anexo b por este (el archivo .bin del anexo a se obtiene descomprimiendo un paquete ipkg).
- O con opkg del paquete con el firmware a

Ya comente esto en otro hilo, al final de esta respuesta viene indicado.
https://foro.seguridadwireless.net/openwrt/voip-en-routers-de-yacom-arv4518-y-arv7518/msg286157/#msg286157
Citar
El firmware encargado de la conexion ADSL puede tener diferentes nombres, segun la distribucion y se encuentra en:
/lib/firmware/adsl.bin
/lib/firmware/ltq-dsl-fw-a-danube.bin
/lib/firmware/dsl-fw-a.bin

Quien tenga el firmware:
  /lib/firmware/dsl-fw-b.bin
Puede reemplazarlo facilmente por el:
  dsl-fw-a.bin
Para que le funcione el adsl.
Se descarga cualquiera de los archivos:
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-ltq-dsl-firmware-a-danube_3.24.4.4-3_lantiq.ipk
http://downloads.openwrt.org/snapshots/trunk/lantiq/packages/kmod-ltq-adsl-danube-fw-a_0.1-1_lantiq.ipk
Le cambia la extension ipkg por tar.gz y lo descomprime, o lo instala directamente con opkg.
Saludos
espeltron
« Última modificación: 02-02-2014, 23:40 (Domingo) por espeltron »

//FINAL Y MÁS DOS RESPUESTAS