Autor Tema: IGMP Proxy (imagenio) no funciona correctamente  (Leído 1424 veces)

0 Usuarios y 1 Visitante están viendo este tema.

darKknight

  • Visitante
IGMP Proxy (imagenio) no funciona correctamente
« en: 04-10-2015, 20:26 (Domingo) »
Buenas, estoy intentando configurar un AR-5381u como cliente wifi del router de Movistar TV (adsl) de un colega para que pueda ver imagenio a través de el. Como no se puede poner en puente transparente el wifi y la lan, estoy usando igmp proxy. Para las pruebas estoy usando un portatil con VLC conectado por cable al comtrend. Al intentar ver cualquier canal rdp://@239.x.x.x.x tarda mas de lo normal en llenar el buffer y la imagen apenas se ve, tarda mucho en actualizarse y la mitad de la imagen es verde o gris.

También tengo instalado udpxy y con esto se ve perfectamente, es decir no es problema de la señal wifi entre el router principal y este, de hecho es la única red wifi que hay. Pero es necesario que sea multicast para usar con el addon de Kodi. Parece un problema de routing de los paquetes multicast que entran por wlan0 y deben salir por br-lan. Ah, mientras se "intenta" ver un canal multicast con igmp proxy la red parece (entre el portátil y el comtrend) que se vuelve lenta. El router tarda en responder por web y SSH, pero no es problema de sobrecarga, la CPU apenas se inmuta.

La configuración es la siguiente.

Configuración de la red:

Citar
config interface 'lan'
   option force_link '1'
   option proto 'static'
   option netmask '255.255.255.0'
   option delegate '0'
   option _orig_ifname 'eth0.1'
   option _orig_bridge 'true'
   option ifname 'eth0.1'
   option ipaddr '192.168.0.1'
   option type 'bridge'

config switch
   option name 'eth0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth0'
   option vlan '1'
   option ports '0 1 2 3 8t'

config interface 'iptv'
   option _orig_ifname 'wlan0'
   option _orig_bridge 'false'
   option proto 'static'
   option ipaddr '192.168.1.210'
   option netmask '255.255.255.0'
   option gateway '192.168.1.1'
   option dns '172.26.23.3'
   option delegate '0'

La instalación de imagenio es nueva, por eso se ha puesto usando las direcciones reservadas para el deco (200-223 creo que era) y la DNS de Imagenio.

Configuración del firewall:

Citar
config zone
   option name 'lan'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'ACCEPT'
   option network 'lan'

config zone
   option name 'iptv'
   option output 'ACCEPT'
   option network 'iptv'
   option forward 'DROP'
   option input 'DROP'
   option masq '1'
   option mtu_fix '1'

config forwarding
        option src 'lan'
   option dest 'iptv'
   

config rule
   option target 'ACCEPT'
   option name 'igmp input'
   option proto 'igmp'
   option src 'iptv'
   option family 'ipv4'

config rule
   option target 'ACCEPT'
   option name 'multicast input'
   option proto 'udp'
   option src 'iptv'
   option dest_ip '224.0.0.0/4'
   option family 'ipv4'

config rule
   option target 'ACCEPT'
   option name 'multicast forward to lan'
   option proto 'udp'
   option src 'iptv'
   option dest_ip '224.0.0.0/4'
   option family 'ipv4'
   option dest 'lan'

IGMP Proxy:

Citar
quickleave

phyint wlan0 upstream ratelimit 0 threshold 1
   altnet 172.0.0.0/8

phyint br-lan downstream ratelimit 0 threshold 1

No se que puede estar fallando, si algún modulo que falta en el kernel (y por lo tanto toca activarlo y recompilar el firmware) o algo que me dejo en la configuración. Estoy usando la 14.07-RC3, aunque también he probado la 15.05-RC3 y 15.05 de Noltari

Muchas gracias de antemano


« Última modificación: 04-10-2015, 21:58 (Domingo) por darKknight »

darKknight

  • Visitante
Re: IGMP Proxy (imagenio) no funciona correctamente
« Respuesta #1 en: 05-10-2015, 09:36 (Lunes) »
He probado con un HG556a y Chaos Calmer oficial y funciona perfectamente. Después he vuelto a probar con el AR-5381u utilizando también la 15.05 oficial y la misma configuración del HG556a y nada. Ocurre lo mismo. ¿A que puede deberse esto? Se supone que los dos firmwares están compilados con los mismos paquetes y configuración.