Autor Tema: Setup IPTV WRT1900AC V2: Problema de forwarding con Videos UDP Multicast  (Leído 1600 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pedgomo

  • Visitante
Hola a todos,

Estoy preparando un setup de IPTV sobre Wifi 11ac en un entorno multinodo.

He comprado 4 Linksys WRT1900AC V2 y les he instalado CHAOS CALMER (15.05-rc3, r46163).

He configurado uno de los routers como AP (WDS) y los otros 3 como STA (WDS).

La interfaz WAN del AP la conecto a través de un switch (con IGMP Awareness y Multicast Filtering) con mi "router multicast": Un PC ubuntu con DHCP server, xorp para IGMP/MLD Querier, con VLC para videos udp multicast y con enrutamiento hacia Internet.

Los STA se conectan por Wifi 11AC al AP y en su parte LAN tienen conectados PCs con ubuntu y VLC para actuar de STBs.

El AP tiene DHCP en la parte WAN. Tiene IP fija en la parte LAN y tiene servidor de DHCP para los STAs y los PCs que trabajan de STBs (conectados en LAN de los STAs).
Los STAs tienen sus servidores DHCP desactivados.

Con esa configuración, consigo conexión a Internet desde los PCs conectados a las STAs y servicio Unicast de Video (rtsp y http).
Sin embargo, ni el IGMP ni los los vídeos Multicast no pasan desde la WAN a la LAN.

Para completar mi setup, he seguido el HowTo https://wiki.openwrt.org/doc/howto/udp_multicast?s[]=iptv

Lo configuro todo según el HowTo y consigo que funcione el proxy de IGMP (el igmpproxy funciona correctamente). Los Joins/Leaves se registran correctamente en el switch y en el router multicast. Sin embargo, no consigo que los vídeos UDP multicast pasen de la WAN a la LAN. Lo he comprobado tanto desde un PC conectado a la LAN de un STA como conectado directamente a la LAN del AP.

Qué debo hacer para que el tráfico multicast se envíe desde la interfaz wan a la interfaz lan? Entiendo que es un problema de forwarding, pero no sé cómo arreglarlo.

Mis configuraciones:
=================================================================

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
                                 
config globals 'globals'
        option ula_prefix 'fde6:0bba:1b82::/48'
                                               
config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'         
        option gateway '192.168.1.1'
                                   
config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
                           
config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
                             

=================================================================

/etc/config/firewall:

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
        option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             wan
        option network          'wan'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option dest             wan
        option src              lan

config rule
        option name             'IGMP-IPTV'
        option src              wan
        option proto            igmp
        option target           ACCEPT

config rule
        option name             'UDP-IPTV'
        option src              wan
        option proto            udp
        option dest             lan
        option dest_ip          '224.0.0.0/4'
        option target           ACCEPT

option rule
        option name             'Allow-Ping'
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

option rule
        option name             'Allow-DHCP-Renew'
        option src              wan
        option proto            udp
        option dest_port        68
        option family           ipv4
        option target           ACCEPT



# include a file with users custom iptables rules
config include
        option path /etc/firewall.user
=================================================================

/etc/config/igmpproxy:

config igmpproxy
        option quickleave 1

config phyint
        option network wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option direction downstream
      
=================================================================

Gracias por adelantado!
Enhorabuena por este magnífico foro!




pedgomo

  • Visitante
Re: Setup IPTV WRT1900AC V2: Problema de forwarding con Videos UDP Multicast
« Respuesta #1 en: 04-12-2015, 13:09 (Viernes) »
Hola a todos de nuevo,

Al final me he dado cuenta de un error tontísimo que es el que impedía que mi tráfico de vídeo UDP multicast no pasase por la gateway: El TimeToLive del stream de VLC estaba puesto a 1.

Lo he cambiado a 10 y ya funciona correctamente!

En fin, disculpad por el error tan tonto.

GRACIAS!