Autor Tema: Problema: Read-only file system  (Leído 3255 veces)

0 Usuarios y 1 Visitante están viendo este tema.

txutxy

  • Visitante
Problema: Read-only file system
« en: 03-10-2016, 18:58 (Lunes) »
Saludos compañeros! En mi corta andadura por openwrt, me ha surgido un error que se me repite cada cierto tiempo..puede pasar 3 o 4 meses sin pasar, pero despues sucede y ya no puedo hacer nada. Supongo que sera una tonteria, pero soy bastante novato y no veo que pasa.
Este error me ha pasado con 3 router distintos, osea que tiene que ser algo que hago mal..la cosa es que como os cuento, todo funciona bien unos meses pero de repente, un dia desde luci no puedo cambiar nada, no se guardan los cambios que hago.
Por terminal, desde putty, no puedo modificar archivos, ni borrarlos ni nada, siempre el mismo mensaje "Read-only file system"...
He buscado en google si podia encontrar la respuesta pero solo he visto que ejecutan la linea "mtd unlock rootfs_data"  y ya les deja guardar...pero en mi caso sigue todo igual.
Las otras veces que me ha pasado, al final he tenido que volver a cargar el firmware y configurar todo otra vez. A ver si con vuestra ayuda, esta vez puedo saber de que puede venir y como repararlo.
Pongo un cacho del logread al iniciar por si sirve de algo.
Muchas gracias y un saludo!

root@OpenWrt:~# logread
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.360000] usbcore: registered new interface driver hub
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.360000] usbcore: registered new device driver usb
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.370000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.380000] ehci-platform: EHCI generic platform driver
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.380000] ehci-platform ehci-platform.0: EHCI Host Controller
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.390000] ehci-platform ehci-platform.0: new USB bus registered, assigned bus number 1
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.400000] ehci-platform ehci-platform.0: TX-TX IDP fix enabled
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.410000] ehci-platform ehci-platform.0: irq 48, io mem 0x1b000000
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.430000] ehci-platform ehci-platform.0: USB 2.0 started, EHCI 1.00
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.430000] hub 1-0:1.0: USB hub found
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.440000] hub 1-0:1.0: 1 port detected
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.440000] ehci-platform ehci-platform.1: EHCI Host Controller
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.450000] ehci-platform ehci-platform.1: new USB bus registered, assigned bus number 2
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.460000] ehci-platform ehci-platform.1: TX-TX IDP fix enabled
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.460000] ehci-platform ehci-platform.1: irq 49, io mem 0x1b400000
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.490000] ehci-platform ehci-platform.1: USB 2.0 started, EHCI 1.00
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.490000] hub 2-0:1.0: USB hub found
Sat Sep 24 11:56:06 2016 kern.info kernel: [    4.500000] hub 2-0:1.0: 1 port detected
Sat Sep 24 11:56:06 2016 user.info kernel: [    5.160000] init: - preinit -
Sat Sep 24 11:56:06 2016 kern.info kernel: [    5.680000] eth1: link up (1000Mbps/Full duplex)
Sat Sep 24 11:56:06 2016 kern.notice kernel: [    5.700000] random: procd urandom read with 8 bits of entropy available
Sat Sep 24 11:56:06 2016 kern.notice kernel: [    9.040000] jffs2: notice: (389) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
Sat Sep 24 11:56:06 2016 user.info kernel: [    9.070000] mount_root: loading kmods from internal overlay
Sat Sep 24 11:56:06 2016 kern.notice kernel: [   10.070000] SCSI subsystem initialized
Sat Sep 24 11:56:06 2016 kern.info kernel: [   10.080000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Sat Sep 24 11:56:06 2016 kern.info kernel: [   10.090000] ohci-platform: OHCI generic platform driver
Sat Sep 24 11:56:06 2016 kern.info kernel: [   10.100000] uhci_hcd: USB Universal Host Controller Interface driver
Sat Sep 24 11:56:06 2016 kern.info kernel: [   10.110000] usbcore: registered new interface driver usb-storage
Sat Sep 24 11:56:06 2016 user.info kernel: [   10.400000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
Sat Sep 24 11:56:06 2016 user.info kernel: [   10.410000] block: extroot: not configured
Sat Sep 24 11:56:06 2016 user.info kernel: [   10.410000] mount_root: switching to jffs2 overlay
Sat Sep 24 11:56:06 2016 kern.warn kernel: [   13.270000] overlayfs: failed to create work directory (EROFS), mounting read-only
Sat Sep 24 11:56:06 2016 kern.info kernel: [   13.300000] eth1: link down
Sat Sep 24 11:56:06 2016 user.info kernel: [   13.320000] procd: - early -
Sat Sep 24 11:56:06 2016 user.info kernel: [   13.320000] procd: - watchdog -
Sat Sep 24 11:56:06 2016 user.info kernel: [   13.990000] procd: - ubus -
Sat Sep 24 11:56:06 2016 user.info kernel: [   15.000000] procd: - init -
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.820000] NET: Registered protocol family 10
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.840000] ntfs: driver 2.1.31 [Flags: R/O MODULE].
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.850000] ip6_tables: (C) 2000-2006 Netfilter Core Team
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.870000] fuse init (API version 7.23)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.870000] Loading modules backported from Linux version master-2015-03-09-0-g141f155
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.880000] Backport generated by backports.git backports-20150129-0-gdd4a670
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.890000] ip_tables: (C) 2000-2006 Netfilter Core Team
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.900000] nf_conntrack version 0.5.0 (954 buckets, 3816 max)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.940000] xt_time: kernel timezone is -0000
Sat Sep 24 11:56:06 2016 kern.info kernel: [   15.970000] cfg80211: Calling CRDA to update world regulatory domain
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.000000] cfg80211: World regulatory domain updated:
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.000000] cfg80211:  DFS Master region: unset
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.010000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.020000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.020000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz, 92000 KHz AUTO), (N/A, 2000 mBm), (N/A)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.030000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.040000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.050000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.060000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.070000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.080000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.110000] PPP generic driver version 2.4.2
Sat Sep 24 11:56:06 2016 kern.info kernel: [   16.120000] NET: Registered protocol family 24
Sat Sep 24 11:56:06 2016 kern.debug kernel: [   16.170000] ath: EEPROM regdomain: 0x0
Sat Sep 24 11:56:06 2016 kern.debug kernel: [   16.170000] ath: EEPROM indicates default country code should be used
Sat Sep 24 11:56:06 2016 kern.debug kernel: [   16.170000] ath: doing EEPROM country->regdmn map search
Sat Sep 24 11:56:06 2016 kern.debug kernel: [   16.170000] ath: country maps to regdmn code: 0x3a
Sat Sep 24 11:56:06 2016 kern.debug kernel: [   16.170000] ath: Country alpha2 being used: US
Sat Sep 24 11:56:06 2016 kern.debug kernel: [   16.170000] ath: Regpair used: 0x3a



Ficht

  • Visitante
Re: Problema: Read-only file system
« Respuesta #1 en: 03-10-2016, 19:41 (Lunes) »
Saludos compañeros! En mi corta andadura por openwrt, me ha surgido un error que se me repite cada cierto tiempo..puede pasar 3 o 4 meses sin pasar, pero despues sucede y ya no puedo hacer nada. Supongo que sera una tonteria, pero soy bastante novato y no veo que pasa.
Este error me ha pasado con 3 router distintos, osea que tiene que ser algo que hago mal..la cosa es que como os cuento, todo funciona bien unos meses pero de repente, un dia desde luci no puedo cambiar nada, no se guardan los cambios que hago.
Por terminal, desde putty, no puedo modificar archivos, ni borrarlos ni nada, siempre el mismo mensaje "Read-only file system"...
He buscado en google si podia encontrar la respuesta pero solo he visto que ejecutan la linea "mtd unlock rootfs_data"  y ya les deja guardar...pero en mi caso sigue todo igual.
Las otras veces que me ha pasado, al final he tenido que volver a cargar el firmware y configurar todo otra vez. A ver si con vuestra ayuda, esta vez puedo saber de que puede venir y como repararlo.
Pongo un cacho del logread al iniciar por si sirve de algo.
Muchas gracias y un saludo!


Hola txutxy;

 Y ¿que configuración "física" tienes hecha con el router? me refiero a si tienes un hd-usb que pudiera estar chupando mucha corriente o con errores, o que programas tienes instalado o script un tanto fuera de lo común... ¿que modelo de router estas usando (ya se que te ha pasado en tres diferentes) y que versión de openwrt?

txutxy

  • Visitante
Re: Problema: Read-only file system
« Respuesta #2 en: 03-10-2016, 19:51 (Lunes) »
Hola Ficht!.
Te cuento un poco..me ha pasado con Barrier y con la actual Chaos, con router Huawei 556 y con Tplink 1043..
Si, del router cuelga un hdd de 2,5 (sin alimentación) donde se guardan,por medio de ftp los videos de las camaras de seguridad..
Scripts tengo varios y diversos..jeje, pero me figuro que no vendrá de ahi, porque sino pasaría enseguida o muy a menudo, no se tiraría meses y meses sin problemas..
Me inclino mas a el hdd..alguna vez he visto que el disco duro, por lo que sea no ha arrancado bien,no le detecta y en vez de apuntar la carpeta Almacen al sda5 (partición Ntfs del hdd), se guardan los videos en la propia memoria interna del router, hasta que se llena muy pronto,logicamente.. y ya no se puede guardar mas..y puede que ahi sea cuando empiece a dar los problemas.
Pero bueno,que ahora ya la he cagado..he ejecutado mtd erase -r rootfs_data y se me ha borrado todo..vaya tela,que manitas..XD
Por lo menos a ver si consigo saber de donde viene el fallo porque de aqui a un tiempo, volverá a suceder...
Un saludo!!

Ficht

  • Visitante
Re: Problema: Read-only file system
« Respuesta #3 en: 03-10-2016, 21:01 (Lunes) »
Hola Ficht!.
Te cuento un poco..me ha pasado con Barrier y con la actual Chaos, con router Huawei 556 y con Tplink 1043..
Si, del router cuelga un hdd de 2,5 (sin alimentación) donde se guardan,por medio de ftp los videos de las camaras de seguridad..
Scripts tengo varios y diversos..jeje, pero me figuro que no vendrá de ahi, porque sino pasaría enseguida o muy a menudo, no se tiraría meses y meses sin problemas..
Me inclino mas a el hdd..alguna vez he visto que el disco duro, por lo que sea no ha arrancado bien,no le detecta y en vez de apuntar la carpeta Almacen al sda5 (partición Ntfs del hdd), se guardan los videos en la propia memoria interna del router, hasta que se llena muy pronto,logicamente.. y ya no se puede guardar mas..y puede que ahi sea cuando empiece a dar los problemas.
Pero bueno,que ahora ya la he cagado..he ejecutado mtd erase -r rootfs_data y se me ha borrado todo..vaya tela,que manitas..XD
Por lo menos a ver si consigo saber de donde viene el fallo porque de aqui a un tiempo, volverá a suceder...
Un saludo!!

Hombre, desde luego, yo le pondría alimentación al hd (se puede dañar el disco y el router) y si puedes, conviértelo a ext4 y no ntfs.
Lo de los scripts, no creas, según que... yo he tenido alguno que tocaba iptables y al cabo de un par de meses el sistema quedaba totalmente corrupto, al punto de no poder iniciar, dejé de usar este script hace mas de un año, y mas nunca.... (mi error, no poner un adaptador serie para ver en el arranque lo que hacía el router, pero de cualquier manera, era el script)

txutxy

  • Visitante
Re: Problema: Read-only file system
« Respuesta #4 en: 03-10-2016, 23:37 (Lunes) »

Hombre, desde luego, yo le pondría alimentación al hd (se puede dañar el disco y el router) y si puedes, conviértelo a ext4 y no ntfs.
Lo de los scripts, no creas, según que... yo he tenido alguno que tocaba iptables y al cabo de un par de meses el sistema quedaba totalmente corrupto, al punto de no poder iniciar, dejé de usar este script hace mas de un año, y mas nunca.... (mi error, no poner un adaptador serie para ver en el arranque lo que hacía el router, pero de cualquier manera, era el script)
Gracias Ficht, verificaré los scripts que se ejecutan por si acaso, pero todos son mover y borrar videos antiguos del disco, chequear ip y mandar mail de alarma,etc..no debería corromper nada..
Cambiar a Ext4..tengo ya una patición ext4, pero esta que uso para el ftp en ntfs para poder verlo desde todos los dispositivos, windows, android tv, etc..
Lo de alimentación, no me lo habia planteado porque al ser un hdd de 2,5" , apenas chupa corriente, el router debería ser capaz de mantenerla constante sin problemas.
Osea que lo que pasa de "read-only file system" puede ser que el sistema se corrompe por algún script pasado bastante tiempo?
Un saludo!

seny

  • Visitante
Re: Problema: Read-only file system
« Respuesta #5 en: 03-10-2016, 23:59 (Lunes) »
Esto que comentais también me ha pasado con hg556a, con el "mtd erase -r rootfs_data" se soluciona pero se pierden las configuraciones.

La forma más rápida de volver a la normalidad que he encontrado es volver cargar la imagen dejando marcado que mantenga la configuración.

El motivo de que suceda esto me da la impresión que tiene algo que ver con el momento en que se apaga o reinicia el router, que algún proceso se queda a medias y al encender queda en un estado no previsto..
Saludos

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1956
Re: Problema: Read-only file system
« Respuesta #6 en: 04-10-2016, 08:49 (Martes) »

Hombre, desde luego, yo le pondría alimentación al hd (se puede dañar el disco y el router) y si puedes, conviértelo a ext4 y no ntfs.
Lo de los scripts, no creas, según que... yo he tenido alguno que tocaba iptables y al cabo de un par de meses el sistema quedaba totalmente corrupto, al punto de no poder iniciar, dejé de usar este script hace mas de un año, y mas nunca.... (mi error, no poner un adaptador serie para ver en el arranque lo que hacía el router, pero de cualquier manera, era el script)
Gracias Ficht, verificaré los scripts que se ejecutan por si acaso, pero todos son mover y borrar videos antiguos del disco, chequear ip y mandar mail de alarma,etc..no debería corromper nada..
Cambiar a Ext4..tengo ya una patición ext4, pero esta que uso para el ftp en ntfs para poder verlo desde todos los dispositivos, windows, android tv, etc..
Lo de alimentación, no me lo habia planteado porque al ser un hdd de 2,5" , apenas chupa corriente, el router debería ser capaz de mantenerla constante sin problemas.
Osea que lo que pasa de "read-only file system" puede ser que el sistema se corrompe por algún script pasado bastante tiempo?
Un saludo!

Si utilizas FTP para acceder al disco, no hace falta que lo tengas formateado en NTFS. Si lo tienes en NTFS es para pincharlo directamente a un PC con Windows, y si es eso lo que haces, debes de tener cuidado con desmontar el disco antes de desconectarlo del router, o tienes muchas papeletas para que se te corrompa. Espero que no sea esto lo que te está pasando.
Lo que yo haría: formatear el disco en ext4, instalar el paquete e2fsprogs y utilizar de vez en cuando e2fsck para ver si en el disco hay algo que se esté corrompiendo con el uso. Y hacer un script para desmontar el disco antes de que el router haga un reset, por si acaso algo se queda colgado y al resetear se dispara todo.
Búscale también una fuente de alimentación al disco, si lo vas a usar de forma tan continuada. Nunca sabes si el disco al escribir va a utilizar un pico de corriente, para escribir un sector débil o una escritura muy continuada, y eso lo dispara todo, al no poder alimentarlo el router... Si la carcasa USB es medio buena, debería tener inductores para atenuar ese pico, pero si la carcasa es mala y han ahorrado en componentes... es una lotería..., mejor con una fuente.

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

eduperez

  • Visitante
Re: Problema: Read-only file system
« Respuesta #7 en: 04-10-2016, 09:27 (Martes) »
Me inclino mas a el hdd..alguna vez he visto que el disco duro, por lo que sea no ha arrancado bien,no le detecta y en vez de apuntar la carpeta Almacen al sda5 (partición Ntfs del hdd), se guardan los videos en la propia memoria interna del router, hasta que se llena muy pronto,logicamente.. y ya no se puede guardar mas..y puede que ahi sea cuando empiece a dar los problemas.

Sí, es muy probable que el problema esté ahí. Yo intentaría modificar los scripts, de manera que no grabasen nada a menos que el disco estuviese montado.

txutxy

  • Visitante
Re: Problema: Read-only file system
« Respuesta #8 en: 04-10-2016, 18:59 (Martes) »
Muy agradecido a todos por las respuestas. El hdd no le muevo, siempre está en el router ya que puedo acceder a él desde cualquier lado, incluyendo remoto para ver los videos. Buscare una fuente para probar un tiempo.
Tambien la pasare a Ext4. Una duda, ahora la monto utilizando en el arranque "ntfs-3g /dev/sda5 /mnt/Almacen -o rw,sync".
Cuando la pase a ext4, simplemente se carga si la añado en puntos de montaje verdad?
Y por último, un ejemplo de inicio de script para que si no está montado el disco no haga nada? Voy aprendiendo mucho..pero me queda mucho mas!!
Un saludo

mOrfiUs

  • Visitante
Re: Problema: Read-only file system
« Respuesta #9 en: 14-10-2016, 15:44 (Viernes) »
monto utilizando en el arranque "ntfs-3g /dev/sda5 /mnt/Almacen -o rw,sync".
Utilizar el modo síncrono incrementa de forma innecesaria el uso del disco y cpu. (man mount).
Respecto al NTFS vs EXT4 los kernels actuales manejan de forma muy eficaz ambos formatos, especialmente para datos que no requieran de permisos, una de las principales diferencias entre los dos. En tu caso (las grabaciones) los permisos no son relevantes.
Y conectar un disco externo sin alimentación es garantía de problemas. La intensidad que es capaz de suministrar un puerto USB es limitada, más en el caso de un router.
Y poco más que añadir a lo dicho por los compañeros.
saludos

//FINAL Y MÁS DOS RESPUESTAS