Autor Tema: Problema cuelgues transmission con swap io Ar-5387un  (Leído 2397 veces)

0 Usuarios y 1 Visitante están viendo este tema.

nickdimoni

  • Visitante
Problema cuelgues transmission con swap io Ar-5387un
« en: 19-08-2013, 21:07 (Lunes) »
Tengo un router Ar-5387un con openwrt compilado siguiendo los pasos del tutorial de jar. Tiene conectado un disco duro de 2TB en formato ext4 y una partición de 1GB de swap activada.

El router funciona mas o menos bien, pero tengo el siguiente problema:
Cuando el transmission tiene un poco de carga (con 1 o 2 ficheros grandes de 1.5 GB ya pasa) el programa se cuelga aleatoriamente (puede ser que se cuelgue en 1 minuto como que este toda la noche funcionando) y de paso inutiliza servicios como nfs o samba.
Cuando está en ese estado me continua dejando acceder a él via ssh o web. Usando el comando top observo que está usando casi el 100% del procesador para io (supongo que será input/output), no observo procesos que usen en ese momento mas del 5% del procesador.
En ese momento el disco duro esta haciendo muy poco o nada y solo se soluciona quitandole la luz. No hace caso reboot.

He leido problemas con el transmission por no tener la swap activada, pero no es mi caso. De hecho, apenas me llega a usar swap.

Que puede ser?

Saludos y muchas gracias.



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Re: Problema cuelgues transmission con swap io Ar-5387un
« Respuesta #1 en: 19-08-2013, 21:13 (Lunes) »
A mi las últimas versiones de transmisión también me han dado ciertos problemas.

Yo te aconsejaría que probaras rtorrent + rutorrent. Tienes el proceso de instalación detallado en el hilo del Huawei HG553.

Enviado desde mi Cube U30GT
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

nickdimoni

  • Visitante
Re: Re: Problema cuelgues transmission con swap io Ar-5387un
« Respuesta #2 en: 19-08-2013, 21:27 (Lunes) »
A mi las últimas versiones de transmisión también me han dado ciertos problemas.
Problemas parecidos al mio?

No se en que versión de transmission empecé, ese router lo tendré en Openwrt desde las versiones de Noltari 33xxx (mas o menos 6 meses creo) y siempre me ha dado ese problema el transmission. 

Probaré el rtorrent + rutorrent. Gracias  ;)

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Re: Problema cuelgues transmission con swap io Ar-5387un
« Respuesta #3 en: 19-08-2013, 22:03 (Lunes) »
Yo notaba problemas de rendimiento (picos elevados en la bajada y subida).

Ya contarás que tal con rtorrent ... ;D

Enviado desde mi Cube U30GT
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Pteridium

  • Visitante
Re: Problema cuelgues transmission con swap io Ar-5387un
« Respuesta #4 en: 20-08-2013, 00:03 (Martes) »
Tengo un router Ar-5387un con openwrt compilado siguiendo los pasos del tutorial de jar. Tiene conectado un disco duro de 2TB en formato ext4 y una partición de 1GB de swap activada.

El router funciona mas o menos bien, pero tengo el siguiente problema:
Cuando el transmission tiene un poco de carga (con 1 o 2 ficheros grandes de 1.5 GB ya pasa) el programa se cuelga aleatoriamente (puede ser que se cuelgue en 1 minuto como que este toda la noche funcionando) y de paso inutiliza servicios como nfs o samba.
Cuando está en ese estado me continua dejando acceder a él via ssh o web. Usando el comando top observo que está usando casi el 100% del procesador para io (supongo que será input/output), no observo procesos que usen en ese momento mas del 5% del procesador.
En ese momento el disco duro esta haciendo muy poco o nada y solo se soluciona quitandole la luz. No hace caso reboot.

He leido problemas con el transmission por no tener la swap activada, pero no es mi caso. De hecho, apenas me llega a usar swap.

Que puede ser?

Saludos y muchas gracias.
No estoy seguro, pero creo que la partición swap es demasiado grande; prueba a reducirla a 128 o 192 MB.
Hasta donde pude documentarme si tienes casi toda la cpu (y me imagino que la RAM no irá tampoco muy sobrada), io "depende" del kernel, y más en concreto de los drivers (usb, ethernet, wireless, etc.) y de los dispositivos de almacenamiento masivo sobre todo. Un disco de 2 TB puede ser demasiado disco para un hardware tan limitado y tan enfocado a tareas de red.
Si puedes, cambia el tamaño de la swap y reduce el tamaño de la partición que usa transsmission a unos 200-400 GB, y busca una comparativa de consumo de memoria y recursos de diferentes sistemas de ficheros soportados en linux (algunos se pueden seleccionar en el menú principal de openwrt y para otros tendrás que añadirlos en el kernel).
Echale un ojo a estos enlaces a ver si te pueden ser de ayuda:
http://blog.scoutapp.com/articles/2011/02/10/understanding-disk-i-o-when-should-you-be-worried
http://forum.directadmin.com/showthread.php?t=43371
Nota: io también puede aparecer como iowait, wait o wa en top u otros programas de monitorización.

//FINAL Y MÁS DOS RESPUESTAS