Autor Tema: Openwrt luci http redirect  (Leído 5092 veces)

0 Usuarios y 1 Visitante están viendo este tema.

SergioTC16

  • Visitante
Openwrt luci http redirect
« en: 18-06-2014, 02:27 (Miércoles) »
Hola, mi idea es configurar el router para que cualquier petición entrante a cualquiera pagina web te redireccione a una ip local conectada a ese router, en concreto 192.168.1.105:8080.
Pero no se como configurar esa redireccion en luci.
Utilizo la última versión de openwrt y no encuentro el menu redirect, si pudierais ayudarme...
Gracias



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt luci http redirect
« Respuesta #1 en: 18-06-2014, 09:11 (Miércoles) »
Eso es cosa del cortafuegos: Red/Cortafuegos/Traspaso de Puertos.

EDITO: leyendo correctamente tu mensaje, no tengo claro que esto sea así, y más teniendo en cuenta tu otro post: https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg311400/#msg311400
« Última modificación: 18-06-2014, 09:15 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

SergioTC16

  • Visitante
Re: Openwrt luci http redirect
« Respuesta #2 en: 18-06-2014, 13:05 (Miércoles) »
En el otro mensaje no me he expresado bien, es justo lo que quiero lo que explicas en el cortafuegos.
¿Cómo tengo que configurarlo dentro del menú de traspaso de puertos?
Gracias.

SergioTC16

  • Visitante
Re: Openwrt luci http redirect
« Respuesta #3 en: 18-06-2014, 20:41 (Miércoles) »
Nada, he probado todas las opciones del siguiente wiki:

http://wiki.openwrt.org/doc/uci/firewall

No me ha funcionado ninguna.
Puedo conectar desde otro PC a la IP 192.168.213:8080 (que es la del ordenador conectado al router) Pero no logro hacer que cada vez que me meta a a cualquier URL por ejemplo Google me lleve a esa IP, quiero que absolutamente todo lo que pongas redireccione a esa IP pero no hay manera...  ???
Y llevo toda la tarde.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt luci http redirect
« Respuesta #4 en: 18-06-2014, 21:16 (Miércoles) »
Eso es lo que haría Nodogsplash: http://wiki.openwrt.org/doc/howto/wireless.hotspot.nodogsplash

Pero la redirección sería al servidor web del propio router  ^-^
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: Openwrt luci http redirect
« Respuesta #5 en: 18-06-2014, 21:18 (Miércoles) »
Nada, he probado todas las opciones del siguiente wiki:

http://wiki.openwrt.org/doc/uci/firewall

No me ha funcionado ninguna.
Puedo conectar desde otro PC a la IP 192.168.213:8080 (que es la del ordenador conectado al router) Pero no logro hacer que cada vez que me meta a a cualquier URL por ejemplo Google me lleve a esa IP, quiero que absolutamente todo lo que pongas redireccione a esa IP pero no hay manera...  ???
Y llevo toda la tarde.

¿No te serviría hacer un port-forward del puerto 80 a la IP 192.168.213 por el puerto 8080?
A lo mejor tienes que definir una nueva zona de firewall, pero yo por ejemplo redirecciono todo el tráfico que entra por la WAN por el puerto 7654 a la IP y puerto escogidos:

Código: [Seleccionar]
config redirect
<------>option target 'DNAT'
<------>option name 'Redir_7654'
<------>option src 'wan'
<------>option dest 'lan'
<------>option proto 'tcp'
<------>option src_dport '7654'
<------>option dest_ip '192.168.2.145'
<------>option dest_port '1234'
Si cambias src_dport por 80 (tráfico web) y lo rediriges a dest_ip, dest_port debería funcionar...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

SergioTC16

  • Visitante
Re: Openwrt luci http redirect
« Respuesta #6 en: 18-06-2014, 22:01 (Miércoles) »
Nada, he probado todas las opciones del siguiente wiki:

http://wiki.openwrt.org/doc/uci/firewall

No me ha funcionado ninguna.
Puedo conectar desde otro PC a la IP 192.168.213:8080 (que es la del ordenador conectado al router) Pero no logro hacer que cada vez que me meta a a cualquier URL por ejemplo Google me lleve a esa IP, quiero que absolutamente todo lo que pongas redireccione a esa IP pero no hay manera...  ???
Y llevo toda la tarde.


¿No te serviría hacer un port-forward del puerto 80 a la IP 192.168.213 por el puerto 8080?
A lo mejor tienes que definir una nueva zona de firewall, pero yo por ejemplo redirecciono todo el tráfico que entra por la WAN por el puerto 7654 a la IP y puerto escogidos:

Código: [Seleccionar]
config redirect
<------>option target 'DNAT'
<------>option name 'Redir_7654'
<------>option src 'wan'
<------>option dest 'lan'
<------>option proto 'tcp'
<------>option src_dport '7654'
<------>option dest_ip '192.168.2.145'
<------>option dest_port '1234'
Si cambias src_dport por 80 (tráfico web) y lo rediriges a dest_ip, dest_port debería funcionar...

Acabo de ponerlo en el Custom Rules del Firewall y ni caso... Me meto con el movil a una URL como google.com y no me carga la de 192.168.1.226.

Ilustro lo que he puesto:
# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.



config redirect
        option target 'DNAT'
        option name 'Redir_8080'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp'
        option src_dport '80'
        option dest_ip '192.168.1.226'
        option dest_port '8080'

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: Openwrt luci http redirect
« Respuesta #7 en: 19-06-2014, 08:33 (Jueves) »
Nada, he probado todas las opciones del siguiente wiki:

http://wiki.openwrt.org/doc/uci/firewall

No me ha funcionado ninguna.
Puedo conectar desde otro PC a la IP 192.168.213:8080 (que es la del ordenador conectado al router) Pero no logro hacer que cada vez que me meta a a cualquier URL por ejemplo Google me lleve a esa IP, quiero que absolutamente todo lo que pongas redireccione a esa IP pero no hay manera...  ???
Y llevo toda la tarde.


¿No te serviría hacer un port-forward del puerto 80 a la IP 192.168.213 por el puerto 8080?
A lo mejor tienes que definir una nueva zona de firewall, pero yo por ejemplo redirecciono todo el tráfico que entra por la WAN por el puerto 7654 a la IP y puerto escogidos:

Código: [Seleccionar]
config redirect
<------>option target 'DNAT'
<------>option name 'Redir_7654'
<------>option src 'wan'
<------>option dest 'lan'
<------>option proto 'tcp'
<------>option src_dport '7654'
<------>option dest_ip '192.168.2.145'
<------>option dest_port '1234'
Si cambias src_dport por 80 (tráfico web) y lo rediriges a dest_ip, dest_port debería funcionar...

Acabo de ponerlo en el Custom Rules del Firewall y ni caso... Me meto con el movil a una URL como google.com y no me carga la de 192.168.1.226.

Ilustro lo que he puesto:
# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.



config redirect
        option target 'DNAT'
        option name 'Redir_8080'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp'
        option src_dport '80'
        option dest_ip '192.168.1.226'
        option dest_port '8080'

Lo del config redirect hay que ponerlo en el fichero /etc/config/firewall, y por lo que veo lo estás poniendo en ¿/etc/firewall.user?
La regla sólo te redirige los puertos, es decir, que si haces la petición de la página www.google.es, te pasará el tráfico a la IP que le digas. Es en esa IP donde tendrás que tener otra forma de sacar una petición a www.google.es. Si al conectarte directamente a 192.168.1.226:8080 ya te saca el tráfico web, entonces esa parte ya está hecha.
¿La interfaz 'wan' es la interfaz por donde los clientes hacen la petición de tráfico web? Si los clientes están dentro de la 'lan' la regla no va a funcionar. A lo mejor necesitas crear alguna vlan y destinar parte de la vlan a los clientes y la otra parte a la redirección del tráfico. No sé si la redirección de tráfico de puertos de 'lan' a 'lan' va a funcionar. No he probado explícitamente esa regla, pero debiera funcionar.

Como prueba, pon la configuración en el fichero /etc/config/firewall
Cambia 'wan' por 'lan'
Prueba a poner una dirección web en el navegador enganchado al router, a ver si te redirige el tráfico web a la IP solicitada.

Al fin y al cabo la regla es : redirige o concentra todo el tráfico del puerto 80 dentro de la 'lan' a la IP 192.168.1.226:8080 en la 'lan' también.
Es en la IP 192.168.1.226 donde tienes que discernir de quién proviene la petición de tráfico para sacar la petición a internet y devolverle los datos oportunos. Esto se hace con un proxy. ¿Tienes alguno instalado en esa IP?
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.