Autor Tema: minidlna no aparece en dispositivos multimedia  (Leído 5065 veces)

0 Usuarios y 1 Visitante están viendo este tema.

aluis13

  • Visitante
minidlna no aparece en dispositivos multimedia
« en: 15-10-2015, 18:25 (Jueves) »
hola, tengo un problema con minidlna de openwrt, se supone que todo esta configurado correctamente ya que la unidad del disco que se encuentra montada, para hacer la funciona del servidor es detectada, pero mi pc no lo reconoce en dispositivos multimedia, me gustaría saber si alguien tiene alguna solución o algun consejo que me ayude a resolver esto y les agradezco de antemano por su ayuda



Ficht

  • Visitante
Re:
« Respuesta #1 en: 15-10-2015, 20:28 (Jueves) »
Has buscado con el teléfono el servicio dlna?
Entra por ssh al router y con htop o top confirma que este corriendo el programa minidlna....
O igual el problema es algun cortafuegos en el pc....

Enviado desde mi LG-D390n mediante Tapatalk


aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #2 en: 16-10-2015, 16:13 (Viernes) »
CPU:   0% usr   0% sys   0% nic  99% idle   0% io   0% irq   0% sirq
Load average: 0.03 0.06 0.05 2/47 4193
  PID  PPID USER     STAT   VSZ %VSZ %CPU COMMAND
 4193  4188 root     R     1504   5%   0% top
 4187  2108 root     S     1220   4%   0% /usr/sbin/dropbear -P /var/run/dropbe
 2114     1 root     S     9172  31%   0% /usr/bin/minidlna -f /tmp/minidlna.co
 2188     1 root     S     3204  11%   0% /usr/sbin/nmbd -D
 2186     1 root     S     3148  11%   0% /usr/sbin/smbd -D
  868     1 root     S     1532   5%   0% /sbin/netifd
  734     1 root     S     1512   5%   0% /sbin/syslogd -l 8 -C16
    1     0 root     S     1508   5%   0% init
 4188  4187 root     S     1508   5%   0% -ash
  513     1 root     S     1508   5%   0% init
 2203     1 root     S     1504   5%   0% /usr/sbin/ntpd -n -p 0.openwrt.pool.n
 1849     1 root     S     1504   5%   0% /sbin/watchdog -t 5 /dev/watchdog
  736     1 root     S     1496   5%   0% /sbin/klogd
 2133     1 root     S     1160   4%   0% /usr/sbin/uhttpd -f -h /www -r OpenWr
 2108     1 root     S     1156   4%   0% /usr/sbin/dropbear -P /var/run/dropbe
 3370     1 nobody   S      944   3%   0% /usr/sbin/dnsmasq -C /var/etc/dnsmasq
  744     1 root     S      872   3%   0% /sbin/ubusd
  738     1 root     S      864   3%   0% /sbin/hotplug2 --override --persisten
  459     2 root     SW       0   0%   0% [usb-storage]
  235     2 root     SW       0   0%   0% [kworker/0:1]

esto fue lo que me arrojo el top estuve investigando y parece que es un problema con el multicast_snooping o algo asi, ya que lo tengo conectado en modo bridge con un router principal por medio de cable y cuando es asi el minidlna no funciona bien pero no estoy seguro de como deshabilitar esto para que no me siga dando problemas.

la verdad no se muy bien lo que estoy haciendo es la primera vez que trabajo con openwrt XD

Ficht

  • Visitante
Re:
« Respuesta #3 en: 16-10-2015, 21:19 (Viernes) »
Una pregunta... Veo que tienes smb habilitado, puedes ver los archivos del disco en el pc?

Enviado desde mi LG-D390n mediante Tapatalk


aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #4 en: 16-10-2015, 22:12 (Viernes) »
si, si puedo verlo el problema esta con el minidlna que no aparece dentro de la red pero el smb si funciona perfecto

Ficht

  • Visitante
Re:
« Respuesta #5 en: 16-10-2015, 22:26 (Viernes) »
Vale....
Que version de openwrt usas?

Enviado desde mi LG-D390n mediante Tapatalk


aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #6 en: 16-10-2015, 22:31 (Viernes) »
Router Name   OpenWrt
Router Model   TP-Link TL-MR3420 v2
Firmware Version   OpenWrt Attitude Adjustment 12.09-rc1 - OpenWrtID / LuCI 0.11 Branch (0.11+svn9599)
Kernel Version   3.3.8

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2119
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #7 en: 16-10-2015, 22:53 (Viernes) »
¿Qué topología de red tienes? Si el flujo de datos pasa por dispositivos intermedios puede que lo estén cortando.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Ficht

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #8 en: 16-10-2015, 23:20 (Viernes) »
Y también ver el archivo de configuración que tienes de minidlna, para saber el log donde está ubicado... y poder ver que dice este.... porque se ve (con top) que funciona .. pero puede que tenga algún error en crear las bases de datos o algo parecido... (este es el único fallo que una vez me dió) pero minidela normalmente funciona muy bien al menos en todas las compilaciones que yo he probado con distintos kernel

aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #9 en: 16-10-2015, 23:27 (Viernes) »
tengo dos router conectados uno principal y otro conectado al principal en modo bridge, el router que maneja el smb y el minidnla es el secundario

router principal===cable utp===router seconduario(bridge con smb y minidnla)
« Última modificación: 16-10-2015, 23:28 (Viernes) por aluis13 »

Ficht

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #10 en: 16-10-2015, 23:51 (Viernes) »
tengo dos router conectados uno principal y otro conectado al principal en modo bridge, el router que maneja el smb y el minidnla es el secundario

router principal===cable utp===router seconduario(bridge con smb y minidnla)


También prueba a escribir en el navegador del pc la IP de tu router    *.*.*.* :8200
ahí debería de salir una descripción de lo que hace el servidor dlna  (MiniDLNA status)

aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #11 en: 17-10-2015, 00:01 (Sábado) »
todo eso funciona, si puedo entrar en la dirección y me sale esto

MiniDLNA status

Audio files: 0
Video files: 13
Image files: 310

el problema esta en que no aparece en la red, ninguno de mis dispositivos pueden sincronizarse con el ni el tlfn ni la pc se supone que todo esta bien configurado y esta funcionando, el problema esta en que no aparece como dispositivo multimedia en la red

Ficht

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #12 en: 17-10-2015, 00:12 (Sábado) »
todo eso funciona, si puedo entrar en la dirección y me sale esto

MiniDLNA status

Audio files: 0
Video files: 13
Image files: 310

el problema esta en que no aparece en la red, ninguno de mis dispositivos pueden sincronizarse con el ni el tlfn ni la pc se supone que todo esta bien configurado y esta funcionando, el problema esta en que no aparece como dispositivo multimedia en la red


Vale, el punto de acceso WiFi es el router principal ?

a ver si esto no lo has hecho    ¿..?
Creo que tendrías que abrir el puerto 8200 en el router principal a la ip que le asigna este al router openwrt.... y luego asignarle manualmente la ip, para que al reiniciar se mantenga igual...


aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #13 en: 17-10-2015, 00:44 (Sábado) »
si el router de acceso wifi es el router principal el secundario solo lo utilice para poder utilizar un disco externo como servidor smb y dnla, ya libere el puerto 8200 en el router y sigue sin poder reconocer el dnla en la red

Ficht

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #14 en: 17-10-2015, 01:02 (Sábado) »
si el router de acceso wifi es el router principal el secundario solo lo utilice para poder utilizar un disco externo como servidor smb y dnla, ya libere el puerto 8200 en el router y sigue sin poder reconocer el dnla en la red

Prueba a activar la wifi del openwrt y conectándote a ella .... deberías ver el dlna... si esto funciona, saltar al router principal y a ver si poniendo el openwrt en DMZ de manera provisional  aparece el servicio... en estos cambios de cortafuego, hay veces que hay que reiniciar... no se, aquí en según el router hay veces que cuesta mas

aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #15 en: 17-10-2015, 01:48 (Sábado) »
el servidor si funciona cuando el opewrt es el router principal lo que pasa es que no puedo usar este como principal por que el otro es un modem wifi y es el que me da el internet, el problema esta cuando el openwrt trabaja como cliente de mi router principal, ahi es cuando deja de funcionar el minidnla

Ficht

  • Visitante
Re:
« Respuesta #16 en: 17-10-2015, 09:17 (Sábado) »
Hombre, si podría usarse como punto de acceso.... pero esto es otra cosa depende de lo que te de cada uno y lo que mas interese...
Aquí el tema es que aparentemente el cortafuegos del principal no deja que salga el servicio a toda la red, mira a ver si tienes una opción que diga network isolator o algo parecido, tendrás que desactivarlo....
Que router tienes como principal? que marca es? y de que compañía?
Prueba lo del DMZ....

Enviado desde mi LG-D390n mediante Tapatalk

« Última modificación: 17-10-2015, 09:59 (Sábado) por Ficht »

aluis13

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #17 en: 17-10-2015, 20:21 (Sábado) »
nada de eso ha funcionado amigo, no se si ya darme por vencido con esto jaja

Ficht

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #18 en: 18-10-2015, 15:44 (Domingo) »
nada de eso ha funcionado amigo, no se si ya darme por vencido con esto jaja

Hombre, lo único que se me ocurre es que llames al servicio técnico de tu compañía y que te guíen para hacer funcionar un servidor dlna en el puerto 8200...

skywalky

  • Visitante
Re: minidlna no aparece en dispositivos multimedia
« Respuesta #19 en: 03-11-2015, 15:30 (Martes) »
¿Tienes bien puesta la linea de configuración de los interfaces en minidlna.conf?

option interface 'br-lan,wlan0'

Tal y como la he puesto transmite por la LAN y por la wifi wlan0. Compruébalo con tu configuración de router.