Autor Tema: fstab problema  (Leído 3352 veces)

0 Usuarios y 1 Visitante están viendo este tema.

~mary~

  • Visitante
fstab problema
« en: 10-05-2013, 19:23 (Viernes) »
Hola, tengo un problema con openwrt y fstab, estoy intentando montar una partición ext4 que tengo en un USB como arranque para tener mayor espacio sobre el que trabajar que el que tengo ahora sólo con el router.

En /etc/config/fstab tengo lo siguiente:
config mount
option device '/dev/sda1'
option fstype 'ext4'
option options 'rw,sync'
options enabled '1'
options is_rootfs '1'
option target '/'

Cuando yo arranco el router con el usb conectado, me monta esta partición pero en:
/tmp/overlay-disabled

El demonio de fstab esta marcado para que se inicie al arrancar el router

alguna idea?



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re:
« Respuesta #1 en: 11-05-2013, 10:07 (Sábado) »
Algo tiene esa partición que no le gusta ....
Mira a ver si con el comando dmesg te alguna pista.

Enviado desde mi Cube U30GT
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Noltari

  • Visitante
Re: fstab problema
« Respuesta #2 en: 11-05-2013, 13:21 (Sábado) »
Creo que tu problema está en que estás utilizando una configuración antigua con la última versión de OpenWrt.

Si estás usando una imagen squashfs:
Código: [Seleccionar]
config mount
        option target        /overlay
        option device        /dev/sda1
        option fstype        ext4
        option options       rw,sync
        option enabled       1
        option enabled_fsck  0

Si estás usando una imagen jffs2:
Código: [Seleccionar]
config mount
        option target        /
        option device        /dev/sda1
        option fstype        ext4
        option options       rw,sync
        option enabled       1
        option enabled_fsck  0

La opción is_rootfs ya no se utiliza.

P.D: Source http://wiki.openwrt.org/doc/howto/extroot.

Saludos!
« Última modificación: 11-05-2013, 13:23 (Sábado) por Noltari »

~mary~

  • Visitante
Re: fstab problema
« Respuesta #3 en: 11-05-2013, 22:25 (Sábado) »
Hola, es bastante raro.

Estoy usando:
https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5831u/

El router ya sabeis cual es, y utilizo la compilada por Noltari en concreto: OpenWrt Barrier Breaker r36114

He probado ambas configuraciones propuestas por Noltari y no ha funcionado ninguna. También probé usando la interfaz de Luci pero tampoco funcionó.

Tengo los siguientes paquetes instalados, por si fuera de ayuda

http://pastebin.com/bbax4M5f

Y con respecto a dmesg tampoco he encontrado nada raro.

http://pastebin.com/5vsiAPC9

Otra cosa muy rara y que no veo demasiado coherente con respecto a sistemas Unix, es que al modificar el archivo /etc/config/fstab, y hacer un /etc/init.d/fstab restart, el archivo /etc/fstab este vacio  ???

Noltari

  • Visitante
Re: fstab problema
« Respuesta #4 en: 12-05-2013, 12:33 (Domingo) »
Hola, es bastante raro.

Estoy usando:
https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5831u/

El router ya sabeis cual es, y utilizo la compilada por Noltari en concreto: OpenWrt Barrier Breaker r36114

He probado ambas configuraciones propuestas por Noltari y no ha funcionado ninguna. También probé usando la interfaz de Luci pero tampoco funcionó.

Tengo los siguientes paquetes instalados, por si fuera de ayuda

http://pastebin.com/bbax4M5f

Y con respecto a dmesg tampoco he encontrado nada raro.

http://pastebin.com/5vsiAPC9

Otra cosa muy rara y que no veo demasiado coherente con respecto a sistemas Unix, es que al modificar el archivo /etc/config/fstab, y hacer un /etc/init.d/fstab restart, el archivo /etc/fstab este vacio  ???
El problema está en que ese firmware no lleva block-mount, necesario para lo que quiere hacer.

Saludos!

~mary~

  • Visitante
Re: fstab problema
« Respuesta #5 en: 12-05-2013, 19:41 (Domingo) »
Supongo por tanto que debo compilarlo por lo tanto con block-mount.

Gracias por todo. Una última cosa, Noltari tu que parece que has probado bastante este router con openWrt sabes si será compatible?

Un saludo.


Pteridium

  • Visitante
Re: fstab problema
« Respuesta #6 en: 12-05-2013, 21:24 (Domingo) »
Cualquiera con puerto usb que funcione bien y esté bien configurado, block-mount no te dará problemas.

//FINAL Y MÁS DOS RESPUESTAS