Autor Tema: ¿Es posible conectar por PPTP a hg556a?  (Leído 2342 veces)

0 Usuarios y 1 Visitante están viendo este tema.

dlop

  • Visitante
¿Es posible conectar por PPTP a hg556a?
« en: 05-09-2012, 18:59 (Miércoles) »
Hola a todos
Tengo un hg556a con openwrt r30964.
No encuentro como configurar PPTP como servidor (para conectar desde fuera). Si intento el comando opkg install , dice que
Citar
opkg install pptpd
Installing pptpd (1.3.4-2) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/pptpd_1.3.4-2_brcm63xx.ipk.
Multiple packages (kmod-ppp and kmod-ppp) providing same name marked HOLD or PREFER. Using latest.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for pptpd                      :
 *      kernel (= 3.3.8-1-d84cefb39b2dcbdf806cc779398b6f69) *   kernel (= 3.3.8- 1-d84cefb39b2dcbdf806cc779398b6f69) *
 * opkg_install_cmd: Cannot install package pptpd.
¿Alguien tiene idea? ¿Tengo que reinstalarlo todo con una nueva compliacion?



« Última modificación: 05-09-2012, 19:35 (Miércoles) por dlop »

thorazine74

  • Visitante
Re: ¿Es posible conectar por PPTP a hg556a?
« Respuesta #1 en: 09-09-2012, 01:18 (Domingo) »
Por lo que entiendo yo si usas una build custom de las que se publican por aqui no se pueden instalar paquetes adiccionales desde el repositorio trunk si estos dependen del kernel, aunque sea la misma version, porque como ves en el mensaje, el paquete no solo pide un kernel 3.3.8-1 sino uno que tenga exactamente ese md5, cosa que solo el kernel oficial trunk cumple.
La solucion por lo que se ha comentado en el hilo del hg556 es o bien compilar los paquetes tu mismo a la vez que el kernel o bien intentar instalar los paquetes de forma forzada, usando opkg --force-depends y esperar que funcione.

Noltari

  • Visitante
Re: ¿Es posible conectar por PPTP a hg556a?
« Respuesta #2 en: 09-09-2012, 18:32 (Domingo) »
Si no te funciona ignorando las dependencias tienes que compilar la imagen tú mismo.

Por cierto, al ignorar las dependencias para evitar el error del kernel recuerda que estás ignorando paquetes adicionales que pueden ser estrictamente necesarios:
http://blog.netnerds.net/2011/02/openwrt-pptpd-a-love-story/

Saludos.

elmasvital

  • Visitante
Re: ¿Es posible conectar por PPTP a hg556a?
« Respuesta #3 en: 10-09-2012, 21:32 (Lunes) »
Por lo que entiendo yo si usas una build custom de las que se publican por aqui no se pueden instalar paquetes adiccionales desde el repositorio trunk si estos dependen del kernel, aunque sea la misma version, porque como ves en el mensaje, el paquete no solo pide un kernel 3.3.8-1 sino uno que tenga exactamente ese md5, cosa que solo el kernel oficial trunk cumple.
La solucion por lo que se ha comentado en el hilo del hg556 es o bien compilar los paquetes tu mismo a la vez que el kernel o bien intentar instalar los paquetes de forma forzada, usando opkg --force-depends y esperar que funcione.


Vaya si es verdad que comprueba el MD5 es muy mala noticia... pq deja fuera a cualquier router que no este soportado de forma oficial. Y tener que compilarlo todo mil veces es un engorro.

//FINAL Y MÁS DOS RESPUESTAS