Autor Tema: Instalando OwnCloud  (Leído 7733 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Altair64

  • Visitante
Instalando OwnCloud
« en: 22-12-2013, 17:19 (Domingo) »
Muy buenas.
Acabo de instalarme Owncloud en mi OpenWRT, pero tengo por aqui algunos problemas :P

El mas grande es que OwnCloud me da el siguiente aviso:
"Su servidor web aún no está configurado adecuadamente para permitir sincronización de archivos ya que la interfaz WebDAV parece no estar funcionando. Por favor, vuelva a comprobar las guías de instalación. "

Creo que el problema radica en el 'servidor web' que estoy usando desde OpenWRT. En las guías de instalación no hay constancia alguna de UHTTPD, que es el que viene por defecto instalado en OpenWRT (en la compilación que tengo yo, mas bien dicho  ^-^ )

En las guias de instalacion (http://doc.owncloud.org/server/5.0/admin_manual/installation.html) salen "guias" para Apache y Lighttpd. Podria usar dos servidores? sin causarme problemas ni liadas con la interfaz web de LuCI  ;D 

S2!



Pteridium

  • Visitante
Re: Instalando OwnCloud
« Respuesta #1 en: 22-12-2013, 17:47 (Domingo) »
Hay que buscar un poquito:
http://wiki.openwrt.org/doc/howto/owncloud

Ahora lo que toca es cacharrear un poco y verás como al final lo tienes funcionando.

Altair64

  • Visitante
Re: Instalando OwnCloud
« Respuesta #2 en: 22-12-2013, 19:30 (Domingo) »
Hay que buscar un poquito:
http://wiki.openwrt.org/doc/howto/owncloud

Ahora lo que toca es cacharrear un poco y verás como al final lo tienes funcionando.

Y quien dice que no busqué?  :P 

En esa guía, que leí ya unas cuantas veces (aunque un poco por encima hehe), veo que usan Lighttpd más que UHTTPD. Por eso preguntaba :B

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: Instalando OwnCloud
« Respuesta #3 en: 23-12-2013, 08:15 (Lunes) »

En las guias de instalacion (http://doc.owncloud.org/server/5.0/admin_manual/installation.html) salen "guias" para Apache y Lighttpd. Podria usar dos servidores? sin causarme problemas ni liadas con la interfaz web de LuCI  ;D 

S2!


Si los configuras bien, no hay problema en tener 2 servidores http.

Yo tengo Lighttpd para servir las páginas de rutorrent (interfaz web para rtorrent), además de uhttpd para LuCi.

Eso sí, están configurados para usar distintos puertos  ;)
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Altair64

  • Visitante
Re: Instalando OwnCloud
« Respuesta #4 en: 23-12-2013, 09:55 (Lunes) »

En las guias de instalacion (http://doc.owncloud.org/server/5.0/admin_manual/installation.html) salen "guias" para Apache y Lighttpd. Podria usar dos servidores? sin causarme problemas ni liadas con la interfaz web de LuCI  ;D 

S2!


Si los configuras bien, no hay problema en tener 2 servidores http.

Yo tengo Lighttpd para servir las páginas de rutorrent (interfaz web para rtorrent), además de uhttpd para LuCi.

Eso sí, están configurados para usar distintos puertos  ;)

Aaaahm asi que ahi debe estar la clave, en los puertos  ;D 
Pues luego lo probaré a ver que tal me tira, porque parece que uhttpd no tira muy bien con el programita (owncloud ya está instalado pero me dice lo del WebDAV y no me deja conectar el cliente de escritorio).. Si lo consigo hacer funcionar ya haré un tutorial.

S2!

skywalky

  • Visitante
Re: Instalando OwnCloud
« Respuesta #5 en: 20-02-2014, 08:37 (Jueves) »
Hola, ¿has conseguido hacer funcionar owncloud en OpenWrt? Es que yo no lo he conseguido, a pesar de configurar bien el lighttpd y el php no me carga la página de owncloud y no se por qué.

Estoy probando instalando el Apache pero al instalar el paquete no me mete el fichero /etc/init.d/httpd o /etc/init.d/apache, ¿alguien sabe el contenido de ese archivo para poder lanzar el servicio adecuadamente?

Altair64

  • Visitante
Re: Instalando OwnCloud
« Respuesta #6 en: 20-02-2014, 13:37 (Jueves) »
Hola, ¿has conseguido hacer funcionar owncloud en OpenWrt? Es que yo no lo he conseguido, a pesar de configurar bien el lighttpd y el php no me carga la página de owncloud y no se por qué.

Estoy probando instalando el Apache pero al instalar el paquete no me mete el fichero /etc/init.d/httpd o /etc/init.d/apache, ¿alguien sabe el contenido de ese archivo para poder lanzar el servicio adecuadamente?
Nah que va, lo maximo que logré fue arrancar la interfaz web, con mucho lag (tardaba igual 1 minuto o mas en cargar), y no iba nada mas, no iba el cliente de escritorio, y en la web me daba bastantes problemas. No lo veo factible para WRT a mi parecer, chupa mucho y tarda mucho en funcionar.

skywalky

  • Visitante
Re: Instalando OwnCloud
« Respuesta #7 en: 20-02-2014, 19:43 (Jueves) »
Gracias, así que mejor dejo de calentarme la cabeza con ésto.

Altair64

  • Visitante
Re: Instalando OwnCloud
« Respuesta #8 en: 20-02-2014, 19:45 (Jueves) »
Gracias, así que mejor dejo de calentarme la cabeza con ésto.

yo creo que mejor si... a no ser que tengas un router mas potente que los que probe yo, que fueron el HG556a y el AR5387un.
Creo que sería más factible usar FTPFS o SFTPFS (no recuerdo bien como se llamaban, pero permiten montar, en un sistema linux, una ubicacion FTP o SFTP) y usar rsync si quieres tener los datos sincronizandose.

//FINAL Y MÁS DOS RESPUESTAS