Autor Tema: Configuracion de los LEDS  (Leído 1457 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ATAGA

  • Visitante
Configuracion de los LEDS
« en: 29-12-2015, 19:00 (Martes) »
Hola todos. Despues de pelearme con la instalacion de Openwrt en un router Home Hub 2B no consigo encontrar cuales son los comandos para configurar correctamente el apagado y encendido de los LEDs ya que quiero programarlos para que se enciendan y se apaguen a hora hora determinada que es como lo tengo en un router Asus RT-N16 con el AdvancedTomato.

En principio no hay problema para apagarlos con los comandos:

    /bin/echo 0 > /sys/class/leds/soc:red:power/brightness

    /bin/echo 0 > /sys/class/leds/soc:red:broadband/brightness
    /bin/echo 0 > /sys/class/leds/soc:orange:broadband/brightness

    /bin/echo 0 > /sys/class/leds/soc:orange:wireless/brightness

    /bin/echo 0 > /sys/class/leds/soc:blue:phone/brightness

Pero cuando intento volverlos a encender se pierde el parpadeo de los LEDs que refleja la actividad de los mismos, es decir, se quedan fijas si utilizo los comandos:

    /bin/echo 1 > /sys/class/leds/soc:red:power/brightness

    /bin/echo 1 > /sys/class/leds/soc:red:broadband/brightness
    /bin/echo 1 > /sys/class/leds/soc:orange:broadband/brightness

    /bin/echo 1 > /sys/class/leds/soc:orange:wireless/brightness

    /bin/echo 1 > /sys/class/leds/soc:blue:phone/brightness

La actividad se vuelve a recuperar si reinicio el router o aplico de nuevo la configuracion de los LEDs desde la interfaz LuCI

¿alguien sabria hacerlo correctamente sin perder esa caracteristica?

Saludos



danitool

  • Visitante
Re: Configuracion de los LEDS
« Respuesta #1 en: 29-12-2015, 19:08 (Martes) »
Comprueba el trigger que tiene cada led antes de apagarlos
Código: [Seleccionar]
cat /sys/class/leds/soc:red:power/trigger
cuando los vuelvas a encender recupera el trigger que tenía antes, si era timer:
Código: [Seleccionar]
echo timer >  /sys/class/leds/soc:red:power/trigger
« Última modificación: 29-12-2015, 19:09 (Martes) por danitool »

ATAGA

  • Visitante
Re: Configuracion de los LEDS
« Respuesta #2 en: 30-12-2015, 13:16 (Miércoles) »
Solucionado

Como tu dices sigue dandome el problema que te comento, pero con este otro comando:

/etc/init.d/led restart

se resetean las luces y vuelve a iniciarse la configuracion establecida desde la interfaz gráfica LuCI

Gracias por todo.

ATAGA

  • Visitante
Re: Configuracion de los LEDS
« Respuesta #3 en: 31-12-2015, 13:05 (Jueves) »
Bueno, para el que lo necesite aqui dejo mi configuracion que he introducido en el programador de tareas SIN necesidad de hacer SCRIPTs:

#Encendido de LEDS a las 9:15
15 9 * * * /etc/init.d/led restart

#Apagado de LEDs a las 8:15
15 20 * * * /bin/echo 0 > /sys/class/leds/soc:red:power/brightness
15 20 * * * /bin/echo 0 > /sys/class/leds/soc:red:broadband/brightness
15 20 * * * /bin/echo 0 > /sys/class/leds/soc:orange:broadband/brightness
15 20 * * * /bin/echo 0 > /sys/class/leds/soc:orange:wireless/brightness
15 20 * * * /bin/echo 0 > /sys/class/leds/soc:blue:phone/brightness